Over 1 million tech questions and answers.

Fibocom L850-GL not working in T480s

Q: Fibocom L850-GL not working in T480s

I bought a wwan card (Fibocom L850-GL). Installed it and was everything all right. I ran System Update today, which found an update V.2.0.1.44, which I installed. System Update suggested me to restart my laptop. I did so an since than the following happens: System Update finds the very same update again and again. (And shows it in the history as installed update.)Cellular connection does not show up among available networks.No trace of the device in device manager, so I am not able to reinstall it or go back to an older version.Windows beeps sometimes, as if a new device was found, but nothing happens.Any idea is wellcome! Thank you!

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Fibocom L850-GL not working in T480s

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 110

Over the last few weeks, I've had at least a half dozen T480s that have severe spikes in latentcy and packet loss when using the Fibocom L850-GL, making them pretty much useless for our users who need them for remote desktop.The usual "working" baseline for these machines on our network is around 40-70ms pings. Show below are the occasional spikes past 3 seconds and timeouts along with the current firmware.    The work around I was using to fix this problem was uninstalling the drivers/firmware from Device Manager, and letting Windows reinstall them, but that doesn't seem to be working anymore.  Any help would be appreciated.

Read other answers
RELEVANCY SCORE 110

We have ~750 T480s (model 20L8S4HL00) laptops running Win10 Enterprise 1703 in our environment, and at least 35 of the laptops have non-functional Fibocom L850-GL WWAN modules. What makes matters worse is that this issue can also cause repeated BSoDs, sometimes multiple per day. Problem Symptoms and Actions TakenThe "Intel(R) USB Flash Loader utility" / "Fibocom USB Flash Loader Utility" repeatedly connects and disconnects roughly once a minute, and when doing so the Windows "device unplugged" sound is heard. The HWID of this device is "USB\VID_8087&PID_07F5\5&1AD8E564&0&6". Refer to the screenshot below The frequent and repeated hardware disconnections cause problems with the enterprise security software we use for encrypting external media, to the point that after a certain point the computer experiences a BSoDThe only associated driver that remains active in Device Manager is the "Intel(R) XMM7360-P WWAN", all other associated WWAN drivers show up as hidden with code 45 (disconnected)If all WWAN drivers are uninstalled and the drivers are deleted, the only devices that are subsequently discovered are the flash loader utility and the Intel XMM7360, all of the others are no longer found and Windows cannot seem to find them againInstalling all of the latest device drivers and firmware using the Lenovo System Update tool do not mitigate this issue, nor does manually uninstalling/reinstalling the WWAN driversTemporarily disabling the built-in... Read more

Read other answers
RELEVANCY SCORE 93.2

I am receiving an error when I try to connect to the cellular network with my X1C7: "Can't connect to this network. Enter an APN and try again" I have tested this SIM card in T420 and it can connect successfully. Win 10 is updated to the latest, all drivers too, but still no success. Output from the cmd shows that the SIM card is recognized and registered on the network, but still no successful connections: One thing I did notice is that my driver is "generic mobile broadband adapter" released by Microsoft and no matter what I try to install the Lenovo one - removing, choosing manual update, it still stubbornly chooses the generic one.   

Read other answers
RELEVANCY SCORE 79.6

Fibocom L850-GL 4G LTE-A cat 9 is orderable with X1 Yoga 3rd Gen. Could it be installed in my X1 Yoga 1st Gen to upgrade the current em7455? If the bios whitelists are shared perhaps the vid/pid for the Fibocom L850-GL 4G LTE-A cat 9 is in the list and it will be accepted. Or is it a pipe dream? I want to stick with 1st gen as the 3rd gen lacks OLED screen option, which I have.

Read other answers
RELEVANCY SCORE 79.6

I am considering buying an X1C gen 6.The model that is available in my region is: 20KH007JIVAccording to https://psref.lenovo.com/Product/ThinkPad/ThinkPad_X1_Carbon_6th_Gen?ch=20kh007It has a Fibocom L850-GL. Does it work with ubuntu 18.04 ? I mean does it work reliably after editing some files here and there or it's a mess ? (I am ok to edit some configs if required). Should I check anything before purchasing ? (I am plannig to only have Ubuntu 18.04 on it for development).I know there seems to be some problem with sleep mode but there are acceptable workarounds. Thank you in advance !

Read other answers
RELEVANCY SCORE 78.8

I want to know if a Lenovo P52 WWAN card will permit me to use that laptop as an additional device in our Google Fi account, which we use for our Android phones.  The card Fibocom L850-GL 4G LTE-A cat 9 is listed as available for P52 workstations.  A Fi chat said that I should use a "data only SIM card", but that does not help me unless I know how to use that in the P52.   I understatnd that the Fibocom card is supposed to work with Verizon, but I want to know if it will also work with Google Fi.





https://www.ingber.com

Read other answers
RELEVANCY SCORE 78.8

I can't seem to establish a cell connection with my 6th gen Carbon X1 and new Fibocom L850-GL WWAN.  I'm using a Verizon SIM - all seems fine from the VZ side, and the machine is correctly recognizing the SIM, but I can't for the life of me get it to make a connection.  All I see is "No Service" from the Windows wifi manager, although the VZ "advanced options" confirm that there is an active account.  Anyone got any ideas on how to make this connect?  The Carbon X1 is fully updated and only recently imaged - latest drivers/firmware applied. Thanks in advance for any help!!!

Read other answers
RELEVANCY SCORE 78.8

I want to know if a Lenovo P52 WWAN card will permit me to use that laptop as an additional device in our Google Fi account, which we use for our Android phones.  The card Fibocom L850-GL 4G LTE-A cat 9 is listed as available for P52 workstations.  A Fi chat said that I should use a "data only SIM card", but that does not help me unless I know how to use that in the P52.   I understatnd that the Fibocom card is supposed to work with Verizon, but I want to know if it will also work with Google Fi.





https://www.ingber.com

Read other answers
RELEVANCY SCORE 78.8

Hello,   I consedering buying a THINKPAD X1 CARBON (GEN 7), the Fibocom L850-GL 4G LTE CAT9  is included in the price, I guess it is used to acces 4G network with a SIM card exactly like a smartphone. But in this case what is the use of the wwan option ? As far as I understand it is also used to acces  cellular network ?What is the difference ? Please feel free to explain if I got this wrong  Thx

Read other answers
RELEVANCY SCORE 78.8

I know this is an old issue, but I can't solve the problem.I've downloaded the last drivers (June 2019) from Lenovo website but still WWAN doesn't work. Diagnostics says SIM is blocked by PIN2 but there is no way to add PIN2 (or PUK).Should I send the laptop to a repair center?Thank you in advance for your helpMassimo 

Read other answers
RELEVANCY SCORE 78

I bought X1 Carbon 6th and X280, both with Fibocom L850-GL. WWAN with Linux do not work. I searched and found the reason. The PCI-E must be disabled, so that the card can run with USB. It seems that Lenovo did not offered a solution since July 2017.  I searched but do not find any direct contact to Lenovo to ask the question.  The WWAN is important for me and Windows is no option anymore. Anybody know if there is an other WWAN card wich works with Linux  and X1 Carbon 6th / X280 ?Anybody know if there is a chance that Lenovo solve the problem with a bios update? Many new Lenovo Thinkpads have this Fibocom L850-GL inside and many business user use Linux...

Read other answers
RELEVANCY SCORE 77.2

I have a T480 with a Fibocom L850-GL WAN card. Frequently, but all the time, when waking up from sleep, it fails to appear in my Wireless options, and when I look at it in the device manager, under Device status Windows gives the message "Windows has stopped this device because it has reported problems. (Code 43)" I see others have had some problems with this card, but I haven't found this specific issue. I've installed the latest drivers as of today (2018-07-28) but I'm still having this problem. If I manually disable and re-enable the device it always comes back, but it's pretty annoying to have to do that.  Before I contact Lenovo for repair (the laptop is only a couple of weeks old) I wanted to check the forum for any ideas. Thanks!  

Read other answers
RELEVANCY SCORE 77.2

Windows device manager shows it as not connected. But it has been working just a week ago! Hardware or software?

Read other answers
RELEVANCY SCORE 77.2

Hi ,I have issue about WWAN Fibocom L850-GL+Antenna  after i bought it and installed already.I has follow this step:1.update bios to version 1.4 and enable wwan2.all update new drivers include fibocom 850-GL from lenovo websiteProblem is why i can't see the cellular network show in my network connection?Can anybody give me advise?My laptop is X1 carbon gen6th Machine Type Model: 20KGS45M00Processor: 1x Intel Core i7-8550U Processor(Core i7-8550U)Memory: 1x 16GBLPDDR3-2133Operating System: Windows 10 Pro 64(EN:English)Hard Drive: 1x 256GBSATAM.2Wireless Network: 1x Intel Wireless-AC 8265 2x2 ACPorts: 1x Microphone/Headphone JacksCamera: 1x 720p HD Camera with Array MicGraphics: 1x Intel UHD 620Monitor: 14.0 WQHD LEDThank you very much for your time and assistance in this matter.     

Read other answers
RELEVANCY SCORE 76.4

So I just added a WWAN card (Fibocom L850-GL (FRU 01AX792)) to the X1 Yoga 3rd Gen, but the typically "pre-installed" Antenna is not pre installed, I guess next year the Sim slot won't be there if you don't buy it out the door with it.  Does anyone know the Lenovo FU... i mean FRU... Part number for the WWAN Antenna for (Fibocom L850-GL (FRU 01AX792)) These connectors are tiny.  

Read other answers
RELEVANCY SCORE 76.4

https://www3.lenovo.com/us/en/laptops/thinkpad/thinkpad-x/ThinkPad-X280/p/22TP2TX2800Because I need LTE900 (Band 8) for my LTE module.  Is my model support with Fibocom L850-GL 4G LTE-A Cat9 which in the list of x280?Lenovo Part no. : 01AX786

Read other answers
RELEVANCY SCORE 75.6

I have a X1 Yoga 3rd Gen equipped with the Fibocom L850-GL LTE modem, using a Verizon LTE sim. I ran into this issue whenever I'm using the LTE connection at high speed, Windows 10 has a high chance of crashing (BSOD). This can be easily reproduced by running a speed test on speedtest.net. I'm in an area with good LTE signal, and my speed on the Verizon sim can reach around 200 mbps. When running the speed test, whenever it goes past around 130mbps, it has a pretty high chance of crashing. It's almost as if the module cannot handle that speed (maybe heat/power related). I'm on a clean installation of Windows 10 1809 with the latest Lenovo drivers (including the Fibocom modem) installed. Anyone else is having this issue?

Read other answers
RELEVANCY SCORE 74.8

Hi allMy WWAN was working previously. I have updated my Windows to 1809 October update.However now my WWAN toggle is missing in windows 10 I can see in device manager -Network\ Fibocom L850-GL is missing (shows up in hidden devices) - as error 45 - not connectedSystem\ Intel XMM7360-P is listed as working I've sinced downgraded - but still can't find the toggle.Anyone have problems after updating windows?  Or anyone NOT have problem after updating?  Thank you 

Read other answers
RELEVANCY SCORE 73.2

Windows still uses Microsoft made "Generic Mobile Broadband" driver, even after installing the Fibocom L830-EB Wireless WAN Dreiver For Windows 10 (Versio 1709 or later).  This ends in only giving a 50 mbps LTE connection even if the location, sim card and subscription gives 300 mps connection possibillities.   Windows only sees the generic driver, even if I manually try to choose a driver for this. No Fibocom drivers are found in the list.  Is there something that got broken during the latest 1803 installation? Has anyone else noticed this?

Read other answers
RELEVANCY SCORE 73.2

 Hello All, New T480 with the Fibocom L850-GL wwan card. Clean install of Windows 10 Pro x64, Redstone 4 (v. 1803). All Windows Updates applied. All Lenovo updates applied through the Vantage app via the Microsoft Store, and manually checked from the support page of the website (BIOS, WWAN, etc. updates). Following the manual, I pulled the external battery, disabled the internal battery, then inserted my T-Mobile USA sim card, then reassembled everything, then rebooted. Manually installed the latest L580-GL drivers from Lenovo. First off, the L850-GL is being shown as a USB device, as opposed to PCIE, with a hardware device instance path of USB\VID_8087&PID_0AC9&MI_00\7&4FA6012&0&0000, and a hardware location of 0000.0000.0000.003.000.000.000.000.000 in the properties dialogue screen in Device Manager. The Driver tab shows the provider is Microsoft with a date of 4/10/2018 and a version of 10.0.17134.1.... I suspect much of that to be a sign that something isn't right from the get-go... Second, every time I close the lid of the machine or leave it running long enough to enduce the proper level of sleep/hibernation, the card simply stops (with a hardware error 43 warning in Device Manager). At that point, my "T-Mobile LTE" network option no longer appears in the Windows 10 notification/network connections sidebar. My only recourse thus far has been to uninstall the L850 in device manager, "Sca... Read more

Read other answers
RELEVANCY SCORE 72.4

Hi,After recent update of Fibocom WWAN L830-EB firmware to version 18300.1002.00.01.01.17 faced an issue that occures on the go (literally in transport) when network is dropped (out of range) and then found again, as it seems. Win 10 troubleshooter returns:"Windows can't communicate with the device or resource (primary DNS server)"Report & logs are attached.Lenovo Thinkpad T480s (type 20L7, model 20L7001HRT)Windows 10 Pro, ver. 1803 Would someone please provide a link to the previous firmware ver. 18300.1002.00.01.01.14 ? Can I downgrade?------------Regards,Andrey Kuzmin

Read other answers
RELEVANCY SCORE 70.8

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version repeated restart Windows Cellular Service  when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It is like the Fibocom WWAN L830-EB DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 70.4

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version always restart Windows Cellular service when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It works like the Fibocom WWAN L830-EB is DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 69.2

Anyone know where to buy the antennas for this product Thinkpad Fibocom L850-GL CAT9 M.2 WWAN. I would be a great help. Also do I need a professional to install these cables?

Read other answers
RELEVANCY SCORE 69.2

This describes my experience with a T580 (20L9CTO1WW) which has the above Fibocom WWAN adaptor. Everything was fine on Win 10 1809. But after the Win system updater prompted me to update to version 1903 the adaptor is no longer functional. In Device Manager it is no longer listed under Network Adaptors but now appears under System Devices as "Intel XMM7360-P'. That is the internal LTE chipset which suggests the card is still functional but not being correctly recognised by Windows. Yesterday, I spent around 2 hours with escalated Lenovo Tech Support trying to resolve this to no avail. We tried the following:updating to the latest firmware/driver package (https://download.lenovo.com/pccbbs/mobiles/nz3wj21w.exe)uninstalling and reinstalling all driversforcing install of Lenovo driversrolling back to Win 10 1809rolling back to previous firmware/driversphysically removing and reinstalling the card So it seems there is a compatibility issue that will have to be resolved. Hopefully the next iteration of drivers/Windows updates can fix this. In the meantime, I would suggest anyone with a similar hardware setup not accept the 1903 May Update if offered. As Tech Support's final suggestion was to do a completely fresh install of (1809) Win 10 - somewhat undesirable for a lone driver incompatiblity. Alternatively, if anyone has successfully updated, please let me know and consider sharing your driver configuration. Or if anyone has any ideas on how to resol... Read more

Read other answers
RELEVANCY SCORE 54

Hi all,I have issues getting mobile (3/4g) broadband to work with my new T470 Thinkpad. In Ubuntu, the Fibocom Adapter is only detected as a generic MBIM adapter, and although Network Manager (and it's applet) display my network provider, the connection is not established, and the system process mbim-proxy is hanging at 100% CPU. This issue has been reported here (but seems to remain unsolved ?) : https://www.spinics.net/lists/linux-usb/msg158286.html Did anyone get this to work?Best whishes and thanks for any hints!

Read other answers
RELEVANCY SCORE 52.8

We have a laptop "Satellite L850-12H". We are having problems with some keys from the keyboard (some keys are not working well or work after press two times...) Always are the same keys: "c", y", "b" and others...

We have tried connecting an external keyboard and all keys from the external keyboard works without problems.

We have Windows 10 64 bits

Could you help us, please?

Thank you in advance

Regards

Read other answers
RELEVANCY SCORE 52.4

Just had an windows update and some keys are not working.

q s d g and a few others.

I know its a driver issue but can anybody point me to which ones I need to change.

Thanks

Read other answers
RELEVANCY SCORE 52.4

Just had an windows update and some keys are not working.

q s d g and a few others.

I know its a driver issue but can anybody point me to which ones I need to change.

Thanks

Read other answers
RELEVANCY SCORE 52

This is more of an intrigue than an issue but I'm still curious as to why this happens. Issue: When placing a T480s on top of another T480s both machines will be forced into sleep mode.  How to reproduce: Line up a T480s on top of another T480s (or T480) and the device will go into sleep mode. I've Stacked T480 units and this does not happen this seems to only affect the T480s line. (These test were preformed on the latest bios/driver revisions) What I think maybe happening is that the T480s when stacked are triggering the lid closed sensor of the other unit. Since this is not the case for the T480 units we have I think it may be because of the thickness of the s models. Is this something that will eventually be fixed via bios update? or is this just a flaw in the T480s design? Thanks for in advanced for your response!  

A:T480s is forced into sleep mode when in close proximity to T480/T480s

I've seen this happen in the past, it was due to how strong the magnets are that keep the lid shut.

Read other 1 answers
RELEVANCY SCORE 52

Hello,

I have a Satellite XC 250895Q. Windows 8 keeps giving me message my graphics card isn't working properly.
I go on the Radeon site and click on the appropriate boxes and let Radeon check my system to see if the drivers are current. It tells me I need to download something (?New driver) but when I do it tells me there is a problem with compatibility with my system.

I haven't noticed any problems with graphics.
It may be a Radeon problem, but what I got on my system is what got installed at the factory.

Thanks for any replie
Hetty

+Message was edited: model nr. added to subject+

A:Graphics Card isn't working properly on Satellite L850 PSKFWA

Just a bit more info after I tried again:
Radeon tells me: AMD Catalyst Mobility is the best driver for my system. After downloading and trying to install I get the following message:
AMD Catalyst Mobility cannot be downloaded due to incompatible hardware/software on your computer.
The version of your graphics adapter is not supported.
Please contact your notebook manufacturer for a graphics driver update.

Read other 6 answers
RELEVANCY SCORE 51.2

Hello, I just received my brand new T480s delivered by Lenovo 2 days ago.The problem is the USB 3.1 connector Gen 1 located on the right side of the laptop doesn't detect any USB flash drives.Only the USB 3.1 connector Gen 1 (Always On) located on the left hand side of the notebook works.I checked and this right USB 3.1 port doesn't work under Windows 10 and Ubuntu 18.04.I've never experienced such a problem with a USB port in any laptop I used, so I'm really dissapointed.Should I contact a service or is there any DIY fix solution? Thanks 

Read other answers
RELEVANCY SCORE 50.4

I have had my T480s and the basic docking station for about 6 months.  I love the laptop!  This week I added the ThinkPad Thunderbolt 3 Dock Gen 2 to improve the overall experience - multiple monitors, etc.  However, now my microphone doesn't work.  Do I need to use an external mic connected to the dock or can I get the laptop mic to work again?  It took a while to get the speakers working again, but the mic still isn't working.  I routinely have teleconference calls over the net, so this is rather inconvenient.  Please help!      Thank you!

Read other answers
RELEVANCY SCORE 50.4

Dear community, around one month ago i bought my first thinkpad, since i read alot about its high quality and its outstanding durability. When i got it, i installed linux (manjaro) on it, did some configurations and was happy that everything worked out so well. Until yesterday when i got concerned about the all in all good battery life. I read an article about how to improve battery life with installing a tool which tells the battery not to load more than 80% and then discharge until 40%. The tool i am talking about is "tpacpi-bat" which depends on "acpi_call". So I was happy to hear to increase battery life even more. I installed the tools, started the service for "tpacpi-bat" while having the ac plugged in and waited for it to reach the 80%. When it reached 80%, i guess it was around that time - but i am not that sure about it, the battery led turned off and i thought that must be the newly installed feature. But for some reason my system didnt told me any change of the battery state anymore. It was frozen at 79%. Then i deactivated the service, rebooted - battery indicator was working again -, discharged a little, plugged the ac in but the led still remains dark. Only the power button led blinks three times when plugging it in. When i fully power off the system and turn it on again, the battery led will turn on too - like all the leds will-, but turn off immediately. After that i uninstalled everything and returned to the state right before i installed every... Read more

Read other answers
RELEVANCY SCORE 50.4

Hello We are using the T480s with the USB-C Dock (40A90090CH). The Dock suddenly stopped working couple of Days ago. I can see it connected in the Device Manager and Thunderbolt Software. The Notebook connected to the Dock:+ Notebook has Power+ Powerbutton on Dock is lighting up - Ethernet is NOT working- No USB Ports are working on the Dock What have i tried:+ Updated all Drivers/Firmware on the Notebook AND Dock+ Removed and reconnected Power to the Dock What else could cause this Problem and any Ideas how to solve it?  

Read other answers
RELEVANCY SCORE 50

Received 300 T480s.  They all have the same behavior.  The screen goes black when placed on top of another T480s.  If placed on a T470s, no screen change.

Read other answers
RELEVANCY SCORE 49.6

Hi all,I have issues getting mobile (3/4g) broadband to work with my new T470 Thinkpad. In Ubuntu, the Fibocom Adapter is only detected as a generic MBIM adapter, and although Network Manager (and it's applet) display my network provider, the connection is not established, and the system process mbim-proxy is hanging at 100% CPU. This issue has been reported here (but seems to remain unsolved ?) : https://www.spinics.net/lists/linux-usb/msg158286.html Did anyone get this to work?Best whishes and thanks for any hints!

Read other answers
RELEVANCY SCORE 49.2

We had purchased a 512GB 760p Series M.2 SSD in order to upgrade one of our P50 laptops.Turns out we didn't need it for the P50 any longer, and someone needed it for their T480s. We tried upgrading the T480s with the new SSD, but it doesn't seem to be compatible with it. We tried installing it in two different T480s', and used different power cables to make sure that wasn't causing an issue.Both laptops worked fine with their initial SSD that they came with, but when installing the new drive the following issues occurred:- Long boot up times, or not booting at all- Froze at the Lenovo logo- When making it past the logo, it would remain at a black screen with a white cursor blinking in the top left- If it would get to the point where you could login, would take forever to install or run any updates We tested the drive in different Lenovo laptops and it booted up immediately with no issue. It works with the P50 and T460s. We figure the SSD may not be compatible with the T480s.Any suggestions on how to resolve this? Should we be using a different M.2 SSD? We need to be able to upgrade the laptop to a 512GB drive.This is the link to the drive we purchased: https://www.memoryexpress.com/Products/MX70646Any assistance is appreciated!

Read other answers
RELEVANCY SCORE 49.2

Just connected a DP-DP cable between the 40A9 dockingstation and the DisplayPort of the monitor.Monitor is set to use the DP as input.T480s is connected to the 40A9 via the USB-C cable.Monitor says there is no video detected. Tried either DP-port on the dockingstation without success. What is wrong here? Advice welcomed. John

Read other answers
RELEVANCY SCORE 49.2

My PC recently ran an automatic update of the thunderbolt software and then the next day it no longer was able to output to a second display from USB C to DP. Then a few days ago Lenovo released a hot fix because of something about the previous version messing with some controllers and I guess mine was one of them. I've spent days trying to fix this and now my thunderbolt controller is pretty much non existent everywhere like device manager even after completely reinstalling windows on a new drive. I can't get it to show up in my device manager even under hidden devices, I can't install the software or the firmware. It just doesn't exist. 

Read other answers