Over 1 million tech questions and answers.

Error 2100 - SSD working fine, but not booting int...

Q: Error 2100 - SSD working fine, but not booting int...

Uhg. So hello folks. So I was using my laptop this morning and ran into an issue - it bluescreen'd and immediatly shut down. Trying to boot it up yeilded what I came to know as one of the most annoying errors I have experianced in my entire life - error 2100, proclaiming that there is a read error in my drive. Now, this is something I have been working on trying to fix for the last 4 hours or so with little success. Unlike other posters, I have mounted the same drive on another PC and the files were all there and it mounted without a hitch. Now, I have yet to attempt to boot from it, but at least I know the drive is not the problem. So I have cleaned the contacts, checked the connection from the controller to the mother board, and nothing seems to work. The only solution that I have yet to try is to update the firmware, but there is a very obvious problem with that - the only non-onboard way to do that is by disc - which sucks, because the Thinkpad Yoga 12 does not have a disc drive. I really do need this laptop to work as soon as possible, and it is upsetting to me that a laptop that is only around a year old is already starting to fail. If anyone has any insight to offer, I would be most grateful.

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Error 2100 - SSD working fine, but not booting int...

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 58.4

Hi,
I wanted to upgrade my SP2100 with a WD1200BEVE. (120 GB from WD).

Disk-Copy via USB + TrueImage worked, but after changing the disk the new one does not boot: The notebook hangs up with blinking cursor.
Already checked that the partition is active and even a new installation from a XP-CD has the same result!? The BIOS seems to accept the disk (if not, installation via CD should have failed) so where is the problem?

Any hints?

A:Satellite Pro 2100 - New HDD is not booting

Hi Kannengiesser,

That?s really strange that you can?t boot from new HDD even it?s recognized in BIOS properly...

Do you have Toshiba recovery disk? If yes you could try factory settings from this disk. If it works, it was just an installation issue.

But I could also imagine that the new HDD is not working properly? Last week I had a similar problem. Did an HDD upgrade but few days later Windows didn?t start anymore because the HDD had a defective sector? Now I wait for a replacement drive.

Read other 3 answers
RELEVANCY SCORE 55.2

Hi, Since a couple of months I have had an issue with my pavilion laptop. When I start the laptop I get once in a while an Internal Error 601 which states I have to replace my battery. When windows has started, windows shows an issue with   the accu and shows error messages like : ''Plugged in, not charging'' and a batterypercentage of 0%. Actually I can work with the laptop for hours, the only problem is when my laptop shuts down because Windows thinks the battery is empty. When I plug in the adapter, reboot the system and unplug the adapter the battery continues to work (but still shows the errors).Sometimes I don't get the internal error at all and windows shows perfectly the remaining power left within the battery, but when connecting the adapter or when the accu is fully charged, the computer shuts down and when rebooting the internal error comes again.  I did run the HP System Diagnostics Battery Test twice (once while showing the internal error and once while everything works fine), the first time it shows I have to replace the battery, the second time it states: ''The battery is working fine'' and shows a capacity of 80%.  I really don't know how to fix this issue, replacing the battery is quite expensive and I don't know if the battery is really damaged. It just charges and delivers power to my computer and except for the shutdowns and errors it seems to work perfectly. Are there any solutions to this, or is replacing the battery th... Read more

Read other answers
RELEVANCY SCORE 54.4

I am running Windows 8.1 on an HP Envy Laptop. I have a wireless HP 6500A Plus printer. I have been using this setup successfully for a couple of years.

The last 4 or 5 times I have printed (over the last 2 or 3 weeks), I have gotten an on-screen "printer offline" popup, but the printer begins printing almost simultaneously. The popup goes away, and when the print job is finished, I get another popup which tells me there was a printer error and the document was not able to print. But it did print! This happens no matter how long the printer and laptop have been turned on.

This occurs every time, but it never occurred at all before 2 or 3 weeks ago, and I can't think of a thing I have changed. Since the popups go away and the printer prints, I guess this is more of an annoyance than a real problem, but something ain't right.

I have not contacted HP because past experience with them seems to always result in a communication problem, and it takes being referred to 2 or 3 people to ever reach a solution. I thought I would try this forum first. Any suggestions?

A:Printer error messages when printing is working fine

I have the same printer. The error I get is " the print spooler didn't lode", but like yours, it prints fine.

Read other 4 answers
RELEVANCY SCORE 54.4

I am using windows 7 and error 561 keeps coming up on home computer, wifi is working fine with other devices connected any help would be greatly appreciated
 

A:windows 7 error 561 wifi working fine with other devices con

http://answers.microsoft.com/en-us/...7/65077414-15f8-450b-bd19-5cce9a57fcf0?auth=1

Maybe one of the solutions will work.
Read both pages of the thread and try what seems to be the easiest solution to you.
 

Read other 1 answers
RELEVANCY SCORE 54.4

Hi,
I have a monthly report I run which outputs single sheet "Invoices" from my workbook that is populated by a months worth of sales. The macro goes through a list of names, pulls the details for that person, populates the pivot table on the invoice,
then saves as both a single excel sheet and a pdf. up until today it has worked fine. the code is, and the error occurs when it reaches the date line. It states "Compile error, can't find project or library":
Sub Save_Sheets_To_New_Books() 'INVOICES
Const strWbPath As String = "D:\Accounts\EA Letters\2020 09 September\"
Dim strDate As String 'todays date
'save the sheets to new books within the active folder and print them
Application.ScreenUpdating = False
Application.Calculation = xlCalculationManual
strDate = Format(Date, "yyyy.mm.dd")     '(Date, "yyyy.mm.dd")
THIS IS WHERE THE ERROR OCCURS the word DATE is highlighted
ActiveSheet.Copy
Call DeleteNamedRanges
Call PrintAreaAndPasteSpecial
ActiveSheet.ExportAsFixedFormat Type:=xlTypePDF, FileName:=strWbPath & Name_of_Artist & "_" & strDate & ".pdf" _
        , Quality:=xlQualityStandard, IncludeDocProperties:=True, IgnorePrintAreas _
        :=False, OpenAfterPublish:=False         
ActiveWorkbook.SaveAs FileName:=strWbPath & Name_of_Artist & "_&quo... Read more

Read other answers
RELEVANCY SCORE 53.6

Hey,

I've been doing some online gaming (world of warcraft), and I kept getting these Error#131 issues. This would cause the game files to become corrupted and then I would have to repair, or reinstall. The WoW tech site says that chronic error #131 messages are either a Hard drive, Ram, or Motherboard issue.

Running the Windows Vista memory diagnostic tool has turned up some odd results, the initial test with a 1gb stick in slot #1 and a 1gb stick in slot #2 came back with errors. I then removed the ram from slot 2 and ran the test on slot 1 with 1 stick of ram.... no errors. I did the same with the other stick in slot 1.....no errors. this lead me to believe that it was slot#2 giving me the issue so I moved the ram from slot 2 to slot 3, thus having 1gb of ram in slot 1 and 1gb of ram in slot 3. After a little while......error#131 appeared.

So I then tested both sticks in slots 1 and 3 together and came back with ram errors, I then tested both sticks in slot #1, and then again in slot #2 and both tests came back fine. Any ideas on what this issue could be? I know both sticks are the same brand, speed, totally identical.
 

A:Ram Works fine in single sticks, not working fine together :P

Read other 10 answers
RELEVANCY SCORE 50.4

Hallo.
I have a failed HDD.
In the past I have usually been able to help myself to at least retrieve any data from the HDD.
But this time the problem seems to be different. If it has any bearing, this is the first time since upgrading to Windows 7 and operating for I can't remember how long, since without any issues.
As I always have in the past, this HDD is formatted with a separate partitions (1) for the OS and program files, and (2) for my data. This has usually this been enough to retrieve my data by installing the drive in a second Thinkpad using a second HDD adapter and retrieving the data. These days I also keep most of my data on a NAS but I do have some folders on a D:\ or Data drive which I would like to retrieve.

This time however I cannot even 'see' the drive at all. Not when I try to boot from it, or as a second HDD using an adapter. It is not even visible under Disk Management in case it needed to be initialized (again?) So this time, I seem stuck, unable to help myself:

In the first instance, I get the Error 2100: HDD0 (Hard Disk Drive) initialization error (2) when booting from the drive.
When I press ESC to continue, the computer tries to initialize the HDD or something, and from memory, I think displays an 'unable to boot from any device' screen and shows the status for the devices without any operating systems.

When I try the same with the affected HDD but this time with an installation disc inserted, I do not see the 'Press any key to boot from CD or DV... Read more

Read other answers
RELEVANCY SCORE 50.4

Hi ,
This morning when i was browsing on my W510, all of a suddent the pc got hanged and restarted.

and showed a messge : Hard drive error 2100: HDDO initilization error (1)
I hard restarted the pc and ran hard disk drive diagnostics program. and results were pass for both "controller diag" and "read verification and speed test "

After restarting the windows normally, the pc is working fine, May I know why this error is caused.
Are there any problems with my hard drive. please help.
I have attached the system information .
Also please let me know, these errors occur only because of hardware errors or this might happen even due to software issues.


Regards,
Vijay.

A:Hard drive error 2100: HDDO initilization error (1)

Quote:
Initialization error on HDD0 (Main hard drive)
Reseat the hard drive
Main hard drive
System board



source

Read other 4 answers
RELEVANCY SCORE 50

Hi,

I'm trying to restore my Presario 2143AP using the Quick Restore CD's that came with it but it keeps shutting down. Initially this was happening on the first CD but I have managed to get it to the end of that one and then it shuts down as soon as I put CD #2 in. If I try rebooting from #2 it says no operating system found. OS is XP Home.

Any ideas would be great.

Thanks
 

A:Solved: Quick Restore CD's not working on Presario 2100

Just kept trying and finally got through all CD's and it appears to be working OK now. Not sure why...
 

Read other 1 answers
RELEVANCY SCORE 50

I have an x1 carbon 4th gen. I bought my laptop and upgraded the hard drive to the samsung 950 pro. Unfortunately, my laptop does not seem to recognize the new SSD. Can anyone help me here? I am extremely frustrated to be honest and I have no idea what to do. Thanks.

Read other answers
RELEVANCY SCORE 50

Hi have a problem with my x61s.Two days ago the computer started doing weird things under vista. I had to make a hard reboot. Since, vista never boot up. The hard drive is not even seen by the bios. And I have a "Error 2100 - Hard drive initialization error".I went on google to find a solution and I found this :http://www.gottabemobile.com/CommentView,guid,32b17bc1-db16-4f37-a4c4-f40e53d37342.aspxBut (there is a but) the solution I found only works for Hitachi/Fujistu/Toshiba, and my hard drive is a Seagate...http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-63685The problem seems common. I'm a bit disapointed, as I used the laptop for a week... I did no backup, and I'm afraid I've lost a whole week of work...If any one has an idea ...

A:"Error 2100 - Hard drive initialization error"

No one has an idea ?...

Read other 9 answers
RELEVANCY SCORE 49.6
RELEVANCY SCORE 49.6

Buenas tardes, desde ayer que me aparece el error 2100: Detection error on HDD. ¿ué tengo que hacer? El portátil (model L480) aún está en garantía. Gracias

Read other answers
RELEVANCY SCORE 49.2

Hi there, i have laptop Lenovo laptop which getting 2100: Detection error on HDD0. Does it means that my HDD gonna die soon? Or the machine as other problem which related to HDD 2100 error? What is the solution?
 

Read other answers
RELEVANCY SCORE 48.8

When I boot up from an ssd I purchased recently (so fresh install) it freezes during the startup logo sequence and goes into startup repair. After failing to repair the startup it gives these error messages-


Problem signature:
Problem Event Name: StartupRepairOffline
Problem Signature 01: 6.1.7600.16385
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: unknown
Problem Signature 04: 1
Problem Signature 05: autofailoever
Problem Signature 06: 1
Problem Signature 07: BadDriver

I've actually never managed to get it to work on my laptop- I had to install windows using my desktop due to it being the only machine with a disk drive I had access to.


The only drivers that were installed on the drive were the appropriate video driver and a driver for the drive itself, which windows downloaded and installed automatically.

A:Windows not booting from SSD on laptop, fine on desktop

If you installed WIn7 on the Desktop and want to move it to the laptop it requires SysPrep to move HD to another computer.

You can also install to the laptop using a flash stick. Extract the ISO image file from the disk using ImgBurn and write it to flash stick using UltraISO Software To Create Bootable USB Flash Drive.

Use the same steps as here to get a perfect Clean Reinstall - Factory OEM Windows 7.

Unplug all other HD's and peripherals during install. Plug only the SSD into SATA port 1.

Read other 1 answers
RELEVANCY SCORE 48.4

How to fix it? Been reading all the problem here but it didn't help me. It suddenly happen when I try to power on the Laptop. Been using it for 2 years this only happen now please help.

Read other answers
RELEVANCY SCORE 48.4

Hello,I have 1 gen x1 carbon laptop and I bought this adapter: https://www.newegg.com/global/il/Product/Product.aspx?Item=9SIAFK56SH2976 but when I connect it to the laptop I recieve this error: "2100: detection error on hdd0 (main hdd)".I have this ssd: https://www.newegg.com/Product/Product.aspx?Item=N82E16820168038&cm_re=2242-_-20-168-038-_-Product and the laptop doesn't recognize it. Do you know why?

Read other answers
RELEVANCY SCORE 48.4

Hello, yesterday my thinkpad t4700 booted with 2100 error. Is using a samsung nvme 250gb ssd. Here in Argentina the nvme drives are very expensive. Is an m.2 sata 2280 compatible with the adapter that come with t470? A ssd like  GREEN M.2 240GB ? the pins seems different buy i read that they are compatible (but slow). Thank you

Read other answers
RELEVANCY SCORE 48.4

Hello all. I've got a user who's T430s just goes to the ThinkPad logo and then after several seconds moves on but never gets to loading Windows. We just get 2100: Detection Error on HHDO. I had another T430s so I swapped drives. Now the T430s that wasn't booting boots fine. So I assumed the hard drive was going but the odd thing is that the 2nd T430s which now has the "problem drive" in it doesn't give me the 2100 error. The catch is the drive is encrypted with BitLocker and no combo of passwords or finger swipes will let us proceed. So my dilemna is I can't tell if this drive is bad because I can't see it. I ran Lenovo Bootable Diagnostics and they said they couldn't scan because it was encrypted. I put the drive in an external dock and connected it to a Windows 10 system and the drive doesn't show up under the Bitlocker to Go section. Is there any way to tell if this drive is completely done? It would be great to get data off of it but I can't seem to find a way. Everything I find seems to require a drive letter and this drive has none. Even booted into a live Ubuntu with the drive in the laptop and it wouldn't see it. Thanks all. 

A:2100: Detection Error on HHDOcan

A lot of people have had this issue with perfectly good drives, and some have said they resolved it by going into setup, and then saving settings upon exit.   Others have said that by pressing F12, entering the boot menu and selecting the HD will let it boot as well.    Another said that by changing from SATA to Compatibility in the BIOS, restarting and then setting SATA back to AHCI will force a reset of the drive so it will boot too. Not sure if any will work for you, but you might put the drive back in the original system and give it a try (if you have not already anyway). I did see also where Amy_Lenovo posted in the same thread that a fix was found for the X250 ThinkPads, but that it required the system be sent into Lenovo.

Read other 1 answers
RELEVANCY SCORE 48.4

I bought a X1 Carbon 3448-B86 G1 without a HDD. I bought a SSD HDD on ebay fru 45n8297, which physically suits. When I start I get this message. Is there any kind of initiation I need to do with the HDD?

A:Error detection HDD0 2100

There is nothing extra that needs to be done.  Try re-seating the drive but it may be defective.

Read other 1 answers
RELEVANCY SCORE 48.4

Hey! I have a Lenovo Thinpad R61i laptop and when I turn it on I receive 2100: Detection error on HDD0 (03). I reseted the BIOS and I've extracted the HDD and tossed it again. No solution! I need to power off it 2 times before it enter the Windows. Please help me!

Read other answers
RELEVANCY SCORE 48.4

The storage in my ThinkPad P51 is configured as follows:1TB SSD in the first M.2 slot (came with the Laptop)500GB SSD Samsung 960 EVO in the second M.2 slot1TB SSD Samsung 840 EVO (MZ-MTE250BW) in the 2.5 Sata slot (with an Eluteng mSata to Sata adapter)I'm not sure if it started happening just after installing the 960 EVO in the second M.2 slot or after some time, but when I turn on the machine in the morning (after a shutdown), I get the "2100: Detection error on SSD1 (M.2)" error.By simply turning the machine off and on again it boots correctly and everything works fine.BIOS version is 1.17 but it happened also with 1.16.

Read other answers
RELEVANCY SCORE 48.4

I have Lenovo Thinkpad X250 with SSDI bought it 3 years ago All of sudden i'm getting an error 2100: Detection error on HDD0 and is unable to boot I tried replacing drive with other working SSD from my friends laptop and tried my old HDD, still same errorReplaced ata cable and updated BIOS to latest version using hiren's boot CD and resetted BIOS, still same error I assume the motherboard is bad right?

Read other answers
RELEVANCY SCORE 48

Whenever I try to restart my ThinkPad T440s, it takes a very long time to get past the "ThinkPad" screen.  If I hard reboot it while it's stuck here (press and hold the power key, then turn it back on), it loads just fine.  However, if I let it keep going it beeps loudly and angrily and gives me the 2100: Detection error on HDDO (Main HDD) on a black screen with only "Press Esc to continue".  When I press Esc it loads the boot screen, but without access to my hard drive.  If I hard reboot it again, it starts just fine. Any ideas on why it would be doing this, or what I could do to fix it?  It looks like it was a common problem a few years ago, but this is new to me and it doesn't really look like there was a fix back then.  Hoping there's better news now? Any help is appreciated!

Read other answers
RELEVANCY SCORE 48

I have a Lenovo ThinkPad Yoga, with a 256GB SSD and an i5 processor. I received it on April 29. After two weeks of normal use, it crashed and gave this error:?2100: Detection error on HDD0 (Main HDD)?I could not get it to boot. I took it to a computer repair shop and they (Lenovo warrantee) replaced the SSD. It worked for about a week, then crashed again, same error. My tech guy said that it might be a bad board, frying hard drives; but Lenovo insisted on replacing the hard drive again. Ten days later, same crash. I unplugged it and put it on a shelf for the weekend, intending to take it back to the shop. Monday morning I plugged it in and it started up normally. It has been working normally for three days, but I am worried about getting the same error and crash. Can you tell me what might be happening, and if there is anything I can do to prevent a recurrence? This seems to be a common problem across many machine models, but I haven't found any solutions to it.  










Solved!
Go to Solution.

A:2100: Detection error on HDD0 (Main HDD)

The connector or the data controller board could be shortcurcuiting the ssd.

Read other 9 answers
RELEVANCY SCORE 48

I have lenovo thinkpad p51. yesterday , i wanted to add a ssd on it. Firstly, i tried to add ssd0 slot  then i got error code 2100 after that i tried to ssd1 slot but this time i got error code 2104. Ssd was work well what is problem? On ssd slots? Im not happy with thinkpad laptop

Read other answers
RELEVANCY SCORE 48

Hi, I bought my P50 like 4 months back and suddenly it has started to throw this error when the machine is starting up."2100: Detection error on SSD1 (M.2)". I have run the tests in BIOS mode and all the tests got passed. I have faced the error 2 times now and after keeping the machine down for few minutes and switching back on resolved the issue. But I can't be sure it will solve the issue next time.Just bit of a background to the error. I have started my machine this morning, and from Windows login screen machine sudddenly restarted saying "DPC_WATCHDOG_VIOLATION". And on the restart I got the error. I do have a feeling that this not related to actual hardware, but firmware etc.  Any ideas would be highly appreciated. Thanks.Jaliya

Read other answers
RELEVANCY SCORE 48

when this error pops up the only thing that is noted as [failure] is my media how do i solve this problem 

A:2100 detection error on HDD0 [mainhdd]

Hello ryuyankataso, welcome to the community,
 
could you maybe post which Lenovo notebook you have as this will help members to assist you best.  Quite often this error wil indicate that a hard drive has failed but can also mean that it has jogged loose and just needs removing and replacing.

Read other 2 answers
RELEVANCY SCORE 48

Hi,i have thinkpad t570 purchased since Juin 2017.i start received error 2100 Detection error, after this i can't see Storage DISK ( SSD or HDD) in BIOS or Lenovo Diagnostic tools .my ssd or hdd disk is connect using ThinkPad T570 m2.5 Hard Drive Connector Cable 01ER034 450.0AB04.0001 . when i connect disk using USB port, computer reboot normal in this disk without any issues can somone help me to resolved issues ? can the problem in this cable ThinkPad T570 m2.5 Hard Drive Connector Cable 01ER034 450.0AB04.0001  ? Thanks

Read other answers
RELEVANCY SCORE 48

Hi all,i am discovering the same problem as most people here.I have an expensive Yoga Thinkpad 12, about 2000,= euro's in januari 2014, warranty endded in januari 2016, my extra 3rd yr warranty i have bought is missing by Lenovo (i forgot the registration but in the mean time i have send the supportdesk from Lenovo al the documents including pincode from the card) and now they say de extra warranty was canceled and / or credited. Nothing of that. poor service for such a great brand.But now my problem. about 3 weeks ago all of a sudden my SSD stopped and generated this 2100 error. It's a Samsung M27TD256 from the same series as Lenovo mentioned. Because of Lenovo's attitude of not servicing (Oh yes the supportdesk guy said SSD Failure, needs to be replaced for new) i went on to the Internet how to open the machine and without any damage that was no problem. I have a computer repaircentre myself and i tried to replace te Samsung SSD with: a 120 Gb Kingston SSD / a 240 Gb Kingston Fury SSD / an Intel 120 Gb SSD. All brand new, right out of stock, non will work !!!So i took the old original SSD, tested it in another PC and it works perfectly, i could install Win 10 and boot from it.I put it bak in the Yoga... nothing. the 2100 error again.So i thought it would be the mailboard or controller but curious a i am, i took an old 250 Gb harddrive, no SSD and guess what....... The Yoga booted up without any error messages, external DVD connected and i could install an OS (whatever, Win8... Read more

A:2100: Detection error on HDD0 (Main HDD) Where is ...

I had the same problem on a S230U Lenovo Twist. I replaced the MB and the HDD and the HD connector/controller and had the same problem. By accident, as a result of testing I installed the HD without the bracket that holds it in place. Voila it has not failed once since then. It has been running flawlessly for 2 months or more now. I havent bothered to reinstall the bracket since it is running great. There is almost no extra room in the HD compartment so I am not worried about it flopping around. Only thing I can figure is there is some kind of static buildup with the bracket installed. I tried bending the bracket to see if I could make it contact the MB to discarge static if that was the case. No good. Removed the bracket, and it worked immediately. I don't know if that will work for you but it worked for me.

Read other 1 answers
RELEVANCY SCORE 48

Bought T580 with 512GB SSD 2 days ago. Yesterday and today it had this error above. Please advise. Running diagnostic did not resolve. Please help. Thank you.

Read other answers
RELEVANCY SCORE 48

Bonsoir,Je me présente Benoît. J'ai reçu hier mon X1 carbon gen 5th 2017 avec le ssd de 1To.Ce matin en redémarrant Windows, j'ai eu l'erreur suivante: 2100 Detection error on Storage Device (M.2)J'ai lancé le lenovo Diagnostic tool, cela a duré plusieurs heures pour me sortir le "Final Result Code" : U1ELMZF71-V895J9Inutile de vous dire que je trouve ça intolérable sur un pc à ce prix ! C'est mon premier Thinkpad et ça commence très mal !Si quelqu'un a eu ce problème, qu'il puisse me donner les démarches à faire, je ne sais d'ailleurs pas comment contacter le service client par mail, la page web est indisponible ...Je joins les photos d'erreur et du diagnostic tool.Merci d'avance,Cordialement,Benoît


























P70520-183733.jpg ?5297 KB

A:X1 Carbon 2017 gen 5th 20HR ERROR 2100 (M.2)

Error 2100 ...


























P70520-184758.jpg ?5952 KB

Read other 1 answers
RELEVANCY SCORE 48

hello.  I have a E540 laptop with a ssd.  Recently I have gotten this error when starting up my computer : 2100 detection error on hdd0.  To get past it I have turn off and on the laptop multiple times.  Does anyone have a fix?

Read other answers
RELEVANCY SCORE 48

Hi after installing the fw Update  update for the hdd controller offered by lenovo vantage driver support automatically my x1 Carbon Touch fails to start with error above. it starts very slowly, i can get access to bios after est 10 minutes. I tried to clear tpm chip, no change. Wht can I do? This is a business notebook and I need it for work very urgent. best regards ralf    

Read other answers
RELEVANCY SCORE 48

Currently have a X1Y3 that is on the fritz. Just (1 month) outside the warranty window.  Exhibits the following symptoms:2100: Detection Error on Storage Device (M.2) about 25% of the boot time.USB C/Thunderbold issues (see: https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Yoga-3rd-Gen-Glitch-causes-cascading-issue...). System tray icon disappears and reappears rapidly and continuously. USB-C charging port indicator stays illuminated even when unplugged, along with other issues.Myriad of BSOD with different error codes. Unpredictable in timing - sometimes immediately after boot, other times when under loadNote that I always kept firmware and software updates current (checked at least twice weekly). It seems like this may have occured after an update, though that's anecdotal and will have to confirm after retrieving the computer from the tech. If not, then it sounds like the mainboard on this expensive, 1-yr old computer may have gone on the fritz. Something that will cost almost the price of a new computer to replace...  Any suggestions?

Read other answers
RELEVANCY SCORE 48

Receiving the following error upon boot:2100: Detection error on SSD1 (M.2)Resetting boot options to default from bios and cycling boot resolves issue. The issue persists on next boot cycle.I've never changed boot settings away from defaults, and the firmware is up to date. Are there any solutions that don't require SSD replacement or mailing my machine in for repair? Thanks.

Read other answers
RELEVANCY SCORE 48

Good day dear forum members! My brand new X1 Carbon arrived fully loaded......with errors. Right out of the box it hit me with a BSOD (CRITICAL_PROCESS_DIED). The system boots from the second attempt, but BSOD pops up every 5-10min. All drivers/BIOS updated. 1TB Samsung nvme ssd (PM961 f/w3L0QCXY7) seems to be using a driver dated 6/21/2006 and so does its "Standard NVM Express Controller". Samsung nvme driver cannot be installed because it claims there's no suitable ssd, Samsung magician doesn't recognize the drive either, however, it is properly identified in the device manager. Any suggestions before I ship this back..? Any help appreciated.
 
Moderator note: post edited to comply with Community Guidelines

Read other answers
RELEVANCY SCORE 48

Hello. Today had this problem, trying to load my laptop. I have wd 320 GB (ATA, HDD). Reseted hdd multiple times, reseted BIOS to standarts, tryied to use recovery from BIOS - no result. Also coudn't find explanation what does (3) and (2) means. Hope, there is a solution. Thanks.

Read other answers
RELEVANCY SCORE 48

Hi,  I need to upgrade the firmware of the SSD and when I put the SSD in Lenovo laptops in ROM mode. I get the following error "2100 Detection Error on HDD0" as disk can't be read.  After this it asks me to press "ESC" to continue. I want it to go to PXE boot when the DISK failure is found as I push OS in the RAM and then treat this disk as secondry (SSD) and then recover it.  My boot order is set as :: SSDPXE  Can some please help how can I avoid getting in the Press ESC to continue and make machine reboot automatically? By the way its 440P lenovo machine I tried this stuff on. Any help is appreciated. Thanks-Vishal

Read other answers
RELEVANCY SCORE 47.6

Hello. I got this error each time after hard reset, or any non-standard unexpected poweroff."2100: Detection error on HDD0 (Main HDD)". I found workaround how to boot: each time in this situation i press F10 to load Diagnostic Utility at boot time, then see error message, press ESC to continue booting into diagnostic utility, and here I already see my hard drive. So just do nothing, quit from utility to restart laptop. And now it see hard drive and boot as usual. BTW, if I boot from USB flash drive, and do hard reset, it throw same error but for m2 SDD instead of sata HDD0. I have stock WDC WD10JPVX-08JC3T5 hard disk and stock SanDisk SSD U110 16GB.Model of laptop Lenovo ThinkPad T440p 20AN0030RT. BIOS GLET83WW. All with lastest firmware (respectively 05.01A05 and U21B001). Latest updated BIOS (2.37). Please, suggest any appropriate solution, because I can't figure out this by googling by myself.

Read other answers
RELEVANCY SCORE 47.6

I am having a Lenova Yoga thinkpad laptop (Lenovo yoga 260).When I start my laptop, it shown: lenovo 2100 detection error on storage device (m.2) How can I solve this?

Read other answers
RELEVANCY SCORE 47.6

Today, when i power on my laptop - T470 - Windows 10 1809. I received the problem "2100: Detection error on storage device "Few day ago, i installed a lot of update, which you can see in my pictureupdate historyPlease help me resolve my issue.Thanks!

Read other answers
RELEVANCY SCORE 47.6

Hello everybody, I know that there are some other posts with this error message. But they all appear on other devices and none of them has a solution which is working for me. I got a T430s back from one of our users which showed this error (mentioned in subject) when booting. I had no no chance to enter BIOS too. 1. I copied all partitions to another SSD and replaced it => the error came up again after few days=> so I thought it must be an hardware issue concerning the internal SATA-connector2. I put the SSD in a completely new device and ordered a replacement of the mainboard because there was waranty left on the older device.3. Yesterday they came and replaced the mainboard of the older device.4. Today the user came back with the same error on the new device with the new SSD In every case it helps to remove the SSD one time and insert it again - then the SSD is detected correctly - until the error appears again after few days of usage. The only thing I did not try until now is to insert the SSD in the old device with the new mainboard. Before I forget this: BIOS is Ver. 2.52 (I see there is 2.54 available since few days, but change log does not say something important - gonna check that later and post it) Any ideas? Thx Martin

A:T430s - 2100: Detection error on HDD0 (Main HDD)

check with the OEM of the SSD drive. You did not mention the Make/model of the SSD. Maybe there is a firmware update for the SSD drive. Especially since the 430 has SATA3 interface.If its not hardware you'd need to assess what you're doing software wise in the "copied all partitions ot another SSD..." I have found out cloning can cause problems and partitions become misaligned. When I went ahead to fix the misalignment with Mini partition Manager it corrupted the registry and so other files. Various applications cannot be updated or uninstalled. I have to reimage it and not clone from the source to get it right.A quick test is to just to a base install on one of the SSD's (EG Windows 7) after purging all the partitions. Letting the OS configure, partition & format the NTFS drive. If it works after that then its not the hardware and a software issue.My thoughts anyway.





T520 Model 4239 Intel(R) Core(TM) i7-2860QMbr>; Nvidia NVS 4200M Win 10 64bitZ70-80 I7 - 5500U 16GB GB - 1TB HD Win 10 64bit FHD 17.3", G840 w/2GB

Read other 9 answers