Over 1 million tech questions and answers.

P50 rear thunderbolt port (usb-c) not working after Windows 10 driver update for Fall Creator

Q: P50 rear thunderbolt port (usb-c) not working after Windows 10 driver update for Fall Creator

Read other answers
RELEVANCY SCORE 200
Preferred Solution: P50 rear thunderbolt port (usb-c) not working after Windows 10 driver update for Fall Creator

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 102

After Windows 10 Fall Creator Update (1709) through Windows Update, my ThinkPad Yoga X1 (Gen1) have issue with driver - Intel(R) Management Engine Interface , latest driver 11.7, ,This device cannot start. (Code 10)STATUS_DEVICE_POWER_FAILURE In Windows Event log it says something about firmware connection not good (firmware of ME is also at the latest) Tried install / uninstall, delete driver, etc. no progress, same issue. Any idea? Thank you 

Read other answers
RELEVANCY SCORE 99.6

After Windows 10 Fall Creator Update (1709) through Windows Update, my ThinkPad Yoga X1 (Gen1) have issue with driver - Intel Wireless AC 8260 This device cannot start. (Code 10)   Tried install / uninstall, delete driver, etc. no progress, same issue. Any idea? Thank you

Read other answers
RELEVANCY SCORE 90.8

Is it possible to use this port as a simple USB 3.0 port ... no Thunderbolt?  USB-C to USB-3.0 adapters are readily available, and this would provide an extra (3rd) rear USB port; useful when the dock isn't there and extra USB ports wanted.

Read other answers
RELEVANCY SCORE 90.4

Tried to upgrade from Windows Update as well as using the Media Creator Tool by downloading from the Microsoft website, neither of them works. In the end, I got an error code "0xC1900101 - 0x20017", and a message "The installation failed in the SAFE_OS phase with an error during BOOT operation." I have every driver and OS software updated to-date. I do have Ubuntu installed as a dual-boot OS and Macrium Reflect configured as a recovery software from the boot, which might have caused the problem. I encountered this issue a while ago with the Spring Creator Update (see here), and I fixed it by deleting the Ubuntu booting partition, which I definitely want to avoid! I searched on Google, similar issued happened for HP laptops and was related to the BIOS driver. Does anyone know if this issue is related to the Thinkpad BIOS setting or something we have to wait for Lenovo to fix? Any solution to this issue? Thanks.





-----------------------------------------------------------------------------TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win 7/8.1/10, Ubuntu8.04-16.04.

Read other answers
RELEVANCY SCORE 90.4

T460p here. After I updated my Windows 10 to Fall Creator Update - Lenovo System Update Shows 11 Updates that are already installed - so it want's to install the same drivers over and over again. Probably a bug. Anyone with the same experience?

Read other answers
RELEVANCY SCORE 89.6

Is there a target date for the Lenovo Thinkpad x131e being compatible with the Windows 10 Fall Creator Update (version 1709)?

Read other answers
RELEVANCY SCORE 89.6

my 320-15IKB (Type 80XL, 80YE) Laptop (ideapad)   type 80XL00HVADafter i make computer reset always make trouble , windows update error message "There were some problems installing updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information, this may help: (0x800705b4) "and when shutdwon or resart take about two hours to work again and i tried to stop update service and rename softwareDistribution folder give acces is denied till i change permission ,  

A:windows 10 Fall creator 1709 update fail

Fiablecleantech stands tall as the reputed Supplier of a defect-free product range. The variety of product Housekeeping Tools Provider, dustbin and home carpet in the reasonable prices.http://www.fiablecleantech.com/


























fjj.PNG ?247 KB

Read other 1 answers
RELEVANCY SCORE 89.6

I was previously running the Window 10 spring creator's update without issue on my Yoga 910. However, after the fall creator's update (1709) the fan is VERY loud when plugged into AC power. When running on battery, it's whisper quiet. All BIOS/Software/drivers are up to date, and I've rebooted numerous times. Power mode slider is set to either all the way to the left (power saver) or one notch to the right. At times with the high fan usage, the system seems bogged down and very slow to respond to keystrokes. Task manager doesn't reveal anything super obvious using high CPU time.  

Read other answers
RELEVANCY SCORE 88.8

As no-one seems to have an answer for my dual display-problems with the P50 and workstation dock, I now have a (hopefully) simple question: Is the rear P50 Thunderbolt 3 port active while the computer is docked? I wonder if I can use the StarTech Thunderbolt 3 to dual displayport adapter, and connect my two displays to this, using the dock only for USB and LAN connections. I hope someone can answer this, as I'd rather not spend another $100 on yet another useless adapter.

Read other answers
RELEVANCY SCORE 88.4

Released: Sandboxie 5.22

Changelog:
----------------------
Released on 30 October 2017.
Windows Creator's Fall Update is now supported.

Made improvements to ForceFolder including adding support for "Open With" dialogs, and running registry files.

Fixed licensing issues causing MS Office applications to crash after 5 minutes [Microsoft Office 2013/16 - Cannot find your license [SOLVED] - Sandboxie Support].

Fixed Firefox/General Drag-Drop issues [Firefox crash when uploading pictures from outside sandbox - Sandboxie Support].

Fixed Save/Recovery issues for Adobe/MS Office [Adobe Reader DC Quick Recovery [SOLVED] - Sandboxie Support].

Fixed an issue in which Sandboxed Internet Explorer proxy settings would modify the registry on the host [IE Proxy Settings are getting out from sandbox [SOLVED Beta 5.21.4] - Sandboxie Support].

Added/Updated templates for AVG, BitDefender, Babylon and Opera.

Implemented code fixes to address "SBIE2101" issues caused by Windows Defender "App & Browser Control" in Windows 8.1 and 10 [If you are using the "Windows SmartScreen Template from Beta 5.21.7, you will need to remove it after installing Sandboxie 5.22].

Implemented a driver fix for a BSOD occurring when Webroot is installed and a new Sandbox is created while a ForceProcess is started.
----------------------

Download link: http://www.sandboxie.com/
 

A:Sandboxie 5.22 Released: Windows Creator's Fall Update is now supported

I am trying it out on fall creators update. So far, so good. With the previous stable version, I saw an error when running Internet Explorer as a forced app. But so far I don't see any issues.
 

Read other 0 answers
RELEVANCY SCORE 87.6

Hi. Few weeks ago i made bootable iso on pendrive USB Windows 10 Fall Creators Update.
Propably 16299.15 version if i remember. But i get issues.

I get a tons of WHEA LOGGER errors in event viewer:

A spam of: WHEA Event ID 19 CPU-corrected hw error

And only one : WHEA Event ID 47 memory-corrected hw error

Looks like this:



Temps of cpu fine,temps of gpu fine. Never had any single BSOD. Memtest86 no errors. All benchmarks passing, no crashing in games.

Only saw that errors in event viewer.

I tried to update to

KB4056892 ( 16299.192).

And it stopped throwing that errors after installing update on 22.01 :

https://support.microsoft.com/pl-pl/help/4056892/windows-10-update-kb4056892

KB4056892 ( 16299.192).

And i update to newest
16299.214
KB4058258
and still no errors.

https://support.microsoft.com/en-us/help/4058258

My pc:

8700K stock, MTE on, 4700mhz auto clock

Asus Z370 Pro Gaming

16GB DDR 3000MHZ ( XMP ON)

Gtx 1080 Ti Aorus

Corsair 750 Rmi

SSD Crucial 525GB

HDD TOSHIBA 500GB

Windows 10 clean install 1709 Creator Fall Update

All settings in UEFI are stock,defaulted . Only XMP profile is on.

Any clues why on 16299.15 i get hardware corrected errors?
 

Read other answers
RELEVANCY SCORE 86.8

Hello, Windows 10 fall creator auto update initialized & update failed multiple times. Requesting to pls confirm is it compactable with Flex 2-14D or tested. Problem is that, I'm unable to stop auto updated & post update installation failed, Its getting downloaded everytime. Why lenovo not prepared for such updates? Regards,VR No clear error logs as well.  

Read other answers
RELEVANCY SCORE 82.4

A few of the many reported problems:

Round-up of Windows 10 Fall Creators Update bugs: BSoD, high CPU usage, and more
 

A:Fall Creator's Update Problems

Well I figured that the "Activation errors" issue would crop up when a new update like this come out - my guess that many people would be doing the upgrade at once.

Blue Screen of Death errors on install: How many of those checked to see if they need to remove some software before the upgrade? Or rather do clean install.
 

Read other 1 answers
RELEVANCY SCORE 80

I upgrade from Windows 10 to Fall Creator's Update 1709 and Edge now crashes after boot.
Please be aware I have already performed the following tasks with no effect.

I've clicked the Repair button under the entry under Apps & Features -> AdvancedI've clicked the Resetbutton under the entry under Apps & Features -> AdvancedI've removed the entry under C:\Users\USERNAME\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe, rebooted:-
Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}
Crash report below:-
?Version=1
EventType=MoBEX
EventTime=131575696774264147
ReportType=2
Consent=1
UploadTime=131575696776104030
ReportStatus=268435456
ReportIdentifier=39ea479b-d7c8-4399-b2f3-e2dabfca429b
IntegratorReportIdentifier=f72fedfb-b5c7-46e3-9706-2c3d53ba8e03
Wow64Host=34404
NsAppName=praid:ContentProcess
AppSessionGuid=000030b0-0001-0007-f250-2a2b6673d301
TargetAppId=U:Microsoft.MicrosoftEdge_41.16299.15.0_neutral__8wekyb3d8bbwe!ContentProcess
TargetAppVer=41.16299.15.0_neutral_!2017//09//29:01:54:21!3d551!MicrosoftEdgeCP.exe
BootId=4294967295
TargetAsId=723
Response.BucketId=c954f1a443a84e0c27b6f2d79451eef1
Response.BucketTable=5
Response.LegacyBucketId=133562955607
Response.type=4
Sig[0].Name=Package Full Name
Sig[0].Value=Microsoft.MicrosoftEdge_41.16299.15.0_neutral__8wekyb3d8bbwe
Sig[1].Name=Application Nam... Read more

Read other answers
RELEVANCY SCORE 79.2

Hello,      After upgrading to the Windows 10 Creators Update (1703), the HP Accelerometer driver does not work properly.     I have tried to reinstall the HP 3D DriveGuard Software (ver 5.2.2.1) on the ProBook 6570b product support website (http://h20565.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=5212928&swLangOid=4&swEnvOid=4192), but it still does not help solve this problem.      Could you please help solve the issue? Since the 3D DriveGuard feature is necessary and critical in my daily work.     Thank you !  

Read other answers
RELEVANCY SCORE 79.2

Hi all. I having a problem with Win 1709 update since december 2017. My system (Win 10 Home 64 bit, ver 1703, OS BUILD 15063.850) is crushes (see attached screenshot) during the installation. I tried to install it multiple times. I also asked for help from MS support, but they killed my system so I had to reinstall it. I also tried following: Windows Memory Diagnostic Tool (mdsched.exe) -> no issues have been foundUpdate your BIOS -> there are no updates for my modelCheck and Repair Windows System Files (sfc /scannow) -> evrything is OKIChange power settings to High Performance -> does not helpTrobelshoot > Windows Update > Run The Trobleshooter. This one fixed some problem with "Service registration is missing or corrupt"Scann for viruses with Windows Defender. The blue screen of death shows stop code MEMORY_MANAGEMENT, not sure what else I can do in order to solve this issue. Thanks.


























IMG_20180113_122946.jpg ?809 KB

Read other answers
RELEVANCY SCORE 78

I updated my OptiPlex 7050 to the Fall Creators Update 1709 and my HDMI port has stopped working.  I'm running a dual monitor system, one monitor is using the display port and the other is using HDMI port.  After the update the port just stopped functioning. 
Here's what I've tried:

I've tried three different monitors
Tried three different hdmi cables, plus one HDMI to display port
Flashed the BIOS
Installed the latest display drivers from Dell

As soon as I roll back the update, everything is fine.  To stop Windows to keep trying to update, I've set the branch readiness level to "Current Branch for Business" and deferred it for 365 days. 
Is anyone else having this problem? 
I'm in No hurry to install this update! 

Read other answers
RELEVANCY SCORE 76.8

All was well until creator update hit. My desktop icons do not display and there is only one screen identified as 1|2. Turns out I don't NEED the port replicator on this new laptop - I have enough ports on it to make it all wok so I want to get rid of the replicator. I uninstalled the software (displayLink and the HP port replicator stuff) and I still have this nonsense:I have also tried to create a new item with the right click menu and it got created because it is on the desktop  but nothing is showing on my desktop on the screen.I think that there is some problem with display mapping and the default desktop.How do I get all this straighened out? 

Read other answers
RELEVANCY SCORE 74.4

Hi, I have a P50 recently updated Windows 10 Fall creators update. After the update I no longer have a cellular connection option in the network menu after clicking the network icon in taskbar tray. I also have no cellular connection section in the networking settings. Device manager no longer lists Sierra Wireless device under the Network Adapters category and there is ther is no longer a cellular connection shown in the network connections control panel under network and internet. What does show up is a Sierra Wireless Location Sensor in the device manager under the sensors category type.What does show up in device manager is a 'Sierra Wireless Location Sensor' under the Sensors category.I did try to install the Sierra Wireless softwar from here: https://forums.lenovo.com/t5/forums/postpage/board-id/tp07_en. But it didn't help.I do not know if any of this has to do with the recent FCU of W10.Any help is appreciated, Thanks.

Read other answers
RELEVANCY SCORE 73.6

For whatever reason, the Windows FALL Creators update was just launched to my Yoga 3 Pro and now I cannot use my touchpad. I have checked and it is enabled. I have tried multiple fixes I've read about online and nothing has worked so far. Looking for any and all suggestions.

A:Touchpad and mouse not working after Windows 10 Fall Creators update!

I just discovered this: 


























Capture.JPG ?90 KB

Read other 1 answers
RELEVANCY SCORE 72.8

Hi - I read through these forums and see a lot of people have problems updating to the latest Windows 10 version (1709) - even on newer models. I was wondering who has the oldest Thinkpad/Lenovo model running this latest version of Windows 10 - fully functioning. Myself, I have a Thinkpad T43 from 2005 running Windows 1709 great - everything is working but of course it is not fast! 

Read other answers
RELEVANCY SCORE 72.4

Hi, I need more informations about Windows 10 Creator update. My laptop, HP Envy 15 k-257ca have all driver for Windows 10 anniversary update but none for the creator update. The laptop is not on the supported list for the Creator update but was there for the anniversary update. I know Microsoft support each build for Windows 10 only 18 month and afterward, no security update. I bought the laptop in 2015, does this mean that my laptop will be only good for the trash after that ? It's a very short life for a laptop... Thanks

Read other answers
RELEVANCY SCORE 72.4

Hi, I have a P50 recently updated Windows 10 Fall creators update. After the update my system no longer shows my wwan hardware (Sierra Wireless EM7455).I no longer have a cellular connection option in the network menu after clicking the network icon in taskbar tray,no cellular connection section in the networking settingsNo wwan device in Device Manager under Network AdaptersNo cellular connection shown in the Network Connections control panel under Network and Internet. What does show up in device manager is a 'Sierra Wireless Location Sensor' under the Sensors category.I did try to install the Sierra Wireless softwar from here: https://forums.lenovo.com/t5/forums/postpage/board-id/tp07_en. But it didn't help.I do not know if any of this has to do with the recent update on Windows 10 but if anyone else has experienced this please share your situation and solution if any.Any help is appreciated, Thanks.

Read other answers
RELEVANCY SCORE 72.4

Battery keeps charging despite any number i put in... this is not working! (x260)

Read other answers
RELEVANCY SCORE 72

Hi,

I have recently been pushed the Windows 10 Fall Creator Edition (Build 1709) and after installation I cannot get any HDMI output (connected to an Acer S240HL screen) - I see an "input not suppoorted" message on the Acer monitor. If I roll back to a pre-1709 build the display works.
I have the Intel HD 620 Video driver 22.20.16.4799 installed, although I also rolled this back to the current version on the Dell site (Intel-HD-Graphics-Driver_1H6KX_WIN_21.20.16.4627_A04.exe) before a second attempt at a reinstallation of Fall Creator.
Has anyone seen anything similar, or a workaround?

Read other answers
RELEVANCY SCORE 72

So I am trying to update my USB 3.1 driver to enable me to switch over to the new TB16 dock.  I did an update to the current bios for the 7370 but I still can't get the driver to update from the old version (15.2.30.280) to the new version (16.2.55.275).  It fails out every time.  I've tried with the dock unplugged and plugged in.  I've tried uninstalling the old version just installing the new version.  No go with that either.  I've tried doing it from the dell command update, direct download from dell and direct download from intel.  Again no luck.Any help would be greatly appreciated!

Running windows 7 64-bit pro

Read other answers
RELEVANCY SCORE 72

I have Intel D945GCPE motherboard (integrated sound card) running Vista Ultimate x32.
It has two front and three rear audio ports.
I want to use Creative 4.1 speakers but cant figure out the right audio driver.

i've run XP on same pc with 6 channel audio....using line-in blue jack and mic-in pink jack as line-out....but i lost that realtek driver and the one i have with my intel disc doesn't allow me to do so....
the old realtek driver gave 6 channel option on XP....however I haven't used that driver on Vista n dont know if it works the same way....

the driver on my intel disc lets me chose 4 channel max....but hav to use headphone jack as front and line out as rear speakers....
on Vista I can switch to 4 channel but cant plug in rear speaker coz only one of front or rear jack works at a time....or both give same output....

my pc was configured by sm1 else previously so i cant say if he did smthing with bios or something else....

if sm1 kows a sol. please let me know...
i've been looking for it from a long time...

Read other answers
RELEVANCY SCORE 71.6

Help I'm having real problems trying to fix my X220 after the windows 10 creator update. computer specs are as follows X220 Type 4286-CTO Windows 10 Pro, i7 -2620M 2.7 GHz, 8gb RAM, Intel 160Gb SSD I have an older Lenovo dock with 2 monitors attached HP LP1965 and HP 2509m. They are not working properly i think because of the following driver problems according to the windows troubleshooter. Missing driver for PCI serial port with hardware id PCI\VEN_8086&DEV_1C3D&SUBSYS_21DA17AA&REV_04  and the Intel(R) HD Graphics 3000 display adaptor says Windows has stopped this device becuase it has reported problems Code 43 That hardware id is PCI\VEN_8086&DEV_0126&SUBSYS_21DA17AA&REV_09I have tried everything I know of and can't seem to find the drivers or how to fix them. And I'm not sure if that is even all the problem. Thanks alot for your help!Greg

Read other answers
RELEVANCY SCORE 71.6

I installed the Windows 10 Creator Update which updated my WIFI driver to 19.50.1.5.  I am on a Thinkpad S5 Yoga-15 - 20DQ. When I execute the Lenovo Companion and ask it about system updates, it says I need to install a back level driver v.18.21.0.2.   your support site says that my system supports the Windows 10 Creator Update.  I am having some issues with internet response time since this update.   Am I supposed to go back level on this driver?

Read other answers
RELEVANCY SCORE 71.6

As the title says, my front and rear audio panels are not working.

Came home on Friday and there had been a power cut, rebooted in safe mode and restarted.. everything was fine apart from the audio.

Red X in the bottom right over the audio volume logo, 'speakers not plugged in'. The speakers were plugged in, so thought it was a dodgy cable going from the speakers to the rear panel on the computer. Changed out the cable and still got 'speakers not plugged in'. The speakers are 100% working, I have tested the usual set AND another set of speakers on both front and back and still getting 'not plugged in'.

I have uninstalled, rolled back the drivers, rebooted and installed the newest drivers, disabled and enabled in the BIOS and still nothing. It's on-board sound from the Gigabyte
GA-MA785GPMT-UD2H board.
I gave a look at the green port on the rear panel (usual port for the speakers) and it seems to be fine, not loose etc.. Any help would be greatly appreciated, have searched the whole of google at this stage and nothing has helped. Could the powercut have caused a problem?
 

A:Rear/Front Jack Port Not Working - Win7

Do you have power to the speakers?
 

Read other 2 answers
RELEVANCY SCORE 71.6

Hi guys, this is the strangest problem I've seen in my 15+ years of being a techie!!!

I have a new pc with a Gigabyte GA-H67MA-UD2H-B3 motherboard and I plugged a Microsoft 600 Wired Keyboard into the rear port (designated for KB/Mouse by Gigabyte). The keyboard works in the BIOS, but when Windows 7 loads, the num lock light switches on, then Windows 7 says that "Driver not installed properly". In the Devices & Printers window, it shows an icon of the keyboard with a yellow exclamation mark and says "hadware not available". However, mouse continues to work.

This happens in all the rear USB ports. If I plug the keyboard in the front port, Windows recognizes the keyboard, install the correct driver and it works! All the USB ports work fine otherwise (tested with thumb drive as well as mouse).

I also tried with a Logitech K120 wired keyboard which also had the same problem. Any ideas on why this is happening? I've been solving PC issues for the last 15 years and still I'm stumped!!!

A:Keyboard in rear usb port not working - geek stumped!

I have some Dell workstations that have only one PS2 slot for keyboards/mouse, and it works if you have a "splitter", the splitter plugs into the ps2 slot and then you plug a keyboard and mouse into the splitter. I'm assuming you would need to do the same type of thing...then again, maybe not. Just my 2 cents worth here....

Read other 2 answers
RELEVANCY SCORE 71.6

Hello

I own a Dell xps 13 9350 laptop.I'm trying to connect an external monitor through the Thunderbolt 3 port, with a USB-C to VGA adapter, but the laptop does not recognize that I've connected an external device at all.I suspect that maybe I'm missing a driver, I've tried installing Intel(R) Thunderbolt(TM) Controller Driver: "Chipset_Driver_D91CC_WN32_16.1.47.275_A02.EXE" but it was no good, still not working.How can I troubleshoot this? Could it be a different driver that's missing?ThanksShahar

Read other answers
RELEVANCY SCORE 71.6

 Nothing happend when DELL Thunderbolt dock plugged in. Monitor connected to the dock does not light up. In Windows device manager,  'Thunderbolt(TM) Controller -1577' state is "Currently, this hardware device is not connected to the computer. (Code 45)" I have updated Thunderbolt firmeware to latest version and the Thunderbolt soft,I have deleted  'Thunderbolt(TM) Controller -1577' item from device manager and reinstalled the thunderbolt several times. They didn't help..Please lenovo give me some information..

A:P70, Thunderbolt port not working

Is there anyone who has thunderbolt port working? Is there any lenovo person who can provide some information about this?Did lenovo know this issue? Is it a intel problem or lenovo problem? Are your man working on it? When this will be solved?     

Read other 6 answers
RELEVANCY SCORE 70.8

Hi my dell OptiPlex 3020MT updated automatically to Fall creators update yesterday everything is working fine expect for the soundcard. It sounds tiny and flat. I downloaded and tried to install official Windows 10 audio driver from dell support but it can't be installed as it is not compatible with latest windows 10 build. I have to rely on windows update and Maxx Volume Pro is not working with driver provided via windows update. MaxxVolume, MaxxLeveler and MaxxBass sounds flat when I try to adjust it manually. All drop down options is empty.. no preset equalizer is available in drop down menu and user defined equalizer does not make any audible sound difference when I try to manually sets it. Also under speaker setup; Speaker size (Small, Medium, Large) does not make any audible sound difference.. it just sounds tiny and flat.
Kindly provide a work around for this issue. At least a compatible audio driver for fall creators update. 

Read other answers
RELEVANCY SCORE 70

I'm having issues getting the TB16 to work with the XPS 15 9550. I successfully installed all the drivers in the proper order as documented prior to plugging in the TB16 for the first time.

I've verified that I indeed do have a Thundrerbolt port - there is a Thunderbolt symbol next to the USB-C port.
When I do plug in the TB16 the power button on it will power the system off/on.
I've used a usb-c to Displayport adapter and a usb-c to usb 3.0 adapter with a flash drive. Both worked successfully so the basic functionality of the usb-c port is working.

When I plug in the TB16 I never got an authentication window pop-up. In the Thunderbolt software it shows no attached devices.

The details setting in the Thunderbolt software looks fine, it appears to have the proper driver and firmware levels.

When I check the Thunderbolt driver it says that 'the hardware device is not connected to the computer'.
I'm at a loss - everything looks good except for the fact that nothing happens when I plugin the TB16. I'm wondering if there's a hardware problem with the Thunderbolt controller itself? I'd appreciate any help that anyone can give me.

A:XPS 15 9550 - Thunderbolt port not working - TB16

You might open the Thunderbolt software and set it to allow all devices.  I reset my system and redid the TB16 and it shows the cable and dock as approved devices.
It was not hard for me.  The thunderbolt controller is on the computer.  You show some correct info for that controller, although since I have a 9365, that specific info may be different, but you do show a different controller generation..

Read other 1 answers
RELEVANCY SCORE 69.2

Hello.
I have purchased the new XPS 13 2-in-1 laptop.
The Thunderbolt 3 port on the left side of the laptop is not working.
I have also purchased the TB16 dock and it is not recognized at all.
In the Thunderbolt software details, it shows the Controller driver as "Unknown".
I am out of ideas.
I have done the following:
1. Clean install Windows and run all updates.
2. Install all of the latest drivers and Bios updates, in order, according to the official Dell guide for this laptop.
3. Followed guides in this forum and Reddit forums.
4. Had Dell support come in and replace the motherboard.
The TB16 dock is still not detected, nor is any other Thunderbolt or USB-C device connected to the port on the left.
The TB16 dock, however, does charge he laptop and properly shuts it down if I press the power button on the dock.
I have checked the Bios settings, and also tried updates/fixes from Intel. Nothing works. The Thunderbolt firmware update cannot even run because it cannot detect the controller. It still says Controller Driver as unknown.
I have the i7 with 16GB RAM, and 512GB SSD.

A:XPS 13 9365 - Thunderbolt/Power port not working - TB16

So you have loaded the Thunderbolt drivers (firmware and Controller) and it is enabled in the Bios?
There are also Dock Drivers.
I do not have any Thunderbolt devices so I cannot check.

Read other 1 answers
RELEVANCY SCORE 69.2

I have only had this laptop for a month or so,  but the Thunderbolt usb-c port stopped working. I can still use this port to charge my laptop, but it won't connect to any other devices nor output video to an external monitor. Has anyone encountered this problem before? Does it mean I need to send my computer back for a repair? Thanks.

Read other answers
RELEVANCY SCORE 68

Hi,
I myself own an XPS 15 9550 and noticed that I was not getting the full Thunderbolt 3 speedover it's Thunderbolt 3 port. I expected speeds around 2700MB/s, because of the overhead withthe theoretical gross speed of 3870MB/s, but I only ever got 1400MB/s out of it.
I did some digging and found out that none of the XPS notebooks with Thunderbolt 3 are evenable to achieve the full TB3 speeds, because they are only connected with two PCI Express lanes (x2.3).You can read more about this on the following links:Dell Subreddit PostChipset Digging on Forum

Thunderbolt 3 and the promised speeds were the MAIN REASON I even bought this notebook.I feel very cheated here.

Read other answers