Over 1 million tech questions and answers.

X1 Carbon 7th Gen (20QD) Issue with ethernet and thunderbolt dock gen1 and gen2

Q: X1 Carbon 7th Gen (20QD) Issue with ethernet and thunderbolt dock gen1 and gen2

Hello, I am using the x1 carbon 7th gen 20QD and trying to get ethernet to work through the thunderbolt docking station. I have installed all the drivers from the lenovo site for the gen1 and gen2 thunderbolt dock and ethernet still does not work through either thunderbolt docking station. Ethernet works fine with the usb-c travel hub and the ethernet adaptor that plugs in next to the USB-C works as well. I have also swapped the dock out with the thunderbolt dock on my yoga 370 and ethernet works through the dock on the yoga. Any ideas?

Read other answers
RELEVANCY SCORE 200
Preferred Solution: X1 Carbon 7th Gen (20QD) Issue with ethernet and thunderbolt dock gen1 and gen2

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 120.8

We recently purchased three of these for our team. They do not work with USB-C portable drives or with the Thunderbolt Dock. I first tired these with a 40A9 dock as CDW stated it was compatible. Since that didn't work, we tested with the Gen 2 docks which Lenovo stated were compatible.  I have tried to reimage the machine, reinstall drivers, tried other cables, laptops, and attempting to change settings in the BIOS like Thunderbolt security. Nothing has worked to allow us to use the docks ethernet. It's just not seen by the system. I have gotten it working sans drivers with the 40AJ docking station. I know this docking station is listed as working with Gen 6 and I can locate plenty of guides on how to configure this machine for the dock.  Any help would be appreciated. 

Read other answers
RELEVANCY SCORE 106

 I am attempting to conenct multiple monitors to my x390 through the thunderbolt dock.  The first monitor comes up fine with 3840x2160 resolution.  However when I connect the second monitor it comes up as 800x600.  I do not have the option for the second display to change resolution.  x390 s connected to dock via Thinkpad TBT cable 40G I have ran lenovo software updates and I am at the latest software version for everything. I tried the windows display app and the Intel display app and both are showing the same behavior for the second monitor. I have tried reversing the order of connecting the monitors.  The first one to connect always goes to 4x, where the second one connected always reverts to 800x600 without the option to change, I have tried turning off the built-in-display to see if that would change anything, but it didn't. I have tried swapping the port on the dock that the monitors are connected to.  The first monitor always correctly displays at 4k and the second is set to a much lower resolution typically 800x600 without any options to change. The intel app has an option to change the refresh rate, so I tried changing to a few different refresh rate to see if that would change anything, and it didn't help. I had the monitors connected via hdmi, so I switched both to display port and now I get 3 options, but the max is 1280x720.  I still do not get the 4k option. I then tried one con... Read more

Read other answers
RELEVANCY SCORE 99.6

Hi all Recently got a Lenovo X1 Carbon (gen 6) and today got a Lenovo Thunderbolt 3 dock, part number 40AC0135AU . I have two 1080p monitors plugged into the dock, however, when the laptop is plugged in via the single TB3 cable, the laptop's fans constantly spin-up loudly for about 10 seconds, then turn off. It repeats this constantly. I have run all Windows Updates (on 1903), Lenovo Vantage updates, and updated all firmware and drivers (that I know of), but it's still doing it. Has anyone got any experience with this, as I can't focus on work with the fans constantly interrupting I don't want to send the laptop and dock back, but it's not suiting my requirements as is. Appreciate any assistance!

Read other answers
RELEVANCY SCORE 96

For my X1 Carbon 5th Gen I got myself a Thunderbolt 3 Dock (Gen 1) - (40AC). But right now the dock doesn't work as expected.I have connected a 1440p-Dell monitor via DisplayPort. Also I conntected a 1080p-Panasonic-TV via HDMI. The manual of the dock suggested to use a certain DisplayPort-Connector, which I did.I'd like to switch on my ThinkPad via the power button on the dock and then wake up my Dell monitor from sleep. Right now the Dell is set as primary display. If needed I'd like to switch on the TV as a secondary display. The ThinkPad should remain closed and only the external displays should be used. In the BIOS of the ThinkPad I alread configured, the an external display should be used prior to the internal one.Right now the following happens: I switch on the ThinkPad via the button on the dock. The Dell monitor doesn't wake up. Only when I switch on the TV (Panasonic 1080p via HDMI) also the Dell monitor wakes up and shows the content. I'm rather lost how to solve this behaviour. I already checked the BIOS version of my ThinkPad and updated it - nothing changed  Has anyone any idea?

Read other answers
RELEVANCY SCORE 90.4

Dear helpy helpers, I am experiencing a heap of trouble when using T490 and Thunderbolt 3 Dock Gen 2 together.When we recieve a new machine, we reinstall it, with a clean latest version of Windows, and run TVSU for the lastest drivers. Software wise, they get Office, Visual Studio, ReSharper, SQL Server Management Studio and Symantec. Nothing fancy. The last 3 machines hav had issues with the docks. The docks are 135W (cable plugged in the correct power port on the dock). Cable for the PC is on the back and not the front. Screens that wont run full resolution, no ethernet, no charging and the like. Checking the Thunderbolt Control Panel, the dock is connected. Reinstalling wont solve the issued, but getting new motherboards for 2 machines worked somewhat. I've been managing Lenovo laptops for 10 years now, and though i don't see myself as an expert, I have seen quite a few different models, and experienced different issues with docking solutions. Though. Nothing. Like. These. Thunderbolt. Docks.  Is anyone else having trouble, or am I the only one fighthing this? I am thinking about running back to Windows 10 1809 instead of 1903, but I dont really like having to be vary of backwards compatibility with a simple setup as above.  Any help would be hawt!

Read other answers
RELEVANCY SCORE 89.2

Hi!I just got a new "X1 Carbon 5th Gen - Kabylake (Type 20HR, 20HQ)" and a "X1 Carbon Thunderbolt 3 Dock". I have an external screen connected to the dock and it works fine (VGA connection). I also have an other monitor with display (DP) connection that I want to use. But my computer can't find the other monitor, only the one with VGA connection. Is there any easy ways to fix this problem?Best regards

A:ThinkPad X1 Carbon 5th gen can't connect 2 external monitors in X1 Carbon Thunderbolt 3 Dock

[Posted moved and topic edited for discoverability.  AG]

Read other 1 answers
RELEVANCY SCORE 88.4

Hi, I'm having issues with my external 4k display to only be able to operate at 30Hz. I have my laptop connected to a generation 2 Thunderbolt 3 dock via the provided cable, and from there I have tried both DisplayPort and HDMI cables (several) to connect to my display.All the technical information I have seen says that my laptop plus the dock should be able to operate at 60Hz even at this resolution, but I'm unable to lock down the settings that enable me to do that. I have pulled the latest BIOS, TB3 FW, display drivers, Intel chipset drivers from the product page.My screen is: AOC U3277FWQ if that matters. I'm running Windows 10 Pro 1809. Has anyone battled with the same issue? I'm running out of ideas on how to solve this. The HDMI port on the side is apparently only 1.4 so this would only support the [email protected], but I'm not using it at the moment. If I set the screen to 1920x1080, I can set the resolution to 60Hz. Best regards,_tero

Read other answers
RELEVANCY SCORE 88

Dear Sir and Madam,
 
I found my computer screen starting to flicker recently. Please check the support Picture in the attachment. Which specialist can give me some solutions for this problem? Thank!

By the way, would you please reply your suggestion to my email *********@yahoo.com? Thanks!
 
Moderator note: email address obscured to keep from the spambots.  Replies belong here in the forum so that others may participate and benefit.
 
Best regards, Xu Yuegen

Read other answers
RELEVANCY SCORE 87.2

Hi there, i have a new X1 Carbon 7th Gen with the new USB-C Dock Gen2. I have 3 Monitors connected with 1680x1050 native Resolution. I get only 2 working with this resolution. The third one will only get 576p. No matter if its connected to DP or HDMI. The last one doesnt get the full resolution.  I made a second test with a Lenovo ThinkVision P27h-10. I dont get it working over DP with 2560x1440 and a secondary monitor over DP. The ThinkVision Monitor falls back to 1920x1080.  All drivers are installed and the latest firmware of the Gen2 Dock is installed.  When i have connected 2 monitors to the dock and open the X1, the monitor of the x1 will get 1920 resolution. Whats wrong? I cannot belive that this new laptop isnt able to power 3 Monitors with 1680x1050 resolution. 

Read other answers
RELEVANCY SCORE 84.4

So I have an X1 Carbon Gen 5 (Kaby Lake) and the Thunderbolt 3 Dock Gen 1 (40AC0135US). I bought two 4k monitors and after several frustrating hours figured out that the Gen 1 dock can't output 4k on two externail monitors at 60hz, this appears to be a dock limitaion only. I see that you now have a Gen 2 dock (40AN0135US) that says it will do 2x 4k @ 60hz, only problem is that every compatability cross refrence I can find does not say the gen 5 X1 Carbon supports this new dock. I don't see a good reason for it not to be compatiable, but wanted to find out for sure one way or the other before I bought it, as it is not cheap. 

Read other answers
RELEVANCY SCORE 83.6

I recently purchased the X1 CRBON 5TH Gen (2017)...type 20HR plus a thunderbolt dock.I connected them together with a Dell 28" 4K (@30Hz) screen (p2815q) connected through DisplayPort from the dock, plus a Microsoft keyboard and Jabra 510 USB speakerphone.Using the Windows 10 stock image from Lenovo, plus Office 2016, Chrome, Visual Studio, Skype,  and various other apps (putty, RDP, SAP GUI, others) the video performance was atrociously bad. Alt-Tab, which I use heavily would take 3-4 seconds to respond, switching between applications, Windows would freeze and sometimes crash, I would often get blank or black windows in Chrome and Office. This was on the embedded Thinkpad screen as well as the external monitor.I ensured Windows Update was up to date, as well as Bios, Drivers etc through the Lenovo companion app. So...I dove into the BIOS and voila! There is a switch that lets me change the Video memory from 256 to 512 MB allocated!I went to change it, and it would not change until I changed the setting:BIOS > Config > Thunderbolt 3 > Security Level = from "User Authority" to "DisplayPort and USB"I switched that setting, and then set my video memory to 512 MB, rebooted and voila! Problem solved. I worked that way for a little while, took it into my office and plugged it back into my Thunderbolt 3 dock and while my video and LAN connections worked...my wireless keyboard (USB dongle), and Jabra 510 did not. Curious. I r... Read more

Read other answers
RELEVANCY SCORE 83.6

Hi, all. I have a problem thunderbolt is not charge notebook, but usb ports and displayport working.1. I connect the Laptop with the Thunderbolt connector on the backside of the Dock (beside the HDMI/DP connectors) and on the frontside, not working.2. I updated all drivers.3. I go into the BIOS and "disable the battery for technical service".But if I use an AC power adapter, it charges.Does anyone have a solution?

Read other answers
RELEVANCY SCORE 83.6

Hey,  Hopefully someone can help.  I am using an X1 Carbon 6th Gen plugged into a Thunderbolt dock using two external displays.  When I plug in the dock, I find that my Microsoft programs are blurring. If I close and restart the programs they are fine.  Any advice? 

Read other answers
RELEVANCY SCORE 83.6

I've been using a USB 3.0 Pro dock with my Carbon X1 5th gen. I wanted to updgrade my external monitor to an ultrawide - so I bought a Thunderbolt 3 dock. The dock will charge my laptop, but nothing plugged into it is detected, nor does it show up in device manager or in the Thunderbolt Software. I did install the drivers for the dock. I then tried a USB-C dock to see if I had different results - same problem. The dock doesn't show up in device manager, nothing plugged into it is detected. The dock does charge my laptop.  Any ideas what I can try to troubleshoot this? 

Read other answers
RELEVANCY SCORE 83.6

Just got purchased the x1 carbon 5th gen along with the Thunderbolt 3 dock.  However, the dock will not charge the laptop.  Every time I get the error message "The dock is not supplying enough power to your computer.  Please use the ac power adapter that came with the dock".  I am, in fact, using the ac adapter that came with the docking station.  I have updated the bios as well as all of the other recommended updates and still get the same error message.  Does anyone have a solution?

Read other answers
RELEVANCY SCORE 83.6

Hello,  I have the X1 Carbon (5th gen) and am looking at purchasing an ultrawide 5k monitor. I then realized, my setup may not support a monitor above 4k. I have the Thunderbolt 3 workstation dock, and know the user manual says I can run a 4k monitor. So does this mean I would not be able to run a 5120x2160 ultra wide? Thanks!

Read other answers
RELEVANCY SCORE 83.6

The X1 carbon 6th Gen supports Thunderbolt 3, yet it is not listed as compatible with the Thunderbolt 3 Dock Gen 2. Anyone have an idea why? Also the ThinkPad T470s.
 
https://support.lenovo.com/us/en/solutions/pd500265
 
The X1 Yoga 3rd Gen and X1 Yoga 2nd Gen are listed as compatible. Perhaps it just means that the dock has been specifically tested with the listed models? Surely Thunderbolt 3 is Thunderbolt 3 and the dock should work with plenty of other Thunderbolt 3 machines?

Read other answers
RELEVANCY SCORE 83.2

I have ThinkPad Yoga X1 (Gen1) with Thinkpad OneLink+ dock.If something (anything, USB memory stick, USB keyboard, USB monitor) is connected to a dock or to a notebook, during powering on, it want pass the BIOS part and start booting Windows OS.It should be fixed long time ago, but same issue still persists.I have latest BIOS firmware - 1.31https://pcsupport.lenovo.com/hr/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-...The issue persis for a months

Read other answers
RELEVANCY SCORE 82.8

We have a number of 6th Gen X1 Carbon laptops which are experiencing an issue reconnecting to the Thunderbolt 3 dock. When a user disconnects and walks off to a meeting and then returns and reconnects, their laptop does not recognise the dock any longer. It is intermittent and we have tried options such as setting the Thunderbolt service to automatic and setting recovery options to restart the service.

Read other answers
RELEVANCY SCORE 82.8

Hi All,  I recently got two 1920x1080 monitors and have been attempting to hook them up to my Thunderbolt 3 dock and X1 Carbon with no success. All firmware has been updated, and the dock detects each display individually, when the other is disconnected and reconnected. Everything else works on the dock with no issues.  Thanks.

Read other answers
RELEVANCY SCORE 82.8

Hello everybody, We have purchased the X1 Carbon 5th Gen Laptop, which by the way is a great piece of hardware, with Thunderbolt 3 dock.  The problem: the laptop does not recognize the dock. other laptop (identical with the problematic one, works perfectly... Any sugestions?













Solved!

Go to Solution.

A:X1 Carbon 5th Generation problem with Thunderbolt 3 dock

There are BIOS settings related to Thunderbolt (in the "Config" menu of BIOS setup), are these settings configured identically on both ThinkPads?  As an experiment, try setting the security level to "No Security" and see if you can get it working that way...
 
Same BIOS version on both ThinkPads?

Read other 3 answers
RELEVANCY SCORE 82.8

I have a bug that is fairly repeatable where when my laptop goes to sleep, the USB ports on the Thunderbolt 3 dock are not active when I wake the computer up. I can unplug the TB3 cable and plug it back in to regain access to the ports. Where can I report this issue?

Read other answers
RELEVANCY SCORE 82.8

I just got a new Carbon X1 6th generation (20KG).  I started using this with my Thunderbolt 3 dock (40AC), that I successfully used with my previous Carbon X1 5th Generation. There seems to be some compatibility issues here. After using it with the docking a while (apprx. 1 hour), the X1 suddenly started to continuously disconnect/reconnect from the dock (each 2-3 seconds), before it permanently was disconnected from the docking and would not connect at all.  When I disconnected the X1 from the dock and restarted (without connecting to dock) the X1 Thunderbolt software and devices/drivers related to that on the X1 "went crazy" and appeared/disappeared from the device manager continuously (each 2-3 seconds). I needed to enter bios and temporarily disable internal battery for it to normalize again. If I then connected to dock, the same would happen after some time. I've updated Thunderbolt software, drivers, firmware and also Thunderbolt 3 dock firmware and drivers, so no more to do there. I have not verified it completely yet, but it might be that the disconnect/crazy_stuff happens when the battery charge of the X1 reaches 100%. I once connected the X1 to the dock when the charge was 97% and it was stable then (the X1 does not charge on AC when the battery is > 95%). If this is the reason, one solution might then be to use Lenovo Vantage to set max charge to e.g. 97%, but I think this is a poor solution. Some ... Read more

Read other answers
RELEVANCY SCORE 82.8

Hello everybody, We have purchased the X1 Carbon 5th Gen Laptop, which by the way is a great piece of hardware, with Thunderbolt 3 dock.  The problem: the laptop does not recognize the dock. other laptop (identical with the problematic one, works perfectly... Any sugestions?

Read other answers
RELEVANCY SCORE 82

I have the Thunderbolt 3 Dock and it is charging up the laptop no issues. The issue is the network part. I have a network cable in the dock, but I am not getting network connectivity on the laptop.

Read other answers
RELEVANCY SCORE 82

Hey Everyone, Hope someone here can help out.We've deployed ~60 of the 6th Gen X1 Carbon's (20KG Model Type) with the Lenovo Thunderbolt Dock (40AC Type)We've used Lenovo System Update to install all system and dock updates.When we've docked the computer the thunderbolt dialogue appears and we select always connect.Everything works for our users for about a day, then they complain that their computer isn't charging, their screens have gone black or are flashing, or the computer starts making device disconnect/reconnect sounds while the thunderbolt icon flashes in the taskbar repeatedly. All symptems persist after a reboot. We've been working around this by going into the BIOs and disabling the built in battery, Then plugging into the dock and powering on the computer from there. So far we've only had 1 user experience a recurrence (We haven't ruled out user error)I'd like to know if there is fix, beyond the "disable internal battery" solution. Thank you in advance for any insight you can offer.

Read other answers
RELEVANCY SCORE 82

Anyone have a fix for the x1 carbon laptop going to sleep mode very quickly (1-2 minutes) while using a lenovo docking station?  It doesnt happen when i use the laptop without dock.  Ive tried all the normal setting in windows.  they are set to 15-20 minutes.  It still happens.  Ive updated the drivers for the docking station.  It still happens.  This is also an issue with an employee's 4th generation X1 and a USB-C dock.  After waiting for 25 minutes on lenovo chat and no one responding, i called in.  They spent 30 minutes playing with the same settings then said it was a software issue and transfered me to another department.  They tried to charge me $200 to fix the problem.  My laptop and dock are less than 6 months old.  I'm extremly upset with lenovo!  

A:X1 Carbon with Thunderbolt 3 dock going to sleep mode quickly

Gets even better. I called back into the original number and they said "what i do with my computer is not their problem. Since it works (even though briefly) then its fine"

Read other 1 answers
RELEVANCY SCORE 82

We purchased a new X1 Carbon 6th Gen with the new Thunderbolt 3 Dock Win 10 1803 and have had all kinds of problems. Bad enough to consider other brand alternatives. All Lenovo drivers are current, we updated the firmware and drivers for the dock. With that we still have the following problems and dont know how to resolve them1. The network connectivity from the dock to laptop with USB-C loses connectivity on occasion. Also when the user shuts off the laptop, comes back and turns the laptop on, no network connectivity is re-established. The only way to fix this is to unplug the USB-C cable and plug it back in. Sometimes that will lock up windows and we have to do a hard shut down and start of the laptop. 2. Running the display out from the dock is not always reliable. The monitor will turn off randomly. To bypass this issue we have to just plug the monitor directly into the laptop. 4. Occasional random bluescreens with a stop  code DRIVER_VERIFIER_DMA_VIOLATION. This error is related to bad drivers.Are we missing something. Is there anything we have to set in the BIOS to resolve these problems? I've been reading up on this dock and a lot of people are having problems with this dock and carbon 6th gen laptops

Read other answers
RELEVANCY SCORE 82

Hello Everyone, I am new here so please go easy on me.I just bought and X1 Carbon 5th Gen laptop c/w Thunderbolt 3.0 docking station.The problem that I have is that the docking station won't recognise any of the external screens that are connected.I am using two Acer screens (one is connected using HDMI port on the dock and the other one uisng Display port).I have tried by connecting just one screen but nothing.I can see that Thunderbolt software is installed and its connected to my laptop.The laptop will charge through the docking station and also the wireless mouse and keyboard will work fine through the dock.Lenovo recommended that i should update my drivers.So I installed Lenovo Companion from Windows store. But it won't update my system. After clicking on System Update, I will get an error message saying "There is a problem in reteriving new updates for your system.Please try again later".Hence I downloaded all the drivers from support website and installed them manually but my docking station is still not working with the external monitors.The monitors works fine when connected directly to the laptop using the HDMI cable. Thanks in advance for your help.

Read other answers
RELEVANCY SCORE 82

Just setting up my new X1C6 with Win10 and the ThinkPad Thunderbolt 3 dock. Everything seems to be working, but occasionally the fan starts spinning like crazy, and a process named "WMI Provider Host" appears in the Task Manager with >25% CPU usage. After a few minutes the system is back to normal.  After a bit of Googling, I went to Event Viewer -> Applications and ... -> Microsoft -> Windows -> WMI Activity, and I found a series of errors that coincided with the excessive CPU load events. Every error has a reference to a process ID that corresponds to "Thunderbolt.exe". This leads me to think that the problem is related to my docking station. I tried downloading the docking station drivers from https://pcsupport.lenovo.com/en/solutions/acc100356 but it turns out that I have an even newer version installed already (something .12 vs .10) . Yesterday, I heard some loud hissing from the corner of the laptop where the TB3 ports are. It disappeared when I unplugged the dock, and came back after I plugged it in again. After a restart, it went away, and the port as well as the dock seems to be working fine (currently with Ethernet and a VGA monitor). Any ideas what to do here? 

A:X1 Carbon (6th) + Thunderbolt 3 Dock: WMI Provider Host goes crazy

@renetrwrote:Just setting up my new X1C6 with Win10 and the ThinkPad Thunderbolt 3 dock. Everything seems to be working,  [...] Yesterday, I heard some loud hissing from the corner of the laptop where the TB3 ports are. It disappeared when I unplugged the dock, and came back after I plugged it in again. After a restart, it went away, and the port as well as the dock seems to be working fine (currently with Ethernet and a VGA monitor). Any ideas what to do here? There's a separate thread discussing the 'hissing' which appears to be coil whine from the dock in my case. Another person resports more of a clicking sound from near the left of the laptop (near the TB3 port), see here: https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-Gen-Coil-Whine-Dock-Issues/td-p...

Read other 1 answers
RELEVANCY SCORE 82

I've never had problems with X1 carbon 5th gen + USB-C dock gen 1. After the new Thunderbolt driver, it craps out daily. Today it acted weird after returning from lunch, ethernet port did not work, device manager crashed/ stop responding if trying to enable/ disable it from there. Tried to reconnect dock, power cycle the dock, no difference. Reboot of the computer fixed it. There is some glitvhy behavior still going on, even after this "fix".
 
Running 1909 with latest cumulative update btw. Enterprise x64.
 
If I can provide any data that can help you guys troubleshoot; please tell me.
 
Admin note: post moved to start new topic, subject edited to represent issue

Read other answers
RELEVANCY SCORE 81.6

I recently purchased Thinkpad Extreme X1 and a thunderbolt dock Gen 2. Every one in a while and sometimes multiple times in a row, my computer will lose the ethernet connection through the dock. If I repair the connection or unplug the thunderbolt cord, it will reconnect immediately. I have turned off security in the bios for the dock but I still lose the connection. Any other ideas?

Read other answers
RELEVANCY SCORE 81.6

I just received my HP ZBook Studio and Thunderbolt Dock. I updated all drivers and BIOS. However, there is no internet connection through ethernet when I connect RJ45 to the dock. Am I missing something? Is it possible to have hardware related problem? Thanks,

A:Re: Ethernet on thunderbolt dock won't work

I am posting this through a Zbook G3 connected to a Thunderbolt dock with ethernet connected to the dock ethernet. Did you specifically install the package of dock drivers? Are you seeing crippled devices in device manager?

Read other 1 answers
RELEVANCY SCORE 81.6

I have ethernet issues with my Thunderbolt 3 dock 150W and my Zbook 15G3, running on windows 7 / 64 bit. I had many issues before with the system after a BIOS update (slow performance, usb poorts that would't work, windows that would not download updates, ect.). I read many postst with similar problems. The hardware was exchanged by HP but the problems remained and I was left alone to install the BIOS and updates. Thank you HP!After a long period of fiddeling I got everything back to work. Exept for the ethernet connection on the thunderbolt dock. Somehow the drivers are not inatlled / available. The ethernet connection / WLAN on the laptop work fine, but not on the dock. I don't know where to find the right drivers / how to install them. Who can help? 

A:Ethernet on thunderbolt dock won't work

I have the Zbook 15 G3 Mobile Workstation using the Zbook Thunderbolt 3 dock: http://www8.hp.com/us/en/workstations/zbook-dock.html I am sending this on the Zbook connected to the dock using its gigabit ethernet port. HP Support Assistant provided all the drivers needed for the dock. Here is the screenshot of my device manager:    What does your device manager look like under network devices? The Intel ethernet is the built in and the Broadcom NetXtreme is the ethernet in the dock. HP has drivers for both on the support page for Windows 10 64 bit under the Zbook G3 Home page.  I did have a bit of a struggle initially getting the dock to work but I went into the BIOS and disabled all Thunderbolt security settings. If you need any more help post back. If this is "the Answer" please click "Accept as Solution" to help others find it. 

Read other 1 answers
RELEVANCY SCORE 80.8

Received the Thunderbolt 3 dock today, though the display works fine, the dock/laptop won't recognize any external USB devices such as mouse. keyboard, webcam, etc. I tried installing the latest drivers to no avail, from: https://support.lenovo.com/us/en/solutions/acc100356 Anyone else havign this issue?  

Read other answers
RELEVANCY SCORE 80.8

USB 2.4Ghz mouse doesn't work on any of the Dock 2 USB ports. Same mouse adaptor works right away when in the ThinkPad USB ports. Tried a couple of other USB devices, old an new, and none work in the Dock ports even though they work fine when in the Win 10 ThinkPad as well as in another older Win 7 laptop. Checked all Win 10 drivers are latest versions, tried the disable/enable toggle, all to no avail. The Dock itself is hapilly driving two monitors and seems to otherwise work fine.  The always-on USB port on the back has power, and so does the one USB port on the front (but neither work for USB connected devices). This is a brand new setup, hoping for a trivial solution otherwise I will chuck this whole thing, at this age this should be plug and play. Suggestions?

Read other answers
RELEVANCY SCORE 80.8

Machine model: 20HRCT01WW At seemingly random intervals the Dock stops working (for USB perphirals) and my wife has to move keyboard/mouse to the machine itself - defeating the purpose of a very expensive dock. Machine is fully up to date the current version of windows and all drivers (including the Thunderbolt dock). I would report this directly to support but Lenovo it won't allow to me register my wife's X1 with my account inspite of the fact that I'm the one who ordered it. Ugh. ThanksMark Levison

Read other answers
RELEVANCY SCORE 80.8

Hi together, I have a problem with my USB-C docking station if I enable the field "Support in Pre Boot Environment" in my X1 bios. Devices:Lenovo X1 (Type 20HR, 20HR002MGE):- Windows 10 up-to-date with Lenovo System UpdateUSB-C Dock (Type 40AC bzw. 340AC0135EU)):- Firmware: 43.00- Drivers 17.4.80.xx My X1 SSD is encryptet with bitlocker and i have to type a password before booting windows, thats why I enabled the preboot Environment for usb with my thundebolt port in bios that i can use my external display and usb keyboard for typing. So far so good. Since I made that setting, my usb ports in my dock are very unstable. After reconnection my dock while running windows all my usb ports of the dock refused to reconnect and my keyboard is not working until I restart. After unplugging and replugging my X1 to my dock I have to connect all my USB directly to the X1 or I have to restart windows. Both is very annoying. If I disable that BIOS Setting, my keyboard is not working for entering my bitlocker password and my external monitor is not showing the bitlocker screen, but disconnecting and reconnecting my X1 with my dock is working perfectly. Am I realy alone with that problem? I hope anybody can help. I already tried to disable my security settings for thundebrolt in BIOS and all other security levels. But it did not help. Thanks in advance,Roland

Read other answers
RELEVANCY SCORE 80.8

Hi, everyone,  I meet a problem of connection. I install the driver but the computer seems not to recognise the graphic dock. I cannot find my thunderbolt controller in the rest of picture 1, and I also cannot find thunderbolt in device manage.  does anybody know how to solve it? Thanks

Read other answers
RELEVANCY SCORE 80.8

Sorry for the bit of a wall of text, I'm trying to be as detailed as I can. I've been pulling my hair out a bit on this one, and I've tried steps found in at least half a dozen threads that I read through on here, but to no avail. I wanted to make a separate thread because my issue seems to be happening before most of everyone else's. I've tried: installing drivers in a specific order, not plugging the dock in until everything is setup, forcing a PD reset (hold power 8 seconds), updating bios to latest and trying all the Thunderbolt security/compatibility/passthrough settings, etc.  Specifics: An end-user has a 6th gen X1 Carbon and purchased this dock: https://www.lenovo.com/us/en/accessories-and-monitors/docking/universal-cable-docks-thunderbolt/Thun... Which specifically says it's compatible, and I've used the dock finder utility to verify the compatibility. I'm running Windows 10 1809 and have triple checked driver versions and BIOS settings. The driver shows up correctly in Device Manager and the Thunderbolt software runs properly. I've disabled my antivirus in case something was interfering.  Problem: However, no matter what I try, when I plug the dock into the machine, I don't get a single prompt or anything that indicates it's been connected, other than that the LED on the dock goes from amber to white, the NIC lights up (if plugged in), and the laptop charges properly and indicates as such. You're suppo... Read more

Read other answers
RELEVANCY SCORE 80.8

I have a 6th Gen X1.  One of the thunderbolt ports no longer works with the monitors on the docking station - the keyboard and mouse do work.  The monitors do work when plugged into the other thunderbolt port.  I am worried that one will stop working too.   I do not know of any damage or issues and I ensured the latest drivers were installed.   Any ideas on how to troubleshoot? 

Read other answers
RELEVANCY SCORE 80

I recently purchased a Lenovo X1 Carbon Generation 6 laptop, Lenovo Thundebrolt 3 dock and Dell U2717D monitor.  Unfortunatly, I am finding that when I connect the monitor to the dock via mini display port OR full size display port, Windows 10 defaults to a 6-bit color pallete resulting in horrendous banding. Through troubleshooting I have found that: The issue appears specific to Windows 10 -- Ubuntu does not have the same issueThe issue appears specific to display port regardless of cable (mini and full size) -- HDMI does not have the same issue but HDMI only runs at 30hz.The issue appear specific to newer Dell monitors -- I have an older Dell U2715H monitor that also runs at 2560x1440 resolution that does not have this issueI've found a few others reporting the sme issue with other Dell monitors but what I have not found is a resolution.  Dell has suggested that I try a USB-C to mini Display port cable which I am considering but I'd really hate to throw good money after bad and so am also contemplating a return. Anyone else out there have this issue? Is there  way to force the color depth to 8-bit like it should be all along?  

Read other answers
RELEVANCY SCORE 80

Hello everyone, I am new to this forum and have a problem regarding setting up 4k displays:Equipment: Thinkpad x1 carbon 2017 (5 gen) with wqhd, thunderbolt 3 dock, 2 4k samsung displayshttps://support.lenovo.com/de/en/solutions/pd029622This is my target setup:1. 4k display at 60 hz connected via dock at dp1 (display port)2. 4k display at 60 hz connected via dock at dp2(ideall: 3. x1 carbon wqhd internal display on) My problem is that the second 4k display (a Samsung TV) did not connect when I connected it via the dock (picture shortly present, then goes away again, when trying again no picture at all). However it works (all 3 displays on) when I connect 2. via the hdmi connector directly at the laptop. Hence: is there any way to get it working like in my target setup? Thank you very much for your suggestions and ideas!Besterev

Read other answers
RELEVANCY SCORE 80

Received Thunderbolt 3 dock for my X1 Yoga 2nd Gen.It's charging the Yoga, the two displays are working.ALL the USB and ethernet ports are not.Did the updates, restart, repower of dock and Yoga.I know the ethernet is good because I have been using an USB to ethernet directly connected to the yoga.Yes I disconected the USB to ethernet adapter when trying the ethernet port on the dock. 

Read other answers