Over 1 million tech questions and answers.

X1 Carbon 7th Gen External Display Not Working + Thunderbolt Missing

Q: X1 Carbon 7th Gen External Display Not Working + Thunderbolt Missing

Hello everyone, At the end of last year I bought a bunch of Carbon X1 7th Generation laptops for our office, and several of these are suffering from the issue that is also described in these threads: https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-gen-HDMI-not-working/td-p/40915... https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-Gen-HDMI-Not-Working-and-Thunde... Basically, the laptops will occasionally cease to recognise external displays, and when this happens Thunderbolt has also gone missing. The top thread mentions that firmware has been released in June that should solve the issue (post 41), but as far as I can see our systems are currently up to date according to Vantage with Thunderbolt driver 1.41.729.0 installed, and the problem persists. (Granted, the thread was about 6th gen, and I am not sure how relevant it is for 7th gen laptops). Another solution mentioned in the same thread is to reset the laptop with the small button on the bottom. This does indeed solve the problem, but only temporarily - after a while, the issue returns. What I am therefore looking for is a permanent fix for this problem, but since I am out of ideas myself, I am hoping that someone here might have another suggestion. Any help would be appreciated. Many thanks!

Read other answers
RELEVANCY SCORE 200
Preferred Solution: X1 Carbon 7th Gen External Display Not Working + Thunderbolt Missing

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 88.8

Machine: X1 Carbon 6th Gen, Windows 10 Home 64 bitEverything is up to date through Lenovo Vantage / Windows Update Issue 1: HDMI port is not working, no output detected on any monitor. Same HDMI cable / monitor using a different laptop works just fine.I did everything here already : https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-gen-HDMI-not-working/td-p/40915... Issue 2: Thunderbolt 3 is not detected in Device Manager under System.Tried everything here already: https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-gen-BIOS-update-broke-external-... In summary I've tried pressing the little button on the bottom the laptop, toggling Thunderbolt BIOS assist, and reinstalling the Thunderbolt drivers but those have not resolved the issue. Any other suggestions I should try?

Read other answers
RELEVANCY SCORE 82

Hi!I just got a new "X1 Carbon 5th Gen - Kabylake (Type 20HR, 20HQ)" and a "X1 Carbon Thunderbolt 3 Dock". I have an external screen connected to the dock and it works fine (VGA connection). I also have an other monitor with display (DP) connection that I want to use. But my computer can't find the other monitor, only the one with VGA connection. Is there any easy ways to fix this problem?Best regards

A:ThinkPad X1 Carbon 5th gen can't connect 2 external monitors in X1 Carbon Thunderbolt 3 Dock

[Posted moved and topic edited for discoverability.  AG]

Read other 1 answers
RELEVANCY SCORE 76.4

Hallo Community, I am using my X1 Carbon gen 4th with an external Monitor via HDMI cable. Now i would like to try to add another external Monitor on it. Without any docking station would be perfect. I notice that there is also a mini display port on my device. I suppose I can connect one monitor via HDMI and the other with mini Displayport? Will these two monitors work together at the same time? I would like to ask, if anyone has experience about that?   Thanks for the  inputs in advance! 

Read other answers
RELEVANCY SCORE 75.6

Symptom: In the Thunderbolt software, nothing appears in the Port even I connect the GPU(aorus gaming box 1070). Nothing shows up in the system devices. GPU driver cannot detect the GPU. The same GPU and thunderbolt port worked a few months ago, but it is not working now. I can use the thunderbolt to charge, but it cannot detect the device. I am confident that there is no hardware damage during these months. What I tried: Updated Thunderbolt firmware, software, checked power setting, checked BIOS, tried everything. Not working.

Read other answers
RELEVANCY SCORE 75.6

Hello, I'm trying to connect two external monitors (1920x1200) to my X1 Carbon 6th and only one of them actually works. The other one is displayed as a small square in Windows display settings. When I checked "Advanced display settings", I see all display adapters (3 total), but one of them shows up as "Display 3 isn't active.". I'm using a Thunderbolt 3 to dual displayport adapter (this one). Can anyone help me with this issue? Thanks!

Read other answers
RELEVANCY SCORE 74.4

Hi All,  I recently got two 1920x1080 monitors and have been attempting to hook them up to my Thunderbolt 3 dock and X1 Carbon with no success. All firmware has been updated, and the dock detects each display individually, when the other is disconnected and reconnected. Everything else works on the dock with no issues.  Thanks.

Read other answers
RELEVANCY SCORE 74

Hello Everyone, I am new here so please go easy on me.I just bought and X1 Carbon 5th Gen laptop c/w Thunderbolt 3.0 docking station.The problem that I have is that the docking station won't recognise any of the external screens that are connected.I am using two Acer screens (one is connected using HDMI port on the dock and the other one uisng Display port).I have tried by connecting just one screen but nothing.I can see that Thunderbolt software is installed and its connected to my laptop.The laptop will charge through the docking station and also the wireless mouse and keyboard will work fine through the dock.Lenovo recommended that i should update my drivers.So I installed Lenovo Companion from Windows store. But it won't update my system. After clicking on System Update, I will get an error message saying "There is a problem in reteriving new updates for your system.Please try again later".Hence I downloaded all the drivers from support website and installed them manually but my docking station is still not working with the external monitors.The monitors works fine when connected directly to the laptop using the HDMI cable. Thanks in advance for your help.

Read other answers
RELEVANCY SCORE 72.8

P1 i7-8850H, 32GB RAM, Quadro P200 conected to a LG 32UD99-WBoth in Windows 1809 and 1903 when resuming from sleep it will randomly happen that:Audio through the external display is lost. Audio device shows a warning mark and you have to disable/enable in device manager to get it back working.External display is no longer recognized (2 times in 24 hours) you have to disable/enable the Nvidia Quadro P2000 in device manager to get it back working. Connectivity is unreliable regarding internal graphics, external screens and thunderbolt It seems to me that these recurring graphics, display and thunderbolt issues found in P1 X1 machines are related to it. Is there anybody experiencing the same? This is a summary of bios versions with fixes related to issues alike.<1.21>UEFI: 1.21 / ECP: 1.10- (Fix) Fixed an issue where WMI BootDisplayDevice option is incorrect. - (Fix) Fixed an issue where the system might not resume from hibernation on Discrete Graphics mode with Windows10 version 1809.<1.19>UEFI: 1.19 / ECP: 1.10- (Fix) Fixed an issue where the system might BSOD when connected the external monitor.(Note)NVIDIA Graphics Driver v25.21.14.1735 or later version is required.<1.18>UEFI: 1.18 / ECP: 1.08- (Fix) Fixed an issue where the system might not boot with Hybrid Graphics.(Note)If the UEFI BIOS has been updated to version 1.18 or higher, it is no longerable to roll back to the version before 1.18 for boot problem prev... Read more

Read other answers
RELEVANCY SCORE 71.6

After the Thunderbolt firmware update, I'm now getting terrible white level clipping on my external monitor. I'm a photographer using a 100% Adobe RGB monitor calibrated with DisplayCal and a Spyder 4. Until updating the firmware, I had 0 problems. Now, compared to before - and compared to other computer attached to the same monitor - the contrast is completely wrong. All RGB values including and above 244 are clipped to 255. This is obviously a huge problem. I've uninstalled all of my calibration software, and removed all my color profiles from Windows Color Management, so Windows should revert to the default profile. Still, the same problem! What is going on? I never had this problem, until the update!

A:X1 Carbon 6th - Harsh white level clipping on external USB-C monitor after Thunderbolt update

Hi benjaminbusch, Can you be precise about WHICH update you are referring to please (e.g. provide a link). Thanks!

Read other 1 answers
RELEVANCY SCORE 69.6

Hi everybody,I'm facing an issue with thunderbolt.It started recently, after one of Vantage update runs. I've read through the forum and tried almost everything, but still no luck. Current state:1. Thunderbolt controller is not in the list in Device Manager. (0x20B SDK_NO_CONTROLLERS)2. USB-C devices (flash, camera) do not work3. Charger only charges when laptop is powered down (when on, it barely maintains the battery level)4. HDMI doesn't work either What I've tried (several times now):1. Running Vantage and installing all updates.2. Flashing newest BIOS (1.44)3. Installing the "critical thunderbolt update".  - Software update went through.  - Firmware update didn't happen cause controller is missing4. Clean re-install of the Thunderbolt drivers, including  - 'sc delete nhi'  - deleting tbt* driver files under system32/driverstore/5. Battery reset (pin at the bottom)6. Toggling 'Thunderbolt assist mode' in BIOS. Current system status:1. BIOS version 1.442. OS version Win 10 Pro 17763 (1809)3. Thunderbolt Software version 17.4.80.550 Nothing worked for me so far. Any ideas as to what I can try next?  

Read other answers
RELEVANCY SCORE 69.6

All of a sudden, my hdmi and the thunderbolt3 ports stopped working. I've tried multiple fixes: 1) Setting Thunderbolt Assist Mode -> Disabled, Reinstalled drivers, Updated Bios 2) Using the pin trick to reset the battery Issues: Cannot see the Thunderbolt 3 under System Devices. I ran the thunderbolt firmware detect tool and got this error message instead: 0x20B SDK_NO_CONTROLLERS Cannot flash/update the Thunderbolt 3 Firmware. All I get is this error:   And if I go and check About in the Thunderbolt Software:   I am pretty much at my wit's end here. I pretty much use an external monitor and it just stops working. I have no clue how to proceed. Help!

Read other answers
RELEVANCY SCORE 69.2

USB 2.4Ghz mouse doesn't work on any of the Dock 2 USB ports. Same mouse adaptor works right away when in the ThinkPad USB ports. Tried a couple of other USB devices, old an new, and none work in the Dock ports even though they work fine when in the Win 10 ThinkPad as well as in another older Win 7 laptop. Checked all Win 10 drivers are latest versions, tried the disable/enable toggle, all to no avail. The Dock itself is hapilly driving two monitors and seems to otherwise work fine.  The always-on USB port on the back has power, and so does the one USB port on the front (but neither work for USB connected devices). This is a brand new setup, hoping for a trivial solution otherwise I will chuck this whole thing, at this age this should be plug and play. Suggestions?

Read other answers
RELEVANCY SCORE 67.2

Has anyone experienced this issue below? I disable my internal Quadro M1000M, I plug in my eGPU (AORUS 1070 Gaming Box) via Thunderbolt, use it for a while. Then when I'm done using it, I unplug it, re-enable my Quadro M1000M and plug in my external monitor via HDMI.   The display driver crashes for both my Quadro M1000M and my Intel HD Graphics 530 and the external monitor never works.  Microsoft starts a Microsoft Basic Display Driver. I tried disabling and re-enabling both display adapters but external monitor still won't work, it just crashes the adapters again. The only fix to this issue I have found is to uninstall the Quadro M1000M in the device manager and restart the computer. Then after it restarts, I can use the external monitor again with the Quadro M1000M. So it's easy to do and not a huge pain in the butt, but if anyone knows a way to fix this issue without needing to restart my computer, that would be a great help.

Read other answers
RELEVANCY SCORE 66.4

I have a P1 GEN2 OLED. While the internet is flooded with complaints of the OLED screen itself, the thunderbolt 3 port of my P1 GEN2 magically stopped working for no reason.  I have been using the laptop with an external display ever since I got the laptop. All went well. Suddenly from yesterday, the external display starts turning into a blue sreen with "NO SIGNAL" shown on it.  I had a windows cumulcative update (KB4532693) and windows security update (KB4524244) yesterday and I suspected that the update might be the culprit. I rolled back the OS. No change. Still NO SIGNAL.  I searched this Forum. Played with Thunderbold 3 menu in the Bios. Everything was enabled and every single option of "security level" was tried. Still NO SIGNAL.  I checked Intel Mangaement Engine software. It is already the latest version. Reinstalled it. Still NO SIGNAL.  I checked Nvidia driver. Latest version already.  In sum, the problem is: the thunderbolt port is still able to power the extenal display but just simply does not pass signal to the external display. HDMI port, however, still passes signal if use an HDMI cable.  I want to give it a shot here to see if anyone has experienced similar issues and how they sovled the problem before I call Lenovo technical support, the staff of which does not seem to know more than some people here on this Forum. 

Read other answers
RELEVANCY SCORE 66.4

Hi, I'm having issues with my external 4k display to only be able to operate at 30Hz. I have my laptop connected to a generation 2 Thunderbolt 3 dock via the provided cable, and from there I have tried both DisplayPort and HDMI cables (several) to connect to my display.All the technical information I have seen says that my laptop plus the dock should be able to operate at 60Hz even at this resolution, but I'm unable to lock down the settings that enable me to do that. I have pulled the latest BIOS, TB3 FW, display drivers, Intel chipset drivers from the product page.My screen is: AOC U3277FWQ if that matters. I'm running Windows 10 Pro 1809. Has anyone battled with the same issue? I'm running out of ideas on how to solve this. The HDMI port on the side is apparently only 1.4 so this would only support the [email protected], but I'm not using it at the moment. If I set the screen to 1920x1080, I can set the resolution to 60Hz. Best regards,_tero

Read other answers
RELEVANCY SCORE 65.6

Hello I seem to have a problem on my P53 laptop, as the external displays, connected on the two HDMI ports on the Lenovo TP Thunderbolt 3 Workstation Dock(Product nr.: 40AN0230EU), they just randomly turn on on the first try. If they not turn on, on the first try, I have to put it back to sleep and then awake again at once. I always use the power button on the dock.So where can I see what firmware version I have for my Thunderbolt 3 Workstation Dock. I se that I have controller driver version 1.41.648.4.I've also search on Lonovo's site to find a download, but can only find this site: https://pcsupport.lenovo.com/us/en/products/accessory/docks/thunderbolt-3-workstation-dock/40an/down... but I can not see the workstation dock listed, just the Thunderbolt 3 dock, but maybe that cover's both? The version listed is: V1.0.0.20 of 07 Aug 2019. I'm also very confused about what dock I really have, is it the:  ThinkPad Thunderbolt 3 Workstation Dock, ThinkPad Thunderbolt 3 Dock Gen 2 or the ThinkPad Thunderbolt 3 Workstation Dock Gen 2 , or are they all the same as they seem to use the same driver if you look at this site:  https://pcsupport.lenovo.com/us/en/downloads/DS505148  , here the latest driver version are : V10015 of 23 Sep 2019. It's also odd that the Sep version(10015) has a lover number that the Aug version(10020)?  I'm also very confused as if the terms firmware and driver's are used correctly, and are there really 3 different... Read more

Read other answers
RELEVANCY SCORE 65.2

I have connected a Thinkpad X1 carbon (model:20BS0057AD) to ThinkPad OneLink Dock which further connects to a ThinkVision Pro2820 28-inch LCD monitor using DisplayPort. In order for the display to work through the dock I have to power down and power up the Dock and Monitor for the monitor to receive display signal. Once its working and I disconnect the dock from the laptop and reconnect it back, the monitor will not come on and remain in low power mode with amber light. I then have to go through the power down and power up cycle for the monitor to display laptop output signal or else it will remain in low power mode. Previously was using a Thinkvision L2251p monitor and never faced any such issue. Is there a fix for this issue

Read other answers
RELEVANCY SCORE 64.8

Recently got i5 7567....GTX 1050 Ti ...I have an old AOC monitor which supports VGA input....through HDMI to VGA adapter connected my laptop to monitor... On duplicate screen mode and second screen only, it works.....but the monitor goes blank saying "input not supported" on 'extend display '.
display settings has detected the external monitor...while intel hd graphics setting and nvidia control panel are not detecting the external monitor... 
Need help folks...!

Read other answers
RELEVANCY SCORE 64.4

Hi everyone,  I am to be the lucky owner of an X1 Carbon soon. There is one thing that I can't find the answer for in the documentation and spec sheets: - what is the maximum resolution that the mini displayport can handle? The display that I'm looking to buy is running 2560 x 1080.













Solved!

Go to Solution.

A:X1 Carbon - Maximum Resolution for External Display

it can exceed 2560x1600.http://www.flickr.com/photos/lead_org/8174271221/in/set-72157631942745040/

Read other 9 answers
RELEVANCY SCORE 64.4

Hi, I have a Carbon X1 Gen 6. When connected to an external display the laptop reboots at random times during operation. When the display is connected, but the laptop is not being used, it seems to remain on. The event viewer shows a few errors before the Critical Kernal-Power error. (events file is attached) All updates, including bios firmware are always up to date. I am posting here because this issue has been since I have owned the laptop. Any help would be apprecitied. Thanks

Read other answers
RELEVANCY SCORE 63.6
RELEVANCY SCORE 63.6

They WORK!
My new 2017 Dell XPS-13 2-in-1 arrived today and just finished testing it with our Apple Thunderbolt Displays & new Apple Thunderbolt Adapter ($29). Plugged it (adapter / mini-dp pigtail) into the LEFT USB-C port and monitor sprang to life without any issues. The LEFT port appears to have a higher class of protocol extensions. The Dell also works in "lid-closed" condition, but requires an "open-shut" to activate sleep after disconnecting.
We also have a Acer R240Hy Usb-C display which works (charge/video) from both ports. The LEFT port is smooth for FHD, but the RIGHT usb-c has drops under FHD.

Read other answers
RELEVANCY SCORE 63.6

Hello, I just bought an X1 Carbon Gen 4 and need to hook up 2 external monitors which have VGA, HDMI or DVI ports available. The idea is to have a 3 monitor setup (all three monitors with a resolution of 1920x1080) including the Built-in monitor and the 2 external ones. I have bought the OneLink+ adapter that has the RJ45 and VGA ports (4X90J31060) and am trying to set the whole rig up so that one monitor connects to the VGA port on the adapter and the other monitor is connected through the HDMI port on the laptop. The problem is that I can only seem to get 2 monitors going at a time, either Built-in & HDMI or Built-in & VGA. Before I go and buy more hardware (i.e. dock or MiniDP to HDMI/DVI adaptor), I was wondering if what I am attempting is even possible, and if it is, what I am doing wrong. Thanks to anyone who can answer.  

Read other answers
RELEVANCY SCORE 63.6

Hi,I just got a X1 Carbon 20HR, and the ThinkPad USB-C Dock with it. The issue is, that when I use the dock and have it connected to my external monitor [Samsung LU28E85] then the mouse is lagging a bit - but enough to annoy me and make it harder to reach the right buttons.... This is both when I use a cabled mouse, as well as via Bluetooth or the Logitech connector. I would say thoug, that the cabled mouse seems to perform a little better than the wireless connections.When not in the dock and working on the screen of the laptop, there are no issues with any of the mice at all.There also seem to be a bit of lack with the keyboard entries...... Any advice?I was wondering if it can be the dock which is "underpowered" and should have been the Thinkpad Thunderbolt 3 Dock instead? I have you can help Kind regardsLasse 

Read other answers
RELEVANCY SCORE 62.4
A:Thinkpad Carbon X1 Display BLANK after Update - External Monitor Works

I spent a day working on an issue and want to share to save folks time.  Bottom line, Intel Graphics Drivers WDDM 1.0, 1.1., 1.2, 1.3 automatically updated with Windows and broke the system. BIOS and Lenovo splash screen showed and safe mode worked fine showing this was not a hardware issue.  Windows began to load and the screen went black.  I connected an external monitor via HDMI, pressed power for 2 seconds to put the machine to sleep, pressed power again for 2 seconds and it woke up on the 2nd monitor. In Device Manager, the 2nd (HP w2007) monitor showed up and there was no mention of the laptop physically connected display. I reinstalled Windows 10 and all was well until the auto-update occurred and I had the same issue.I installed Windows 7 and all was well until I installed all updates, same issue. I didn't think this was a display adapter problem because the 2nd monitor worked just fine and it was the monitor that didn't show in Device Manager.  Alas, my assumption was incorrect. After HOURS of selecting which Windows 7 updates to install, nearly 180, I finally narrowed it down.  I thought it was a Windows problem, turns out this was an Intel Graphics driver issue. SOLUTION: I used Revo Uninstaller to remove the Intel Graphics driver program and the system recovers.  Sadly, in both Windows 10 and WIndows 7, the auto updates would put the drivers back and the same problem recurred.  I was finall... Read more

Read other 1 answers
RELEVANCY SCORE 62.4

I have a monitor attached via hdmi to an x1 carbon 6th gen with the HDR display. No matter what I try in windows color management, I cannot apply a color profile to the monitor. The only thing that changes the color is when I switch the color profile of the internal LCD using Lenovo Vantage (native, standard, photo pro, etc) and ONLY if the monitor is not connected. Once I plug the monitor in it will inherit the color profile of the internal LCD. Needless to say, none of the available profiles within Vantage are ideal for my monitor and all look ghastly oversaturated. I've tried uninstalling the Portrait Chromatune software. No affect. I've tried uninstalling Lenovo Vantage. Nothing. Tried reinstalling the Intel display drivers. Nothing. Can't apply any color profiles, not even the default WCS ones or any other. Tempted to nuke my windows install...

Read other answers
RELEVANCY SCORE 62

I am trying to use a 3rd party external GPU enclosure that attaches via thunderbolt, and when attached, I got the message pop-up that external GPU support was not enabled by the vendor, and as such the device will likely not work? Has Dell locked the Latitude 7480 down to no external GPU support?

A:Latitude 7480 - Thunderbolt 3 - Thunderbolt software say external GPU support not enabled?

Probably.  I read somewhere that since Dell is pushing their Alienware external GPU stuff that uses a proprietary connection, they never enabled external GPU support via Thunderbolt.  

Read other 1 answers
RELEVANCY SCORE 61.6

Hello, I tried to use Lenovo Vantage to fix my problem, make all necessary updates and tried to contact support.Until now I could not find any useful information so any link to a page which can help me to narrow down the problem is highly appreciated! My display stopped working from from standby mode to the next. I opened the laptop and could barely see the Lenovo sign but nothing else from that point on. I can connect a display through HDMI and can work with the laptop. As I could see "something" I tried to look into new drivers or any system information which might say there was a problem with an update. Lenovo Vantage did not provide any information but I updated to the latest drivers as far as I can tell.In a perfect world I could get some help from Lenovo to narrow down the problem before sending the laptop in.If anybody else has a hint where to start to fix a X1 5th Generation display this would be much very helpful. Thank you Sven

Read other answers
RELEVANCY SCORE 60.8

Hello, My Thinkpad X1 carbon gen 3 displayed stopped working.   i can use an external monitor via the hdmi.   I tried updating the display driver to 20.19.15.4531 but that does not help. Any suggestions  

Read other answers
RELEVANCY SCORE 60

Display issue in Lenovo X1 CarbonDisplay non touch. Native resolution 2560x1440 on ci7 8GB 256GB SSD.When I wake the laptop from sleep/power on/restart it keeps happening for around 5 -10 mins then screen goes to normal.Sometimes screen stays dark but when I move the screen to and fro at different angles at some point display starts working.Though on external display it works fine.Now I would like to ask if any one who has the Idea that? 1. Is it a BAD/loose connection between display cable & mother board or between cable and back side of LCD panel?2. Is it a bad cable itself?3. Is it an issue of faulty LCD panel? or 4. Is it a bad motherboard? Please watch the video for exact issue.

Read other answers
RELEVANCY SCORE 60

Display issue in Lenovo X1 CarbonDisplay non touch. Native resolution 2560x1440 on ci7 8GB 256GB SSD.When I wake the laptop from sleep/power on/restart it keeps happening for around 5 -10 mins then screen goes to normal.Sometimes screen stays dark but when I move the screen to and fro at different angles at some point display starts working.Though on external display it works fine.Now I would like to ask if any one who has the Idea that? 1. Is it a BAD/loose connection between display cable & mother board or between cable and back side of LCD panel?2. Is it a bad cable itself?3. Is it an issue of faulty LCD panel? or 4. Is it a bad motherboard? Please watch the video for exact issue.

























Lenovo-X1.jpg ?35 KB

Read other answers
RELEVANCY SCORE 60

When I put my laptop to sleep, the display would not turn on.  However, the HDMI output still works with an external monitor.  I reset Windows and the display worked fine again.  Then, after putting the computer to sleep, it went black again.  I don't want to reset Windows as there appears to be some type of bug in the BIOS/Windows drivers/Intel drivers.  Has anyone experienced this type of issue and been able to resolve it?

Read other answers
RELEVANCY SCORE 58

I already typed something here, since I thought it is related:https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Carbon-6th-gen-BIOS-update-broke-external-... Pulling Thunderbolt cables was fine. After a while:Pulling Thunderbolt cables gave me 1 in 3 cases a bluescreen (internal power error). I did a BIOS / Thunderbolt / Driver update on 21th of May 2019. Everything was fine, restart worked. Went to work, this time, turned into standbye before pulling the cable. Everything was fine. At home, I opened the Screen after getting out of Sleep (old Linux Standby), saw the welcome for a short moment, and than bluescreen again.  Reboot, ... freezes in BIOS. Directly at the "Lenovo" Splash screen, before having the chance to put on the finger on the fingerprint reader.Super laggy. Tried EVERYTHING mentioned in this forum, enabled/disabled all settings in BIOS, had to reset with the button in the bottom with a paper clip, tried to deactivate internal battery. By a chance of 1 in 4 I could get into the BIOS or select a boot media.  Lenovo hardware test says, that everything is fine. Have been many times, close to a brick, since it hangs directly after pressing the power button. By chance could boot, made a backup. HDMI is also not working. Does not recognize any thunderbolt devices. Flashed old BIOS version, no difference.  What makes a difference: completely disabeling thunderbolt in bios. Than BIOS/booting works like a charm, b... Read more

A:X1Carbon6th, Pulling Thunderbolt cable broke Thunderbolt CHIP, BIOS is freezing, HDMI not working.

For me it sounds like the Thunderbolt Chip or Firmware is broken. Similar to the more popular bricking of Yogas, P51, before. I maybe could flash it manually like discribed here, but I guess, this is against warranty regulations: https://posts.nadim.computer/2018/10/26/repairing-a-thinkpad.html  

Read other 1 answers
RELEVANCY SCORE 57.6

Hello,the thunderbolt on my X380 Yoga completely stopped working. As I try to connect a P27h for instance, the laptop charges but does not recognize the monitor or USB Hub.I installed every update available on system update and tried to update the Thunderbolt Software and Firmware. The software installed fine but upon updating the firmware the following promt appears:    When I check the version inside the Thunderbold software, this is what shows up:    I am running Windows 10 Home 1803. Any idea why this is not working? Is my thunderbolt controller not working properly?Thanks

A:Thunderbolt not working / Unable to update thunderbolt firmware

There is an issue with the update for the tunderbolt firmware when updating through the system update utility. This is a known issue that the Engineering department has been working on. The only known resolution to this issue so far has been to replace the system board. Im sorry for the inconvenience this is causing. If the device is still under warranty i would speak with the support center to have a tech install a new board.

Read other 1 answers
RELEVANCY SCORE 57.6

Over the last few months I've had around 7 different occurances of a monitor not displaying anything while powered on and hooked up. This has happened with multiple makes and models of monitors and also laptops, even the connections are different in some cases whether it be VGA, VGA to Mini display, HDMI, or HDMI to Mini display. The only similarity of all the occurances is 2 monitors were used while this happened. Each time I've replaced all the adapters and cords to see if that would fix it. The only thing that seems to fix it, is to switch the monitor out with another one. This happened after the founders update for Windows. All PC's are using Windows 10 64 bit. Any help would be appriciated on this! 

Read other answers
RELEVANCY SCORE 56.4

I have a new Toshiba A60 with XP Home SP2 and whenever I try to view a video stream on the external display, I only see a black box. All the other items/controls display on the external monitor correctly. This happens with Media Player, Powerpoint etc.

Any ideas? I have found other postings with this problem but no solutions

Read other answers
RELEVANCY SCORE 56.4

Hello all, I have a 6th gen X1 Carbon that I've been using a Caldigit TS3 Plus with. I took my laptop on a trip and when I come back, I can't see the speakers plugged into the dock. It has shown as Caldigit prior to this, but now nothing. Also, in the Windows start logo box, Thunderbolt software is not listed. If I recall, it said Thunderbolt software (or something similar) before. When I tried downloading TB software and firmware from the Lenovo site, it said it was already there. Something similar happened once before, and I don't remember how I resolved it. Thoughts? Thanks

Read other answers
RELEVANCY SCORE 56.4

I got a fully specced X1 Carbon 6th Gen (16g, 1TB, i7).  Had issues with it.  Took about a month for Lenovo to fix and send back (they had to basically replace everything).  Now, my computer crashes whenever I plug in my CalDigit T3 (kys.sys error).  CalDigit works perfectly fine with other T3 laptops including my 2018 Macbook Pro. Further, this newly "fixed" computer will not allow me to install the latest critical update and will not recognize my scansnap ix100 scanner. I'm getting flung around from tech support claiming this is a software issue and I need to purchase the $199 service to fix.   

Read other answers
RELEVANCY SCORE 56.4

So I have an X1 Carbon Gen 5 (Kaby Lake) and the Thunderbolt 3 Dock Gen 1 (40AC0135US). I bought two 4k monitors and after several frustrating hours figured out that the Gen 1 dock can't output 4k on two externail monitors at 60hz, this appears to be a dock limitaion only. I see that you now have a Gen 2 dock (40AN0135US) that says it will do 2x 4k @ 60hz, only problem is that every compatability cross refrence I can find does not say the gen 5 X1 Carbon supports this new dock. I don't see a good reason for it not to be compatiable, but wanted to find out for sure one way or the other before I bought it, as it is not cheap. 

Read other answers
RELEVANCY SCORE 55.6

Just got purchased the x1 carbon 5th gen along with the Thunderbolt 3 dock.  However, the dock will not charge the laptop.  Every time I get the error message "The dock is not supplying enough power to your computer.  Please use the ac power adapter that came with the dock".  I am, in fact, using the ac adapter that came with the docking station.  I have updated the bios as well as all of the other recommended updates and still get the same error message.  Does anyone have a solution?

Read other answers
RELEVANCY SCORE 55.6

I recently purchased the X1 CRBON 5TH Gen (2017)...type 20HR plus a thunderbolt dock.I connected them together with a Dell 28" 4K (@30Hz) screen (p2815q) connected through DisplayPort from the dock, plus a Microsoft keyboard and Jabra 510 USB speakerphone.Using the Windows 10 stock image from Lenovo, plus Office 2016, Chrome, Visual Studio, Skype,  and various other apps (putty, RDP, SAP GUI, others) the video performance was atrociously bad. Alt-Tab, which I use heavily would take 3-4 seconds to respond, switching between applications, Windows would freeze and sometimes crash, I would often get blank or black windows in Chrome and Office. This was on the embedded Thinkpad screen as well as the external monitor.I ensured Windows Update was up to date, as well as Bios, Drivers etc through the Lenovo companion app. So...I dove into the BIOS and voila! There is a switch that lets me change the Video memory from 256 to 512 MB allocated!I went to change it, and it would not change until I changed the setting:BIOS > Config > Thunderbolt 3 > Security Level = from "User Authority" to "DisplayPort and USB"I switched that setting, and then set my video memory to 512 MB, rebooted and voila! Problem solved. I worked that way for a little while, took it into my office and plugged it back into my Thunderbolt 3 dock and while my video and LAN connections worked...my wireless keyboard (USB dongle), and Jabra 510 did not. Curious. I r... Read more

Read other answers
RELEVANCY SCORE 55.6

Hi, all. I have a problem thunderbolt is not charge notebook, but usb ports and displayport working.1. I connect the Laptop with the Thunderbolt connector on the backside of the Dock (beside the HDMI/DP connectors) and on the frontside, not working.2. I updated all drivers.3. I go into the BIOS and "disable the battery for technical service".But if I use an AC power adapter, it charges.Does anyone have a solution?

Read other answers
RELEVANCY SCORE 55.6

The X1 carbon 6th Gen supports Thunderbolt 3, yet it is not listed as compatible with the Thunderbolt 3 Dock Gen 2. Anyone have an idea why? Also the ThinkPad T470s.
 
https://support.lenovo.com/us/en/solutions/pd500265
 
The X1 Yoga 3rd Gen and X1 Yoga 2nd Gen are listed as compatible. Perhaps it just means that the dock has been specifically tested with the listed models? Surely Thunderbolt 3 is Thunderbolt 3 and the dock should work with plenty of other Thunderbolt 3 machines?

Read other answers
RELEVANCY SCORE 55.6

Hello,  I have the X1 Carbon (5th gen) and am looking at purchasing an ultrawide 5k monitor. I then realized, my setup may not support a monitor above 4k. I have the Thunderbolt 3 workstation dock, and know the user manual says I can run a 4k monitor. So does this mean I would not be able to run a 5120x2160 ultra wide? Thanks!

Read other answers
RELEVANCY SCORE 55.6

Hey,  Hopefully someone can help.  I am using an X1 Carbon 6th Gen plugged into a Thunderbolt dock using two external displays.  When I plug in the dock, I find that my Microsoft programs are blurring. If I close and restart the programs they are fine.  Any advice? 

Read other answers