Over 1 million tech questions and answers.

X1 Carbon Thunderbolt docking station, no ethernet.

Q: X1 Carbon Thunderbolt docking station, no ethernet.

I have a 5th gen Carbon connected to the Lenovo Thunderbolt docking station. After some time, perhaps a sleep or hibernation, the laptop loses ethernet connectivity and can only use wifi. ipconfig reports media disconnected. But if I do a restart of Windows 10, ethernet is back, no problems. Also if I use the ethernet dongle connected to the laptop's weird little ethernet port, there are no issues. There are other issues with the dock, like intermittent loss of wireless keyboard and mouse connectivity, but I'll worry about those in another thread.

Read other answers
RELEVANCY SCORE 200
Preferred Solution: X1 Carbon Thunderbolt docking station, no ethernet.

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 113.2

I have installed the drivers and rebooted, but it still does not show up.  The docking station is a 40AC0135US which was indicated as the correct docking station by Lenovo's docking station finder.    I have no idea how they have managed to make this so difficult.   

Read other answers
RELEVANCY SCORE 113.2

I have installed the drivers and rebooted, but it still does not show up.  The docking station is a 40AC0135US which was indicated as the correct docking station by Lenovo's docking station finder.    I have no idea how they have managed to make this so difficult.   

Read other answers
RELEVANCY SCORE 112

Hello ... I use an Thinkpad Yoga370 together with the Thunderbolt 3 Docking-Station for business. For private use I have an Thinkpad X1 Carbon 4th Generation. Is there any possibility to connect it to the Thunderbolt 3 Docking-Station e.g. by an adapter? So I would like to use the Thunderbolt 3 Docking-Station with connected Screen, Keyboard, Mouse with both Laptops. Thanks for your help and best regards ...

Read other answers
RELEVANCY SCORE 111.6

I am connecting my X1 Extreme to Thunderbolt 3 Docking and find out the Ethernet is not working. By looking into network adapters in Control Panel, it shows the Ethernet of the docking station is disabled. However, whenever I try to enable it, it automatically goes back to disabled state. Any help?

Read other answers
RELEVANCY SCORE 90

I am struggling with my docking station for my ThinkPad 480s.  I have two docking stations.  One by Lenovo type 40AJ and the other by DELL.  The dual monitor DP setup resets every 3 to 5 minutes causing the monitors to go black with the Lenovo UltraDocking Station.  So I switched out that docking station with the DELL universal docking station.  When I use the USB C/Thunderbolt port the same thing happens.  When I use the USB 3 port, I have no problems.  I have looked in the event viewer and I can see where the laptop switches from external to battery power, but nothing else.  Also, I have updated the drivers for Thunderbolt. Has anyone seen and resolved this issue?

Read other answers
RELEVANCY SCORE 88.8

I recently received a ZBook 15 G3 with the ZBook dock. After installing Ubuntu 16.04 the dock didn't work at all, it only powered the laptop. I changed the BIOS security configuration for the Thunderbolt port (under Advanced, Ports) and was able to get an external disply working.However, the USB ports on the dock are still not working, the audio jack isn't working and the ethernet port isn't working. When connecting a cable to the ethernet port on the dock the laptop will show that it's connected but there still isn't any internet connection.I will appreciate any help as right now the dock is pretty much unusable.

Read other answers
RELEVANCY SCORE 88.8

Hello, Notebook is super noisy and dock wire is way too short to put it somewhere far away. I though may be it's possible just pluging power into notebook and connect docking station via Thunderbolt only but not sure if it will work and if docking station in fact needs external power which thunderbold cable will not be able to provide.

Read other answers
RELEVANCY SCORE 88

Hello, does anybody know if ThinkPad Thunderbolt 3 Dock is compatible with T480s? I have installed all the drivers  https://pcsupport.lenovo.com/ie/en/products/accessory/docks/thinkpad-thunderbolt-3-dock/40ac/40ac013... I have searched this forums and followed some advice re BIOS settings for TB3 (didn't make any difference). Everytime I connect this dock the mesage comes up "Display connection may be limited".All it does it charges the laptop, but no USB devices work (mouse, keyboard), also Monitor connected through display port does not work. I replugged and restarted everything multiple times. I also updated all possible drivers for T80s (Win10 x64). Any ideas how to get this working, or are those products not compatible? Many thanks for assistance 













Solved!

Go to Solution.

A:T480s - unable to use "Thunderbolt 3 Docking Station"

Okkkkk I got it solved... very embarassing. On the laptop I plugged originially USB-C cable to the same port as charger.Next to it is another port that looks like something slightly else, but there is actually usb-c in it too. Connected and all is working Take this tip if you struggle like me, hah  Thank you

Read other 1 answers
RELEVANCY SCORE 86.8

Community: we just recently purchased a brand new Thinkpad X1 Extreme laptop and Thunderbolt 3 Workstation Dock.The Laptop is awesome but unfortunately we're on our second dicking station and wondering what we're doing wrong--or if we have a defect.  The docking station came with a 230W and 65W AC power cord, and the dock has both a 230W/170W port and 135W/65W power port. When the 230W cord is plugged into the 230W port, the dock doesn't turn on (nothing plugged in). When the 65W cord is plugged into the 135W/65W port, it lights up but no network when a laptop is plugged in or charge. The only way I get a light on the station is to plug the 230W cord into the 135W/65W port, and then when a laptop is plugged in I get network and charge. We contacted Lenovo and they sent a replacement as they admitted it was not working as it should. The second one also exhibits the exact same behavior and we are at a loss and ready to return for a refund.  I also don't want to plug a 230W power brick into a 135W/65W port for fear of overheating. Anyone else experience this or have any ideas, we'd like to hear them.  Thanks.

Read other answers
RELEVANCY SCORE 86.8

Hello,I have got a Dell thunderbolt docking station but it's not working with my Yoga laptop. I have installed the docking station driver and it is able to deliver the power to the yoga but neigther the LAN connection not the VGA display is detected. Please advise. Dell docking station model:https://www.dell.com/en-ca/shop/dell-thunderbolt-dock-tb16-240w/apd/452-bcnu/pc-accessories TIA

Read other answers
RELEVANCY SCORE 86.8

I have several Dell 5510 Precision series with the Thunderbolt USB-C adaptor. Each 5510 is plugged into a Dell K17A docking station powered by a Dell 130W power supply. When I connect the docking station via its USB-C connection to the 5510 laptop, I get a BIOS warning that it only sees 95W of the 130W. But the battery charges and the laptop runs. I can turn off the power warning in the BIOS (which is current) but I worry about powering the 5510's Nvidia video card and other components if the BIOS is not seeing all 130 watts.
Plugging in the 130W psu supplied with the laptop has no such BIOS error.
Why does the Dell docking station K17A not see the Dell power supply? Is it throttling it?

Read other answers
RELEVANCY SCORE 86.8

I just purchased a new XPS laptop and the D3100 docking station. I need to connect a Focusrite Saffire Pro 14 that has a 6 pin Firewire 400 out.
Should I connect directly to the XPS via the Thunderbolt port using the Apple sold Thunderbolt to FIrewire adapter?
Is there a way for me to connect with the dock via the Thunderbolt compatible USB 3 ports?
Any help is appreciated, thanks!

Read other answers
RELEVANCY SCORE 86.8

Hopefully someone here can help me before I get an aneurysm. I got the HP Thunderbolt 3 Docking Station (150 watts, model number P5Q54AA). Everything is connected ok but as soon as the dock connects to my laptop it crashes my computer instantly and generates the blue screen of death. It doesn't matter if a monitor is connected or not. There was a couple of scary moments when it sent my fans into overdrive and started beeping loudly as if a bomb was ready to explode. I spent more than eight hours on this yesterday and at this point the dock seems like nothing more than a nice looking brick. I have went through all of the help threads here and tried everything. I updated the bios from 1.14 to 1.15I updated all audio drivers, graphic drivers, firmware drivers, chipset drivers, and thunderbolt related driversI rolled back everything twice and reinstalled everythingI removed the security setting in the bios that relates to thunderbolt devices connectingI've made numerous other changes that didn't work and had to roll backNothing seems to work. I am puzzled as to why HP haven't set this up better. Surely there needs to be a dedicated app for this that handles everything and installs and removes all necessary drivers. By the looks of it this docking station has been a mess from the start. What else can I do at this point? 

A:Thunderbolt 3 Docking Station Crashes HP ZBook Studio G3 as...

It is possible you have a defective dock. I have exactly the same setup and went through some difficulties when I first got it but turning off Thunderbolt security made mine work. It is still occasionally finicky coming out of sleep mode or if I disconnect the laptop and use it as a laptop then try to reconnect the dock. Takes a restart or 2 sometimes but mine generally works well.  I would suggest your problems point to a bad piece of hardware. 

Read other 2 answers
RELEVANCY SCORE 86

Hello Team,
Currently we have one Group policy which is block Thunderbolt docking station due to security reason. More recent versions of Windows 10 (1809 we are currently using) have a built-in ?Kernel
DMA Protection for Thunderbolt? 3? that should be used instead. To do that we need to enable Kernel DMA Protection , how we can enable it?

In BIOS VT already enabled and also enable the Windows Defender Core isolation. Kindly help to mitigate the issue.

Thanks
Amit Laha
  

Read other answers
RELEVANCY SCORE 86

Hey, Just got my new X1 Extreme Gen 2 and the docking station (which doubles as a charger) doesn't charge. All other functionality of the dock works. The dock brand is Belkin Thunderbolt 3 Express Dock HD and the model number is F4U095. I have already updated the bios and software in line with https://pcsupport.lenovo.com/sk/en/solutions/ht508988 even though my model isn't listed as an affected one. Thanks in advance.

Read other answers
RELEVANCY SCORE 86

Heyo,so i ran into a problem at work with a notebook from an user.She has the Thinkpad P51s with a Thunderbolt 3 Docking Station and 2x Dell U2717D.If one of the two monitors is connected via HDMI to the Notebook directly, the bit depth is at 8-Bit.If the 2nd monitor is connected via DP to the Dock, the bit depth drops to 6-Bit, which i can't change. The 6-Bit creates a horrible banding, especially in photoshop with color gradients you can see the banding in full effect.Firmware for the dock is up to date.Anyone else ran into this issue?EDIT: Wrong board, sorry

Read other answers
RELEVANCY SCORE 86

Hey, Just got my new X1 Extreme Gen 2 and the docking station (which doubles as a charger) doesn't charge. All other functionality of the dock works. The dock brand is Belkin Thunderbolt 3 Express Dock HD and the model number is F4U095. I have already updated the bios and software in line with https://pcsupport.lenovo.com/sk/en/solutions/ht508988 even though my model isn't listed as an affected one. Thanks in advance.

Read other answers
RELEVANCY SCORE 86

Hey, Just got my new X1 Extreme Gen 2 and the docking station (which doubles as a charger) doesn't charge. All other functionality of the dock works. Dock works fine with both my Macbook Pro's (13 & 15). The dock brand is Belkin Thunderbolt 3 Express Dock HD and the model number is F4U095. I have already updated the bios and software in line with https://pcsupport.lenovo.com/sk/en/solutions/ht508988 even though my model isn't listed as an affected one. Both my Apple power adapters work and charge the X1 Extreme also... is it because the thunderbolt from the dock is also carrying data and video? Surely not? Thanks in advance.

Read other answers
RELEVANCY SCORE 85.6

Hi,
 
I just got hold of a X1 Carbon 2nd gen and am in need of a docking station.  The docking station must have 2 displayports or the ability to plug in two monitors via HDMI.
 
Can anyone recommend one?
 
The only one I can see is the Onelink Pro which has one display port and one DVI (which I cannot use).
 
I read somewhere that the Thinkpad Ultra dock is compatible but there are so many conflicting posts out there.
 
Many thanks
 
Moderator edit: Added detail to Subject.

Read other answers
RELEVANCY SCORE 85.2

HelloWhen 1903 Windows update installs on my Windows 10 64 system, the docking station stops working (everyting including video, usb, etc)I rolled back 1903 and it works. So it is definetely an issue with compatibility of the docking firmware/software with the 1903 update, as all my drivers should be up to dateDoes anyone know if there is official word on an update/patch that will solve the above?BestOmar

A:Lenovo Thunderbolt USB C Docking station does not work after I update Windows with 1903

nice post Padron Cigars

Read other 1 answers
RELEVANCY SCORE 85.2

I have just bought a Dell XPS 15 (9560) and a Dell WD15 docking station with 130W power brick (same wattage as the laptop's AC-adapter). When I only use the docking station to power the laptop the discrete graphics card (GTX 1050) does not seem to work. When I am in a game (eg. Starcraft 2), I get like 15 fps with the NVIDIA recommended settings. Then when I plug in the laptops's own power brick (while still in the game) I get an immediate four-fold increase in framerate. When I unplug the laptop's own power brick the framerate drops down to 15 fps again in a heartbeat. Furthermore, when I only power the laptop through the docking station, I cannot even find the discrete GPU in the list when I'm trying to run the Geekbench 4 compute benchmark (OpenCL). Only the integrated graphics shows up. When I plug in laptop's power brick I find GTX 1050 in the list.
I have run the Dell Command Update application and all my drivers and firmware are up to date. 
Does anyone have any idea to what the problem could be?

Read other answers
RELEVANCY SCORE 84.8

Hi. I have a 3rd Generation Carbon X1 (Type: 20BS-00ACUK S) and I bought for it what was suppsed to be a OneLink Port Replicatior for it (P/N: 40A4009-0UK). Lo and behold, the connector from the Port Replicator does not fit into the laptop . It looks like it is not compatible with the Carbon X1 20BS. So the first question is, is there an adaptor cable available to make this work? Failing that, what is the best Docking Station\Port Replicator for the Carbon X1 20BS? Thanks

A:Incorrect Docking Station for Carbon X1??

Hi Deano ,Warm Greetings & welcome to Lenovo Community, happy to have you here.As I understand that you have query regarding Docking station for X1 Carbon 20BS
The dock which you have bought is ThinkPad OneLink+ Dock which is not compatible with your system
 
DeanoCeltic wrote:
So the first question is, is there an adaptor cable available to make this work?

The problem here is X1 Carbon 3rd Gen has OneLink port for dock connectivity, may be ThinkPad OneLink to OneLink+ Adapter will solve your issue. 
 
I hope the above information helped you.
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 1 answers
RELEVANCY SCORE 84.8

I have an X1 Carbon (1st generation) with a machine type starting with 3444.Is there any docking station comaptible with this machine? Thanks in advance.

Read other answers
RELEVANCY SCORE 83.6

I have a Lenovo X1 Carbon and I was considering either purchasing the Thinkpad Onelink Pro Dock or the Thinkpad One Link Dock.  I need to be able to connect a monitor and keyboard to my new computer. I have a some questions that I was hoping someone can help with.  1.  What is the difference between the Pro Dock and the Regular Dock? 2.  If my monitor does not have HDMI will these two docking stations still allow me to connect a monitor? 3.  Can you connect two monitors with both the pro dock and regular dock stations? 4.  Are there other docking station options that are better? 5.  Do these docking stations work with all versions of the x1 carbon? Your help is greatly appreciated.  Thank you.  

Read other answers
RELEVANCY SCORE 83.6

Have a problem with connecting monitors to the laptop (Lenovo ThinkPad X1 Carbon 2nd Gen).When I connect the monitor to the docking station using DP, the monitor previously connected to the laptop via HDMI stops working.How can I fix this?

Read other answers
RELEVANCY SCORE 83.6

I have the Thunderbolt 3 Dock and it is charging up the laptop no issues. The issue is the network part. I have a network cable in the dock, but I am not getting network connectivity on the laptop.

Read other answers
RELEVANCY SCORE 82.8

Dear community, I got a new X1 Carbon (2018) and a Lenovo ThinkPad Pro Dock Station with 135 Watt. It also works very well, but after some time, the external monitor (connected via Display Port) as well as power stop working, while mouse and keyboard connected via USB continue working.  What is going on? Thank you for your help! Kind regards!

Read other answers
RELEVANCY SCORE 82.8

Hi, I have a Thinkpad X1 Carbon 6th Gen which came with the USB-C docking station. I have a USB headset (Logitech), plugged into the docking station, which I use for Skype calls. The laptop runs Win 10 Pro. The problem is this: I'll start a Skype call with the audio routed to the headset, both speaker and microphone.The headset is also configured in Windows Control Panel as the default speaker. A minute or so into the call, the speaker audio will drop out and revert to the laptop's built-in sound card. Even though Skype is set to route the audio to the headset, the audio doesn't make it to the headset, it just goes out the laptop analog audio. I get the idea that this is a problem with the DisplayLink driver for the docking station. I tried updating the driver but it says that I have the latest version (even though it's dated 2006?!?).  Any ideas?  Thanks! - bill. 

Read other answers
RELEVANCY SCORE 82.8

Hi, Getting a tad exasperated and wondered if anyone else has had/ resolved this issue. X1 Carbon 6th Gen. Windows 10 Enterprise - all drivers up to date, all BIOSs latest version (docks and laptop). Works wonderfully for the first couple of hours in the morning and then will start disconnecting and reconnecting to the dock. All I've found in the Event logs so far suggest that the power source has changed 'and was handled successfully'. It will do this for approximately 5 minutes and then will settle down and work fine for the rest of the day. I've two docks. At work I use a Thunderbolt 3 dock with 2 x 27" monitors. At home I use an Ultra dock with 2 x 24" monitors. This happens on both.  So far I've re-installed Windows and the drivers in case it was software related. Given it started doing this out of the box I raised a support call with Lenovo and they eventually diagnosed it was the X1 having a hardware fault. I now have a new X1 Carbon 6th gen and it does the same thing! I'm at a loss to what to try next so any advice would be greatly appreciated. Phil

Read other answers
RELEVANCY SCORE 82.8

I have a HP 6530b Laptop, and on-board Broadcom NetLink Gigabit Ethernet adapter.
When I remove my laptop from the docking station, I obviously lose Network connectivity, however, when I replace the laptop back (or even just plug in a cable directly), I cannot reconnect to the network until I reboot or go to device manager and scan for additional devices in the Network Devices section. Then the Broadcom Gigabit adapter shows up and the connection is automatically restored.

Why does my computer lose the adapter when i un-dock?
 

Read other answers
RELEVANCY SCORE 82

I have a t480s coupled with basic docking station type 40AG. everything was working perfectly fine until yesterday I updated the Thinkpad docking station utility unsuccessully. this generated an error message any attempt to load the docking station driver (see enclosed file description) proved unsuccessful. Any possibility to restore the situation ex ante or to overwrite these errors> thanksenclosed file description and error message

Read other answers
RELEVANCY SCORE 82

I have a brand new X1 Carbon 6th generation, in a Thinkpad Pro Docking Station (40AH0135US), and the display ports will not connect to my monitor (LG 32UD59-B). However, when using HDMI on the side of the computer, the monitor has no issue. Please tell me what I am doing wrong. Thanks in advance for your time.

Read other answers
RELEVANCY SCORE 82

I have a new Folio 9470m running 64-bit Win7.  I am attaching it to a UltraSlim Docking Station The ethernet port on the Folio works fine and I am able to connect to the LAN in the office without issue. However, when I connect the same Ethernet cable to the docking station and then place the Folio on the docking station I am *not* able to get a connection.  The link lights on the docking station will not even blink. The docking station is connect to power and the lights are illuminated.  I also have an external monitor,  wireless mouse and a wireless headset connected to the docking station.  All of these work flawlessly. Any suggestions?  I am completely unable to find a driver for the folio that would be related to a docking station.











Solved!
View Solution.

A:Ethernet passthrough for UltraSlim Docking station will not ...

You may get a better answer in the enterprise support forums located here.

Read other 5 answers
RELEVANCY SCORE 81.2

I have the new X1 Carbon 6th Gen with the ThinkPad Ultra Docking Station (40AJ0135US) and have noticed any time I lock my computer and my screens turn off or my screens just turn off from the computer being idle for the set amount of time that when it comes back up that all my windows have moved to the main laptop screen. I have two monitors plugged in with DisplayPort to the dock and I use the laptop screen as the main screen. Has anyone else noticed this same issue? Any fixes?

Read other answers
RELEVANCY SCORE 81.2

Hey, I have a T480 with all driver up to date. I'm bougth a Lenovo USB-C docking station, but it doesn't work properly.The sound-, the ethernet-, and usb ports, don't work.  only the VGA port works. Well then connected vga switch also loses the connection from time to time. in the device manager I get unreconized USB device,  the hardware ID of the docking station is USB\DEVICE_DESCRIPTOR_FAILUREThe firmewire update tool for the dockingstation can't find the docking station. and also my laptop freezen when I want to shut it down with the docking station connected. The driver package  thinkPadthunderbolt-3dock_and_usb-cdock_driver_v10013  is installed. Does anyone have the same problem ? Kind regards

Read other answers
RELEVANCY SCORE 80.4

Hi There, i got a serious problem with my X1 6th gen - i'm not able to see anything on my external monitors. HDMI neither the Displayports/VGA Port on the docking station is working. I've tried several vga drivers and so on.I also tried the "reset button" under my notebook with no luck. As far as i understand is that problem connected to the thunderbolt interface? any new ideas are welcome. regardsHenrik 

A:X1 Carbon 6th Gen - (Type 20KH, 20KG) - no external Monitor(s) on HDMI & Docking Station

try google it

Read other 1 answers
RELEVANCY SCORE 80

I have a setup with a home office and a work office in which I have a Dell SuperSpeed USB 3.0 Docking Station at each location.  Mysteriously about two to three weeks ago the Dell Gigabit Ethernet connection on BOTH docs just stopped working - it briefly connects, tries to identify the network and then shows no connection.
The laptop is an XPS 15 but to debug I also tried a Latitude E5470 - both laptops act the same way on both docks.  On the XPS 15 I updated all of the drivers from Dell and Intel.   TCP stack reset, adapters deleted and re-added, etc, etc.
When the Ethernet is connected directly to the latitude it works just fine at both locations.
I called Dell support and was told if the Ethernet works on the Latitude then I have to go back to the retailer where I bought the dock and ask them how to fix it because the dock and the laptop are out of support [I offered to pay but was told that the dock isn't covered regardless]... STUPIDEST TECH SUPPORT RESPONSE EVER (and I'm in tech support myself so I've heard it all) for multiple reasons as noted above - two docks and two laptops.
At roughly the same time the WiFi throughput on the XPS built-in adapter dropped to kbps speeds (well documented but no real solution - google "dell Wireless-N 7260 performance issues").
On the XPS I even upgraded from Win 8.1 to Win 10 to see if a "fresh" OS would flush out any bad drivers, etc - no help, same issue.
The only workarounds I fou... Read more

Read other answers
RELEVANCY SCORE 80

Hi Guys,

New user, glad to be here.

I have slight problem with a Dell latitude D630.

Whenever I un-dock it and move it to my projector room and plug in the ethernet, the net doesn't come up unless I restart the machine. There's is one other user with the same model who has the same issue, but no-one else seems to have it...

What's amiss?

Bye,
 

A:Solved: Ethernet fails when inserting to laptop in Docking station

Read other 9 answers
RELEVANCY SCORE 79.6

Hi, Thinkpad Ultra Docking Station - 40AJ0135EU Thinkpad X1 Carbon 6th - 20KH006JMXBIOS: N23E56W 1.31 Recently installed updates: ThinkPad BIOS Update - 10 [64], version 1.31Synaptics Touchpad Firmware Update Tool - 10 [64], version PR2698617 / PR 2812761ThinkPad Hotkey Features Integration Package Setup - 10 [64], version 9.0.2.15 Everything was working fine before these updates, but now I can't get the wireless mouse and keyboard (usb dongle) or the usb headset to work connected to the dock. Works fine when connected directly to the X1 Carbon. I suspect the BIOS update, anyone got any tips? The dock is listed as "Unknown USB Device (Device Descriptor Request Failed)" under Windows settings. I have of course tried to uninstall/remove device and install it again, but it won't work.  I have a colleague who also has a X1 Carbon, with recent updates and his X1 Carbon works perfectly with my dock. And similarly, my X1 Carbon works perfectly with his dock, which is a Thunderbolt 3 Dock. Edit: Tried to update Dock firmware with driver from https://pcsupport.lenovo.com/no/en/products/monitors-and-projectors/docks/thinkpad-ultra-docking-sta... But problem still remains When I try to run automatic scan for updates through Lenovo support I get the failure message: "The package catalog for your system is currently being updated on the System Update Server. Please try again later" 

Read other answers
RELEVANCY SCORE 78

I contacted Lenovol support and they send me a replacement unit. The the replacement unit has the same problem. Thinkpad Thunderbolt 3 docking station does not charge Thinkpad P51 battery.  I need to plug in the power adapter for both docking station and notebook.  Does anybody have similiar problem? 

A:Thinkpad Thunderbolt 3 docking station does not charge Thinkpad P51 battery.

Everbody's p51 would be the same.  The thunderbolt port won't work as a charging port.  The thunderbolt specs specify 100w max.  That's not enough.  Your thunderbolt port is not for charging.  To charge via the dock, you need a workstation dock, not a thunderbolt dock.  A thinderbolt dock can charge things like an x1 carbon (5th gen) or x1 yoga (2nd gen)

Read other 1 answers
RELEVANCY SCORE 77.6

For a few days only ! After my laptop has been in sleep mode for a long time only. When waking from sleep mode ThinkPad USB-C Dock Ethernet has no network connection. I select 'troubleshoot problem', it then resets 'ThinkPad USB-C Dock Ethernet' and say that the problem has been fixed.  It says the 'default gateway was not available'. All my Bios, drivers and USB-C firmware are up to date! Do you have any idea ? Thank you

Read other answers
RELEVANCY SCORE 76

Hello, I am using the x1 carbon 7th gen 20QD and trying to get ethernet to work through the thunderbolt docking station.  I have installed all the drivers from the lenovo site for the gen1 and gen2 thunderbolt dock and ethernet still does not work through either thunderbolt docking station.  Ethernet works fine with the usb-c travel hub and the ethernet adaptor that plugs in next to the USB-C works as well.   I have also swapped the dock out with the thunderbolt dock on my yoga 370 and ethernet works through the dock on the yoga. Any ideas? 

Read other answers
RELEVANCY SCORE 70

Hello -  My x220 does not lock into  Mini Docking Station Series 3 that I bough recently. The rubber pads on the battery seem to be preventing the laptop from being docked. (Not sure if I am doing something wrong instead.) Also I am trying to set up a multi monitor display ( Dell U2415). Will appreciate some inputs on how I should resolve both the issues or a link if that has been covered before .  

Read other answers
RELEVANCY SCORE 70

Hi!
I have a Latitude E7740 that runs Ubuntu Xenial (16.04). I dock it to a "Dell EURO2 Advanced E-port II" docking station. 
If I boot it in the docking station, everything works fine, and I find all my two DVI-connected monitors. 
However, if I undock, then put it into the dock again while running, it fails to enable the screens. I'm using a script called autorandr for switching between display modes - it uses xrandr. It tries to run:
xrandr --output DP1-1 --gamma 1.0:1.0:1.0 --mode 1920x1200 --panning 0x0 --pos 0x0 --rate 59.95 --reflect normal --rotate normal --output DP1-2 --gamma 1.0:1.0:1.0 --mode 1920x1200 --panning 0x0 --pos 1920x0 --rate 59.95 --reflect normal --rotate normal
But the X server responds with:
X Error of failed request: BadMatch (invalid parameter attributes)  Major opcode of failed request: 140 (RANDR)  Minor opcode of failed request: 21 (RRSetCrtcConfig)  Serial number of failed request: 48  Current serial number in output stream: 48
Running this exact command after booting in the dock is doing the right thing, but after undocking then docking, it doesn't work.
Any ideas here? I have updated to the latest BIOS version.
Problem also reported in launchpad with lot's of debug info, here:
bugs.launchpad.net/.../1585884
Autorandr script is here: github.com/.../

Read other answers