Over 1 million tech questions and answers.

T570 and ThinkVision X24 pro with USB-C will not connect

Q: T570 and ThinkVision X24 pro with USB-C will not connect

I have a T570 running Windows 10 64bit. (English) and aquired a nice Thinkvision X24 Pro monitor. It's just that when the USB-C cable is connected (tried multiple cables) to the right USB-C port (or the left) the only thing that happens is that on the PC in devicemngr a root hub USB 3.0 is appearing - but nothing else. There is no monitor being detected. I've tried the monitor with display port on my old T450, and it works fine. The onscreen display is being set to USB-C , doesn't matter if still set to DP port. Tried installing the monitor drivers, updated Intel / thunderbolt software and installed latest bios from Update site. Alas, to no resolve Any ideas greatly appreciated..

Read other answers
RELEVANCY SCORE 200
Preferred Solution: T570 and ThinkVision X24 pro with USB-C will not connect

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 101.2

I have a T570 running Windows 10 64bit. (English) and aquired a nice Thinkvision X24 Pro monitor. It's just that when the USB-C cable is connected (tried multiple cables) to the right USB-C port (or the left) the only thing that happens is that on the PC in devicemngr a root hub USB 3.0 is appearing - but nothing else.  There is no monitor being detected.  I've tried the monitor with display port on my old T450, and it works fine.  The onscreen display is being set to USB-C , doesn't matter if still set to DP port.  Tried installing the monitor drivers, updated Intel / thunderbolt software and installed latest bios from Update site.  Alas, to no resolve   Any ideas greatly appreciated.. 

Read other answers
RELEVANCY SCORE 63.2

Hi I read here that T470s supports 3 independent displays.I want to have my 3 Think Vision monitors to be these 3 independent displays (preferrably all connected to the dock station) and the first of them mirroring (duplicating) the buid in Laptop monitor. I tried several things without sucess: I can for example have two monitors connected to the Dock via DP and have 3 independent displays. I can connect the other monitor to the docking station via VGA, but obvioulsy I cannot have 4 independent displays.When I try to mirror (duplicate) the internal monitor with one of the external monitors  I get the odd message :"Unable to save display settings.". During trials with different settings one time the third monitor also just showed a very low resolution and could not be changed... Another time I also created a few freezes when I pressed the apply button and not even the mouse moved and I had to turn the computer off and on again...Before I now spend any money on a bunch of cables and try all combinations and then find out it is impossible or a sofware issue (read that sometimes such an error could be related to old saved monitor configurations and a manual deleting of registry keys would be needed...). Could someone please tell me if/how this is doable at all and how to connect the third external since there are just 2 DP ports at the dock. Thanks. 

Read other answers
RELEVANCY SCORE 56

Hello, I just got a new T570 for work. I'm allowed to purchase whatever dock I want to go with it and get expensed. I want to make sure I buy the right one. I have a monitor that supports 2560x1440 resolution however it only works over DVI-D connection. There are so many docks to choose from I want to make sure I get the right one. Any help would be much appreciated. Thank you.

Read other answers
RELEVANCY SCORE 53.6

I have a Lenovo T570 (Type 20JW, 20JX) Laptop (ThinkPad) and ThinkPad Basic Dock (40A00000WW).   I have a monitor plugged into the VGA connection on the docking station.  I have another monitor connected to my laptop with HDMI.  When the laptop is docked, the display will show on the laptop and the monitor connected to the dock.  The monitor connected via HDMI goes black.  When the laptop is off the dock, the HDMI monitor works.  Is there a way to get both monitors to work without having to buy a different docking station?  I know the ideal situation would be to get a different dock with 2 connections on it, but I was hoping not to have to pay for another dock.

Read other answers
RELEVANCY SCORE 44.4

Hey SevenForums

I'm new to the forum, and i have a major problem with my monitor. I have seen several others who couldn't force their screen to go past 60 or 75hz, and i have the same problem.

Some people said that if you found the display driver, you could fix this problem, but my problem is that i simply can't.

Since i cannot find my display driver i ask ALL OF YOU to help me!

CAN I FIX THIS IS ANOTHER WAY?

A:IBM ThinkVision C190 CRT Driver

Lenovo, who purchased IBM's PC line does not list any drivers. Many ONLY have the built in plug and play drivers and if that is the case you are stuck with that.

Read other 2 answers
RELEVANCY SCORE 44.4

Hi,  Is the P70 Thinkpad under Lenovo ThinkVision product range? I want to know because all ThinkVision products are under the International Warranty Service and I need to replace a motherboard. 

Read other answers
RELEVANCY SCORE 44

I am using the X1 Carbon 4th generation with WiGig dock and wanted to have 4k resolution on the ThinkVision X1 display. It is connected via HDMI, but the system preferences only offer 1920 pixel width, no matter whether it is the only display, extended or duplicated. What do I need to do to run the ThinkVision at full resolution via WiGig dock?

Read other answers
RELEVANCY SCORE 44

I have an old IBM ThinkVision L150p 15" that when i plug in the LED in the front will blink once green and there is a high pitch beep then nothing.... screen doesnt come on, LED isn't on... nothing

I've tried two different power cords, 2 video cords, replaced both boards ( one that you plug power into and another you plug video input into) and still nothing...

if anyone has any idea what might be going wrong please let me know.
 

A:Broken IBM ThinkVision L150p 15"

Sounds like blown caps inside the monitor
If it does the same on another computer as well, then throw away or warranty return it, if it's covered by warranty
 

Read other 4 answers
RELEVANCY SCORE 44

I own ThinkVision LT2223z monitor and I have troubles with getting sound to work. What cable do I need to plug in to make it work?

Read other answers
RELEVANCY SCORE 44

Hi everyone,Its my first post!My ThinkVision 28 28-inch 4K2K Tegra K1 has android 4.4.2 and I need to upgrade to lollipop or the latest friwmare.I heard that I can Intall windows platform on it !!! Is that possible? How can I do that?Please help!

























20160929_035757.jpg ?3559 KB

Read other answers
RELEVANCY SCORE 44

Se necesita resolver como puedo conectar mi laptops Thinkpad X1 4th con docking wigig.ademas en la compra del equipo lenovo buy, no me permite agregar la tarjeta wigig tri-band.graciassaludos, 

Read other answers
RELEVANCY SCORE 44

I have a yoga 920 and I recently purchased the lenovo thinkvision and a dell monitor to be able to use two additional monitors. I got all three monitors connected but when I touch the thinkvision screen, it moves stuff on the yoga 920 screen and not on the thinkvision screen. They are step up as three different screens becasue I can put different pages up on each.

Read other answers
RELEVANCY SCORE 43.6

Hi, I noticed that my X1 Yoga 2nd Gen + Thinkvision X1 Monitor (usb-c) no longer is able to turn off the monitor to safe power. What happens is: 1) When the computer tries to turn off the monitor, it seems to also trigger something (perhaps a disconnect of the usb accessories?)2) Which then triggers the computer to recognize something is up3) Which then wakes the computer up4) This cycle continues over an over again This cycle also prevents any sleep or hibernation since the computer seems to think something is always happening.  Am I the only on experiencing this issue? Is there a fix? Thanks for all the help.  Thanks, David

Read other answers
RELEVANCY SCORE 43.2

My customer has a brand new T470S, USB-C dock and a Thinkvision X24 Pro monitor with Intel Realsense SR300 webcam build-in.The problem is when USB cable from monitor (for webcam) is connected to USB port on dock, the webcam disappears from Windows device manager after 10-30 sec. Unplugging the USB and re-plug then the webcam appears again.Connecting the USB directly to the T470s, problem is gone.Tried swapping the X24Pro at Lenovo, which makes no difference,Other USB devices works fine on same USB port on dock.Maybe a USB-C dock firmware issue?Lenovo support has not yet returned any replies to me on the support case.Just wondering if others might have same issue? 

Read other answers
RELEVANCY SCORE 42.8

I just recently connected dual TV P24 IPS monitors to my X1 Yoga (2nd Gen). The monitors are capable of displaying 2560x1440 rez. I have them both connected to the USB-C dock via display port.  One of the monitors displays fine, but the other won't display more than  1920x1080 and even then it continuously flickers. I've tried updating drivers, changing cables, etc.  Is the X1 Yoga not capable of outputting that resolution to both displays at the same time?

Read other answers
RELEVANCY SCORE 42.8

Yesterday (June 15), I had a major Windows 10 update on my W510 ThinkPad. Now my external monitor (a ThinkVision L2440P) isn't correctly identified as a device, and the result seems to be that the fonts overall are grotty--much less crisp than they were prior to the update. The driver is NVIDIA Quadro FX 880M, and this has been successfully updated. Right now, both the integrated laptop monitor and the external monitor are identified in the Device Manager as "LCD 1920x1080". Does anyone have a suggestion for how to get back to the crisp fonts I had before this update?  Many thanks!

Read other answers
RELEVANCY SCORE 42.8

hi I'm using thinkpad p70 with thinkvision 3840 x 2160 monitor and finding elements of patterns in adobe illustrator missing on screen - any advice on what's going on? 

Read other answers
RELEVANCY SCORE 42.8

hi I'm using thinkpad p70 with thinkvision 3840 x 2160 monitor and finding elements of patterns in adobe illustrator missing on screen - any advice on what's going on? 

Read other answers
RELEVANCY SCORE 42.4

Hello, I am not really sure if this is an X280, a CS18 (Pro) or a ThinkVision T24v-10 issue, maybe all of them - I post in this cateory anyway. When docked to the side dock which is connected to a ThinkVision T24v-10 (Display Port and USB 3 - yes, definitely a USB 3 port), the T24v's camera and microphone are extremly stuttering being effectively unusable for skype or any other form of VoIP. When the USB cable from the monitor gets connected directly to the still docked X280 (i7-8650, 16GB, [email protected]) using the right hand side USB port of the computer, it works without problems. But this obviously is not the idea of how to use a dock... Is this a well-known issue? Google didn't seem to know about this. Any dock-firmware or upcoming driver updates addressing this issue? Can't imagine that ThinkVision's "optimized for VoIP" camera shouldn't work properly while being connected to a dock. What did I miss?  Regards,Logan P.S.  Using stock Windows 10 installation plus additionally installed T24v-10 drivers.

Read other answers
RELEVANCY SCORE 38
Q: T570

would somebody please kindly tell me if T570 which came with a 2.5: drive can also add a M,2 SSD.  I was told that the I can use the WWAN slot to install the M.2 SSD,  thanks

A:T570

Hi Rocky88,Warm Greetings & welcome to Lenovo Community, happy to have you here.
 
Yes, you can add M.2 SSD in the form factor of 2242 like this 00UP432. And also have a look on this thread
  
I hope the above information helped you.
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 1 answers
RELEVANCY SCORE 38

would somebody please kindly tell me if T570 which came with a 2.5: drive can also add a M,2 SSD.  I was told that the I can use the WWAN slot to install the M.2 SSD,  thanks
 
Moderator edit: Added detail to subject













Solved!

Go to Solution.

A:T570 add M.2 SSD

Hi Rocky88,Warm Greetings & welcome to Lenovo Community, happy to have you here.
 
Yes, you can add M.2 SSD in the form factor of 2242 like this 00UP432. And also have a look on this thread
  
I hope the above information helped you.
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 7 answers
RELEVANCY SCORE 38

HiHow can I use the Internal GPS who is build into the LTE Card?The Lenov Sierra Wireless Software Sucks is there any from Sierra Wireless?Thanks

Read other answers
RELEVANCY SCORE 37.6

I have a T570 (Type 20JW) that I am trying to upgrade the m.2 drive on.  I have a WD Blue 3D NAND SATA SSD M.2 2280 (500GB) drive that is not recognized by the system.  I have read in other threads that any M.2 drive should work.  Is this not correct?

A:T570 m.2 SSD upgrade

Welcome to the CommunityThe SATA SSD you have isn't compatible with T570 as it supports m.2 2280 PCIe NVME SSD, not SATA.

Read other 1 answers
RELEVANCY SCORE 37.6

Why are the 512GB SSD so awful please? I will be on my third drive in less than 10 months shortly. Thanks.

Read other answers
RELEVANCY SCORE 37.6

I have a T570 20Hx.After updating windows 10, it now tells me that my TPM needs a firmware update.Win 10 tells me that my TPM is v 1.16 (Fri Jan 15, 2016)However, my BIOS has been updated to the latest version (1.32). When I look at Lenovo support, it appears that it tells me that my T570 is affected by this issue, but the fix appears to direct me to the update for the BIOS.  I already have the most current BIOS.Is there another fix available that I am not finding?Is there some reason that the fix is not being automatically made available to me?Or, is there not yet a fix available for this TPM version? 

Read other answers
RELEVANCY SCORE 37.6

Why my T570 lost the "AMT"  in "BIOS config" tab, even I update the BIOS and AMT firmware version Is the Lenovo provider disable the option before sell it.   

Read other answers
RELEVANCY SCORE 37.6

I have a T570 (20H90001IX)  with SSD 256Gb , I would like if it possible to add a second SSD Drive ? if possible which kind of ssd I should purchase?

Read other answers
RELEVANCY SCORE 37.6

Yesterday while playing a not strenuous game the laptop was quite hot, on my mac i had installed a fan control software (smcFanControl) where the OS would only be overridden when i chose to manually turn up or down the fan, i tried that with this laptop and the fan control software most highly recommended seemed to fiddly so i uninstalled it.  Now the laptop is running hot with the fan on for tasks like Word where it never ran hot before. Any ideas on how to fix this? Laptop is less than two months old

Read other answers
RELEVANCY SCORE 37.6

It died with my data after just one year and it's the most expensive nvme option. I bought this T570 since my previous X1 Carbon randomly freezes itself for every 3-4 hours. Good job Lenovo, you've completely ruined my faith in "best business laptop" Thinkpad,, Ironically my four years old cheap $600 ASUS laptop which I bought during  a travel still works well!!

A:T570 ssd died!!

Do you recall running Vantage or Lenovo System Update during the last 2 weeks, ie, around August 4, and seeing a FIRMWARE update for your M.2 device?

Read other 2 answers
RELEVANCY SCORE 37.6

Hello, I have bought a brand new Lenovo Thinkpad T570 with the following specifications:Intel Core i7-7500U256GB PCI-e SSDFingerprint sensorBacklit keyboard with numpadGeForce 90MX Today I started my laptop and suddenly I had to suffer a BSOD.I thought it probably is just an incident, but it wasn't...I have had a BSOD for about 5 times in 20 minutes, so it is irritating me a bit.Have you guys got any recommendation on how to solve this? Greets from, Daan

Read other answers
RELEVANCY SCORE 37.2

My T570 started intermittently not being able to get past the Lenovo boot screen a few days ago and by two days later, I was not able to get in at all. I tried everything I could find on the forums here including testing the ssd in another laptop and putting another ssd in (the ssd seems to be fine). When I go into the bios, the ssd is not recognised. I have reset the bios to default settings too. I have looked at the connection to the motherboard and it seems to be okay visually. The last time I was able to log into windows, the desktop background image was partly distorted, I'm not sure if thats related. Any assistance in trying to figure this out would be greatly appreciated. The T570 specs are:Part No: 20H9CTO1WWConfiguration Details?  Intel Core i5-7300U Processor (3M Cache, up to 3.50 GHz)?  Windows 10 Pro 64?  Windows 10 Pro 64 English?  15.6" UHD (3840x2160), non-Touch, no WiGig, WLAN, WWAN?  4GB DDR4-2133 SODIMM?  NVIDIA GeForce 940MX 2GB GDRR5?  Hardware dTPM?  Keyboard with Number Pad - English?  Integrated Fingerprint Reader?  Fingerprint Reader?  Hardware dTPM2.0 Enabled?  IR & 720p HD Camera with Microphone?  128GB Solid State Drive, SATA3?  Smart Card Reader?  4 Cell Li-Polymer Battery 32WH?  6cell Battery 48Wh Rear?  65W AC Adapter - US... Read more

Read other answers
RELEVANCY SCORE 37.2

Hi, I've purchased new Lenovo ThinkPad T570 with the following specs: CPU i7 7600UGPU 940MX32Gb RAM1Tb SSD PCIe (Samsung PRO 960)"15.6UHDLTEBatteries: 32Wh 4Cell Li-Ion front battery + ThinkPad Battery 3 Cell Li-Ion (24Whr) - up to 13.5 hrs according to OEM System setup: Win10 x64- All unnecessary apps are off/deleted (all background apps disabled)- No resource-consuming apps running (Skype and that's it)- Visual Windows effects are turned off- All possible background Windows services (such as error reporting, Cortana and etc. are off). I did not touch any services through msconfig though, they are at defaults.- Power type: Balanced- Screen brightness at 95%  What I am experiencing from time to time is dimming screen (Power Options -> Advanced Settings -> Display - > Enable adaptive brightness is both OFF (on battery and plugged-in). 1. What can be the cause for dimming? 2. Other question - battery is holding maximum 5.5-6 hrs (no resource heavy tasks, only browsing, 1080p videos on youtube). How to optimize that? 3. Windows update or simple JAVA setup can trigger fan to start working heavily blowing basically cold air - very annoying. All newest drivers are installed. BIOS is updated to the latest version. Feedback is highly appreciated. Thank you.

Read other answers
RELEVANCY SCORE 37.2

I have been using this new T570 for just over a week and have noticed some really upsetting discomfort. After only a few minutes, my eyes become fatigued and I start to experience a strange chilling unpleasantness. The first time this happened, I ended up with a migraine for the rest of the day and got sick.  As a disclaimer, I have normal (20/20) vision and I have never experience any negtaive side effects of using a computer, laptop or phone before. My main driver before getting this machine was a Samsung Tab S2 (AMOLED) and occasionally a normal desktop. I also own an LG G6 (LCD). This tells me that it is not simply the technology of LCD or AMOLED that is making me sick.  I believe the T570 is an LED powered LCD screen (not sure though). This one is FHD with a matte filter.  I have looked up things like PWM but this issue seems to occur whether or not the screen is full brightness.  It took me a week to acknowledge that the issue is actually coming from the screen. I am currently using this with it plugged in to an external monitor and haven't had any negative side effects. Does anyone know what the problem could be? BTW, I also tried changing the resolution (didn't help) and zooming in to 175% (which I thought helped but it didn't). Is this just how these screens are made?Is it somehow bc of the matte finish (hard to believe) or the FHD (really hard to believe)?Is this a defective screen?Did I get stuck with a laptop that had a... Read more

Read other answers
RELEVANCY SCORE 37.2

Is it possible to have an SSD together with a HDD in the T570? I spoke to a sales rep in Australia who assured me it was possible, but advised me to contact technical support about the details; I was informed by technical support that it was not at all possible. Plugging an SSD into WWAN slot was specifically excluded by the tech rep as an option. I am asking this because in my T500, with which I have been happy for many years, I had a 256GB SSD for my OS and programs and a 1TB HDD (in the Ultrabay) for my files; the latter could be conveniently removed for transport when necessary. This set-up was not possible in the T560, for which reason I have delayed replacing my T500.

Read other answers
RELEVANCY SCORE 37.2

Hi,My T570 at startup beeps 3 times and then 3 times again with noting afterwards though power button stays on. what can be issue with it?

Read other answers
RELEVANCY SCORE 37.2

Hi!I'm looking for information & ressources about boot sequence topic. What I need to do is to boot from USB-3 key. 1 - I know to enter into BIOS setup after boot (by the way F1 key works only on my machine if hybernate mode is off. it waste my time to understand why I was not able to enter BIOS setup with my machine out of box)2 - I can locate the startup tab 3 - but I'm no sure about the PCI LAN highlighted "by default"  USB CD should be my dvd burnerUSB FDD should be floppy diskNVMe0 --> ?ATA HDD1 should be Hard drive disk ATA HDD0USB HDDPCI LANother CDother HDD Is there around documentation about meaning of all these items?And also the way to define first device as USB key ? thanks in advanceregards

Read other answers
RELEVANCY SCORE 37.2

Just recently (<30 Days ago) purchased a t570 notebook. I am experiencing these odd lags and hangs while on the Internet. I suspect that it may be a compatibility issue between the AC 8260 WIFI adapter and my Netgear B/G/N router. Support refuses to take a look at the event log which has produced a number of errors. I wonder if anyone here can help with this, because I think the answer may lie here. Description : Intel(R) Dual Band Wireless-AC 8260Type : Wireless LAN AdapterDriverVersion : 19.10.10.2PNPID : PCI\VEN_8086&DEV_24F3&SUBSYS_00108086Description : Intel(R) Ethernet Connection I219-LMType : Wired LAN AdapterDriverVersion : 12.15.23.7PNPID : PCI\VEN_8086&DEV_156F&SUBSYS_224717AA=============================================================Ok AcSvc. SYSTEM(Prvlg).3532.10096[1/7]12:37:13:856 ACConfigManager::CreateNotificationWindow exit form gbWinCreatedERROR AcSvc. SYSTEM(Prvlg).3532.10096[1/7]12:37:13:987 AcConfigManager::GetRegistryProperty: CM_Get_DevNode_Registry_Property() Failed for PCI\VEN_8086&DEV_24F3&SUBSYS_00108086&REV_3A\4&384063A9&0&00E6. Registry property=13!ERROR AcSvc. SYSTEM(Prvlg).3532.10096[1/7]12:37:14:007 AcConfigManager::GetRegistryProperty: CM_Locate_DevNode() Failed for BTH\MS_BTHPAN\6&373C1D06&0&2. Registry property=10!ERROR AcSvc. SYSTEM(Prvlg).3532.10096[1/7]12:37:14:007 AcConfigManager::GetAdapterGUIDFromPnpID: GetRegistryProperty() Failed for BTH\MS_BTHPAN\6&373C1D06&0&... Read more

Read other answers
RELEVANCY SCORE 37.2

New TopSeller channel model - anyone know how a supervisor password would already be set on a brand new system, just booting for the first time?

Read other answers
RELEVANCY SCORE 37.2

HelloSince a few weeks I see flashing on my Display. A kind of white lightning that comes only once in a while when I use my machine ... Have you ever seen that kind of thing? My screen is a UHD model. And my model a T570 20H9. my GPU are Intel HD Graphics 620 and NVIDIA GeForce 940MX. What should I do to try to better understand what is happening and potentially identify the cause ...I do not remember having recently installed a driver update for the display. thanks in advance

Read other answers
RELEVANCY SCORE 37.2

Hi there. Out of nowhere my two month old T570 started beeping in Windows 10. It's not a BIOS or hardware failure code. Just an on-off-on-off beep forever. Also, the keyboard just doesn't work. I can thankfully plug in a USB keyboard. If unplug the keyboard ribbon connector the beeping immediately stops. But it instantly starts beeping again the instant the connector is reinserted. What's happening here?

Read other answers