Over 1 million tech questions and answers.

T580 + Ultra Dock: mouse keeps freezing and reconnecting

Q: T580 + Ultra Dock: mouse keeps freezing and reconnecting

I got my new T580 today, and with it the Ultra Docking Station.It generally works fine except for some minor issues with my monitor still needing DVI, but that is easily solveable. The one big issue I have with it is my mouse:Moving it in circles shows freezes every few seconds, for up to a few seconds at a time! The mouse is practically unuseable as it is.It's a Logitech G500 mouse. Connecting it to one of the Laptops USB ports works makes it work just fine.Connecting one of our cheap default Microsoft mice to the dock also works just fine, but I'd really rather use my Logitech. I tried updating all the firmwares and drivers(OS in use is Windows 10 64bit), but nothing made any difference. The mouse is not only freezing, but judging by the constant device disconnect/connect sounds also completely reconnects every like 30-60 seconds. Using a USB event viewer confirmed that it is indeed the mouse being reconnected.

Read other answers
RELEVANCY SCORE 200
Preferred Solution: T580 + Ultra Dock: mouse keeps freezing and reconnecting

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 100.8

I have a ThinkPad T580 with the Ultra Dock (40AJ0135US) and I'm wanting to use two external 4k monitors. I found this post (https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/How-many-DisplayPorts-are-available-on-t...) that seems to indicate that this cannot be done, but it doesn't make sense since the dock utilizes two USB-C connections from the T580. Can a DP and USB-C on the dock be used for two 4k monitors? Is there any combination of ports that would allow the dock to support two 4ks? Will Lenovo be releasing a monitor compatibility matrix soon for their new laptop lineup, like this one: https://support.lenovo.com/ca/en/solutions/pd029622#USB-C%20dock ? I appreciate any help!

Read other answers
RELEVANCY SCORE 76.8

Hi,After updating to the JBET67WW 1.31 BIOS my mouse and trackpad cannot click on most UI elements in Windows 10 (1709) when connected to a ThinkPad Ultra Dock (40A2), some still works like minimize/maximize and close buttons on windows but most dont. I've tried to force a re-apply of the update but it is still having the same problem. Previously I used 1.30 without any problem, so the question is where can I get the files for 1.30 to do a downgrade?

Read other answers
RELEVANCY SCORE 76.4

Over the past few weeks I've been experiencing a problem with my USB mouse. what happens is it randomly disconnects for about 1-2 seconds, only to reconnect afterwards. During this time my cursor freezes for the whole duration of the process. It occurs at random intervals and an entire disconnect/reconnect spree can last up to an hour. I hear the Windows sound that notifies me something has been disconnected(and then reconnected), and I get a small popup from my taskbar saying "touchpad driver disabled notification" every disconnect/reconnect

A:USB mouse problem, freezing, disconnecting, reconnecting

From post #1






Quote:
"touchpad driver disabled notification"


Your specs show this.






Quote:
Computer type PC/Desktop
OS Windows 7 x86


How long has Windows 7 been installed on this computer and where did you get Windows 7 from?

Read other 1 answers
RELEVANCY SCORE 75.6

Im new here and im not sure if i posted in the right place, so please bear with me.

anyway...

laptop specs:
HP Compaq Presario CQ50
Windows 7 Ultimate (32 bit)
AMD Anthlon Dual-Core QL-60, 1900 Mhz, 2 Cores, 2 Logical Processor
BIOS: Hewlett-Packard F.54

Symptoms:
USB Mouse freezes/stutters every few seconds/minutes on some days.
USB Mouse constatnly disconnects/reconnects (with matching bu-dum sound) on other days.
USB Mouse does not install properly at all on worst days.
USB Mouse works perfectly on other laptops.
Other good condition Mice attached to my laptop show same symptoms
USB flash drives and other devices (except mouse) works perfectly
Windows will not boot when USB Mouse is attached during start-up (the second I remove the mouse, boot initiates)
Touchpad acts up every now and then (with or without USB Mouse attached)
I cant find:
"HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/services/USB" in regedit
all i find is ".../usbccgp" "../USBCCID" "../usbhub" "../usbcir" "../usbehci" "../usbohci" "../usbprint" "../USBSTOR" and "../usbuhci"

When it started happening:
When I accidentally removed a couple of USB Flash drives without "safely removing" them.

I have updated all drivers and BIOS.
I have tried uninstalling and reinstalling USB Drivers in Device Mgr.
I have tried turning off "Allow computer to turn-off this device to save power" option
... Read more

A:USB Mouse glitch - Freezing/stuttering/disconnecting/reconnecting

Hello stanejera, welcome to the forum

Try this; USB Driver - General Fix for Problems[2]=Hardware%20and%20Drivers

Read other 9 answers
RELEVANCY SCORE 68

I'm experiencing an issue with intermittent shutdowns on my new T580 (20L9) with the Ultra Docking Station (40AJ). The issue appears to derive from the Intel Dynamic Platform and Thermal Framework driver, as I typically see a corresponding error (DPTF Event ID 256 - Unhandled Exception) in Event Viewer, the details for which I'm including below. I'm running Windows 10 x64 1803 (Build 17134.81). It appears that certain CPU/GPU-intensive tasks will tip the driver to immediately put the system in sleep mode, so not technically a full system shutdown. Most recently, I attempted to restore a browser session in Chrome after an OS restart, opening a number of browser windows w/ multiple tabs each, which triggered the issue. Over the course of my daily use, it will happen anywhere from one to five times, and it's extremely annoying. I have not experienced the issue with the system undocked, however, my computer is docked about 90% of the time I'm using the machine, and I did recently update to Win 10 1803, which could be part of the problem (?) I am using **all** of the latest drivers available on Lenovo's site, including that for the Intel Dynamic Platform and Thermal Framework, version 8.3.10207.5567 as of the time of this post. I'm also running the latest BIOS, i.e. 1.10.  I'm not sure if there's a BIOS setting available that could help with the issue or some power management setting? I'm including the full Event Viewer details below. Please advise. Log Na... Read more

Read other answers
RELEVANCY SCORE 68

I'm experiencing an issue with intermittent shutdowns on my new T580 (20L9) with the Ultra Docking Station (40AJ). The issue appears to derive from the Intel Dynamic Platform and Thermal Framework driver, as I typically see a corresponding error (DPTF Event ID 256 - Unhandled Exception) in Event Viewer, the details for which I'm including below. I'm running Windows 10 x64 1803 (Build 17134.81). It appears that certain CPU/GPU-intensive tasks will tip the driver to immediately put the system in sleep mode, so not technically a full system shutdown. Most recently, I attempted to restore a browser session in Chrome after an OS restart, opening a number of browser windows w/ multiple tabs each, which triggered the issue. Over the course of my daily use, it will happen anywhere from one to five times, and it's extremely annoying.
 
I have not experienced the issue with the system undocked, however, my computer is docked about 90% of the time I'm using the machine, and I did recently update to Win 10 1803, which could be part of the problem (?) I am using **all** of the latest drivers available on Lenovo's site, including that for the Intel Dynamic Platform and Thermal Framework, version 8.3.10207.5567 as of the time of this post. I'm also running the latest BIOS, i.e. 1.10. 
 
I'm not sure if there's a BIOS setting available that could help with the issue or some power management setting? I'm including the full Event Viewer details below. Please advise.
 
... Read more

A:Random sleeps on T580 w/ Ultra Docking Station - Intel Thermal Framework issue

Did you ever get this resolved?  I have a user with the exact same symptoms, but we haven't done a lot of testing off the dock yet.  We've updated to the latest Intel Thermal Framework drivers from Lenovo (Just came out on 6/8) but that didn't help.  Updated to the latest drivers from Intel, no better.  Tried dock firmware, nothing.  Lenovo came out and replaced the system board - no better.  We push a clean corporate image to ALL machines, include a few hundred Thinkpads we have out there, and this is the only one exhibiting this behavior (Also the only T580 we have out there so far, everything else is T480.)  Lenovo wants their image back on it before we do anything else, which is tough because the user is a few hundred miles away.

Read other 9 answers
RELEVANCY SCORE 66.4

I have read a lot and tried updating the firmware - nothing works.When I put the laptop in the docking station - it does not recognize the monitar and also says AC power is not connected when it is. Help appreciated!

Read other answers
RELEVANCY SCORE 66.4

Hi, Everyone. Got me a nice little x270 to replace my old x201.  Happy enough with the machine, but getting it connected to my accessories (monitor, keyb, mouse, ethernet) is a bit of a chore. This machine appears to have a "proper" dock port on the bottom.  Is there a compatible ultradock available for the model 20HN x270?  By proper - I mean, Not USB.  A nice dock I can simply drop the machine into when I'm at the home office.. Thanks!

Read other answers
RELEVANCY SCORE 60.8

I have a few thousand Ultra Dock scattered across NA. We are in the process of replacing all monitors attached to these docking stations. Before we can send someone to replace the monitors, which maybe VGA, DVI, HDMI or DP, I need to determine how each monitor is connected to the computer. This is so that I can ensure that the correct cables and monitors are sent to each location. This last piece I already have done using a 3rd party software, they use details collected from Windows to detect the monitor connection type and it works perfectly on all computers and docking stations.  However, what we have noticed is that on the Ultra Dock no matter what monitor connection type (VGA, DVI, HDMI, or DP) is used, the Ultra Dock always shows that they are connected via DP. My questions are:Is this a known issue with Ultra Dock's?Is there a way to have the Ultra Dock show the true monitor connection type? If so how can this be done?

Read other answers
RELEVANCY SCORE 60.8

Will the USB 3.0 ports on a Ultra Dock 40A2 run an external monitor?

Read other answers
RELEVANCY SCORE 60

Hi, I have a T470 Thinkpad running Windows 10 in a brand new Ultra Dock with two monitors plugged in by display port: a Asus PG278Q and an AOC i2352Vh.The AOC works fine, but the Asus monitors mostly sits at "no signal" with intermittent flashes of the display working.I found some old threads detailing a similar issue, but the fix seems to be to update the dock firmware, but mine already appears to be up to date (2.33.000). The Asus monitor works fine using the same cable in my desktop PC, and I've tried swopping the monitors around in the display port ports on the dock itself. Could anyone please assist me in getting my second monitor working?

Read other answers
RELEVANCY SCORE 60

so - I tried saving money on a 2nd ultra dock for my W540 (I have 2 offices I travel between with desks setup..) And I bought something off ebay for an OK price.. Despite the dock and power supply being described in the auction body as the 170W version, when it showed up it's actually the 90W version... Now the dock and power supply came halfway across the world from Israel, so I'm preferring not to have to waste my time and money sending it back. The vendor has offered me $20 refund to keep it and use it as-is, which I think is pretty unfair seeing it's their mistake, and it'll cost more than that to make it good I think.... On the flipside, if I send this back at my cost it'll be $30-$40 to send.... and what if it goes missing on the way back? I was hoping that even though the part numbers on the actual docks are slightly different (my old one = SD20A06041, this new one = SD20A06046) they look pretty much identical, and  I can still at least use this new dock at 2nd office , and continue to lug my power supply between offices. Am I right here? Would prefer to ask rather than try as trying involves opening the plastic on the dock, which is factory sealed right now... also would hate to damage it..Then, Ideally I need to sort out a 2nd PSU as one of the main points of having 2 docks was going to be I didnt have to keep disconnecting and reconnecting and lugging that huge brick from office to office!  I'm wondering wh... Read more

A:W540 with 90W ultra dock (and the 540's 170W PSU)

hmmm... looks like buying the cheap 170W adapter and frankensteining the 90W rectangular cable onto it could be problematic?? these square connectors have ID resistors in them and I'd have to hack open the overmould to fix this? Looks like there's a nice cheap 3rd party adapter on ebay for connecting an old round power supply into a new rectangular laptop, but these adapters also need hacking open to change an ID resistor?   

Read other 1 answers
RELEVANCY SCORE 60

Hi, I have an T540P connected to a Ultra DOck 40A2 station which in turn connects to two monitors via ViewPort cables. My problem is that when I press the sleep button the monitors turn off but the workstation does not go to sleep mode. Once I press the enter key on the keyboard the login screen comes right away, then I have to click "change user" and then, without logging in, I press the sleep once again, only then will the workstation go tot he sleep mode! This is driving me nuts as I have tried updating the Viewport hum firmware, have set all possibel power settings, have downloaded the Lonovo Power Manager, but to no avail. My workstation is just stubborn and will only sleep after the second attempt, as described above. Any help would be appreciated! Cheers, Nermin

Read other answers
RELEVANCY SCORE 60

I have a Thinkpad 540W. Its docked to a thinkpad ultra dock 135W.If I have to monitors connected via display port to my ultra dock, can the ultra dock handle 2560x1440 resolution on both screens? cheers

A:2560x1440 resolution - ultra dock

I have the same problem, did you already get a solution? Just trying to find a solution like a crazy all day long

Read other 1 answers
RELEVANCY SCORE 60

I would like my screen on the T440 to be visible on an external screen (Philips TV) using the HDMI connection from the dock. I have read the other contributions containing the upgrad to firmware 2.30, but the solution is not stable.Occasionally, using this sequence would give a result, but seldom:1. Apply power to TV set, but do not turn it on2. Apply power to the Ultra dock3. Place the T440 in the dock and turn it on (usually from sleep)4. Turn on the TVBut on most occasions, both screens turn black, and it is not possible to get any picture on either PC or TV (which just states "no signal")When it works, both picture and sound comes over fine (in control panel, the TV sound function has to be set active)Connecting the TV directly from the T440 using a dvi-hdmi converter cable works flawlessly. What do I do wrong?  




Hans-HenrikT440 20B7-S0HN00 replacing T60 2007-VPX CoreDuo T2400 1,83GHz, ATI x1300 SXGA+, Win8.1 Pro, 4Gb RAM (=3), Kingston SSDNow V200 128GB, MS Office 2007, OpenOffice. 3 more T60 in family - all now running Windows 10

Read other answers
RELEVANCY SCORE 60

I just connected my new T440s to my new Ultra Dock. I an have external monitor connection and a live AC charging function. However, none of my USB ports are live. Nothing I plug into the Dock's USB ports works (everything plugged directly into the laptop works fine). After an hour with a Lenovo Tech, I was told, "send it back. We'll send you a new Dock". I am in the process of do that. But-has anyone experienced this; and know the cause of it (i.e.; is the laptop docking connection bad)? 

A:T440s and Ultra Dock (USB connections)

Hi Charnjohn,
 
Welcome to Lenovo Community Forums!
 
I?m sorry to hear that none of the USB ports in your docking station is working fine.
 
I would suggest you to Open Device Manager. Scroll down to the bottom of the Device Manager Window, and click on ?Universal Serial Bus Controllers? to expand it. Uninstall the devices listed there, and reboot the system. This will refresh the USB drivers. Now check if the USB ports in the docking station works. Try updating the BIOS and power management driver to the latest version.
 
If the above said didn?t help, it probably indicates some fault in the docking station and I would recommend you to get it replaced.
 
Best regards,
Mithun.



Did someone help you today? Press the star on the left to thank them with a Kudo!If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.Follow @LenovoForums on Twitter!

Read other 9 answers
RELEVANCY SCORE 59.6

I'm trying to find a replacement cord for an Ultra Dock that works with a T450s Thinkpad.  Can someone look at theirs and let me know what I need to order?  Suggestions as to where to order also appreciated. 

Read other answers
RELEVANCY SCORE 59.6

I use 2 display that is connected directly to the pc and then i use 2 more via the ultra dock everything works fine at first then now sudenly it started to disconnect the displays connected to the dock when the computer has been locked during the night  when i come back the displays are black and wont respond like if theyre disconnected while everything else works from the dock. I then have to remove the display link and re install it. to get them to come alive again....  whats happening? it only happens when i lock the computer during the night (computer is still on), but not when they go in standby when i lock it during the day casue they're not in standby for that long maybe?

Read other answers
RELEVANCY SCORE 59.6

I am running 2 monitors (Dell U2414H @ 1920 x 1080 60Hz) on my ThinkPad USB 3.0 Ultra Dock.  I also have my Yoga 900 monitor on and the desktop is extended to all monitors.  I have a regular issue where the Displayport monitor turns off for 1-3 seconds then comes back on for no apparent reason.  I have searched the internet and the only similar issue I have found suggestes the dock is under powered to run 2 monitors however that does not seem consistent with what other people are doing.  There is no particular application that causes the issue. Can anyone help?  It's very frustrating waiting for the monitors to come back on. 

Read other answers
RELEVANCY SCORE 59.6

I'm trying to see how to charge the x380 Yoga through the Ultra Dock we have just purchased. It seems like i need to have BOTH the DOC and a seperate charger connected - is this really true? Thanks for your help in explaining this. p.s. you can't do a Network boot through the ultra dock either, for that you need to seperate mini network cable. 

Read other answers
RELEVANCY SCORE 59.6

I'm trying to see how to charge the x380 Yoga through the Ultra Dock we have just purchased. It seems like i need to have BOTH the DOC and a seperate charger connected - is this really true? Thanks for your help in explaining this. p.s. you can't do a Network boot through the ultra dock either, for that you need to seperate mini network cable. 

Read other answers
RELEVANCY SCORE 59.6

Hello, is it possible to update the Lenovo Ultra Dock Pro to the latest version without a Windows Operating System? https://support.lenovo.com/de/en/documents/ht081248 A bootable ISO for this would be perfect. I use Linux as Operating System installed on a T440p, so a Windows based update is not possible for me. Thanks in advance! Best regrads, Michael

Read other answers
RELEVANCY SCORE 59.6

Hi all,I recently bought an ultra dock for my t460p in person from a previous owner. It's basically like new. According to him, he had bought it for his thinkpad but switched to Mac pretty soon afterward, rendering the ultra dock useless.It's been two days and I'm pretty pleased with the dock. It does what it was advertised to do. But there's one thing that really bothers me. It's extremely sensitive!Sometimes, just moving the laptop lid or evne pushing down on the laptop a bit will cause it to disconnect from the dock, or disconnect suddenly and reconnect. I think it's physically being detached, but I thought the ultra docks were a lot hardier than this? Is it really supposed to be this finicky? This happens if I lock the dock with my keys as well. Did I get ripped off with a defective device?

Read other answers
RELEVANCY SCORE 59.6

Trying to figure out how to charge my Yoga 3, while using my new Thinkpad Ultra docking station. The power USB for the Yoga 3 and docking station USB only work in the Yoga 3 power port. None of the other USB ports on the Yoga 3 will work. Do I need an adapter? 

Read other answers
RELEVANCY SCORE 59.6

I'm considering to upgrade my workstation. It would be a T470p w/a 2560x1600 display, 940mx and 4G support. The screen is a Dell Ultrasharp U2718Q. Do anyone know if it supports HDR through the Ultra Dock?

Read other answers
RELEVANCY SCORE 59.6

When connected to the Thinkpad DisplayLink, the driver shuts off useability of the Jack sound ports (on both the computer and the display link). Earlier I could not initiate the driver installation of my USB-ports, and thus could not use the rest of my computers' USB ports -- The Display Links' Ports work. This issue was solved when connencting to the port while the DisplayLink was disconnected.I was connecting a Samsung phone System & Device Firmware/ USB Composite Devices: 10.0.16299.15 peripheral Jack Driver vers. 10.0.16299.15DisplayLink driver vers. 8.3.1905.0USB Root Hub, USB Hub Drivers SuperSpeed and not: 10.0.16299.334USCI USB Connector Manager: 10.0.16299.251eXtensible Host Controller 3.0 10.0.16299.431SAMSUNG Mobile USB Composite: 2.12.5.0Phone Driver: Samsung Galaxy S7: 2.9.317.215Realtek Driver: 6.0.1.8224DisplayLink//Lenovo Audio: 8.3.1888.0 most of rest of drivers are firmware vers.: 10.0.16299.15my processor driver vers is 10.0.16299.371

Read other answers
RELEVANCY SCORE 59.6

I have a 40A20170US Ultra Dock 170W and the P50 Adapter plate, I finally got around to setting it up and it all works after the firmware update to latest firmware except for the NIC, It will only negotiate at 100Mbps vs the 1Gbps my network is. I did not get the workstation Dock as I do not need that many usb 3.0 ports and at the time of purchase it was supposedly supported (I mean they sell an adapter plate for it). IT negoiates the 1Gbps on the internal nic fine when undock and same cable is used for the dock, have latest nic driver off the driver matrix aswell. EDIT: forgot OS info: 10 Pro x64 Hope this can be resolved, I saw similar issues people had with w500's Malcolm





I own a Y510p SLI (retired), Yoga 2 Pro, and a P50 4K.

Read other answers
RELEVANCY SCORE 59.6

I have a T440s presently with a T480s due for delivery this week - It seems that the docking platform for the T440s won't work with the T480s - correct?  I have looked for a similar dock for the T480S without success (though this doesn't always mean something isn't available, just impossible to find on the Lenovo website...)  Can anyone pont me to an Ultr Dock for the T480s - and/or confirm that the one for the T440s won't work?  Is the Thunderbolt 3 dock the closest I can get to the same functionality (without the usefulness of an actual docking base) for the T480?  Thanks for any assistance in advance. 

Read other answers
RELEVANCY SCORE 58.8

I have recently received an Ultra Dock 135W to use with my T460p. I have two external 24" monitors connected. One to the HDMI port, and one to the DisplayPort next to the DVI plug (using a DisplayPort to HDMI cable). I have color issues on both monitors. These issues are not present if I connect the monitors directly to the PC. They are also not present on the laptop's internal display. The colors are washed out. The issue seems to be that the monitors are not in the correct quantization mode/dynamic range. I have verified that by looking at this picture: http://i.imgur.com/Bw61l68.jpg. On the internal screen, I can see 4 squares. On the external monitors, I only see two columns. I have tried following the instructions from this article to correct the issue: https://www.howtogeek.com/285277/how-to-avoid-washed-out-colors-when-using-hdmi-on-your-pc/. However, neither Nvidia Control Panel nor the Intel Graphics Settings (I have the Optimus dual graphics card) show the Quantization Range setting. I have installed the most recent graphics card drivers from Lenovo's website for both the Intel and Nvidia card. I have verified that my Ultra Dock has the latest firmware version (2.33.000). How do I set the graphics to use full quantization range/full dynamic range? Thank you in advance!

Read other answers
RELEVANCY SCORE 58.8

Hello, I recently bought the Ultra Dock 90 for my T450s.  I have one external monitor currently connected through the dock.  When I push the power button on the docking station (laptop lid closed) to turn on the computer, the computer turns on, but the external monitor does not engage.  When I lift the laptop lid, there is no image on the laptop screen either.  The laptop is on, but does not respond to any key stokes on the actual laptop.  I then have to do a hard reboot using the power button on the laptop. If I initially power the laptop by lifting the lid and hitting the laptop power button, the compter boots and my external screen works.  I can then close the laptop lid and everything is fine. I know the power button on the dock should power the computer and external monitor on.  I am guessing there is a simple solution to resolve this, but I am not a computer person and need help. One thing to note - when I lift the lid after trying to power the laptop through the dock, I see that the Function Green Light is illuminated.  Not sure if this information is helpful in determining the problem. Please help! Peterrabbit33

Read other answers
RELEVANCY SCORE 58.8

Hello everyone,that's my question:I put the notebook on the docking stationg (lid shut). I push the docking's power button and the notebook turns on (obviously everything's working fine).The only thing is that the led of the docking is totally off, while I guess it should be green as the notebook power button is.Is the power button supposed to be green or this is the normal behaviour?The notebook firmware is the latest one (BIOS LENOVO N1KET19W (1.06 ), 10/03/2016).ThanksGiovanni

Read other answers
RELEVANCY SCORE 58.8

I have a new T560 (20FH002JUS) laptop which I am trying to use with a Ultra Dock and Dual 27" Dell Monitors both using Displayport connections. When I have the unit docked I cannot set both monitors to 2560x1440 resolution. One monitor will only max out at 1920x1080 while the other is able to scale all the way to 3840x2160. No matter what cominbation I use, the first will not go past 1920x1080. I've updated all drivers to most current, tried the windows and intel display tools with no luck. I have an older T460 laptop as well which I can dock to the exact same setup and it has no issue doing dual 2560x1440 so I know the dock and monitors are functioning properly.  Help

Read other answers
RELEVANCY SCORE 58.8

I've been having some issues with dual display with a T440s and a 40A2009US Ultra Dock. OS is Windows 7 64 Enterprise. I two identical Dell LCDs connected to the dock. One via VGA and the other DVI. Both displays are being mirrored and I can't seem to change it. There is only one monitor listed in Device manager.Both external monitors will only display an image if the PC is started closed from the docking station power button. Removing the laptop and replacing it on the docking station does not wake the monitors and there is no image until the laptop is manually shutdown and restarted. I have updated graphics drivers, as well as any driver related to the dock (USB3.0 etc). I have tried a displayport to DVI connector as well, no go. After some research I discovered the firmare may need to be updated. The synaptics package from the lenovo support downloads site gave me the message that my firmware was already up to date. The other fwdphb06.exe that is recommended elsewhere would not update. When I double-click the package there is no install prompt or process being run. There is an external monitor connected to the dock. I have swapped the dock for another, as well as the power supplies for each. I'm stumped. Any idea what my issue may be?

A:T440s+Ultra Dock Dual Display issues

I have the same problem and worse, when resuming from sleep it will often fail to bring up one or both of my monitors and I have to manually unplug their power cords to revive them. Worked fine with my old Thinkpad and dock. Trying the firmware update now... Lto 3 tapes

Read other 1 answers
RELEVANCY SCORE 58.8

I have just taken delivery of a T470p and have done a fresh install of Windows 10 Enterprise and updated that to version 1703 build 15063.540. The T470p replaces an aging X240. I used the X240 with a ThinkPad Ultra Dock type 40A2 (P/N SD20F82750) with 2 ThinkVision LT2452p monitors attached via DisplayPort. Everything worked reasonably fine with the X240 docked - both monitors ran at 1920x1200 resolution. I'd get the occasional problem where I'd have to open and close the X240's lid to force it to realise it was docked, but I could live with that. But...if I dock the T470p then neither monitor works. Both monitors' power LED turn green when I dock the laptop (so I assume the dock and the monitors are talking to one another) but they then turn orange and there isn't a picture on either monitor. If I unplug one of the DisplayPort cables from the Ultra Dock one of the monitors gets a picture, but as soon as I plug the cable back into the dock the monitor goes blank. Is this a known problem? My employer are about to order 40-50 T470p laptops but if we need to purchase new Ultra Docks as well I think we will have to have a rethink. Kind regards, /Neil  

Read other answers
RELEVANCY SCORE 58.8

printer and USB keyboard connected to USB ports on dock.  When laptop is undocked and then redocked, the printer and keyboard sometimes work after a long pause (30 seconds or more).  Other times they don't work even after 5 minutes.  If the system is restarted that seems to resolve it. If the devices are plugged directly into the laptop there is no issue. Is there any known issue - perhaps a firmware update or other software issue?

Read other answers
RELEVANCY SCORE 58.8

Hi there, when I undock my X280 from the Ultra dock (notebook closed but running) and open the lid the device will not respond to keyboard or trackpoint input.I need to close the lid again which triggers entering 'energy saving' mode.Then opening the lid again will resume everything to normal. I can reproduce this every time on two identical Docks. Funny thing is, my wifes identical X280 does not show this behaviour but works fine. Any idea what I could try to solve this small (but a bit annoying issue)?Thanks.Q.    

Read other answers
RELEVANCY SCORE 58.8

My docked T540p glitches when I move it slightly on the desk. The external monitor blanks for a few seconds and the USB connections crash, ruining data transfers and causing nasty clicks in the external speakers (active and connected via USB). It?s the Ultra Dock not the laptop because it?s happened with two specimens (one in Jan 2014 and a warranty replacement in Dec 2014, both with latest firmware). Each time they were ok for several months but then they got more and more sensitive to movement. After months of frustration I found a bodge - push a slice of 1.5mm thick cardboard into the gap at the left (see picture). It?s crude but it stops mutual rotation between laptop and dock. It?s what the dock ought to do but doesn?t.Cardboard stops movement glitches?Unfortunately, this is only a partial solution to my Ultra Dock woes because the notorious ?speaker buzz? issue meant I had to buy an external USB sound card to replace the audio jack. By the time I?d heard that Lenovo had a hardware fix for the buzz, the warranty on the dock had expired and Lenovo UK refused to replace my dock with the buzz-free version. The only good news? At least the frequent loud clicks in the speakers, and the cardboard, are a daily warning not to be an early-adopter for Lenovo again .  




T540p / 64-bit Win7 / 840 Pro SSD / Ultradock.

Read other answers
RELEVANCY SCORE 58.8

Hallo an alle, ab und zu bekomme ich einen Bluescreen mit meinem x240. Egal ob ich das x240 im laufenden Betrieb auf die Dockingstation setze oder auch, wenn ich das x240 von der Dockingstation boote. Treiber und BIOS ist auf dem neusten Stande. Hat jemand noch eine andere Idee??? DANKE! Ich verwende WIN10 Enterprise.

Read other answers
RELEVANCY SCORE 58.8

I have a T460p (Window 10) in an ultradock and am unable to switch between 2nd output speakers (plugged into ultradock headphone port) and internal laptop speakers. The Realtek driver recognizes both "playback devices", but when the computer is docked there is absolutely no way to play any sound through the internal speakers, even if the external speakers are turned off. The only way to get the internal speakers to play is to physically unplug the external speakers from the ultradock, or undock the computer.  Is there any way around this? I don't always want to use my external speakers, especially when on a skype call etc. Tried reinstalling the Realtek driver to no avail. Should I just uninstall it altogether and use the default Windows audio drivers? I used to have a T440p (Windows 8.1) and I was able to switch between internal and external speakers easily when docked (via volume mixer > playback devices). 

Read other answers
RELEVANCY SCORE 58.8

Yesterday, I updated my T450s and, among other updates,I updated the Ultra Dock 90W firmare to version 2.29.00.  Afterward, when the laptop is docked, with the cover shut, and I try to power up the unit, it won't do so.  When I open the laptop in the dock, the power indicator is green and there is a green light on the function key.  No matter what I try, the machine won't power up after this.  If I force it to shut down and then try to power it up open instead, it powers up normally and both the laptop screen and the attached monitor work and, if I close the cover after, the attached monitor still works.  Obviously, I can use the machine docked with this work around, but I can't figure out why it won't work when I try to poweer it up closed.  I subsequently updated to version 2.30.00 and the behavior continues. What am I missing here? 

Read other answers
RELEVANCY SCORE 58.8

Anyone finding stability with the X1C6 and the Ultra Dock to not be perfect?  I'm finding sometimes the laptop won't wake from sleep properly, requiring me to hit the power button on the dock (to put back into sleep) and then to hit the power button again (to wake it up, which usually resolves the issue).  Sometimes when it wakes from sleep, I lose my background (just a teal colour) and it goes to a black background (which I can revert back to teal right away in my desktop options).  Also, every time I wake up, I find all my open apps are now only on Monitor 1 instead of where I left them (some on Monitor 1, some on Monitor 2) requiring me to spend a few seconds reorganizing.  Finally, I find that each time I wake up, some (not all) of the icons in my taskbar next to the clock begin to get blurry, with each wake worse until I log out / log back in.   I do keep the laptop in clamshell mode when docked, with only my two external monitors in use and I have the laptop set up to not sleep when I close the laptop lid to ensure clamshell is as stable as possible.   All of my drivers are up to date, and I am on the Windows 10 April update that just came out (but the issues began before the update).  I never had issues like this on previous ThinkPad models with the previous Ultra Dock or OneLink Plus docks. 

Read other answers
RELEVANCY SCORE 58.8

Hey guys,I've got new P50s (running W10 x64) with Quadro M5000M, and Ultra docking station for it. I want to use 4 external monitors in any configuration, just that they all work. I tried updating BIOS and Docking station, installed latest Intel and Nvidia graphics driver, power management driver.. everything.I get 4 monitors displayed in Windows display settings, but as soon as I turn on the fourth, one of the others goes dark. Somewhere I read about BIOS setting for Hybrid graphic, but I don't have such setting in BIOS. Any help would be great Thanks!

Read other answers