Over 1 million tech questions and answers.

Issue on Lenovo T480s update Fibocom WWAN L830-EB firmware V18300.1002.00.01.01.17

Q: Issue on Lenovo T480s update Fibocom WWAN L830-EB firmware V18300.1002.00.01.01.17

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Issue on Lenovo T480s update Fibocom WWAN L830-EB firmware V18300.1002.00.01.01.17

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 306.4

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version repeated restart Windows Cellular Service  when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It is like the Fibocom WWAN L830-EB DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 238.4

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version always restart Windows Cellular service when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It works like the Fibocom WWAN L830-EB is DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 212.8

Hi,After recent update of Fibocom WWAN L830-EB firmware to version 18300.1002.00.01.01.17 faced an issue that occures on the go (literally in transport) when network is dropped (out of range) and then found again, as it seems. Win 10 troubleshooter returns:"Windows can't communicate with the device or resource (primary DNS server)"Report & logs are attached.Lenovo Thinkpad T480s (type 20L7, model 20L7001HRT)Windows 10 Pro, ver. 1803 Would someone please provide a link to the previous firmware ver. 18300.1002.00.01.01.14 ? Can I downgrade?------------Regards,Andrey Kuzmin

Read other answers
RELEVANCY SCORE 146

I've a problem with my T480 (non-s) with the Fibocom L830-EB after installing the newest firmware version 18300.1002.00.01.01.17 und driver.  Since this one new firmware, the L830-EB it is unusable for me due to connection dropouts and even due to L830-EB-device-whole-disappear-issues on system driver level, where only a device-disable-and-reenable on the device manager or a reboot helps then in these cases. The longest stable connection i have had since then is about one minute, after which the problems will occur, in other words it is completely unusable now. Please fix it, or alternately provide the old firmware with downgrade-option. My T480 is running with Windows 10 1809 and Arch-Linux (full-encrypted dual-boot).

Read other answers
RELEVANCY SCORE 116

Windows still uses Microsoft made "Generic Mobile Broadband" driver, even after installing the Fibocom L830-EB Wireless WAN Dreiver For Windows 10 (Versio 1709 or later).  This ends in only giving a 50 mbps LTE connection even if the location, sim card and subscription gives 300 mps connection possibillities.   Windows only sees the generic driver, even if I manually try to choose a driver for this. No Fibocom drivers are found in the list.  Is there something that got broken during the latest 1803 installation? Has anyone else noticed this?

Read other answers
RELEVANCY SCORE 104.8

We have ~750 T480s (model 20L8S4HL00) laptops running Win10 Enterprise 1703 in our environment, and at least 35 of the laptops have non-functional Fibocom L850-GL WWAN modules. What makes matters worse is that this issue can also cause repeated BSoDs, sometimes multiple per day. Problem Symptoms and Actions TakenThe "Intel(R) USB Flash Loader utility" / "Fibocom USB Flash Loader Utility" repeatedly connects and disconnects roughly once a minute, and when doing so the Windows "device unplugged" sound is heard. The HWID of this device is "USB\VID_8087&PID_07F5\5&1AD8E564&0&6". Refer to the screenshot below The frequent and repeated hardware disconnections cause problems with the enterprise security software we use for encrypting external media, to the point that after a certain point the computer experiences a BSoDThe only associated driver that remains active in Device Manager is the "Intel(R) XMM7360-P WWAN", all other associated WWAN drivers show up as hidden with code 45 (disconnected)If all WWAN drivers are uninstalled and the drivers are deleted, the only devices that are subsequently discovered are the flash loader utility and the Intel XMM7360, all of the others are no longer found and Windows cannot seem to find them againInstalling all of the latest device drivers and firmware using the Lenovo System Update tool do not mitigate this issue, nor does manually uninstalling/reinstalling the WWAN driversTemporarily disabling the built-in... Read more

Read other answers
RELEVANCY SCORE 104.8

Over the last few weeks, I've had at least a half dozen T480s that have severe spikes in latentcy and packet loss when using the Fibocom L850-GL, making them pretty much useless for our users who need them for remote desktop.The usual "working" baseline for these machines on our network is around 40-70ms pings. Show below are the occasional spikes past 3 seconds and timeouts along with the current firmware.    The work around I was using to fix this problem was uninstalling the drivers/firmware from Device Manager, and letting Windows reinstall them, but that doesn't seem to be working anymore.  Any help would be appreciated.

Read other answers
RELEVANCY SCORE 94.8

Unable to boot up T490s (model  20NX-000ART comes with PREINSTALLED  wwan) Fibocom L830-eb after thinkvantage updated firmware of Fibocom L830-eb.post error 1802 Unauthorized network card 

Read other answers
RELEVANCY SCORE 88.8

Hi ,I have issue about WWAN Fibocom L850-GL+Antenna  after i bought it and installed already.I has follow this step:1.update bios to version 1.4 and enable wwan2.all update new drivers include fibocom 850-GL from lenovo websiteProblem is why i can't see the cellular network show in my network connection?Can anybody give me advise?My laptop is X1 carbon gen6th Machine Type Model: 20KGS45M00Processor: 1x Intel Core i7-8550U Processor(Core i7-8550U)Memory: 1x 16GBLPDDR3-2133Operating System: Windows 10 Pro 64(EN:English)Hard Drive: 1x 256GBSATAM.2Wireless Network: 1x Intel Wireless-AC 8265 2x2 ACPorts: 1x Microphone/Headphone JacksCamera: 1x 720p HD Camera with Array MicGraphics: 1x Intel UHD 620Monitor: 14.0 WQHD LEDThank you very much for your time and assistance in this matter.     

Read other answers
RELEVANCY SCORE 85.2

Hi allMy WWAN was working previously. I have updated my Windows to 1809 October update.However now my WWAN toggle is missing in windows 10 I can see in device manager -Network\ Fibocom L850-GL is missing (shows up in hidden devices) - as error 45 - not connectedSystem\ Intel XMM7360-P is listed as working I've sinced downgraded - but still can't find the toggle.Anyone have problems after updating windows?  Or anyone NOT have problem after updating?  Thank you 

Read other answers
RELEVANCY SCORE 85.2

Hi All, I'm trying to update the firmware on the Fibocom WWAN device on my X270 laptop. I'm running windows 10 x64. I downloaded the Firemware update from here: https://download.lenovo.com/pccbbs/mobiles/nz2wi01w.exeThe Readme is Here:https://download.lenovo.com/pccbbs/mobiles/nz2wi01w.txt When I try to run the unpacked executable, L831_FWUpdateTool_L831_V2E.0C.00.16_NAND, nothing happens. Don't even get a window that then prompty dissapears, just nothing happens. I've tryed starting it from a commandline and using /? type switches to see if I can get anything else from it but nothing happens. Also checked to see that it's not blocked, or being stopped by AV, also checked event logs, there's nothing there.... Any ideas? Is it me, or is the EXE at fault? I've checked the manufacturer site directly, but they don't offer firmware downloads (As I'd exepect really) My laptop is currently running v7 so this would be jumping to v16, as at the moment I only get a "Limited Service" with my sim card. I've checked the Sim in a MiFi device and on a phone and it works fine. So I'm hoping a firmware update will help. Any suggestions greatly appreciated.  

A:Fibocom Firmware Update Tool Doesn't Run

Welcome to the CommunityTry to perform the fw update from either Lenovo System Update or Lenovo Vantage applications.

Read other 1 answers
RELEVANCY SCORE 84.8

Anyone know where to buy the antennas for this product Thinkpad Fibocom L850-GL CAT9 M.2 WWAN. I would be a great help. Also do I need a professional to install these cables?

Read other answers
RELEVANCY SCORE 84.4

Hello, I update the ME firmware to version 11.0.18.1002 Rev.A on the 850 G3 (T9X36EA).After update i shutdown the laptop en restarted. The laptop cannot power up correctly and i get blinking leds on the capslock and numlock keys (blinks with a 3 second delay) After some time the laptop blower is at full speed and screen stays black with only power button / wifi and sound led on. I have been using the correct version.http://support.hp.com/nl-nl/drivers/selfservice/swdetails/hp-elitebook-850-g3-notebook-pc/7815299/sw... What steps i can take to resolve this? Br, Dennis

Read other answers
RELEVANCY SCORE 83.2

Hello,one of our x280 has already the Windows Build 1809. The Fibocom L830-EB is not really working. The Simcard is detected and also showing how good / bad the connection would be. But if you try to connect, it will only show "setting up.. preparing". I was reading, that the same problem also happend in the last builds and we have to wait for a firmware / driver update. Fibocom is not offering any (!) drivers to download. So it looks like we have to wait for Lenovo..

Read other answers
RELEVANCY SCORE 81.2

Hello Community.New user here. We are experiencing problems with the new L series with WWAN (Fibocom L830-EB) when it connects to Cicso AnyConnect.I've spent many hours twisting my head to figure out what is wrong. I have attached some pingtest so you can see what happens.I have two troubleshooting scenarios. {L580 running Windows 10 Pro 1709Microsoft approved driver 10.0.16299.98Fibocom Sensor driver 3.17134.0.6 L580 running Windows 10 Pro 1803Microsoft approved driver 10.0.17134.1Fibocom Sensor driver 3.2.0.3} What I have tried:Installing Microsoft driver 10.0.16299.98 on the 1803 (rollback driver) didn't work. (Which I thought would have been a solution, since it works with VPN on 1709) Updating Firmware (L830-EB_FWUpdateTool_18300.1002.00.01.01.14_signed)Uinstalling Antivirus (Symantec)Install latest Fibocom driverInstall (anyconnect-win-4.6.03049-core-vpn-predeploy-k9) I am out of ideas at this point.  Regards, Mark 

Read other answers
RELEVANCY SCORE 80

Lenovo Vantage updated the T480s BIOS on 8/9. I immediately started getting a Thunderbolt error when starting Windows 10 64, which says to update the Thunderbolt firmware. I downloaded the current firmware from Lenovo (n22th06w) but I get the following error when trying to update: 0x20D SDK_INVALID_OPERATION_IN_SAFE_MODE What's the solution, Lenovo? Thanks.  

Read other answers
RELEVANCY SCORE 79.2

I've read numerous other posts in this thread on ways to remedy the situation, but none are working for this system.The computer is running Windows 10 64bit 1903Thunderbolt Controller 15BFThe computer has the latest version of the Thunderbolt Software Installed (17.4.78.500)The firmware Version is currently the version previous to the last. 17 01 No matter what method I have tried, all fail.  I tried using Gigabyte updater and select the TBT.bin from Lenovo.  Doesn't work.Tried the administrator silent install, doesnt work.Uninstalling the device, uninstalling the software and reinstalling the software doesn't work. I'm just stuck and don't know what to do.  We have somewhere between 30-50 users reporting error messages from the Thunderbolt software but cannot get the firmware to update!  Hello Lenovo!

Read other answers
RELEVANCY SCORE 78.8

Hi, My ThinkPad is x230 Tablet and i can see a SIM slot under the battery (See photos) also i think it has an antenna top right on the screen, my questions now is: 1- Does this mean that my x230 Tablet support WWAN?2- If yes, which Ericsson firmware & drivers i should install for windows 10? Note: I have used the auto update on Lenovo website & it did nothing to the broadband feature (assuming i have it). Thank you

Read other answers
RELEVANCY SCORE 76.8

Hi everyone, I'm a student and planning to buy the Campus version of the Thinkpad T480s with the Nvidia chip. It doesn't come with a WWAN module, but I'd like to add one. Information on that topic seems sparse and I tried to look for M.2 slot WWAN modules at different online stores. I found a few ones, namely- Huawei ME906S, listed to be compatible with 2016 Thinkpads- Sierra EM7455, listed to be compatible with the *70 series Thinkpads- Fibocom L831-EA (Intel XMM 7160), listed to be compatible with *70 series Thinkpads According to this reddit, at least the Huawei and Sierra ones are incompatible unauthorized for a T480s which, if true, is simply inconvenient, annoying and disappointing. As I mentioned above, buying a Thinkpad with a pre-installed LTE module is not an option because I'd like to have the Nvidia chip and am buying a Lenovo Campus Thinkpad which comes at a reduced price (and in Germany, it's the only way to get one with an Nvidia chip). As the Lenovo configurator and the T480s platform specifications indicate, the Fibocom L830-EB (Intel XMM 7262) and Fibocom L850-GL (Intel XMM 7360) are officially used and should definitely be compatible. However, I can't find them anywhere except pre-configured with a Thinkpad, which is not an option for me. Can anyone please help me with either of the following:- Is the Fibocom L831-EA (Intel XMM 7160) authorized for and compatible with the T480s?- Is there any place where I can get a Fibocom L83... Read more

Read other answers
RELEVANCY SCORE 76.4

HI, I wanted to update a firmware on my HP lt4112 modem in HP 840 G1 Laptop, so I downloaded from the Drivers page proper file: http://h20565.www2.hp.com/hpsc/swd/public/detail?sp4ts.oid=5405097&swItemId=ob_152395_1&swEnvOid=419... . I downloaded it and run the exe. After a few phases, when it came to "restoring user data" it stuck, and after a while an error popped up saying: "Error code: 21 - couldn't restore user data". From that point the modem is not visible in Device manager in WIndows. I removed the cover, remove the modem, run laptop and then instal it once more and restarted laptop, but the system said that a new WWAN modem was installed which is not on the list and therefore the system will switch it off. I tried to run previous upgrade: sp69476, but now the system does not even find the port for update ("Error code 10- Could not find the port"). Please help me, because I did everything properly and now my modem does not work. 

A:Firmware update broke HP LT4112 WWAN Modem

Exactly same issue here. HP ZBook 17 G2, LT4112.OS Windows 8.1 Pro.After executing the sp72435 Softpaq, the program stopped with Could not restore user data.After that the only thing left in device manager is the serial port Gobi PC UI.If the above softpaq is executed again it detects the port but times out at Get Device Information. Is it possible to put the device somehow in Recovery mode?   

Read other 2 answers
RELEVANCY SCORE 75.6

I bought a wwan card (Fibocom L850-GL). Installed it and was everything all right. I ran System Update today, which found an update V.2.0.1.44, which I installed. System Update suggested me to restart my laptop. I did so an since than the following happens: System Update finds the very same update again and again. (And shows it in the history as installed update.)Cellular connection does not show up among available networks.No trace of the device in device manager, so I am not able to reinstall it or go back to an older version.Windows beeps sometimes, as if a new device was found, but nothing happens.Any idea is wellcome! Thank you!

Read other answers
RELEVANCY SCORE 74.4

Hello all, just bought a X1 carbon from costco. i noticed a empty WWAN slot when i took the bottem cover off. i think i believe a Fibocom WWAN will fit there but i cant find where i can buy it anywhere . i will be using this for work and need this WWAN. can anyone tell me what the part number is and where i can buy one? thank you 20KG-0022US.

Read other answers
RELEVANCY SCORE 73.6

I want to know if a Lenovo P52 WWAN card will permit me to use that laptop as an additional device in our Google Fi account, which we use for our Android phones.  The card Fibocom L850-GL 4G LTE-A cat 9 is listed as available for P52 workstations.  A Fi chat said that I should use a "data only SIM card", but that does not help me unless I know how to use that in the P52.   I understatnd that the Fibocom card is supposed to work with Verizon, but I want to know if it will also work with Google Fi.





https://www.ingber.com

Read other answers
RELEVANCY SCORE 73.6

Hi all, Am running an X1 6th Gen, in which my Fibocom 850-GL has been sporadically working. 1. The device does not appear in Device Manager under Network Adaptors at all (even if I search for hidden devices)2. Lenovo Vantage picks up that the device drivers need to be updated, and asks me to download the update3. The update runs, and when the laptop reboots, a small white install box appears in the bottom right of the window... and then does nothing.4. A few seconds later, the Windows 'Device Disconnected' chime sounds5. A few seconds later, the Windwos 'Device Connected' chime sounds6. I can re-install the drivers7. Cycle back to point 2.  I'm unable to uninstall the device as it doesn't ever show in device manager; just constantly get Windows finding / un-finding the device, and it never installs. Running latest version of Windows 10; Vantage + Windows seem to think everything is updated. Thanks in advance!

Read other answers
RELEVANCY SCORE 73.6

I want to know if a Lenovo P52 WWAN card will permit me to use that laptop as an additional device in our Google Fi account, which we use for our Android phones.  The card Fibocom L850-GL 4G LTE-A cat 9 is listed as available for P52 workstations.  A Fi chat said that I should use a "data only SIM card", but that does not help me unless I know how to use that in the P52.   I understatnd that the Fibocom card is supposed to work with Verizon, but I want to know if it will also work with Google Fi.





https://www.ingber.com

Read other answers
RELEVANCY SCORE 73.6

Hello,   I consedering buying a THINKPAD X1 CARBON (GEN 7), the Fibocom L850-GL 4G LTE CAT9  is included in the price, I guess it is used to acces 4G network with a SIM card exactly like a smartphone. But in this case what is the use of the wwan option ? As far as I understand it is also used to acces  cellular network ?What is the difference ? Please feel free to explain if I got this wrong  Thx

Read other answers
RELEVANCY SCORE 72.8

I bought X1 Carbon 6th and X280, both with Fibocom L850-GL. WWAN with Linux do not work. I searched and found the reason. The PCI-E must be disabled, so that the card can run with USB. It seems that Lenovo did not offered a solution since July 2017.  I searched but do not find any direct contact to Lenovo to ask the question.  The WWAN is important for me and Windows is no option anymore. Anybody know if there is an other WWAN card wich works with Linux  and X1 Carbon 6th / X280 ?Anybody know if there is a chance that Lenovo solve the problem with a bios update? Many new Lenovo Thinkpads have this Fibocom L850-GL inside and many business user use Linux...

Read other answers
RELEVANCY SCORE 72

Hi, i have problems to get into internet via wwan card Fibocom L831-EAU on W10. System sees the SIM, it prompts for PIN an then I see signal strength bars. Ive already received some SMS. The problem is, I still see the message No internet access. I cant understand why. The SIM was tested in a mobile phone and internet works normal there. I have tried also another SIM from other network operator, but still No internet access.  Any ideas? Thanks in advance.  Matus

Read other answers
RELEVANCY SCORE 71.2

So I just added a WWAN card (Fibocom L850-GL (FRU 01AX792)) to the X1 Yoga 3rd Gen, but the typically "pre-installed" Antenna is not pre installed, I guess next year the Sim slot won't be there if you don't buy it out the door with it.  Does anyone know the Lenovo FU... i mean FRU... Part number for the WWAN Antenna for (Fibocom L850-GL (FRU 01AX792)) These connectors are tiny.  

Read other answers
RELEVANCY SCORE 71.2

https://www3.lenovo.com/us/en/laptops/thinkpad/thinkpad-x/ThinkPad-X280/p/22TP2TX2800Because I need LTE900 (Band 8) for my LTE module.  Is my model support with Fibocom L850-GL 4G LTE-A Cat9 which in the list of x280?Lenovo Part no. : 01AX786

Read other answers
RELEVANCY SCORE 68.4

 Hello All, New T480 with the Fibocom L850-GL wwan card. Clean install of Windows 10 Pro x64, Redstone 4 (v. 1803). All Windows Updates applied. All Lenovo updates applied through the Vantage app via the Microsoft Store, and manually checked from the support page of the website (BIOS, WWAN, etc. updates). Following the manual, I pulled the external battery, disabled the internal battery, then inserted my T-Mobile USA sim card, then reassembled everything, then rebooted. Manually installed the latest L580-GL drivers from Lenovo. First off, the L850-GL is being shown as a USB device, as opposed to PCIE, with a hardware device instance path of USB\VID_8087&PID_0AC9&MI_00\7&4FA6012&0&0000, and a hardware location of 0000.0000.0000.003.000.000.000.000.000 in the properties dialogue screen in Device Manager. The Driver tab shows the provider is Microsoft with a date of 4/10/2018 and a version of 10.0.17134.1.... I suspect much of that to be a sign that something isn't right from the get-go... Second, every time I close the lid of the machine or leave it running long enough to enduce the proper level of sleep/hibernation, the card simply stops (with a hardware error 43 warning in Device Manager). At that point, my "T-Mobile LTE" network option no longer appears in the Windows 10 notification/network connections sidebar. My only recourse thus far has been to uninstall the L850 in device manager, "Sca... Read more

Read other answers
RELEVANCY SCORE 68.4

Hi. My brand new T480s is giving me a rough time already. I bought it with the Fibocom L850-GL modem and inserted an AT&T sim. Today I wanted to upload 14 files totaling about 1.66gb over cellular as the upload speeds are much better in town than they are on the home internet. Also I have 48gb of data on the plan so let's ignore that. First question, why does it keep changing the network back to metered mode? Every time I turn cellular off and back on it's again marked as such. Even if the connection drops briefly and comes back on its own it is again metered. One drive refuses to upload on metered connections until I go into it and hit resume. If the connection drops briefly one drive pauses again as it is again metered. That's the first, and the less troublesome, issue believe it or not. The real problem I have is, once I do have one drive uploading, I can get speeds according to one drive of around 2.6 or 2.7mb/s. It'll do that for about 4 minutes or so, till it reaches around 80 to 100mb transfered, then the computer will just hickup and stop responding for a few seconds then come back, and now one drive is uploading at 0.0kb/s and my computer starts getting hot. Looking in task manager, I see that system is using 99 percent of the cpu, I'm talking about the system process and not speaking of some process running under the system account just to be extra clear. Btw I'm using a port of the windows 7 task manager, I don't like the wind... Read more

Read other answers
RELEVANCY SCORE 67.6

Hello, I got my X1C7 with LTE card yesterday, and spent half of the day figuring out why the cellular connection is not appearing. I noticed that the LTE card is not visible in device manager or network adapters, and the computer keeps making noices every few minutes as if a new device was being connected to it. I've checked BIOS that the Wireless WAN connection is enabled, and installed all Windows updates. When updating drivers through Lenovo System Update, I found that installing the Fibocom L850-GL drive package actually never goes through. After the installation process has finished, the software says driver installation was succesfull and the computer needs to be restarted. However, when I restart the computer and check for drivers again, the option to install the LTE card driver is still there. I did find the following device in device manager under system devices, but I'm not sure if it has anything to do with the Fibocom L850-GL. I'm currently running Windows 10 Pro Version 1903.Has anyone else had the same problem and managed to fix it?

Read other answers
RELEVANCY SCORE 67.6

This post is partially to request assistance and partially to voice aggravation and disappointment. My old laptop was failing and I was in need of one for travel with WWAN capability. I initially bought an X1C6 that showed the WWAN card as enabled in BIOS. When I found out that the card was not present, I returned the laptop. After doing further research, I settled on a T480s that was WWAN upgradable, expectating a wait for the EM7565 with FRU 01AX762. Now the Fibocom L850-GL with FRU 01AX786 is available for new builds, but I cannot find where to buy it on the site or elsewhere; if this is not simply due to me being unable to navigate the poorly-designed Lenovo site, it effectively punishes anyone who ordered early. Finally, I tried my old EM7345 with FRU 04X6014 and encountered the 1802 error for an unauthorized device. Researching that further led to understand that Lenovo uses a whitelist - another punishment. I am now ready to return this laptop as well unless I can make some progress before traveling again. I would not be surprised if a class-action lawsuit were brought against Lenovo and any other manufacturers restricting individuals from making use of their own legitimately purchased hardware, especially when false or incomplete information is pushed by the company. If anyone knows where to obtain either LTE card, I would appreciate it.

A:X1C6/T480s WWAN difficulties

Looks like the Fibocom is available on the Lenovo Encompass site based on the part number you posted.
 
https://lenovo.encompass.com/item/11586506/Lenovo/01AX786/Wirelesscmbfbcl850gl

Read other 1 answers
RELEVANCY SCORE 66

Hi, since a couple of weeks, system update prompts me to update my NVMe disk firmware. It downloads and runs Lenovo Storage Device Firmware Update Utility, but it always fails with the same error: Update Failed: Firmware update FAILED! RC=0x1 Stopped by a device reason.  This happens to me with the last version of the firmware update toot (FWNV29), but also has happened to me with previous versions. Also, downloading FWNV29 and running it independently from system update leads to the same error. Can someone help? Thanks. The log from fwwinsd.exe (fwwinsd.log) shows the following:[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - IN
[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - OS : Windows 6.2 Build 9200
[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - Current path : C:\Users\fpiris\Desktop\FWNV29
[2019/03/27 07:47:09]: CFWWinDlg::openProfile - IN - fwwinsd.pro
[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - Profile verified to exist
[2019/03/27 07:47:09]: CFWWinDlg::disableAutoODDPowerOffFeature - IN
[2019/03/27 07:47:09]: CFWWinDlg::disableAutoODDPowerOffFeature - Open registry key : Software\Lenovo\PWRMGRV\Data
[2019/03/27 07:47:09]: CFWWinDlg::displayDrives - IN
[2019/03/27 07:47:09]: CATADrivesScanner::scan - IN
[2019/03/27 07:47:09]: CATADrivesScanner::cleanUp - IN
[2019/03/27 07:47:09]: CATADrivesScanner::enumerateDevice - IN : GUID=0x53f56307
[2019/03/27 07:47:09]: CATADrivesScanner::enumerateDevice - Device info se... Read more

Read other answers
RELEVANCY SCORE 64.8

Hi!After upgrading to Windows 10 Fall Creators Update I experience the problem that the wwan card cannot connect anymore.When trying to connect the error message "Can`t connect to this network. Enter an APN and try again".I`ve tried serveral drivers for the wwan adapter but with no results. APN is set. Uninstalled and installed the wwan adapter, clear the apn and configured it new, installed fall creators update again, etc. nothing seemed to work.One odd think. If i disable Wifi and reboot the device the wwan card works. I can enable the wifi adapter and it still works. But if i boot with wifi and wwan adapter enabled, wwan doesnt work.Do you have any ideas what would help?! Update: WWAN Card Sierra Wireless EM7455 

Read other answers
RELEVANCY SCORE 64.4

Hello, I have Carbon X1 5th (20HR) running Windows 10 pro (updated).  Altought I followed the instructions here - https://pcsupport.lenovo.com/cy/en/downloads/ds120390 (This is the page for Lenovo users who wish to update TPM firmware) - and installed the "BIOS Update Utility for Windows 10" version 1.33, Windows still keeps telling me to update the TPM firmware driver.  In BIOS it shows that I have TPM ver 2.0, enabled. Since Windows kept telling me to update the TPM driver, thanks to Google I found out that there is a tool created by Lenovo called "TPM Firmware Update Utility -ThinkPad" (It is worth noting that this tool is not mentioned on the instruction page). I downloaded the tool, but can't understnad how to use it (assuming that I should use it at all, because this tool is not mentioned on the TPM instructions page). Could you please help me to solve the TPM issue described above? Is there a way to check what version do I have? Thanks in advance!  

Read other answers
RELEVANCY SCORE 64

Seems like I?m not the only one with this problem and no answers as I can see in this post:https://forums.lenovo.com/t5/Lenovo-P-Y-and-Z-series/Lenovo-Z510-Battery-Issues/m-p/2248499#M138065 as you can see this post is marked as SOLVED but these is like 14 more pages after that which denies this post as a fix because it DOES NOT SOLVE the problem! Me and lots of other people have this battery issue, battery indicator shows 100% and stuck on that and after like 30 minutes is turns off without dropping 1%. My searches ended up here that I have to use the firmware update program that always say "there are no attached batteries that require a firmware update" so how about a real fix hah???

Read other answers
RELEVANCY SCORE 64

Hi I have a T430 and yesterday (12 feb) it said that it needs to do a Lenovo firmware update. I ran through the installation and it finished and prompted me to reboot. I didn't think it at the time but I have never before seen a firmware update install unprompted (this was not a windows update it was a Lenovo Firmware Update and ran through some considerable command line output before finishing and then asking for a reboot). When it booted back up everything was fine but within a few hours I started to experience wifi problems. Connections would randomly drop and so on.  And I would get strange DNS errors such as DNS_FINISHED_NO_INTERNET. After a while the wifi became unusable. So I performed a windows restore to before the Lenovo firmware update and it fixed the wifi issues, the NIC connected again as normal. But then today the sound started to go crackily and jumpy.  This resolved itself on reboot however I am concerned that after having the laptop for about a year (refurbished) with no issues (except a keyboard issue which  I will write another post about) that I then have 2 hardware issues hours after the Lenovo firmware update.So my 2 questions are: Is the Lenovo firmware update legitimate? if so it known to have caused issues to anyone else? and depending on the answer to them questions is there any advice I should be following? Official or otherwise.ThanksDamian

Read other answers
RELEVANCY SCORE 63.6

I did a clean windows 10 install on my T480s, and installed Lenovo Vantage.  I used Vantage to install the recommended drivers and updates.  After using the "trackpoint firmware update utility," the touchpad and trackpoint both no longer functioned at all.  On restart, the first thing to appear on the screen was "PS/2 Mouse Not Detected" with a beep.  A USB mouse did work, however. I believe this is the same problem that was described in threads regarding the P52 and the X1C 6th gen (https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/Lenovo-Think-Pad-P52-updated-BIOS-with-e...).  According to those, the updated trackpoint firmware was faulty and caused the problem on both the touchpad and trackpoint.  The solution was to provide a firmware version for both (touchpad and trackpoint).   The model of touchpad on the T480s, however, is different than the P52 or X1C.  I installed the firmware from the P52 downloads anyway, and this got the trackpoint working well.  However the touchpad doesn't work quite right; sensitivity is off, and right click does not work (regardless of windows settings).  Coming out of sleep, the touchpad can take a minute to begin working as well.  I did try using drivers for T480s touchpad as well as P52 (P52 drivers work the best at the moment, probably because it has P52 firmware). I guess my options are to preferably find firmware for the T480s t... Read more

Read other answers
RELEVANCY SCORE 63.2

Hello How can I find if my model type of Lenovo ThinkPad Yoga 370 type 20JJ-S4W61C is WWAN or not? WWAN model: 8GB 2133MHz DDR4 soldered to systemboardNon-WWAN model: 16GB max / 2133MHz DDR4, one DDR4 SO-DIMM socket I dont see it in Lenovo Vantage utility and even can't searched it google/duckduckgo. And of course, how can I identify it without opening a laptop chassis physically. thank you

Read other answers