Over 1 million tech questions and answers.

Lenovo y520-15IKBM 80YY005MRI does not boot with Asus Gladius mouse connected with bios 5XCN22WW

Q: Lenovo y520-15IKBM 80YY005MRI does not boot with Asus Gladius mouse connected with bios 5XCN22WW

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Lenovo y520-15IKBM 80YY005MRI does not boot with Asus Gladius mouse connected with bios 5XCN22WW

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 335.6

Hi,2 days ago I updated BIOS to 5XCN22WW on my Lenovo Legion.Then problems appeared:1. Windows 10 pro did not want to boot anymore(INACCESSIBLE_BOOT_DEVICE), bitlocker ON2. After fixing 1, the laptop does not boot if my Asus Gladius mouse is connected to any USB port. To be noted that I also have a mechanical keyboard attached, and mini display port connected and they don't create any issue. The laptop hangs on the Lenovo LOGO. If I detach the  mouse, restart, enter BIOS and then connect the mouse while in BIOS, the laptop hangs with the BIOS image left on it!3. If I enable secure boot in BIOS and leave the mouse connected, then I get a blue screen with info that Windows 10 wasn't able to boot correctly, press the restart button and then the laptop boots. Questions:1. Might this be related to this new BIOS? Because it just created a lot of problems to me after update. If you ask if I'm sure that I installed the correct BIOS then yes, it's correct, because the machine was detected by Lenovo service bridge, and also I checked the sticker on the back.2. I don't see any downgrade options on the support site. Only the latest BIOS. How to get previous BIOS versions?3. Shall I contact ASUS? I don't know what they will do though, because it seems that this is an issue with the latest BIOS, as with the previous version I had no such issues! Thanks!

Read other answers
RELEVANCY SCORE 101.2

HelloI need to buy a new laptop and I found this one which people say it's suitable for games (and within my budget). Do you guys think it meets all the requirements for playing games, new games especially like assassin's creed odyssey? I'm no real expert when it comes to these kind of things . Will this configuration last long or it's going be old in a couple of years (in terms of gaming requirements I mean). And last but not least... is actually 16 the maximum ram supported?ThanksLENOVO Legion Y520-15IKBMProcessor: Intel Core i7Processor identification: - 7700HQ, Quad Core- GPU: Intel HD Graphics 630- Processor architecture: Kaby LakeClock speed (GHz): 2.8Max Turbo Frequency (GHz): 3.8Third level cache (MB): 6Chipset brand: IntelRam MemoryRAM: 16 GBType of RAM: DDR4Maximum Ram Supported: 16 GBTotal RAM slot number: 2Hard DiskHDD: 1000 GBHard Disk Type: HDDSSD: 128 GBGraphic cardGraphics: nVidia graphicsGraphic model: - GeForce GTX-1060Memory Graphics Card (MB): 6000Other features of the graphics card: - Dedicated- GDDR5Operating systemOperating system: Windows 10 Home (64bit)DisplayDisplay size: Display 15.6 ''Display ('): 15Convertible: NoHD: Full HDDisplay resolution: 1920x1080 pixelsScreen format: 16: 93D: NoAnti-reflective display: YesIPS display: YesOptical UnitOptical drive: NoAudio cardSound card: Audio by HarmanSpeakers: 2 x 2.0 WConnectivityEthernet: YesEthernet type: 10/100/1000Wi-Fi: YesBluetooth: 4.1InterfacesUSB 2.0: 1USB 3.0: 2Number of usb type 'C' ports... Read more

Read other answers
RELEVANCY SCORE 96.8

Hello, I have Lenovo Legion Y520-15IKBMLenovo Y520-15 - Intel Core i5-7300HQ 2.5/3.5GHz; GeForce GTX 1060M MaxQ 6GB GDDR5; 8GB DDR4; 128GB SSD m.2NVMe ADATA SX7000 + 1TB HDD; 15,6" FHD; Windows10 I want to buy 144Hz monitor. Should I buy USB-C to DisplayPort cable adapter like that:https://www.morele.net/kabel-usb-microconnect-usb-c-to-displayport-4k-0-5m-czarny-usb3-1cdpb05-14189... or mini DisplayPort to DisplayPort adapter? BR

Read other answers
RELEVANCY SCORE 82.8

I've just bought Y520 15IKBM and I want do a ram upgrade with more 16 GB and have some confusion around it. My laptop has a ramaxel module at 2666MHZ speed CAS 19, product code for it is RMSA3260MH78HAF-2666 8GB and the laptop official specs states the ram is at 2400MHZ and also CPU-Z is showing 1197MHZ thus I'm inclining to believe is 2400MHZ the supported frequency.- So should I buy a new 2400MHZ SODIMM or 2666MHZ to work well with existing memory module?- In my area Romania Europe I cannot find any ramaxel buying options, I found available Crucial 16GB module product code CT16G4SFD824A 17ns CAS, which is 2400MHZ thoughIs this crucial memory compatible wih ramaxel module in my unit? Thank you,Ciprian

A:Y520 15IKBM RAM Upgrade

Hi Ciprian,Warm Greetings & welcome to Lenovo Community, happy to have you here.
 
Lenovo Legion Y520 supports DDR4-2400 MHz, SODIMM × 2 (max 32 GB) according to Lenovo 
You can also check the System configured parts through Lenovo parts lookup. Crucial CT10745090 will work fine with your system. You can try different vendors as well just make sure Memory specifications are matching. 
 
I hope the above information helped you.
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 1 answers
RELEVANCY SCORE 82

How can I reduce the fan speed on my Y520-15IKBM? While I'm doing less intesive activities like typing into text editors (no intelli sense), browsing text mainly web pages, I'm not expecting to hear the fan noise.I bought this laptop for doing my programming job and fan noise is disturbing when you know you're not hitting your system with anything. There are no windows updates pending in background, no antivirus activity. Thank you,Ciprian

Read other answers
RELEVANCY SCORE 72

Hi everyone,I've got a Lenovo Legion laptop with a year old BIOS. I need to update it however on the website with the driviers the BIOS update is missing and I can't find it anywhere else. My PC is having serious issues with performance in games and after contacting Nvidia I was told to update my BIOS first. I need this update as fast as possible because I basically can't use the laptop without it. Also I can't contact any sort of support or chat because my product is apparently "not supported" and no one has replied to my emails a week now. Thanks in advance! 

Read other answers
RELEVANCY SCORE 72

Hi all, The laptop model is  y520 151BN  / 80WKI bought a cheap SSD called  -> Solid State Drive Intel E5400s, 120GB, M.2  I installed it in the laptop however BIOS or Windows 10 is unable to see it . Can you please let me know if this SSD is not compatible or what troubleshooting i could try ?

Read other answers
RELEVANCY SCORE 70.4

I attempted to install the new Y520 BIOS release in hopes of addressing recurrent wake-from-sleep issues. The "System Update" function in Lenovo Vantage shows "BIOS update - 10 [64] V.4KCN41WW" but will not install it. The resulting message is "Failed installed on 1/25/2018 at 6:40 PM".

Read other answers
RELEVANCY SCORE 69.6

I updated the BIOS yesterday and after using it today, i realised that the laptop was heating up, even though i wasn't playing any games. Just watching some videos on youtube using Microsoft Edge. The bottom side of the laptop, the one below the keyboard, felt hotter than usual. Same for the part right above the fan, one where the power button is. Never had an issue before the update as it never used to get hot enough for me to feel it unless I was playing a heavy game. It only gets better if I use the extreme cooling feature, but that shouldn't be the case for regular browsing. Could this BIOS update be the reason for my laptop heating up? Please help. 

Read other answers
RELEVANCY SCORE 69.6

Hey,I really need some help with the following issue: Details:HW: Y520 with 16GB RAM, GTX 1060, SSD (GPT) + HDD (MBR)SW: Win10 pro - including latest updates. On GPT based SSD and in UEFI mode.BIOS: latest one is loaded Problem:In short; The FIRST boot each day is unsuccessful, but the SECOND right after the failed attempt is always successful. More details:This also happens, if I switch the notebook on after not using it for a few hours, like 3h<So during the first attempt the notebook is just freezing and and I have to press and hold power button. The last thing I can see is the lenovo logo and the stopped spinning circle animation. Notebook doesnt react to ctrl+alt+del.The strange thing is that right after these 1st attempts the 2nd boot attempts are always successful, windows10 loads in and no problem after that. What I already checked:-Windows event viewer: There are no records from the failed boot, I guess because windows is not even loaded.-Drivers: All drivers are installed-BIOS: I didnt see any related setting. The OS was installed in UEFI mode and bios is set this way (UEFI)-I run all the quick and deep hw diagnostics test on lenovo support page - No issues.-Win10 reinstall: Even after a clean install the freezes are still happening. Installed win10 twice but no change, still freezing.What causes the freezes!?If needed I can make a video as well.Thanks in advance!

Read other answers
RELEVANCY SCORE 59.6

Hi,After updating to the JBET67WW 1.31 BIOS my mouse and trackpad cannot click on most UI elements in Windows 10 (1709) when connected to a ThinkPad Ultra Dock (40A2), some still works like minimize/maximize and close buttons on windows but most dont. I've tried to force a re-apply of the update but it is still having the same problem. Previously I used 1.30 without any problem, so the question is where can I get the files for 1.30 to do a downgrade?

Read other answers
RELEVANCY SCORE 58

Ok here is the thing, I have my Lenovo Y520 for almost a year. My external monitor is ASUS and its connected through vga cable/hdmi convertor in laptop. Recently screen just started to blink, and then monitor goes off, there is no signal on monitor. I took same monitor connected it on other laptop its working fine. I brought another monitor BENQ, connected it to laptop directly with hdmi cable and no convertors. I can see that monitor is connected but still no signal on it. The thing is first monitor every time when i plug it in there is picture for about 10 seconds and then it start to blinking and signal goes of. The other monitor BENQ doesnt get picture at all. I have installed all lates drivers, and I dont know where is the proble,

Read other answers
RELEVANCY SCORE 57.6

This is my computer: Link Gateway GT5228
This is my motherboard: Link FIC K2BC51 Motherboard with NVIDIA GeForce 6100 Chipset
This is my new HDD: Link WD Caviar Black Model: WD1002FAEX

Brief history of the problem:

After an office move, old HDD failed 4 times in 2 weeks; recovered, reformatted, re-crashed, each CHKDSK revealing more and more bad clusters… figured it for physically toasted & bought a new HDD
Installed new HDD; did nothing but open the case, slide the new drive into an empty spot in the bay, secure screws, and swap the power & data cables from the old HDD to the new at the drive end; taking precautions, re: static discharge, of course
Powered machine up & it would not progress beyond the Gateway splash screen w/F2 for BIOS and F10 for Setup; no response to F-key presses whatsoever, would sit as long as overnight with nothing whatsoever happening or changing
Tried all 7 USB (keyboard) ports, just in case: no change. Tried a PS2 keyboard: no change.
Checked HDD cable connections, tight; no change.
Carefully removed & re-seated memory – no change.
Cleared CMOS w/jumper: no change. Removed battery for 2 hours & replaced: no change.
Tried to boot with original Gateway O/S disc in CD-ROM drive: no change. Tried boot with new Windows 7 disc in CD-ROM drive: no change.

With all of the above, system powers on, fan runs, don’t hear any POST beeps at all… failing somewhere early on… can’t even boot into BIOS no matter what.

Next: d... Read more

A:After new HDD, can't boot to BIOS w/HDD connected

Read other 8 answers
RELEVANCY SCORE 57.6

Hi
I am running a home-constructed PC (started out life as a Dell, but i had to replace the motherboard and - well, one thing led to another).

Asus A8N-E running NVidia nForce4 with AMD processor
Windows XP professional
Zone Alarm security suite

It's been working fine for a couple of years with the odd hiccup but i transferred to Zone Alarm from McAfee about four months ago, and upgraded to IE7 - security and fire walls seem to be a big part of the problems i've had in the past so i thought i'd mention it.

last week i had the "application error with winlogon.exe" error on log on and I couldn't boot at all. I did a repair install from the XP disk which *Mostly* worked, but now I have no mouse. I am having to tab through the browswer fields to even post this message which is incredibly frustrating!

Odd symptoms:
* IE has rolled back to version 6 (I guess that might be a function of the repair install)
* In the device manager there is NO "mouse and other pointing devices" entry, let alone any mouse recorded under it
* In the control panel, the mouse hardware properties are completely blank (no way of updating driver or getting more inform,ation - selecting the buttons does nothing)
* In Regedit the particular registry key that Microsoft says I should be looking for (at http://support.microsoft.com/kb/142405) which is HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Class/Mouse doesn't even exist in the registr... Read more

A:Mouse Not Detected, bios problem? Can't even get INTO bios on boot

Most likely a bad mouse, or a bent mouse pin, or you are using one of those wireless mouse units, or a cheap usb mouse.

Mouse detection problems are exceedingly rare except for the above... never heard of a mouse being affected by a virus.

Uninstall Zone Alarm if you are using Internet Explorer 7.0 because you will always have problems otherwise.
 

Read other 3 answers
RELEVANCY SCORE 56.4

I have a lenovo g500s touch laptop that I am trying to get to work with an external graphics card setup, but when I turn the computer on, the screen remains blank. I can hear the fans spin up, and the external PSU and GPU fans spin up also, but the computer won't boot, not even BIOS. The weird thing is that when I remove the 4gb RAM stick, and leave the 2gb one, the computer works, the graphics card is recognized and works as expected also, I just can't play some games on 2 gigs of RAM. Also, the computer works fine with the 6gb of ram as long as the gpu isnt plugged in. Here is my setup:

OS: Windows 10
GPU: Nvidia GTX 750 ti SC (2gb of VRAM)
RAM: one 2gb, and one 4gb
External Pcie adapter: http://m.banggood.com/Mini-PCI-E-Ve...al-Independent-Video-Card-Dock-p-1011222.html
 

Read other answers
RELEVANCY SCORE 56.4

Hi all

I am having a weird issue, as the title says, I am unable to boot into BIOS when I have the external HDD connected via USB 3.0.

when i want to start it up and boot into windows it starts to load the windows installer which you would find like on a win 7 install disk but then stops.

- the external HDD is not loaded with any win 7 and is not setup as a bootable image, its just data
- the HDD is a Buffalo Drive Station 3 TB with USB 3.0

my current setup looks like this below, i suspect that something went wrong during the OS install despite not using this HDD for any installation but another USB dongle which was slip-streamed with the USB and Samsung nvme drivers necessary for install.

On my asus laptop i did not have this issue before just with this new built i just did.

i have to unplug the HDD so i can boot into bios and windows normally.

i cant see the boot order in BIOS as the drive is not live and visible even if i connect it in bios once unplugged previously.

any help appreciated or if more info is needed, thanks much
cheers
stephan

Read other answers
RELEVANCY SCORE 56.4

P8P67 EVO mobo will not allow me to boot into bios with my external hd connected. The computer will keep reseting itself, trying to boot the external hdd. I can only set the internal hd as 1st priority boot when the external is not in. Therefor I cant change the priority of the external. Stuck ><
 

A:Wont boot into bios with external HDD connected

Read other 11 answers
RELEVANCY SCORE 56.4

I bought a new WD External hard drive and if I plug it in before starting my PC, it will not boot.  WD support tells me that I need to turn off Legacy Boot Sources, but if I do that my PC will not boot. They suggested I update my BIOS, but AMD seems to think I have the latest. 

A:PC won't Boot with External HD Connected - BIOS Woes

This is depressing. Not one single response. No questions. No suggestions. Nothing.

Read other 1 answers
RELEVANCY SCORE 56

Greetings all,

I have searched up and down the forums for an answer to this, and my issue is slightly more specific than most.

This is a rundown of my setup:

OS Version: Microsoft Windows XP Professional, Service Pack 3, 32 bit
Processor: AMD Athlon(tm) 64 Processor 3200+
RAM: 1022 MB
Graphics Card: NVIDIA GeForce 7950 GX2 , 512 MB
Motherboard: ASUSTeK Computer INC., M3N78 PRO, 1.XX, MS1C92B34902999
CD/DVD: Sony DVD-RW+/- (Failure, Not Functioning at the Moment)

I think that's all that is currently relevant to the issue.

I purchased Windows 7 Ultimate from NewEgg, Received my discs, awesome. - used the Windows 7 USB DVD Tool to install windows onto an external drive of mine, which is plugged in via USB. Reason for this is, my DVD drive as listed above is not currently functioning, so I wanted to install via USB.

Well of course, I run SETUP upon powering on my pc, and there are no options under boot priority related to USB at all. My options are still: Hard Disk, CD Drive, Removable Devices. I know the computer is recognizing the drive, because when I move to the hard-disk portion of the BIOS, it shows the drive listed.

Granted, I am not a computer wiz, I do know a lot and am well rounded in almost all aspects, but this I am not. Am I missing something? When the computer recognizes the drive that I have plugged into via USB, that to me says the port and USB are functioning correctly. The drive fully works when in Windows. I guess my question is, ASUS Updater is tel... Read more

A:Solved: ASUS Motherboard BIOS - USB Boot

Read other 6 answers
RELEVANCY SCORE 56

hello
i have a asus et1602
it has a bios boot block on it
it does not have a floppy, cd , or dvd rive
only usbs
i have tried a external usb dvd r/w to install xp back on itand it hangs up when it says starting windows
win7 gives me a blue screen and a string of error codes
blocks uniflash in bios
removed cmos battery and it did not help
forgive me but i knowi will say this wrong
but it install ubito? just fine
ive tried several online sugestions on flashing it from a thumb drive
im either doing it wrong or its acting the same way as dvd r/w
it just blinks forever with no action
ive ran into some tuff ones butthis takes the cakebios says there is no password but reset it anyway
so, ive reached the point of desperaty and thought maybe i would short the pins on the bios chip
i have had to do that before
i cant figure out wich is the bios chip
its not obviouse to the eye and i think ive searched almost every chip on the board
it hasa atom cpu
motherboard number isem16-dhs rev.1.036
this is crazy hard
ive googled my brains out
can anyone help me please
thanks as usual
 

A:Asus et1602 BIOS boot block

Have you contacted Asus support for this issue?
 

Read other 1 answers
RELEVANCY SCORE 56

Hello,

I did not buy this computer. Just happen to come across it at work in one of our computer labs.

I turn on the computer and the fans in the computer turn on for about 1 second and then the computer totally turns off. No error beeps or anything.

Would this be something wrong with the PSU or the Mobo?

I did some testing, but still getting the same problem. I took the mobo out of the PC and set it on a book and built it outside the PC Box and I am still having the same problem.

Any help would be appreciated!
 

A:ASUS M4A79T Deluxe won't boot to bios

Read other 11 answers
RELEVANCY SCORE 56

My Yoga 260 will not boot up when it is connected to the one+ docking station. I have to remove it from the dock to boot up. When connected to the docking station the boot up freezing at the Lenovo logo. When I disconnect, the boot up starts again. The problem appered after BIOS uppdate to version 1.58  

Read other answers
RELEVANCY SCORE 55.6

Hi.About half a year ago, I bought the Lenovo ideapad 720S-14IKB. Since day 1, I noticed this problem where the mouse becomes invincible for a few seconds after I open a new tab in the webbrowser or start a new program. Here is a video of it: https://i.imgur.com/FSR05gs.mp4 Futhermore, after installing the latest BIOS update (4VCN41WW), the laptop has started to freeze for a couple of seconds on me every once in a while.  Are these, things that can be fixed by myself? Or should i talk to the store where i bought it about sending it to repair? I live in Denmark, so I have 2 years warrenty. 

Read other answers
RELEVANCY SCORE 55.2

Hey guys, looking at this here: https://kb.wisc.edu/showroom/page.php?id=58779
 
I have tried all keys showing F2, F9, F8, Delete, ESC but nothing works, help?

A:Asus x54C model can't get to boot menu or bios

What do you see?
 
Anything at all on screen, or is it just black?

Read other 0 answers
RELEVANCY SCORE 54.8

No BIOS or video with P5LD2

Greetings.

I have just built a new PC (see specs bellow) and I am receiving neither a BIOS beep nor video signal.

MB: ASUSTeK P5LD2
CPU: Intel-PentiumD (LGA775) 820 2.80GHz BOX(EM64T)
RAM: 240PIN DDR DDR2 PC4300-1GB(DDR533) HYNIX original (two sticks for a total of 2GB)
VIDEO: HIS HX70PRQ128-3TOEN IceQII (ATI x700Pro 128MG)
HD: Hitachi/IBM HDT722525DLA380 SATA 250GB
OD: LG GSA-4167BB Multi DVD drive
C/PS: Antec SONATA II with 450W Smart Power 2.0 PS
MISC: MITSUMI FA405T(B) (3.5 inch card reader)

Here is what I have done:

- assembled the system both in and out of the case, piece by piece;
- verified both the 4-pin ATX 12V and the EATXPWR 24-pin power connectors are firmly attached;
- confirmed jumpers are set to factory defaults;
- doubled checked that the RAM modules are inserted in the appropriate DIMM_A1 and DIMM_B1 slots -- though, I have also tried every slot with one module and all two-module combinations;
- checked that the HD is connected to the SATA1 port;
- cleared the RTC RAM; and,
- cleaned video card and RAM connectors with rubbing alcohol.

Here is what I have observed:

During both in- and out-of-case assemblies I was able to power up the system (CPU fan, case fan, video card fan, and motherboard) but received neither BIOS beep nor video signal. Only silence. After trying multiple RAM configurations, resetting the RTC RAM, and cleaning components with rubbing alcohol, I was greeted with ... Read more

A:ASUS P5LD2 won't boot + No BIOS beep or video signal

Try different Video card.

OR

My experience

Ok i recently had the same problem with a new machine i built.

I realize that the CPU FAN was shorting the board.

I used a CPU with a fan controller it was shorting it some how. in the end i cut the wire from the Fan controllor(was like to wires together) so i just joined them then taped them up.

I would recommend testing a Different CPU fan,(i know it sounds weird but i was very suprised an noone ever came accross this i know off)

Also make sure. you have the board placed properly on the motherboard using spacers. about 0.5cm of the case using the spacers provided with the case.

I would also suggest that your CPU would be fine and properly anything else.

If your cpu dint work you would here the same beeps codes as if it was removed (are something along the line)
 

Read other 32 answers
RELEVANCY SCORE 54.8

Well, the title says it all.  My Lenovo Yoga 2 11 is refusing to boot, and I cannot even boot from a USB, run recovery, or enter the BIOS.  Please help me.

Read other answers
RELEVANCY SCORE 54.8
RELEVANCY SCORE 54.8

Hi there, I need to upgrade my ram, Currently housing 1 x 8gb module stock. Would someone kindly be able to offer me a list of compatible 8gb modules that I can purchase and install. Further to this due to my current location in Thailand I have the following more readily available. Crucial - CR239ELAB8TNTXANTH-99364522 Kingston HyperX - HX424S14IB2/8 Both clock in at 2400 Thanks in advance.

Read other answers
RELEVANCY SCORE 54.8

Hi.My Lenovo have a 1tb hdd.I want to know if I can buy a ssd and the both disks.And if so what sdd can I buy MTM:80wk00mmpg

Read other answers
RELEVANCY SCORE 54.8

Hey everybody, I am trying to install Windows 10 x64 over USB (Created with Microsoft tool).BIOS version: 4KCN43WWWhat I want is to install Windows in UEFI Mode (Not legacy), but when I set everything in BIOS I can?t see USB on boot menu.I can use it and install it when I set: Boot Mode: Legacy SupportBoot Priority: UEFI First But that is not an option, I don?t want my Windows to be on Legacy mode.I am not able to install it like that and switch to UEFI after, keep getting error that HardDrive cannot be found.SATA Controller Mode is on ACHI.OS Optimized Defaults is on ENABLED.Secure Boot is DISABLED.Fast Boot is DISABLED. If anyone has any solution that I didn?t try it would be great.

Read other answers
RELEVANCY SCORE 54.8

Hello people, i have a big problem,bought a brand new laptop few days ago its Lenovo y520 i7-7700hq/16gb rams and gtx 1050ti 4gb, and i cant play games at all,tried tom clancys the division i have 15-10 fps there and the rust on medium settings have big laggs i dont know what to do,tried to set my battery settings to high performance still the same thing...Please help.

Read other answers
RELEVANCY SCORE 54.8