Over 1 million tech questions and answers.

Lenovo Legion Y530-15ICH-1060-81LB overheat problems

Q: Lenovo Legion Y530-15ICH-1060-81LB overheat problems

While I am gaming my processor temperature goes MAX +99C and even idle temperature is +50C even bottom is faced up so air can flow 100% away. This isn't any normal to have temps like +100C while playing CSGO, Overwatch etc... The processor is i7-8750H. I think Lenovo should fix this issue for me.

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Lenovo Legion Y530-15ICH-1060-81LB overheat problems

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 151.2

I apologize for my English, I'm from Russia. I'm writing here because there is very little information in the Russian community. From the very moment of purchase of this laptop I had a problem with sound. Crackles appear while listening to music, watching videos in the browser, and even during games. I reinstalled the sound drivers, reinstalled Windows, checked the DPC latency (it's ok). Alternately, shut off various devices in the device manager to identify the cause, updated the BIOS, changed the OS power settings, but nothing helped, at all. I didn't perform any manipulations on overclocking the processor. Crackle appears randomly, at different times and with different frequency. The problem is exacerbated if I install the sound driver from the official page of this laptop. Drivers from Realtek also don't fix the problem. As far as I understand, this problem is not only on my laptop, many people have written here about it, and this applies to different models. I really would not like to contact the service center, because this is my main laptop, on which my work depends. In addition, I read somewhere here that someone did just that, and he was told that there was no hardware problem. Therefore, I see no point in this. I'm asking for help! Maybe someone has already been able to solve this problem!

Read other answers
RELEVANCY SCORE 150.8

Hello everyone I come from Italy, sorry my bad English. I bought legion Y530-15ICH new, from 1 month but also browsing on Chrome with only two tabs open my cpu has a temperature between 50 and 70 degrees celsius (sw cpu temp). I have updated drivers, I have no viruses and malware but I can not use the PC to play if it has a high temperature only by browsing online. the fans work well because you feel that they pull a lot of hot air. who can help me?

Read other answers
RELEVANCY SCORE 144

I have a laptop Lenovo Y530L-15ICH-1060 model 81LB and until yesterday I was satisfied. I just had to switch to W10-Pro to connect multiple monitors.However, I dropped the sound yesterday, there was a defect in the High-Definition Controller Audio (in the Control Panels - Device Manager - System Devices): this device could not be started (code 10).What with this? Didn't the soundboard go? Thank you for your help.

Read other answers
RELEVANCY SCORE 112.8

As the title says I purchased the Lenovo Legion Y530-15ICH today at Best Buy. I got the 1050TI version with a 1TB 7200 RPM HDD. The initial setup took almost an hour and I have been trying to do all the updates for Lenovo Vantage and Windows Update for another 2 hours. Normal boot time is almost 5 minutes to get to a Usuable Desktop and app loads are ungodly slow. Additionally, everything I can find says this laptop should have the 144 Hz Display but I can't get it to go above 60 Hz no matter where I try and change it. I have two other Older Lenovo Laptops: * Lenovo Yoga 710-15IKB that is about 2 years old* Lenovo Yoga Y50-70 that is about 4 years old Both of them run absolute freaking circles around this one in general boot time, app load times and overall usage. Any idea if I have a defective unit (thinking bad hdd) or how I should go about finding the problem? I was thinking about upgrading the ram from the 8GB it came with to 32GB and adding in a 1TB M.2 NVME drive and ghosting the HDD to the NVME and setting it as the boot drive. *  Crucial 32GB Kit (16GBx2) DDR4 2666 MT/s (PC4-21300) DR x8 SODIMM 260-Pin Memory - CT2K16G4SFD8266* Crucial P1 1TB 3D NAND NVMe PCIe M.2 SSD - CT1000P1SSD8 Any thoughts, helpful tips or advise??? UPDATE: I ran some benchmarks using GeekBench 4 and the results where, well, surprising!  * CPU Benchmarks where about 10% below average for the i7 8750H CPU in this laptop! According t... Read more

Read other answers
RELEVANCY SCORE 96.8

Hello - this is the second charger that seems to be having problems.  The last one I had overheated so badly (after having the laptop for two weeks) that I could smell burning plastic, and it would no longer charge the laptop.  I returned the laptop and got a new one of the same kind, with a new charger (same model), and now it's charging the laptop but is making a crackling noise...is this normal?  I'm considering getting another kind of laptop (not lenovo) since this has been a bad experience so far.

Read other answers
RELEVANCY SCORE 90

Hello all,  I am working on a Lenovo Legion, and I use my Fn buttens pretty frequently... there is no Fn lock key on my keyboard, is there another way to toggle Fn lock? Thanks!  

A:Lenovo Legion Y530: Fn Lock

Hi,
 
Welcome to the forums.  Do you have Lenovo Vantage installed?  Under hardware settings is there something that looks like the below?  I have that option on my Thinkpad and I believe my nephew had it on his Ideapad too.
 

Read other 1 answers
RELEVANCY SCORE 89.2

Hello everyone.I was wanting to play some game on my Lenovo when the screen froze. I manually shutdown my computer and ride to turn it back on. I got stuck on the automatic repair failed error message. So I searched for a lot of solutions which didn?t work so I decided to rinitialise windows because it has only been two weeks since I got it so it?s not a big deal. When it was done that?s when the problem started. When I press the power button, it displays the legion logo and i hear the fans and the keyboard LED?s light up but then it shutsdown and does the same loop ove and over again. I don?t know what to do.

Read other answers
RELEVANCY SCORE 89.2

I bought my leptop few months ago in Ukraine. After the month of work it started to have led screen issues (screen just became dark in one moment and didnt turn on since then. I tried to plug in tv screen via hdmi. The system works correctly. Notebook is working. But there is no way I can turn on a screen. It doesnt work in bios as well as in os) and I want to bring it on warranty repair but the problem is I am in Thailand now. Is there any way to contact local support using Ukrainian warranty? Where should I go? How can I solve the problem? My notebook is important for me now so I have to solve the issue as soon as possible.Please help=(

Read other answers
RELEVANCY SCORE 88

Recently I decided to dual boot Linux along with Windows 10. But due to a small issue in my boot menu I was unable to do so. The bootable drive is being recognized but due to some unknown reason I am not able to Select or Enter the bootable USB drive from the boot menu even though I have it in my boot options.(The "Enter" Key is not functioning in the boot menu, unable to select the bootable drive only) Can anyone help me out with this. . .?Thank you for your response 

Read other answers
RELEVANCY SCORE 88

So I have a Lenovi Legion Y530, I bought this very recently. Specs: i7 8750H, Gtx 1050Ti, 16 Gigs of Ram, 128Gb SSD, 1Tb HD. So I decided to overclock my gpu (with Msi Afterburner) I increased the GPU clock by 350mhz, and the memory clock by 150mhz. I also undervolted the cpu by -0.140 volts. (I'm pretty sure this is the gpu's problem). I tried running Time Spy in 3DMark. This worked before I overclocked. While the benchmark was loading, it froze on the loading screen. Everything else worked, but I couldn't exit. It was just stuck on the screen. I couldnt enter task manager, or go to the desktop. My only option was to force shutdown. When I turned it on the Legion logo popped up and had the loading icon. Then it disappeared and nothing's loads after it, it stays as a black screen. Keep in mind that I don't have the tools to access the internals of the laptop. So I need a way to fix it someway else. Thanks in advance.

Read other answers
RELEVANCY SCORE 88

Hi, I recently upgraded my system by installing a Samsung 970 EVO 1TB SSD. I switched to AHCI, did a fresh install of Windows, installed all of the drivers from Lenovo, and everything was working fine. About a day after that, I turned on my laptop and noticed that the GTX 1060 was not being detected. I opend the task manager and only saw the GPU 0 which is the Intel HD Graphics, but I didn't saw the GPU 1 which is suppoed to be the 1060. I opened device manager and nothing. Tried to re-install NVIDIA drivers but it said that there wasn't any compatible hardware (meaning the system is not recognising the GPU. Went to the page of NVIDIA and dowlnoaded the drivers from there and same result. Opened GeForce Experience and nothing. No GPU detected. Entered the BIOS and nothing. No signal of the GPU. My question is: What can I do about it? Is there a way I could solve this without having to send my laptop to service?  Any help would be appreciated.  Thanks

Read other answers
RELEVANCY SCORE 87.2

Hey I just bought Lenovo Legion y530 / 16GB RAM / 255 SSD / 1Tb HDD / Nvidia graphicswith NO WINDOWS preinstalled.So i booted MX LINUX from an USB. Started the instalation. Wanted to install system on 255 SSD drive.Everything went all right.... and when a reboot time came it all got frozen. I could see only a desktop, no mouse pointer, not any keyboard shortcuts working...So I restarted a computer with a power button. MX Linux started normally I logged into a new system... and when I tried to shutdown a system it got frozen again.I checked a Linux Mint demo mode from an usb... and when it came to shutdown time - same problem happened again. Frozen screen.What can be a problem? Nvidia graphics?There is also one thing -When I turn on the computer this error appears. What can it be? How to solve it?This is the error message at when turning computer on.I went to the shop to change a laptop for the same new model. Maybe it is a BIOS problem?Is it possible to have MXLINUX on a Lenovo Legion? ;-)please help. Thank youAdam

Read other answers
RELEVANCY SCORE 86.4

Hello, I have had the following happen to 2 different Lenovo Legion Y530 laptops in the last week.For the first laptop it was accidentally allowed to run down to zero.For the second laptop it was intentially run down to zero to try to recreate this problem.  Unfortunately it succeeded.Here are the steps:Laptop runs down to zero and shuts off.  When plugged in, on power on, states laptop was not powered down normally and then brings up Recovery screen (blue screen).  Claims missing or errors in iaStorAC.sys.  The first laptop problem claimed HAL.dll was missing or corrupt.From the blue screen, most options lead back to this recovery screen.  Only the BIOS options goes elsewhere. From the novo button, I've tried:- System Recovery - appears to work but returns to Recovery screen.- Restore from Restore point (after booting from USB) - claims it works (after some hd repair) and then returns to Recovery screen.- From command line, repairing the boot config data (ran into permission errors on some commands) - no success. I called Lenovo support and after verifying that the harddrive was still recognized by the bios, had me attempt System Recovery from the novo menu.  When that failed, claimed it was a hardware issue and needed to be sent in for repair.  Seems unlikely it would be the same hardware problem on 2 separate laptops.  It seems related to the power down corrupting the boot files. From the recent reviews at Bestbuy... Read more

Read other answers
RELEVANCY SCORE 85.2

I've had my laptop for less than 2 months, but recently I got stuck in an auto-repair loop (possibly a virus), so I took my laptop to my university's tech center. Once there they wiped my laptop clean and installed a fresh install of Windows 10. A couple of my drivers got deleted like my mouse and wifi drivers, but they re-installed them there as well. Everything was fine just a little slow, I re-installed all my apps/games back. I never really checked for Windows 10 updates until a couple days ago because I randomly got this error when trying to play my games. It would say something like this: "ERROR: your video card does not support alpha blending with floating point render targets (D3DFMT_A16B16G16R16F)". I have a GTX 1050 ti, so I was really confused. I looked up how to fix it on other forums and even Reddit. Apparently, this happens when your laptop tries using the GPU built into the motherboard instead of the actual graphics card. Many suggested uninstalling the current GPU drivers and re-installing them. So that's exactly what I tried, but now whenever I try to express install the newest driver on Geforce Experience; it says "The Standard NVIDIA graphics driver is not compatible with this version of Windows. Please update your driver using...(website)". The website it gives is not even available, so I look up and manually try to download/install the driver myself, but it gives me the same message it did on Geforce Experience. So I finally decide to update Win... Read more

Read other answers
RELEVANCY SCORE 83.2

I recently purchased a new Y530-15ICH from the Lenovo site and came up with the following Windows BSOD issue after installing an SSD upgrade:  Stop code: SYSTEM_THREAD_EXCEPTION_NOT_HANDLEDWhat failed: iaStorAVC.sys Further details on the issue: this is caused by waking up the laptop after either putting the system to sleep and/or hibernate by closing it or by manually choosing the sleep/hibernate option from the Windows power menu.  Original HDD included: generic 1 TB 7200 rpm HDUpgraded SSD drives with the issue: Samsung Evo 860 500 GB and Kingston HyperX 240 GB (I have installed both and both are causing the same issue) I have downloaded and installed every updated and recommended drivers from the Lenovo/Samsung/Kingston official product sites and I have even updated the BIOS for the Y530 (also from the Lenovo official site). This issue happens every time I wake the computer up, no exception.  I can post additional information. I already spoke to the service contact phone with no luck - they are requesting me to send the computer to repairs but I wanted to try a different solution if available first. I have tried almost everything - Lenovo diagnostics, formatting both drives and reinstalling Windows, etc.  Has anyone had the same problem and solved it successfully? Is this hardware related? Or driver related? Does Optane memory included with the laptop influences this issue?  Please feel free t... Read more

Read other answers
RELEVANCY SCORE 82.4

 Hello! Although I seriously dislike the very noisy manners of my Y530 15ICH - when rendering videos or if the antivirus scans in background... - I decided I am gonna keep it.......But now I would like to plug a music program which requires 44.100hz sample rate. I can't see any other options than 16 or 48bit 44.800hz in the Realtek audio preferences... How is this possible!? I understand providing a higher sample rate is probably great to offer in 2019 but what about a more basic rate as well? What should I do? I would love to install an older version of the audio drivers, if that's a solution, to get 44.100hz back in the sample rate scroll menu... But I am not sure that would even work. Who know more about this, please tell me! Thanks for helping.Emiliano

Read other answers
RELEVANCY SCORE 74

I bought the laptop very recently about a month ago. One week ago i noticed that there is a gap between the display and frame. I went to the service center and theyput two sided tape to stick it.  I came back home and the camera section was overheating and the gap appeared again. I don't know if they can fix it or not. It's a very bad quality product to me. Did anyone face any issue like this? Thanks

Read other answers
RELEVANCY SCORE 72.8

Hi everyone, I have a series problem with my new Legion Y530. When I run any game laptop crashes to blackscrean but only when the AC Adapter is on. When i run the same games only on battery power source everything works fine.  I update Nvidia and Intel drivers, update bios and nothing help.  I run almost every test in Lenovo Diagnostics Tool  and it was fine. I can't run graphics test because LDT crashed. Please Help. Lenovo Legion Y530 I7 + 1050ti  

Read other answers
RELEVANCY SCORE 72
RELEVANCY SCORE 72

Hi, i just bought the laptop from a retailer 2 days back. 1) I did a GPU stress test on Heaven Benchmark 4.0 and attached the results. The bench mark score is horrible. ( the FPS and GPU clock results are less than average , Nvidia settings were set to prefer Nvidia Geforce GTX 1050TI GPU and set for max performance ;not sure why? ) i also used GPU-Z to monitor the GPU clock speed and Nvidia 1050 TI has not been able to run further than 200 MHZ. 2) aside from this, the display will increase brightness suddenly then dims back to original brightness. ( adapative brightness is not ON in power plans btw)  i have done a Vantage hardware scan and nothing abnormal came up.Is there some defect with the GPU or related?

Read other answers
RELEVANCY SCORE 72

I have a problem with my newly purchased Legion Y530.Sometimes the left fan make noises when it working at low rpm.Noise sounds like something is in the way of fan working properly, like a wire or something.It's really annoying and driving me crazy.what should i do? should i send it for warranty or open it myself?does opening it viod the warranty?I attached a recording of the noise!

Read other answers
RELEVANCY SCORE 72

Hey,I have issue with my keyboard. The key "\" "|" is not working. Both left and right keys are not working.Keys works on external usb keyboard.What should I do?

Read other answers
RELEVANCY SCORE 72

Heeeey everyone, sorry to bother, can anyone help me and let me know if this 8GB RAM memory is compatible with the Legion Y530. My memory is almost the same, but this one on amazon is AC and mine is AD. Thanks  https://www.amazon.com/Hynix-PC4-21300-DDR4-2666MHz-260-Pin-HMA81GS6CJR8N-VK/dp/B07JP4C1PD/ref=sr_1_...

Read other answers