Over 1 million tech questions and answers.

Thinkpad T470 Mobile Broadband (Fibocom L831-EAU) not working in Ubuntu (17)

Q: Thinkpad T470 Mobile Broadband (Fibocom L831-EAU) not working in Ubuntu (17)

Hi all,I have issues getting mobile (3/4g) broadband to work with my new T470 Thinkpad. In Ubuntu, the Fibocom Adapter is only detected as a generic MBIM adapter, and although Network Manager (and it's applet) display my network provider, the connection is not established, and the system process mbim-proxy is hanging at 100% CPU. This issue has been reported here (but seems to remain unsolved ?) : https://www.spinics.net/lists/linux-usb/msg158286.html Did anyone get this to work?Best whishes and thanks for any hints!

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Thinkpad T470 Mobile Broadband (Fibocom L831-EAU) not working in Ubuntu (17)

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 198.8

Hi all,I have issues getting mobile (3/4g) broadband to work with my new T470 Thinkpad. In Ubuntu, the Fibocom Adapter is only detected as a generic MBIM adapter, and although Network Manager (and it's applet) display my network provider, the connection is not established, and the system process mbim-proxy is hanging at 100% CPU. This issue has been reported here (but seems to remain unsolved ?) : https://www.spinics.net/lists/linux-usb/msg158286.html Did anyone get this to work?Best whishes and thanks for any hints!

Read other answers
RELEVANCY SCORE 94.8

Hello I recently bought a Thinkpad T470p .... win 10i have installed all the driver it needs ...... but couldn't manage to use the mobile broadband ......can anyone suggest.... thankyou

A:Thinkpad T470p mobile broadband is not working....!!!!

Hello and welcomeAre you sure the WWAN modem is installed in the laptop? What's the laptop' MTM code (starts with 20J)? If it's a CTO model (MTM includes CTO symbols), laptop' s/n is needed to determine factory specification. Don't share it here, send it to me via forum private messages service. I'll try to help.

Read other 1 answers
RELEVANCY SCORE 80

Hi there, Using a X1 Thinkpad, with mobile broadband module (Ericsson FG5521gw). When a SIM is loaded it comes up and tells me 'No SIM card found'.I've upgraded all the Lenovo software to the latest versions... including Broadband drivers, Access Connections software, etc.Is this a common problem? It seems to be the case in all industry reviews in Australia for all X1s that were tested.1. http://www.arnnet.com.au/short_review/388015?2. http://www.pcworld.idg.com.au/review/notebooks/lenovo/thinkpad_x1_1291-23m/388015?Is this a known problem?    Do we have faulty broadband modules being shipped?I'll speak to  Lenovo support  -- just wondering if others are experiencing the same issue?












Solved!

Go to Solution.

A:Thinkpad X1 : Mobile Broadband - Does not recognis...

We have the same issue on german X1s. On mine Lenovo has already changed the mainboard twice and also the WWAN card. No success. Sim is still not being recognized. Seems to be a faulty sim reader on all units. Very sad.  If you get more details from Lenovo on how to fix it i will be glad to hear from you. I am also in permanent contact with them because for me this WWAN feature is essential. 

Read other 9 answers
RELEVANCY SCORE 76.8

I am considering buying an X1C gen 6.The model that is available in my region is: 20KH007JIVAccording to https://psref.lenovo.com/Product/ThinkPad/ThinkPad_X1_Carbon_6th_Gen?ch=20kh007It has a Fibocom L850-GL. Does it work with ubuntu 18.04 ? I mean does it work reliably after editing some files here and there or it's a mess ? (I am ok to edit some configs if required). Should I check anything before purchasing ? (I am plannig to only have Ubuntu 18.04 on it for development).I know there seems to be some problem with sleep mode but there are acceptable workarounds. Thank you in advance !

Read other answers
RELEVANCY SCORE 76.8

Hello, I'm thinking to buy ThinkPad Sierra Wireless EM7345 4G LTE Mobile Broadband FRU: 04X6014 for my ThinkPad X250. I?ve few questions, Pease suggest ...1. Is it really any good and practically beneficial?2. Can I use it on Fedora 27, How?s Linux support?3. X250 has two PCI Express M.2 card slot and one is already occupied by WLAN Card and other slot is available, Can I use empty slot for FRU-04X6014?4. Can I use both WLAN and WWAN simultaneously?5. What is the impact on battery (Windows and Linux)?6. Is AliExpress a good place to buy? Thankyou  

A:Sierra Wireless EM7345 4G LTE Mobile Broadband FRU: 04X6014 for my ThinkPad X250

Regarding your questions:1) I personally use it and it's really good, as I don't want to use additional USB modem or WWAN wireless router.2) Can't say, as I don't use Fedora.3) There's a dedicated port for this module. Please make sure, that you have an antenna connectors for module and adapter for a SIM card. Moreover, instead of WWAN module, you can install there a m.2 2242 SSD disk.4) Both can be enabled and connected, but application will use one at time.5) I have an extended battery, so it's hard to tell. I guess it have a simmilar power usage as WLAN module (basing on Windows power utilization). Can't say about Fedora.6) It you don't want to have a problem with whitelist (it prevent system from booting, when unauthorized module is installed), then I look for module on eBay. Make sure, that photos explictly show FRU PN: 04X6014 on module's label. Models without it will not work.

Read other 1 answers
RELEVANCY SCORE 76

I have recently installed the Huawei ME906S 4G LTE module on my ThinkPad X260. I have installed the driver and enabled WWAN in the sytems Bios. I can see the module in the device manager. Windows network manager is showing the Mobile Insert SIM. When I insert sim, nothing happens at all. It seems like the sim card is not being detected at all. Can someome help? Device managerNetwork mangerI have attached a screen shot of the device manager and the network manager. 

Read other answers
RELEVANCY SCORE 74

I just bought my lenovo thinkpad t470 thinking that it would be a beast of a machine. But to my dismay, the touchpad stopped working and i have to attach a mouse to use the system. Is there any solution to it. This is pathetic to be honest

Read other answers
RELEVANCY SCORE 72.8

Hi Everyone ! I have Hp-ProBook 6440b, with windows 7 (64 Bit) installed. The issue is that mobile broadband driver is not working properly. I've installed latest drivers from hp, did almost everything, But it still isn't working. When i open Hp Connection Manager, on Mobile Broadband (WWAN) tab, it says "Disabled by device manager". And when i go to device manager, > Ports (COM & LPT) the driver "Hp un2420 HS-USB QDLoader (COM 4), it says the device is working properly. And when i go to "Network Adaptors there is no driver installed for my Mobile Broadband. Please help!!! I'm attaching images of HP Connection manager and deiver manager.

Read other answers
RELEVANCY SCORE 72

Upgraded my Helix to Windows 10, clean install.  I noticed that my AT&T mobile broadband (Sierra wireless EM7700 4G LTE) isn't working. I keep getting a connection error and it asks me to enter another APN. I've instaled system update and all of the Lenovo drivers etc.  I've added the AT&T APN settings.  The signal meter in the connection manager is a little wonky also.  I changed the Selective Suspend value to disabled.  Windows thinks that the default microsoft driver is the best choice.  The Sierra Wireless Mobile Broadband Update app says I'm up to date with drivers and firmware. Can anyone confirm that their Helix (gen 1) mobile broadband is working with Windows 10? Thanks

A:Helix (gen 1) - Mobile Broadband not working after...

I am having this issue with Helix (Gen 2) and Verizon, but same APN issue. Sometimes after reboot it will connect. Has "Default" APN applied. Added Verizon APN information and tried using new APN profile, but did not resolve. Running on Windows 10.

Read other 1 answers
RELEVANCY SCORE 72

Hello, i have a brand new notebook with integrated Mobile Broadband but i cant use it. The Hardware is not displayed in the device manager and i installed these drivers: HP hs3110/hs3114 Mobile Broadband Drivers  HP LT4120 Snapdragon X 5 LTE-Treiber   I also scanned my Notebook with Tools like PCAudit but cant find any hardware for the LTE-Modul. The SIM-Card is plugged in but dont get any option to connect to the 3G/4G Network. I have Windows 10 64-bit Enterprise Edition installed. Tried also different Connect Tools (Huawei & Vodafone) but nothing. How i can check which hardware my notebook is using?  Thank you!

A:Mobile Broadband not working on HP EliteBook 840 g3

technik Allow me to welcome you to the HP forums!I read your post about the Mobile Broadband problems and wanted to help. Since this is a relatively new machine, instead of struggling for hours to fix it yourself, why not just let HP fix it for free!!  You should contact HP Customer Support directly to have them put you in touch with HP Technical Support to see what they can do about diagnosing and repairing your machine remotely.I did this recently and the HP Tech was able to remotely access my PC from the Internet and do the needed repairs.If you live in the US or Canada, contact information is on this page: http://www8.hp.com/us/en/contact-hp/phone-assist.html#section1If you live elsewhere, contact information is on this page: http://www8.hp.com/us/en/contact-hp/ww-contact-us.htmlGood LuckI am a volunteer and I do not work for, nor do I represent, HP.========================================================================If you feel my suggestions helped you, please click the Thumbs-Up symbol to say thanks!If they helped resolve your issue, please click "Accept As Solution" to help others find similar information.

Read other 2 answers
RELEVANCY SCORE 71.2

Hi,

I have an Huawei E1752 mobile broadband dongle from Orange, installed the software and the program successfully installed.

When i open the Orange Mobile software the program opens then after 30 seconds or so says "OrangeMobileBroadband.exe has stopped working", this happens everytime. I have looked in the problem reports for the error which is below:

********************************************************

Problem Event Name: APPCRASH
Application Name: OrangeMobileBroadband.exe
Application Version: 0.0.0.0
Application Timestamp: 4c7b7bdb
Fault Module Name: MFC80U.DLL
Fault Module Version: 8.0.50727.762
Fault Module Timestamp: 45713438
Exception Code: c0000005
Exception Offset: 00023c4d
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 2057
Additional Information 1: 7eaf
Additional Information 2: 6991d326870909c4f16b970cdd55f1e7
Additional Information 3: 1e25
Additional Information 4: 5eb03c7925e5d7dc83b54705b390f9f5

**********************************************

I am running Vista Home Premium Service Pack 2 and have Avast as my anti-virus software.

I have run Malware Bytes & avast and no infections were found.

Has anybody experienced any problems like this and managed to fix them.

Thanks in advance.
Andy

A:Orange Mobile Broadband has stopped working

Andy

Have same problem with the same Orange Dongle running the latest version of VISTA and Avast. Only started recently, dongle OK when running
with XP and Avast on another computer, any solution come up yet??

Percy

Read other 2 answers
RELEVANCY SCORE 71.2

I try to keep that short: symptons:- i see my mobile broadband network in tray, i can connect it. it shows fine, no error, looks like connected perfectly.- on Diagnose the Mobile NUmber shows cryptic signs, and i get the error:the mobile broadband adapter is sim-pin2 locked. (hope translation is fine, my installation is german: "Das mobile Breitbandgerät ist durch eine SIM-PIN2 gesperrt." - i cannot browse anywhere, i cant ping, i cannot even ping own IP and Gateway.- Hardware: Sierra Wireless EM7345 4G LTE- Driver: 10.0.16299.192- Firmware FIH7160_V1.2_WW_01.1616.01- GPRS; EDGE; UMTS,HSDPA;HSUPA;LTE;HSPA+ This started 2 days ago, 5th February 2018, after i installed new Windows 10 Updates (Windows 10 , 1709 (Build 16299.192) i tried:- remove SIM card,- replaced SIM card with a new one- uninstalled driver, reinstalled- deleted and reconfigure APN ... Still all looks fine, as it would be perfectly connected, but cannot ping/reach anything. Any ideas? Thank you!  

Read other answers
RELEVANCY SCORE 70.4

Here's an odd thing.
After switching off my Dell Dimension 5150 and then switching off the power at the mains, which I do when I go away for long periods, it then won't restart until I remove the mobile broadband dongle. I get the flashing amber signal on the power button. However, as soon as I remove the dongle, then the PC starts up fine, or at least it has done so far, so it's not really a problem, but it would be interesting and probably quite wise to find out why this is happening.

I did recently remove the case to replace the CMOS battery as I was getting the low battery message on start-up, but, apart from that, I can't recollect doing anything that may have caused this.
 

Read other answers
RELEVANCY SCORE 69.6

Hello All: I can't get the GPS location feature working on my new W520 (4270-CTO).  The device did work once, the first day I had the computer (before running Microsoft Update and Lenovo Update), however, it has not worked since then. I've tried everything I can think of - removing and re-installing all the software, double-checking the BIOS, looking for device driver problems - but no luck.  When I launch the 'GPS Enabler' application, all I see is 'Satellite Acquisition in progress...".  I know the laptop can see the satellite constellation because I have a small hand-held GPS beside the laptop, and it has an excellent view of the satellites.  So does my Blackberry. My operating system is Windows 7 Pro, 64 bit, SP 1 (what the computer shipped with).  I've installed the 83wo13ww driver package (nominally version 6.4.1.6, according to the readme file, but displayed as driver version 1.4.0.5 in the properties sheet of the driver when viewed via the Device Manager); the 83wa20ww Lenovo Mobile Broadband Activation package ( version 4.0.0020); and the 83gp31ww ThinkVantage GPS package (version 2.72). I'm running Access Connections 5.84 (build 83c755ww), which I believe is the current release.  I have placed a SIM card in the slot in the back of the computer, and when I launch the Lenovo Mobile Broadband Activation, it shows all the appropriate information (IMEI, ICCID, etc.) for the SIM card... Read more

A:Can't get GPS working on W520 with Ericsson F5521gw Integrated Mobile Broadband

Just a postscript - I have found another discussion from about 18 months ago that mentions similar problems with a W500 and a T500.  One of the participants in that discussion suggested that improper assignment of COM ports might be the cause of the problem... but, if that is so, how does one go about re-assigning the two ports used by the GPS?  The picture I provided (link is above) shows that my W520 is using COM ports 10 and 11 for the GPS.  I have no idea at all how to change this port assignment. Here's the link to the prior discussion: W500 GPS Problem Regards, Michael





W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...

Read other 9 answers
RELEVANCY SCORE 69.6

I run Windows 7 64bit os with an Orange high Speed (!) mobile broadband dongle (515m).
The software (Internet Everywhere) stopped working months ago and after much arguing with Orange, they admitted that it was a software compatibility problem with my os but promised that an update would be coming soon. They gave a workaround which meant the dongle worked on dial up (with associated speed).
However, after waiting months for the update, it's finally arrived but it still doesn't work!
Just like the last software version, after installing it clean, it crashes at start up and won't operate.
Last night I had to stay up hours to roll back my system to get the dial up working again as it prevented that from working too.
I'm really sick of this and Orange's response has been woefully unsatisfactory, bordering on insulting. The latest gem was to uninstall everything internet connected then download the software! How? This has been pretty much the level of response from Orange. I'm about ready to cancel my contract with them for breach of contract.
Any ideas anyone?

Oh, my laptop is an Acer Aspire 7540.

A:Orange Mobile Broadband 515m Dongle not working with Windows 7

Hi, not sure if this is what you meant by the workaround, but I had the same problem and solved it by manually configuring a dial-up connection with windows using the number *99#
The software started crashing whenever I started it and, much like Orange have now pointed out, I suspected it was some sort of conflict with Windows 7. Initially the only way I had to get round it was constant system restores whenever the problem started, but that wasn't practical. The manual dial-up seems the best way I have found so far. The speed and service using it this way appears to be the same if not better than when using it with the software.

Read other 1 answers
RELEVANCY SCORE 68

Hi,

I have a feeling this may be a driver error, but I dont know.
A friend gave me a computer,

Os: Vista x86
OEM I think
Hardware age: 2007
Age of installation: not sure, its my friends. Might not have been reinstalled before

CPU: Athlon 64x2
Video Card: Onboard Graphics
Mobo: Inspiron 532 mobo
PSU: Bestec ATX0300P5WB 300W

System Manufacturer: DELL
Model No.: Inspiron 531

It works perfectly fine, apart from when I connect to the internet through 3 mobile broadband (3 Huawei E122). Once it connects, internet explorer launches. As soon as I begin using IE, the computer freezes, mouse will not move, keyboard will not work, then after 2 mins it blue screens. stop code is 0x77. I have tried to exit IE and use firefox instead, this works much better but it still bluescreens, just less frequently.

My friend brought it to a local shop who told him the usb header on the mobo is the problem and needs a new mobo and qouted him ?250 repair. However I dont think this is the problem as, no other usb device gives any trouble at all. And the mobile brodband dongle only crashes once it connects and the browser is launched.

I ran Norton antivirus, super anti spyware, malwarebytes antimalware, and RU Botted. All I picked up was a few malwares.

I also ran full system diagnostic test, with no problems.

list of installed software (incase there are known issues with them): Norton Antivirus, Easus Partition manager, thunderbird, microsoft works, ccleaner. I dont know if a... Read more

A:BSOD when using mobile broadband computer freezes, mouse + keyboard stops working

Okay, I ran the driver verifier

When I restarted the computer, I get the blue screen and it will not turn on
The stop error is 0x7E this time I think

I booted into safe mode and restored, then ran "verifier /query" in cmd
which returned: "No driver are acurrently verified"

I have attached the new dump file below

It must be a driver problem, what do you guys think?

Hopefully You can help me out guys

Read other 6 answers
RELEVANCY SCORE 62

I purchased a HP ENVY TouchSmart 14-k111nr Sleekbook that came with T-mobile Mobile Broadband for 2 years from the Microsoft Store two months ago. When I clicked 'Internet Access', there would be a 'Mobile Broadband' option for me to choose and select the T-mobile Mobile Broadband. Unfortunately, that has not been appearing since the last few days. I checked my hardware and it appears that there still is a 'Smart Card' but with no information regardin it. I also checked the HP Support Assistant and HP Utility Center but they had nothing. I have tried removing the card and placing it back again. The computer emits the sound that recognizes new hardware but no installater comes up Searching forums, I tried downloading the HP Connection Manager, but it failed to install when an error message ' NO WWAN' came up I also downloaded and reinstalled the latest Mobile Broadband Drivers but nothing happened. In fact, I suspect that it maybe the new updated drivers that caused my T-mobile SIM card to be disabled. I have tried calling HP support but they cannot help and demand payment for 'advanced tech support' when my Laptop is still under Warranty. I tried calling T-mobile, but they said that it was a problem that I needed to contact HP for. I contacted Microsoft that said I need to get in touch with T-mobile. The second call on HP, they told me to contact T-mobile, One big circle. TL;DR: I need the installer for my T-mobile SIM Card, mobile broadband... Read more

A:T-mobile Mobile Broadband doesn't even Appear

@YdocZ ,
 
I have brought your issue to the attention of an appropriate team within HP. They will likely request information from you in order to look up your case details or product serial number. Please look for a private message from an identified HP contact. Additionally, keep in mind not to publicly post personal information (serial numbers and case details).If you are unfamiliar with how the Forum's private message capability works, you can learn about that here.Thank you for visiting the HP Support Forum.

Read other 7 answers
RELEVANCY SCORE 60.4

Hey there, i just got my t470 today and i love it so far! But i have the following problem. I cannot install Windows 10.I created bootable flash drives multiple times and tried all bios settings (according to some posts both uefi and legacy in combination with secure boot turned off should be working) but after selecting the flash drive the screen turns dark for a couple of seconds and then brings me back to the bootmenu. I tried it in the diagnostics mode and got the following error message:"media test failure - check cable" I tried to boot from a ubuntu flash drive and it worked instantly!I even went as far to burn the newest bios update onto a flash drive and flash the update. Still not working though. Does anybody have any idea what i am doing wrong? I couldn't find any more posts about this issue. I tried all the solutions which worked for other people. A friend of mine got the exact same laptop from the same seller and used the same flash drive and it worked the first time for him.. is my laptop the problem? I mean i dont think its the bios, maybe a mainboard issue? I have no clue. Thanks for your help! Linus

Read other answers
RELEVANCY SCORE 60.4

Hello,my Lancom VPN-Client doesn't work with mobile web on the newer series of Lenovo notebooks.The client connect correctly with the network of the company, but it doesn't work and after some time the internetconnection drops. It's only with mobile web, with wifi the VPN connection works.I tried a working VPN-profile and sim card - doesn't work. But when i try the sim-card and the VPN-profile on an older notebook (T520) it works. Therefore i can say, there is a problem with the notebooks or to be precise with the LTE-modules.Has anyone ideas or the same problem?Thanks

Read other answers
RELEVANCY SCORE 59.6

Hello: I'd like to buy a 16 GB (2 x 8GB) RAM kit for my ThinkPad T470 (SKU # 20JM000CUS) Is this Crucial SKU compatible:CT2K8G4SFS824Ahttp://www.crucial.com/usa/en/ct2k8g4sfs824aDDR4 PC4-19200 ? CL=17 ? Single Ranked ? x8 based ? Unbuffered ? NON-ECC ? DDR4-2400 ? 1.2V ? 1024Meg x 64 ? I searched but I couldn't find any compatibility information for the T470 on the Crucial website. Thanks in advance

Read other answers
RELEVANCY SCORE 58.8

Hi everyone,
 
I recently got the T470 and it's a great product. I however have problems with my the connecting to the internet with the SIM.
 
I installed Fibocom L831-EAU WWAN module to my T470, problem is my laptop is detected my sim card only in the first time im insert the sim card, and it's all, can not detect sim card anymore. The message displayed is: Insert Sim, my sim card still working fine with another 4g devices, i try to change another sim card but got the same result.
i try to run command: netsh mbn sh int
here the information:
 
There is 1 interface on the system:
Name : CellularDescription : Fibocom L831-EAUGUID : {3283C712-D22A-4F38-ACB9-063548EF9C1C}Physical Address : bc:90:b2:******State : Not connectedDevice type : Mobile Broadband device is embedded in the systemCellular class : GSMDevice Id : 862727030******Manufacturer : FIBOCOMModel : Fibocom L831-EAUFirmware Version : L831_V2E.0C.00.16Provider Name :Roaming : Not roamingSignal : 0%RSSI / RSCP : 0 (-113 dBm)
anybody know why my laptop can not detect my sim card?
thanks.

Read other answers
RELEVANCY SCORE 58.4

Hi there, I was wondering whether I could replace my Intel Dual Band Wireless-AC 8265 on my T470 with another WIFI adapter. I have heard that there is a whitelist on the adapters that can be used. Some say newer models don't have it but I'm not sure, and I wouldn't want to buy a WIFI card just for it not to work.I was looking forward to a BCM94352Z. Would that be compatible? Sould it be an m.2 half size PCIe card? Thanks in advance for the feedback.

Read other answers
RELEVANCY SCORE 58.4

I have disabled the adaptive display option on both my settings and the Intel graphics control panel, and yet my brightness still changes without my input. Any solutions?

Read other answers
RELEVANCY SCORE 58.4

I just got my T470 laptop a few weeks ago and it's already having problems with maintaining a stable connection to the wifi. When I run the troubleshooter, I always get the error message "The connection between your access point, router, or cable modem and the internet is broken" and "The default gateway is not available." Is there any way to fix this? I've tried installing new drivers from lenovo and almost all the solutions found online, but none of them are working.

Read other answers
RELEVANCY SCORE 58.4

Hiya guys, I've recently bought a Lenovo Thinkpad T470, and all works fine. What I would like to know, If I can upgrade that Notebook with an hdd drive beside a 512 GB Solid State Drive, PCIe-NVMe OPAL2.0. thanks 

Read other answers
RELEVANCY SCORE 58.4

I have disabled the adaptive display option on both my settings and the Intel graphics control panel, and yet my brightness still changes without my input. Any solutions?

Read other answers
RELEVANCY SCORE 58.4

Is it normal for a Thinkpad T470 to drain battery after it has been shut down completely? I first observed this after not using the notebook for about a week. After switching it back on, the external battery had lost more than 10% charge, while the internal battery's value hadn't changed. Curiously, while using the notebook, this behavior is reversed, i.e. the internal battery is discharged first. Things I tried so far: Disabled Wake-on-LANDisabled USB chargeDisabled Thunderbolt deviceDisabled the fingerprint readerDisabled Fast BootDisabled all wake events and timersChanged power planPerformed a full shutdown via shutdown -sUpdated BIOS and Embedded Controller to latest version availableResetting Windows to factory defaults I also ejected the external battery and disabled the internal battery before shutting down to make sure that they don't discharge by themselves. However, no drain occurred under this condition. Effectively, none of these options have helped. The external battery still loses approximately 2% charge every 24 hours.

Read other answers
RELEVANCY SCORE 58.4

Hello guys,I have a T470 Thinpad 20HE but the fingerprint reader no longer works. It is dead and I am convinced it is a hardware problem since the device no longer shows up in device manager and not detected in BIOS. My question for you guys is wether it is possible to replace the Fingerprint reader with a new one or is it married to the motherbord of my computer and can't be replaced.Thnaks a lot

Read other answers
RELEVANCY SCORE 58.4

Hello All!I just bought a T470 notebook with 8GB of RAM. Turns out that I'm going to need more RAM so I would like to upgrade to 32GB. Would installing 2 units of "16GB DDR4 2133MHz SoDIMM" work? Thank you! 

A:Need Advice on Upgrading RAM on Thinkpad T470

Hi Loungepuppy,Warm Greetings & welcome to Lenovo Community, happy to have you here.
 
It depends upon your requirement ideally you will need a same kind (like frequency, type, size) of RAM in both slots to achieve a dual channel configuration.
Therefore, you can either install an 8GB stick to the existing configuration or go ahead with even 16GB stick aswell.
 
Edit- This system does support 32GB max 2400MHz DDR4 (source)
 
I hope the above information helped you.
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 3 answers
RELEVANCY SCORE 58.4

Hello , i bought my laptop some weeks ago, but i am facing one problem with the touchpad. Sometimes is working, and then stops working at all ,and with reboot sometimes comes back and some other not. The trackpad is working very good with the buttons of the touchpad. I found that if i will go to device manager and i will delete/unistall the touchpad (synaptics pointing device) then the mouse is working perfectly until the next reboot, when will be automatically installed the latest driver from windows or from update manager of lenovo, so i think that is not hardware problem. I have the latest original drivers on the pc, installed from the site of lenovo. Also i saw on the settings that the touchpad is enabled. Please i need some help regarding this issue.

Read other answers
RELEVANCY SCORE 58.4

Hi, the monitor of my notebook, during the switching from the first battery to second battery (power bridge technology), goes blank for 1/2 seconds because the refresh rate of monitor changes from 60 Hz to 48 Hz. I tried to set the refresh rate rate on 60 Hz but the problem persits. Thanks in advance. 

Read other answers
RELEVANCY SCORE 58.4

Hi all. New to the forum but have a quick question on the thinkpad t470s. I am looking to upgrade the ram from the 8 gig currently in it and replce the 4 gig module with a 16 gig one to max it out. Can anyone give me pointers on which module i should be buying for the 16 gig module. I was hoping to find locally at best buy but unfortunately they do not have 16 gig modules. Any input would be greatly appreciated. 

A:Need Advice on Upgrading RAM on Thinkpad T470

Hello and welcome,
 
I've moved your post to the T-series forum.
 
Your subject says T470 but the message body says - and implies - T470s.  I think you already know that one module is soldered and one socketed, but just checking...
 
Both base specs say "2400MHz DDR4".  I'd be inclined to go to a reputable vendor's site (Crucial for instance - not pushing them...)  and use their memory finder for specifics.  In the hopefully unlikely event of compatibility issues you'd have that to fall back on for a return.
 
Probably not necessary, but it's not a bad idea to pull the specs of the soldered module and try to match those exactly.
 
Z.

Read other 3 answers
RELEVANCY SCORE 58.4

Hello everyone, I have 5 new T470p laptops. After the update and first restart, all the 5 laptops stop at this point (To interrupt nprmal startup, press enter) and do not continue booting to the OS. so every time, I have to shut them down by the pressing the shutdown buttons and then they boot to the OS but after i do restart again for 3 times, again they stop at the same point (To interrupt nprmal startup, press enter). any insight for the problem??? thanks in advance

Read other answers
RELEVANCY SCORE 57.6

Hi all, I recently purchased a lenovo thinkpad t470. after the first boot setup, i can no longer boot the computer again because it always stucks at the Lenovo screen (it doesn't have the loading circle under the lenovo simble). I wonder if anyone has encounter the same problem and have any idea on how to solve this issue ? Any help would be greatly appreciated

Read other answers
RELEVANCY SCORE 57.6

Hi everybody,i got stuck with my Lenovo T470. I often have issues to boot.Sometimes one reboot is enough, other times it takes 5-10 reboots to get the system started.I'm more successful, when the power plug is plugged in or the computer is in the dockingstation.I tested it under Windows10 only, dual-boot Windows10 and Ubuntu16.04.02 with grub2 and a bootable USB-Stick with Ubuntu16.04.02.There are different points to get stuck while booting.1. Windows10 - Windows Boot Manager1.1. Get stuck at Lenovo screen, without anything moving.1.2. Get stuck at Lenovo screen, Microsoft points are moving in a circle.1.3. Get stuck at Lenovo screen, with Automatic Repair.2. Dual-boot - Windows10 Ubuntu16.042.1 same as Windows10 above2.2 Get Stuck after grub2 boot menu, while trying to load initramfs.Attempted solutions:1. Grub2 update and reinstall grub2 under Ubuntu2. Ubuntu boot repair yannubuntu3. Install brand new Windows10 via usb stick with GPT-table4. Windows 10 Update 01.05.20175. Bios Update6. Install all lenovo drivers manually7. Install lenovo drivers automatically via Lenovo System Update8. Install lenovo drivers automatically via Lenovo Companion9. Lenovo Diagnostics Version 03.10.001 - all tests passedIf you need further informations, please let me know.What else can I do, before i need to contact the support ? System Information:Special Settings: Bios Secure boot disabled, UEFI only, no CSM, fast startup disabled. Different settings tested without success.*Model: Lenovo T470 ... Read more

Read other answers
RELEVANCY SCORE 57.6

I have recently purchased a Thinkpad with a 256gb ssd m.2 model SSDPEKKF256GL (Intel drive). I can not find much of any information on this drive. Can someone suggest an equivalant 512gb m.2 replacement drive so I can go look and and purchase ?Thanks

A:Thinkpad T470 SSD M.2 256gb upgrade to 512gb

Hi seabirdwt,Warm Greetings & welcome to Lenovo Community, happy to have you here.
 
Below M.2 SSDs are tested by Lenovo to work with your system: 

00UP435            512G,M.2,2280,PCIe3x4,INTEL,OPAL
00UP437            512G,M.2,2280,PCIe3x4,SAM,OPAL
00UP622            512G,M.2,2280,PCIe3x4,TOS,OPAL
00UP642            512G,M.2,2280,PCIe3x4,TOS,OPAL

For complete list please have a look on T470 FRU BOM list 
 
I hope the above information helped you.
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 1 answers
RELEVANCY SCORE 57.6

Do the ThinkPad T470 use the same docking station of the ThinkPad T440

A:ThinkPad T470 docking stations compatibility

All docking stations for T440 are compatible with T470.Follow this guide:https://download.lenovo.com/pccbbs/options_iso/ocm_october_2017_revised.xlsx

Read other 1 answers
RELEVANCY SCORE 57.6
A:Dock pro 40A5 is it compatible with ThinkPad t470

Sorry is the T470 work with the docking station pro 40A5?

Read other 1 answers
RELEVANCY SCORE 57.6

Is there a stylus that works with the 2017 touchscreen version of the Thinkpad T470? Any info would be gratefully accepted. Nik

Read other answers
RELEVANCY SCORE 57.6

Hi all, I work IT for a US HQ company and we have a user in our smaller London office who has a T470 and he is trying to connect 2 external displays to it.  Both displays are Dell P2210 https://noteboox.de/mediafiles/Sonstiges/Dell-Professional-P2210-Users-Guide.pdf which have 1 VGA, 1 DVI-D and one DIsplayPort. We don't have any T470's here in US that I can test to replicate his issue on. The T470 has an HDMI port and a USB-C port. He currently has one of the monitors successfully connected via a HDMI(male) to VGA(F) adapter. When he tries to connect his 2nd monitor via the USB-C the PC will not detect it. He is using a USB-C to DIsplayPort cable  USB Type C(Thunderbolt 3) to DisplayPort [email protected] UHD 6 Feet CableFrom all I have read on this machine, it should be able to use the USB-C and HDMI port at the same time for video. I don't want to just tell him to go get a different cable, as I'm not sure if there's something I'm missing here.The T470 does support video over USB-C am I correct? All the specs sheet says on the 470 is "Lenovo USB-C to VGA adapter, optional." This is not very helpful and does not specify if it will support video over other means, nor if this "Lenovo adapter" is a converter or simply an adapter.  Can someone please help me pinpoint where my issue might be? Thanks.

A:Cannot use external monitor on USB-C port (ThinkPad T470)

I'm having the same problem with that dock on x1 Carbons. What's odd is that the computer thinks the second monitor is working fine. If I Remte Desktop into the computer I can use the second monitor fine. The Monitor even wakes up when the computer boots but then displays 'no signal detected' after searching it's available ports.

Read other 2 answers