Over 1 million tech questions and answers.

WWAN Fibocom L850-GL and Linux support

Q: WWAN Fibocom L850-GL and Linux support

I bought X1 Carbon 6th and X280, both with Fibocom L850-GL. WWAN with Linux do not work. I searched and found the reason. The PCI-E must be disabled, so that the card can run with USB. It seems that Lenovo did not offered a solution since July 2017. I searched but do not find any direct contact to Lenovo to ask the question. The WWAN is important for me and Windows is no option anymore. Anybody know if there is an other WWAN card wich works with Linux and X1 Carbon 6th / X280 ?Anybody know if there is a chance that Lenovo solve the problem with a bios update? Many new Lenovo Thinkpads have this Fibocom L850-GL inside and many business user use Linux...

Read other answers
RELEVANCY SCORE 200
Preferred Solution: WWAN Fibocom L850-GL and Linux support

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 130

https://www3.lenovo.com/us/en/laptops/thinkpad/thinkpad-x/ThinkPad-X280/p/22TP2TX2800Because I need LTE900 (Band 8) for my LTE module.  Is my model support with Fibocom L850-GL 4G LTE-A Cat9 which in the list of x280?Lenovo Part no. : 01AX786

Read other answers
RELEVANCY SCORE 118.4

Anyone know where to buy the antennas for this product Thinkpad Fibocom L850-GL CAT9 M.2 WWAN. I would be a great help. Also do I need a professional to install these cables?

Read other answers
RELEVANCY SCORE 117.2

I currently have T580 with pre-installed WWAN module (Fibocom L850-GL) and trying to get to work it on Linux. It works perfectly fine on Windows. So far I discovered that Windows driver uses PCIe protocol to communicate with WWAN module, but Linux is supported apparently only through USB protocol, and if PCIe is enabled, the module ignores all USB commands according to its hardware specs document (page 26) - https://www.mev-elektronik.com/files/MEV%20Elektronik%20Service/produkt-downloads/rf-microwave-wirel... Fibocom recommendation is to disable PCIe in BIOS, that is not supported by stock ThinkPad. Thus in Linux the device is only displayed as "Wireless controller: [0d40]: Intel Corporation Device 7360 (rev 01)" through lspci , and nothing on lsusb . Any suggestions how to make it work on Linux? As an alternative I'm considering getting another WWAN module, but it's quite likely it will not work due to whitelists. The only other module that is whitelisted for sure is L830-EB, that does not have global coverage and thus doesn't work in the US or China, even so it was reported that it's Linux-compatible (USB-mode only). Maybe there is a patched BIOS that has whitelists removed? Wondering if there are Linux enthusiasts who are also looking for a way of using WWAN.

Read other answers
RELEVANCY SCORE 111.6

I want to know if a Lenovo P52 WWAN card will permit me to use that laptop as an additional device in our Google Fi account, which we use for our Android phones.  The card Fibocom L850-GL 4G LTE-A cat 9 is listed as available for P52 workstations.  A Fi chat said that I should use a "data only SIM card", but that does not help me unless I know how to use that in the P52.   I understatnd that the Fibocom card is supposed to work with Verizon, but I want to know if it will also work with Google Fi.





https://www.ingber.com

Read other answers
RELEVANCY SCORE 111.6

Hello,   I consedering buying a THINKPAD X1 CARBON (GEN 7), the Fibocom L850-GL 4G LTE CAT9  is included in the price, I guess it is used to acces 4G network with a SIM card exactly like a smartphone. But in this case what is the use of the wwan option ? As far as I understand it is also used to acces  cellular network ?What is the difference ? Please feel free to explain if I got this wrong  Thx

Read other answers
RELEVANCY SCORE 111.6

I want to know if a Lenovo P52 WWAN card will permit me to use that laptop as an additional device in our Google Fi account, which we use for our Android phones.  The card Fibocom L850-GL 4G LTE-A cat 9 is listed as available for P52 workstations.  A Fi chat said that I should use a "data only SIM card", but that does not help me unless I know how to use that in the P52.   I understatnd that the Fibocom card is supposed to work with Verizon, but I want to know if it will also work with Google Fi.





https://www.ingber.com

Read other answers
RELEVANCY SCORE 109.2

Hi ,I have issue about WWAN Fibocom L850-GL+Antenna  after i bought it and installed already.I has follow this step:1.update bios to version 1.4 and enable wwan2.all update new drivers include fibocom 850-GL from lenovo websiteProblem is why i can't see the cellular network show in my network connection?Can anybody give me advise?My laptop is X1 carbon gen6th Machine Type Model: 20KGS45M00Processor: 1x Intel Core i7-8550U Processor(Core i7-8550U)Memory: 1x 16GBLPDDR3-2133Operating System: Windows 10 Pro 64(EN:English)Hard Drive: 1x 256GBSATAM.2Wireless Network: 1x Intel Wireless-AC 8265 2x2 ACPorts: 1x Microphone/Headphone JacksCamera: 1x 720p HD Camera with Array MicGraphics: 1x Intel UHD 620Monitor: 14.0 WQHD LEDThank you very much for your time and assistance in this matter.     

Read other answers
RELEVANCY SCORE 108

Over the last few weeks, I've had at least a half dozen T480s that have severe spikes in latentcy and packet loss when using the Fibocom L850-GL, making them pretty much useless for our users who need them for remote desktop.The usual "working" baseline for these machines on our network is around 40-70ms pings. Show below are the occasional spikes past 3 seconds and timeouts along with the current firmware.    The work around I was using to fix this problem was uninstalling the drivers/firmware from Device Manager, and letting Windows reinstall them, but that doesn't seem to be working anymore.  Any help would be appreciated.

Read other answers
RELEVANCY SCORE 108

We have ~750 T480s (model 20L8S4HL00) laptops running Win10 Enterprise 1703 in our environment, and at least 35 of the laptops have non-functional Fibocom L850-GL WWAN modules. What makes matters worse is that this issue can also cause repeated BSoDs, sometimes multiple per day. Problem Symptoms and Actions TakenThe "Intel(R) USB Flash Loader utility" / "Fibocom USB Flash Loader Utility" repeatedly connects and disconnects roughly once a minute, and when doing so the Windows "device unplugged" sound is heard. The HWID of this device is "USB\VID_8087&PID_07F5\5&1AD8E564&0&6". Refer to the screenshot below The frequent and repeated hardware disconnections cause problems with the enterprise security software we use for encrypting external media, to the point that after a certain point the computer experiences a BSoDThe only associated driver that remains active in Device Manager is the "Intel(R) XMM7360-P WWAN", all other associated WWAN drivers show up as hidden with code 45 (disconnected)If all WWAN drivers are uninstalled and the drivers are deleted, the only devices that are subsequently discovered are the flash loader utility and the Intel XMM7360, all of the others are no longer found and Windows cannot seem to find them againInstalling all of the latest device drivers and firmware using the Lenovo System Update tool do not mitigate this issue, nor does manually uninstalling/reinstalling the WWAN driversTemporarily disabling the built-in... Read more

Read other answers
RELEVANCY SCORE 108

So I just added a WWAN card (Fibocom L850-GL (FRU 01AX792)) to the X1 Yoga 3rd Gen, but the typically "pre-installed" Antenna is not pre installed, I guess next year the Sim slot won't be there if you don't buy it out the door with it.  Does anyone know the Lenovo FU... i mean FRU... Part number for the WWAN Antenna for (Fibocom L850-GL (FRU 01AX792)) These connectors are tiny.  

Read other answers
RELEVANCY SCORE 105.6

Hi allMy WWAN was working previously. I have updated my Windows to 1809 October update.However now my WWAN toggle is missing in windows 10 I can see in device manager -Network\ Fibocom L850-GL is missing (shows up in hidden devices) - as error 45 - not connectedSystem\ Intel XMM7360-P is listed as working I've sinced downgraded - but still can't find the toggle.Anyone have problems after updating windows?  Or anyone NOT have problem after updating?  Thank you 

Read other answers
RELEVANCY SCORE 103.6

 Hello All, New T480 with the Fibocom L850-GL wwan card. Clean install of Windows 10 Pro x64, Redstone 4 (v. 1803). All Windows Updates applied. All Lenovo updates applied through the Vantage app via the Microsoft Store, and manually checked from the support page of the website (BIOS, WWAN, etc. updates). Following the manual, I pulled the external battery, disabled the internal battery, then inserted my T-Mobile USA sim card, then reassembled everything, then rebooted. Manually installed the latest L580-GL drivers from Lenovo. First off, the L850-GL is being shown as a USB device, as opposed to PCIE, with a hardware device instance path of USB\VID_8087&PID_0AC9&MI_00\7&4FA6012&0&0000, and a hardware location of 0000.0000.0000.003.000.000.000.000.000 in the properties dialogue screen in Device Manager. The Driver tab shows the provider is Microsoft with a date of 4/10/2018 and a version of 10.0.17134.1.... I suspect much of that to be a sign that something isn't right from the get-go... Second, every time I close the lid of the machine or leave it running long enough to enduce the proper level of sleep/hibernation, the card simply stops (with a hardware error 43 warning in Device Manager). At that point, my "T-Mobile LTE" network option no longer appears in the Windows 10 notification/network connections sidebar. My only recourse thus far has been to uninstall the L850 in device manager, "Sca... Read more

Read other answers
RELEVANCY SCORE 79.6

I am considering buying an X1C gen 6.The model that is available in my region is: 20KH007JIVAccording to https://psref.lenovo.com/Product/ThinkPad/ThinkPad_X1_Carbon_6th_Gen?ch=20kh007It has a Fibocom L850-GL. Does it work with ubuntu 18.04 ? I mean does it work reliably after editing some files here and there or it's a mess ? (I am ok to edit some configs if required). Should I check anything before purchasing ? (I am plannig to only have Ubuntu 18.04 on it for development).I know there seems to be some problem with sleep mode but there are acceptable workarounds. Thank you in advance !

Read other answers
RELEVANCY SCORE 79.6

Fibocom L850-GL 4G LTE-A cat 9 is orderable with X1 Yoga 3rd Gen. Could it be installed in my X1 Yoga 1st Gen to upgrade the current em7455? If the bios whitelists are shared perhaps the vid/pid for the Fibocom L850-GL 4G LTE-A cat 9 is in the list and it will be accepted. Or is it a pipe dream? I want to stick with 1st gen as the 3rd gen lacks OLED screen option, which I have.

Read other answers
RELEVANCY SCORE 78.8

I know this is an old issue, but I can't solve the problem.I've downloaded the last drivers (June 2019) from Lenovo website but still WWAN doesn't work. Diagnostics says SIM is blocked by PIN2 but there is no way to add PIN2 (or PUK).Should I send the laptop to a repair center?Thank you in advance for your helpMassimo 

Read other answers
RELEVANCY SCORE 78.8

I bought a wwan card (Fibocom L850-GL). Installed it and was everything all right. I ran System Update today, which found an update V.2.0.1.44, which I installed. System Update suggested me to restart my laptop. I did so an since than the following happens: System Update finds the very same update again and again. (And shows it in the history as installed update.)Cellular connection does not show up among available networks.No trace of the device in device manager, so I am not able to reinstall it or go back to an older version.Windows beeps sometimes, as if a new device was found, but nothing happens.Any idea is wellcome! Thank you!

Read other answers
RELEVANCY SCORE 78.8

I can't seem to establish a cell connection with my 6th gen Carbon X1 and new Fibocom L850-GL WWAN.  I'm using a Verizon SIM - all seems fine from the VZ side, and the machine is correctly recognizing the SIM, but I can't for the life of me get it to make a connection.  All I see is "No Service" from the Windows wifi manager, although the VZ "advanced options" confirm that there is an active account.  Anyone got any ideas on how to make this connect?  The Carbon X1 is fully updated and only recently imaged - latest drivers/firmware applied. Thanks in advance for any help!!!

Read other answers
RELEVANCY SCORE 78

I am receiving an error when I try to connect to the cellular network with my X1C7: "Can't connect to this network. Enter an APN and try again" I have tested this SIM card in T420 and it can connect successfully. Win 10 is updated to the latest, all drivers too, but still no success. Output from the cmd shows that the SIM card is recognized and registered on the network, but still no successful connections: One thing I did notice is that my driver is "generic mobile broadband adapter" released by Microsoft and no matter what I try to install the Lenovo one - removing, choosing manual update, it still stubbornly chooses the generic one.   

Read other answers
RELEVANCY SCORE 77.2

I have a T480 with a Fibocom L850-GL WAN card. Frequently, but all the time, when waking up from sleep, it fails to appear in my Wireless options, and when I look at it in the device manager, under Device status Windows gives the message "Windows has stopped this device because it has reported problems. (Code 43)" I see others have had some problems with this card, but I haven't found this specific issue. I've installed the latest drivers as of today (2018-07-28) but I'm still having this problem. If I manually disable and re-enable the device it always comes back, but it's pretty annoying to have to do that.  Before I contact Lenovo for repair (the laptop is only a couple of weeks old) I wanted to check the forum for any ideas. Thanks!  

Read other answers
RELEVANCY SCORE 77.2

Windows device manager shows it as not connected. But it has been working just a week ago! Hardware or software?

Read other answers
RELEVANCY SCORE 75.6

I have a X1 Yoga 3rd Gen equipped with the Fibocom L850-GL LTE modem, using a Verizon LTE sim. I ran into this issue whenever I'm using the LTE connection at high speed, Windows 10 has a high chance of crashing (BSOD). This can be easily reproduced by running a speed test on speedtest.net. I'm in an area with good LTE signal, and my speed on the Verizon sim can reach around 200 mbps. When running the speed test, whenever it goes past around 130mbps, it has a pretty high chance of crashing. It's almost as if the module cannot handle that speed (maybe heat/power related). I'm on a clean installation of Windows 10 1809 with the latest Lenovo drivers (including the Fibocom modem) installed. Anyone else is having this issue?

Read other answers
RELEVANCY SCORE 74.4

Hello all, just bought a X1 carbon from costco. i noticed a empty WWAN slot when i took the bottem cover off. i think i believe a Fibocom WWAN will fit there but i cant find where i can buy it anywhere . i will be using this for work and need this WWAN. can anyone tell me what the part number is and where i can buy one? thank you 20KG-0022US.

Read other answers
RELEVANCY SCORE 73.6

Hi all, Am running an X1 6th Gen, in which my Fibocom 850-GL has been sporadically working. 1. The device does not appear in Device Manager under Network Adaptors at all (even if I search for hidden devices)2. Lenovo Vantage picks up that the device drivers need to be updated, and asks me to download the update3. The update runs, and when the laptop reboots, a small white install box appears in the bottom right of the window... and then does nothing.4. A few seconds later, the Windows 'Device Disconnected' chime sounds5. A few seconds later, the Windwos 'Device Connected' chime sounds6. I can re-install the drivers7. Cycle back to point 2.  I'm unable to uninstall the device as it doesn't ever show in device manager; just constantly get Windows finding / un-finding the device, and it never installs. Running latest version of Windows 10; Vantage + Windows seem to think everything is updated. Thanks in advance!

Read other answers
RELEVANCY SCORE 72

Hi, i have problems to get into internet via wwan card Fibocom L831-EAU on W10. System sees the SIM, it prompts for PIN an then I see signal strength bars. Ive already received some SMS. The problem is, I still see the message No internet access. I cant understand why. The SIM was tested in a mobile phone and internet works normal there. I have tried also another SIM from other network operator, but still No internet access.  Any ideas? Thanks in advance.  Matus

Read other answers
RELEVANCY SCORE 70

Hi! I have a new T480 with the factory installed WWAN option. It works on a fresh startup, but when the laptop goes into hibernate mode (not sleep) and then I wake it up, the WWAN stops workding. Windows Device Manager shows it as "Windows has stopped this device because it has reported problems. (Code 43)" Why does this factory installed option not work correctly in normal use? I would prefer not to have to disable hibernate or have to restart the laptop every time I want to have working WWAN. Thanks for any advice!

Read other answers
RELEVANCY SCORE 70

Hi all, I just began ordering T480s devices as the old T470's are gone, and running into an issue on one where every time the computer goes to sleep it simply states "No Connection" in the cellular section.  Prior to going to sleep it works fine, but after waking this happens every time.  A reboot resolves the issue, but this is incredibly aggrvating. I downloaded the drivers that were released for this WWAN from July 23rd and installed them, but even after doing so Windows is showing the installed driver as a generic device and NOT the drivers I installed(In device manager under wireless it does show as the Fibocom L850 though).  I've tried adjusting power settings, removing the card and putting it back in, uninstalling and trying a fresh install of the drivers: nothing seems to work. Has anyone encountered this or know of a potential solution?  Just about at my wits end here.

A:T480 WWAN L850-GL No Service after hibernation

I have Same problem on x1c gen 6. See x series forum. Do you have this problem only on one device? And others unaffected ? 

Read other 2 answers
RELEVANCY SCORE 69.2

Until yesterday, the Fibocom L850-GL worked perfectly in my T480. After a restart, the device was gone and instead the error message "Detected unrecognized USB driver" appears permanently three times in the system log. The device manager recognizes a USB-Com device instead of the Fibocom. Detected unrecognized USB driver (\Driver\pci).Detected unrecognized USB driver (\Driver\ACPI).Detected unrecognized USB driver (\Driver\UDE). Even after a clean Windows 10 Pro (1803) installation, the error is repeated.The original installation of Windows 10 Pro (1803) immediately detected and installed the Fibocom.BIOS is up to date. For now I deactivated the device. Any hint? 

Read other answers
RELEVANCY SCORE 69.2

This describes my experience with a T580 (20L9CTO1WW) which has the above Fibocom WWAN adaptor. Everything was fine on Win 10 1809. But after the Win system updater prompted me to update to version 1903 the adaptor is no longer functional. In Device Manager it is no longer listed under Network Adaptors but now appears under System Devices as "Intel XMM7360-P'. That is the internal LTE chipset which suggests the card is still functional but not being correctly recognised by Windows. Yesterday, I spent around 2 hours with escalated Lenovo Tech Support trying to resolve this to no avail. We tried the following:updating to the latest firmware/driver package (https://download.lenovo.com/pccbbs/mobiles/nz3wj21w.exe)uninstalling and reinstalling all driversforcing install of Lenovo driversrolling back to Win 10 1809rolling back to previous firmware/driversphysically removing and reinstalling the card So it seems there is a compatibility issue that will have to be resolved. Hopefully the next iteration of drivers/Windows updates can fix this. In the meantime, I would suggest anyone with a similar hardware setup not accept the 1903 May Update if offered. As Tech Support's final suggestion was to do a completely fresh install of (1809) Win 10 - somewhat undesirable for a lone driver incompatiblity. Alternatively, if anyone has successfully updated, please let me know and consider sharing your driver configuration. Or if anyone has any ideas on how to resol... Read more

Read other answers
RELEVANCY SCORE 69.2

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version repeated restart Windows Cellular Service  when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It is like the Fibocom WWAN L830-EB DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 68.4

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version always restart Windows Cellular service when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It works like the Fibocom WWAN L830-EB is DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 61.6

Hi
Model Satellite L850-Y3110(PSKFWG-00F00C)
my laptop specs are i73630QM with 8gb DDR3 Ramand Raedon HD7670M 2Gb graphics in 64 bit Windows 10 pro.When i purchased it was installed with Win8.1 afterwards i manuallyt upgraded it to Win10.Everything was fine graphics is also ok.

From toshiba's website i found that my laptop is not up-gradable to Windows10. Anyway i have upgraded and there is no going back.
So my drivers are now auto updated with windows.

But to find drivers from my OEM's website i checked all toshiba's websites.But most of them does not recognize my model except this website.
In this site also i am not getting any drivers of Windows8.1.Only drivers of Windows 7 is available.

1)I would like to know where i can get these drivers.(Win 8.1)?

Please check with my model number before replying because i have spent many days for this.Again toshiba-india website provides only bios update drivers for my version.
2)So i would like to know whether other L850 model's drivers are compatible with my lap?

Now i will come to actual problem.
From intel's website i am aware that my laptop is having inbuilt graphics intel HD4000.
3)So where is it?
But nowhere in my laptop i can see this display adaptor.I looked into bios also to see whether it is disabled in bios.
And i found that there is no tab in bios regarding display/graphics.

I tried all latest drivers from intel for HD4000 and drivers from AMD for Redon7670M.
Everytime intel's setup driver installation fails.Add de... Read more

A:Support for Satellite L850

Hi there, I know it's been long and you could of changed your laptop already but did you find a solution for this?

Read other 1 answers
RELEVANCY SCORE 56.4

dear all, i just purchased the X1 Carbon 5th gen 20HR-A01JHH, found the micro SD slot and the SIM card slot at the back, i am wondering my one is WWAN supported but this is not my intention. how can i confirm my one is WWAN supported or not? i tried to insert a micro-SIM card and it can, but seems nothing special after going into the windows. please kindly help. brgds/fred

Read other answers
RELEVANCY SCORE 55.6

I have a T470P laptop. I wanted to upgrade it with a WWAN card. Checked the supported devices and bought the Sierra Wireless EM7455. I installed the card and I got the 1802 unauthorized network error on boot up. Check this forum and I can see that there is a FRU number and that is important to be compatible. This is out of my mind how it is possible that this important information is not written at the supported cards. Now I have a EM4755 card with newer FRU number that is supported and I can not use this. Is it possible to update the supported card list in the bios or some other trick to use my stuff? Thanks a lot

Read other answers
RELEVANCY SCORE 55.6

hi everyone ..what is meaning thinkpad p50 not support Network Card ? what card done ? It does laptop not connect to the internet and Wi-Fi ?

A:Network Card , No WWAN Support

Hi friend,
 
Welcome to Lenovo Community! And happy to have you here.
 
As I understand that you have query regarding Network card, No WWAN support in P50
Here's No WWAN support means there is no WWAN card in the system. It is different from WLAN card P50 has WLAN and you have access to internet and Wi-fi.
 
I hope the above information helped you
Please feel free to post in Lenovo Community Forums if you have any further queries!
 
Regards,Prabhansh_______________________________________________Tap that Kudos button if I helped.If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Read other 1 answers
RELEVANCY SCORE 55.6

Hi All,I have a question T490 support 2nd SSD on WWAN port?  Thank youBOSS

Read other answers
RELEVANCY SCORE 55.2

Anyone install a NVMe (2242) in the WWAN slot?I have a 240GB RC100 that works in my T480 without issue. Installed it in my new X1 Yogo Gen4 and it's not recognized. I can't find any documention referencing the specs and or support for the WWAN slot. Just curious if anyone else has tried yet maybe with a different NVMe other than the RC100?

Read other answers
RELEVANCY SCORE 55.2

Hello! I just buy X1Y without WWAN-modem, because I don't really need it for now, and try to use empty WWAN M.2 slot for SSD like I did with all my previous Thinkpad's - so I install Transcend TS256GMTS400 that perfectly works at my previous Thinkpad Yoga 12... but SSD does not apper at BIOS! At "BIOS - Boot priority" there are some empty device named "NVMe0" - because of absent of external NVMe ports and present of Samsung SSD as different device at M.2 2280 slot, its possible can be support for NVMe-PCIE SSD at that WWAN-slot... but I can not find any SSD M.2 2242 NVMe at all world...  Also I dont find any WWAN-antennas near WWAN-slot. Also because of gluided Yoga touch screens its unpossible to install WWAN-antennas by user without waranty lose. So it seems that X1Yoga's that sell's without WWAN-modems does not support WWAN-modems at all! So after all those problems it seems that at all configurations of Thinkpad X1 without WWAN-modem this WWAN-slot is absolutely useless!!! PS Also X1 have flimsy soiled case, loud keybord and a specially very loud touchpad buttons and trackpad buttons!  Does Thinkpad X1 with such problems are really premium device?!?!?!  Any suggestions for WWAN-SSD?!

Read other answers
RELEVANCY SCORE 53.2

Hi, some people are reporting, that they can receive a GPS-signal with their Dell 5520 mobile broadband card.Actually a GPS-Button was shown in a former software version of the Dell Mobile Broadband Card Utility. In the specifications for the 5520 (Dell) and EU870D (Novatel) is no precise answer to this question. Does anyone definitely know if there is GPS support by the 5520 card? If yes, why GPS isn´t supported by the newest Dell software for the 5520 card? BTW: Anyone got the firmware upgrade files for supporting HSDPA up to 7,2 Mb/s yet?

A:Does the Dell WWAN 5520 HSDPA Minicard (Novatel EU870D) support GPS?

Answering by my self: GPS works fine with the Dell 5520. It needs just a registry hack...

Read other 5 answers
RELEVANCY SCORE 50.4
RELEVANCY SCORE 50.4

I guess since I am trying to uninstall Linux from a laptop the linux junkies dont want to help! Im trying to uninstall Linux entirely and install Win XP. I dont know where to begin!

A:no help in Linux support!

you expect help in an hour???? Please have patience, since nobody lives here and they themselves have lives other than tsf, it may take a while for someone who can help to get online.

Read other 3 answers