Over 1 million tech questions and answers.

Dell WD15 180W with XPS 15 9550

Q: Dell WD15 180W with XPS 15 9550

Just purchased a XPS 15 and have a few questions about the Dell WD15 180W Docking Station.

Will the docking station charge the XPS 15 while docked through USB-C with multiple external monitors connected?

Is the mini DisplayPort version 1.2 and able to daisy chain monitors?

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Dell WD15 180W with XPS 15 9550

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 103.6

Good day!
When I leave work, and close the lid of lapto it goes into hibernation mode. Arriving home, I open the laptop and turn it on with the power button. First, the monitor displays the BIOS splash screen, and then loads the window, but then the screen is lit in gray and there is no possibility to enter a password. Today, having come to work, I spent exeperimental.1) Turn on the computer, a gray screen.2) Connect the docking station to a stationary monitor all appeared.3) I came in, worked, shut the cover - the laptop went into hibernation.4) Turn on the computer, do not disconnect the docking station, a gray screen on the laptop, on a stationary monitor power saving mode.5) Reconnect the docking station to a stationary monitor all appeared.
Updated window to update all drivers, update the firmware docking station. Nothing helped!
Dell experts help please it is not convenient to work!

A:My dell XPS 13 (9350-1288) and WD15 180W (452-BCCW)

It appears to me that the operating system hibernation is the culprit and not hardware. Test this at the end of you work day.* Do not close the lid to enable hibernation* Shutdown properly =Click Start- Shutdown- Shutdown- Ok or Click Start- Turn Off Computer- Turn Off-or-Tap the lower left Start button to open the Start MenuClick the Power Options button on the top middle, and select Shut down-or-Right-click the bottom left corner on the desktop to open the menu, tap Shut down or sign out and choose Shut down-or-Press Alt+F4Click the down arrow, choose Shut down in the list and tap OK* Then close the lid* Once home =Connect the laptop to whatever dockOpen the lid and power it on

Read other 1 answers
RELEVANCY SCORE 86

Hi everyone,
I got a WD15 dock and made sure all the drivers and bios were updated. plugged it in and started having issues. First it wasn't working with my keyboard and mouse when plugged into the Docking station (with the lid closed). No biggy plugged the into the laptop and continued working. Now it acts like the Ethernet Cable is being unplugged and plugged in constantly (lid still closed). Sometimes everything will work with the lid open, other times if acts like I unplugged the dock making the monitors flash on and off. Please help!

Read other answers
RELEVANCY SCORE 83.2

I've been using my Dell XPS 15 9550 for a couple of months now and everything was fine, i decided to connect it to an external monitor P2715Q through a Dell WD15 Type-C docking station, which working fine except for having the Monitor at 30Hz versus 60Hz. i've been facing alot of Blue Screen Errors, and one day found there was a firmware update for the Docking Station, the Monitor went blank and found the firmware was updating usually when i startup my laptop and it's connected to the docking station it gives me a warning message about the power being less than 60W so i unplugged the Type C cable connecting the dock to  the Laptop mid installation, it rolled back and i then figured i shouldn't have disconnected it. This morning i connected my dock as usual but it wasn't being recognized it's as if the Type C wasn't reading the Dock, i connected a Type C to Display port cable direct to the monitor to check if it was the port but that worked instantly, please help what should i do? 

A:DELL WD15 Type-C Docking Not working with XPS 15 9550 after failed firmware update

Unplugging mid firmware update is a no no. Try the firmware update once or twice or so again, with nothing else connected to the dock. If that fails, try Dell service. Mine updated the second time but said failed at the end, then third time reported to be updated, and now seems to work just the way it did before.
I've had horrible issues with the WD15 initially, all sorts of devices disconnecting and not working properly, including plain wired USB mouse and keyboard. After tens of driver and BIOS updates, things eventually stabilized (although the screen developed a flicker meanwhile). Now it seems to work stably, as long as the laptop is in airplane mode, otherwise I still get temporary freezes. Many people blame it on some sort of the Dell Wireless 1830 adapter with USB - some say wifi power should be reduced to 75% in driver settings, but that replacement with the Intel 8260 is a better solution. Please report back if the airplane mode helps with stability (wired Ethernet now stable here, if you're on wifi regularly and worried about withdrawal symptoms during a possibly prolonged airplane mode testing period).  
30 Hz is max for a 4K display on the WD15, there's not enough bandwidth for more via the USB protocol. Recently a revised version of the Thunderbolt 3 dock, the TB16, has been released, and perhaps even works finally with a fan built in, supporting even two external 4K displays @60Hz. 3rd-party TB3 docks have started appearing too, but make sure... Read more

Read other 1 answers
RELEVANCY SCORE 68.8

Hi!
Today I've upgraded my BIOS to the latest recommended version by SupportAssist that is to 1.2.29. Also today's update comes with new version of ASMedia USB Extended Host Controller Driver.
Once I installed them I've got unwanted results: - My peripheral devices connected to WD15 aren't responsive, it looks like a connection with them is broken occasionally. - BIOS doesn't recognize USB-C Charger (180W), and it claims that either it has 60W or aaaW, it warns that charging is disabled.

Solution what works for me was to downgrade BIOS to 1.2.25 version from: http://www.dell.com/support/home/us/en/19/drivers/DriversDetails?productCode=xps-15-9550-laptop&driverId=3W30W

@Dell Support: Please let me (us) know if this is known issue for 9550 (I've seen so far that there's a problem with 9360 after BIOS bump).

Cheers,Piotr

Read other answers
RELEVANCY SCORE 68.8

I have a new XPS 15 9550 that I really like and it has a fantastic display. When I connect it to an external Dell monitor with the WD15 the display image is very washed out. I've updated my BIOS and all drivers to the most current version. It makes the use of the external monitor difficult at best. What's interesting is that when I reboot the laptop connected to the Thunderbolt connector the initial external monitor image is fine and then after a second or two flickers and then changes to a washed out display. I've found that if I keep the laptop open so it's display is up, at times the external monitor's display is OK and not washed out. The WD15 is connected to the Dell wide screen monitor with a VGA connector.

I used this monitor with a Dell Latitude E6420 with no issues at all for years. It still works perfectly with the Latitude. There seems to be an issue with this WD15 or the Thunderbolt connector.
Please investigate this issue and find a solution. It's very frustrating.

Read other answers
RELEVANCY SCORE 67.6

Hi,
I've been having a terrible time getting the WD15 USB-C dock to work with my XPS 15 9550.  I have two monitors plugged into the dock (one HDMI, one VGA) and I have the 9550's monitor on (total of three screens).  
I'm able to use all three monitors when I'm connected to the dock, but when I disconnect the dock, the laptop screen stays black.  The computer is still running the whole time (if I have music playing, it keeps playing).  If I plug the dock back in, all 3 monitors come back.
I've tried everything I can think of from updating every driver, following the dock driver installation guide, updating BIOS, removing and reinstalling display drivers, but I don't know what's going on.
Any ideas?
Thanks!

Read other answers
RELEVANCY SCORE 61.2

I have two displays connected to the laptop (one to the native HDMI and one to the docking station). In effect, I am able to drive three displays (Laptop display, native HDMI, and DP from WD15). I wanted to connect one more display to drive four display? 

When I connect the fourth display it's not showing up in the detected displays list. 
How can I do this? Is it possible? 

A:How to drive four displays from DELL Precision 5520 with Dell Dock WD15 and native ports??

It's not going to be possible without some other type of hardware purchase - no.  The internal GPU cannot drive four displays at a time.

Read other 5 answers
RELEVANCY SCORE 57.6

I have a WD15 dock trying to connect to a Dell E5570 without a type C usb how can I get it to connect?

Read other answers
RELEVANCY SCORE 57.2

Hi,
I'd like to use Dell Dock (WD15) with my new Dell Alienware 13 R2 via Thunderbolt 3 (USB-C).It is possible, isn't it?If so, could the laptop be charged via this docking station?What is the difference between 'WD15 with 130W Adapter' (Dell part 450-AFGM) and 'WD15 with 180W Adapter' (Dell part 450-AEUO)? Which one to choose for my purposes (external monitor via VGA, network via RJ-45, external USB keyboard, USB headphones, USB Flash Drive)?
Please, advice. Any answer would be appreciated.

Read other answers
RELEVANCY SCORE 57.2

Hi All
I am posting my first post here... I've reading all posts regarding usb-c dock issues. I have fallen victim too... I bought brand new Dell WD15 dock and before begin i install latest drivers and still get under power warning! Please see photo attached! 
I spent hours with Dell support and they advice me to clean install and install drivers in right order, so wasting almost a day i did all this and problem don't go away! 
Aside the power warning the display randomly disconnects... leaving me no screen at all (the laptop screen doesn't switch back either) and now laptop gets very hot, making me wonder if i somehow damaged the laptop itself?
I will return this item but wonder if this can somehow have damaged my brand new $2500 laptop? Super disappointed with overall experience... 10k + dell products in past and this is as bad it can get, making me question buying anything from Dell both for personal and business :-(

Read other answers
RELEVANCY SCORE 57.2

After the latest WD15 dock update there are two bugs:
1. The Dell Dock Update 'Updates Complete' popup continually appears when any device is connected to the dock or the attached XPS 15.
2. All audio is lost whenever any USB device is plugged into either the XPS 15 or the dock itself. Audio continues to play (ie through spotify) but there is no sound. Unplugging the audio jack on the WD15 and reinserting appears to fix this bug.

Read other answers
RELEVANCY SCORE 57.2

Can I configure the new XPS 13 to power on with the lid closed when connected to the Dell Dock WD15?

Read other answers
RELEVANCY SCORE 57.2

Hello All,
I have a Dell XPX 13 9360 laptop with a WD15 dock that I want to use two Dell 2316M monitors.
The dock connects up to the laptop fine - I am getting ethernet, USB and power from the dock via the Thunderbolt port. But, I am getting no video output from it. The laptop does not recognize that there are additional displays connected. The monitors are on the correct input and the monitors work on their own respectively (tested by connecting to another machine).
I have tried installing the drivers from Dell (Thunderbolt, ASMedia USB, Intel Graphics, etc.), but nothing makes it work. I attempted to install the Firmware, but it fails.
The laptop is Windows 10 Pro.
Does anyone have any suggestions to make this work?

A:Dell WD15 w/XPS 13 9360 - No Video

Hmm, video is typically the easiest thing to get working because the USB-C port just has a DisplayPort output wired to it, so there are no special dock drivers to make that work.  In terms of the firmware update that failed, if you're referring to the WD15 firmware I'm linking below, what's the exact failure error?  That firmware update involves restarting your PC and having it update the firmware while it boots, and it would be a good thing to get working because one of the listed fixes pertains to the DisplayPort MST hub that controls the video outputs.  Link: www.dell.com/.../driversdetails.

Read other 2 answers
RELEVANCY SCORE 57.2

Hello, I have a Dell XPS 13 with a WD15 dock, the last days the dell audio stopped working but I fixed reinstalling the drivers (http://en.community.dell.com/support-forums/laptop/f/3517/t/19993911
But also my dock WD15 stopped displaying video or audio. The ethernet and the usb works fine but I cant output any video as the scree says no HDMI signal detected. I've tested the HDMI with other computer and the monitor works fine.
I've downloaded and installed the firmware and driver for thunderbolt and the Realtek driver from here: http://www.dell.com/support/home/es/es/esbsdt1/product-support/product/dell-dock-wd15/DRIVERS?rvps=y 
If I go to playback devices i can see the monitor audio (VW246) but the dock audio shows as not connected:

In windows devices manager there isn't any device without controller.

Read other answers
RELEVANCY SCORE 56.4

Hello together,
we have new test systems from Dell (5580, 5480, 7480 and 7280) and the new Dell dock WD15.
To installing our clients, we booting with PXE to starting our Windows 7 / Windows 10 installation. In the BIOS settings we have activate

Settings - System Configuration - Thunderbolt Adapter Configuration - Enable ThunderboltAdapter Pre-boot Modules
Settings - System Configuration - Thunderbolt Adapter Configuration - Enable Thunderbolt Adapter Boot Support
Settings - POST Behavior - Fastboot - Thorough
Settings - System Configuration - Integrated NIC - Enable w/PXE

After this default settings, I change the Boot Sequence order

USB NIC(IPV4)
OnBoard NIC(IPV4)
Windows Boot Manager (Harddisk)

The Idea:I have set USB NIC to first postion, then when the user dock in the WD15, the client is using the network from the WD15 and not the OnBoard netcard. When the user plug in the cable into the OnBoard netcard, then I will be received the message USB NIC have no cable and he will check the connection on the OnBoard netcard.
Now my problem:When I remove my WD15 from the notebook, the client is booting from PXE OnBoard - thats OK! But when I plugin again the WD15, the Boot order was changed.

Onboard NIC(IPV4)
Windows Boot Manager (Harddisk)
USB NIC(IPV4)

The LAN capel is connected in the WD15 and not in the OnBoard netcard. Now, the client is starting, will not found a network connection on the OnBoard netcard and is booting into Windows. But I neet a PXE boot on my USB NIC.
... Read more

Read other answers
RELEVANCY SCORE 56.4

Dearsi have just Bought a Yoga 900 13isk2 and tried using it with a new Dell WD15 dock (Docking Station). Display from the HDMI & Display port do NOT WORK. Charging also does not workeven though the Dell ws15 is 180W. i Need a fast solution please!!

Read other answers
RELEVANCY SCORE 56.4

The thunderbolt cable to by Dell Dock was damaged. I figured out how to remove the cable (there are screws hidden under a rubber cover). However there is a very strange (proprietary?) connector on the other end. Where can I buy a replacement. Dell sales and support don't seem to know anything about it.

Read other answers
RELEVANCY SCORE 55.6

I have Dell Precision 5520 laptop connected to Dell WD15 dock. 
There is a Dell U3011 2560x1600 display connected to MiniDP of the dock. 
The laptop display works in 1920x1080 mode, in order to get DPI similar to the one on U3011 (that's on purpose I'm fine with that). 
Today I tried adding the third display with 1280x1024 resolution connected to VGA of the dock.
It doesn't work. The third display gets detected by the Ubuntu display settings, but it can't be turned on. It works only if I unplug U3011. 
It is also possible to run all 3 displays in mirror mode, but not in extended desktop mode.
Is it a hardware limitation (Intel graphics in Precision, WD15 dock) or just problem with Intel Linux graphic drivers? 
BTW: Nvidia card is turned off.
From  the WD15 and laptop specs it looks like the config I'm trying to do should be supported:
- 1920x1080 builtin laptop screen- 2560x1600 through WD15 and miniDP - 1280x1024 through WD15 and VGA

Any ideas, what I can try?
Thanks,
Piotr

Read other answers
RELEVANCY SCORE 55.6

Hey
We have the problem that the usb mouse and keyboard does not work lots of times with the Dell 5480 & wd15 if Citrix Receiver is installed, did any of you try that.

we have the same problem with the 5 Dell 5480 that we have in the company.

A:Dell 5480 USB not working with WD15 & Citrix Receiver

That's a known issue on the TB16 dock due to the ASMedia USB driver that it requires to be installed. That driver is not required for the WD15 docks, but if you installed that driver anyway on those systems, it might affect them as well.  The fix is simply to update Citrix Receiver on the affected systems to at least 4.9.  This Dell support article explains the issue and provides a link to Citrix to download an updated Citrix Receiver client: www.dell.com/.../tb16-dock-losing-connection-to-peripherals-and-network-on-reboot-with-citrix-receiver-client-software-installed

Read other 1 answers
RELEVANCY SCORE 55.2

To back up Dell-Brian B's threads you can find all the available Dell documents for the Dell Dock and Dell Thunderbolt Dock here. 
TB

Read other answers
RELEVANCY SCORE 55.2

Hi everyone,
New owner of the XPS 13 9360, great product aside from some coil whine. I have an issue with the audio port, from the WD15. Sometimes when I am listening to music, I will notice distortion for 3-5 secs, and then it will cut out completely. Then the audio interface is completely unavailable to the OS. Spotify will say "Cannot play right now", as if the interface is blocked.
I have BIOS updated to 2.2.1 on the XPS 13 9360, and WD15 F/W is up to date (according to the update tool). Realtek USB is updated to March 17, 2017, the newest one available on the website. I have no display issues or ethernet issues with the dock otherwise, but the audio issue is very annoying.
Can anyone provide a clue as to why this is happening? Even when it doesn't cut out completely, I'll hear an occasional stutter from the audio, as if audio interrupts are not being handled in higher priority over other I/O. Not sure what the problem is, but I guess I can also ask here and start a discussion with Dell support as well.
Thanks

Read other answers
RELEVANCY SCORE 55.2

Hello,
After much troubleshooting, I discovered an issue when using the WD15 docking station with a Dell Precision 5510 laptop if the Cisco Systems VPN Client 64-bit software is installed and especially if Symantec Endpoint Protection exists on the laptop together with Cisco VPN (Symantec Endpoint Protection can manage the enabling and disabling of a wired ethernet connection).
To give some background, I provide I.T. support for a company that has deployed Dell laptops to its staff for many years.  In our environment, our Dell laptops run Windows 7 Pro 64-bit.  In this environment in the past, we've never had any issues using the Cisco Systems VPN Client with any Dell laptop that either has a built-in ethernet port or a USB ethernet dongle (including the Dell Precision 5510 when used with its included USB-C ethernet dongle).  But I've discovered ethernet connectivity problems from the WD15's wired ethernet connection when used with a Dell 5510 when Cisco VPN is installed (regardless of whether or not a VPN connection is active).
With the WD15 connected to the 5510 and with a wired network connection attached to the WD15, if Cisco VPN is installed and if Symantec Endpoint Protection is not installed, when after starting up Windows 7 and then logging into Windows, sometimes within the first few minutes, the wired ethernet connection will then drop connection (an exclamation mark will appear over the wired network icon on the taskbar of Windows). ... Read more

Read other answers
RELEVANCY SCORE 55.2

I've got a WD15 hooked up to my XPS15 laptop and it works fine. Latest drivers and chipset/BIOS installed on both Dock and laptop.
I have a pair of external active studio speakers hooked up to the 3.5 mm Speaker out jack on the back of the dock and it works fine.
However if I use Google Hangouts or Skype for business calls and plug in a headset to the front 3.5 mm Headset Jack of the dock the external speakers starts a high pitch static noise. If I then un-plug and replug the 3.5 mm jack for the speakers the noise is gone. The sound and mic of the headset is working fine from start.
The same thing happens when I unplug the headset from the front of the dock, the external speakers starts to "hum" static noise. Again un-plugging the 3.5 mm jack of the speakers and plugging it in again stops the humming static.
If I instead plug the headset into the Laptop there is no problem and the external speakers remains quite.
Why is it doing this and how can I get rid of this annoying behavior?

A:WD15 dock with DELL XPS15 causes static in speakers after using headset

Hi awasen,Thanks for posting.Here is a Forum post from one of our Dell team members that may be helpful.http://dell.to/2lrqLR2

Read other 2 answers
RELEVANCY SCORE 55.2

Greetings,
Have a new WD15 Thunderbolt dock I am trying to get to work with two monitors connected to an ASUS GL552VW laptop. USBs, ethernet and audio that is connected to dock all work fine. But the VGA and HDMI monitors connected do not. The HDMI monitor works fine when I directly connect it to the laptop, but not when I connect it through the dock.
I have tried the troubleshooting tips in this:

I have installed the ASMedia Host Controller from here, twice for good measure:

ASUS support refuses to help me. I'm working on seeing if I can do the BIOS update.
Any advice? Will this not work with a non Dell laptop?
Thank you very much, quite frustrated.

- Dan

A:Unable to get Dell WD15 dock to work with ASUS laptop

I was right.  Here's an ASUS forum page where someone asked this question about your model.  Post #5 contains a reply from ASUS indicating that its USB-C port does not support display output: rog.asus.com/.../showthread.php

Read other 5 answers
RELEVANCY SCORE 54.4

So I am to receive a precision 5510 in the next couple days. I've already bought monitors and a wd15 dell dock. I am a bit confused as to how to hook up dual monitors given that there aren't two of the same port on the WD15 like there was on the E-dock I am currently using for my precision m4700.

At any rate my monitors have HDMI (2), and VGA (1) inputs. The WD 15 has one HDMI, One mini display port, and one VGA.

To run dual monitors I  am assuming I need to run one from the dock's HDMI port to one monitor's HDMI and one either from the dock's Mini display port (with an adapter to HDMI) tot he HDMI port on the other monitor? I supposed I could go VGA to VGA as well, but prefer HDMI.
IS this correct?

Read other answers
RELEVANCY SCORE 54.4

I have just bought a Dell XPS 15 (9560) and a Dell WD15 docking station with 130W power brick (same wattage as the laptop's AC-adapter). When I only use the docking station to power the laptop the discrete graphics card (GTX 1050) does not seem to work. When I am in a game (eg. Starcraft 2), I get like 15 fps with the NVIDIA recommended settings. Then when I plug in the laptops's own power brick (while still in the game) I get an immediate four-fold increase in framerate. When I unplug the laptop's own power brick the framerate drops down to 15 fps again in a heartbeat. Furthermore, when I only power the laptop through the docking station, I cannot even find the discrete GPU in the list when I'm trying to run the Geekbench 4 compute benchmark (OpenCL). Only the integrated graphics shows up. When I plug in laptop's power brick I find GTX 1050 in the list.
I have run the Dell Command Update application and all my drivers and firmware are up to date. 
Does anyone have any idea to what the problem could be?

Read other answers
RELEVANCY SCORE 54

After a failed Windows 10 Update, the laptop will not boot. I tried SAFE MODE and since then the machine just stays black. I cannot get it to boot!!
I have tried:
- Holding down power 10 seconds and trying again.
- Spamming F12, F8 keys to no avail.
- Holding CTRL+ESC and then plugging in AC and still nothing! Just a black screen!
Please help me! Machine is well out of warranty now.

Read other answers
RELEVANCY SCORE 54

When I powered up my new dell xps 15 9550 this morning, (bought less than 1 week ago) I had a message from Dell in the bottom right hand corner of the screen saying there was a firmware update notification. I clicked on this and proceeded to update the firmware.
since this, I have been suffering from the screen going blank and the only way to get it back on again is to switch off the laptop completely!
I have restored the bios to factory settings (F2) and have also tried disabling the nvdia video card but still have the same problem of the intermittent screen going black.
At the same time, if I am listening to music, the music also switches off, so it doesn't appear to be just a video card problem.
It all appears to point to this firmware update?!
any help would be much appreciated.

thanks

A:Dell XPS 15 9550 screen going black intermittently after Dell firmware install this morning help!

I have the same problem:

I initially reported that my XPS 15 locks-up displaying an all white display, however, I have since noticed it locking-up with a black display or gray display. Recycling power is the only way to get the computer working again. Prior to an automated firmware update, my XPS had been working fine. If you find a solution, please post it. I will do the same.

Read other 1 answers
RELEVANCY SCORE 54

After a failed Windows 10 Update, the laptop will not boot. I tried SAFE MODE and since then the machine just stays black. I cannot get it to boot!!
I have tried:
- Holding down power 10 seconds and trying again.
- Spamming F12, F8 keys to no avail.
- Holding CTRL+ESC and then plugging in AC and still nothing! Just a black screen!
Please help me! Machine is well out of warranty now.

A:Dell XPS 9550 Black Screen, no Dell logo after failed Windows 10 Update

Can anyone help me on this?

Read other 7 answers
RELEVANCY SCORE 54

We're encountering scrolling issues with Excel 2013 (and 2016).
What we mean by that is graphic distortions (blocks of black) appearing on the worksheet during the scroll action.
It happens almost exclusively on the externally attached monitor.
Even after the scrolling action is finished the blocks of blacks will persist and will obscure the data in the cells. Generally only opening the worksheet anew will correct the issue (until scrolling is once again initiated)
This is on a new Dell XPS 15 (9550) running Windows 10.The monitor is a Dell U2717D connected via the HDMI.
We've done quite a bit of troubleshooting but before describing in detail we wanted to know if anybody had seen something similar?

Read other answers
RELEVANCY SCORE 54

Hi,
I just received my XPS 15 9550 and it is exactly as I was expected.
However, it seems that I do not have the basic software suites, especially the Dell Premier Color software that I really wanted to try.
Is there something I forgot to do during the laptop configuration?
Thank you!

A:Dell XPS 15 9550 Missing basic Dell softwares(Color Premier, ...)

 Dadouvic,
If you ordered the software for your computer it can be downloaded from MyDellDownloads. The link is listed below. You will need to sign into the site with computer information.
My Dell Downloads
For me to better assist in troubleshooting, please click my DELL-Jesse L and send me a Private Message with the Dell Service Tag number and your Dell Order number.

Read other 1 answers
RELEVANCY SCORE 54

Hello,
As soon as I open a few windows in my browser, I get a popup that says "Memory insufficient - close some programs). And then my browsers crash all the time. Often the popup says the problem is with "Dell Premier Color" but not always.
How can I fix that? I though this laptop had so much RAM?

A:Constant Memory Issue on Dell XPS 15 (9550), usually with Dell Premier Color

The exact messages which I get are:
"Your computer is low on memory. To restore enough memory for programs  to work correctly, save your files and then close or restart all open programs."
AND
"Your computer is low on memory. Save your files and close these programs: Dell PremierColor"
I get this even though I do not use much memory at all (just normal usage!)
Please let me know how to fix this, thanks!

Read other 1 answers
RELEVANCY SCORE 54

I am picking up the XPS 15 this week and currently have two P2815Q monitors I am using with the Microsoft Surface Book.  Currently these are connected to the Surface Book via a single mini-display port cable with the 2rd 4K connected to the first via mini-display port.
So my question is how do I connect these monitors to the XPS 15.  I understand the XPS has Thunderbolt and a single HDMI 1.4 port.  While HDMI 1.4 is not capable of driving 4K at 60hz, I'm also wondering what the new Dell Dock is going to bring to the game here.
Would love some help, so thanks in advance.

A:Dell XPS 15 9550 and Dual Dell 4K P2815Q Monitor Hookup Question

Did you find out the answer to this? I'm killing myself trying to find a solution.

Read other 1 answers
RELEVANCY SCORE 54

Dear Dell,
I bought my XPS 15 in December 2015. The battery is swelling and lifting the trackpad above the laptop case.
I am finding the trackpad increasingly difficult to use, and I am afraid that the battery will rupture and destroy the computer and/or injure me!
I went to your site to obtain a replacement battery. But the site says you no longer offer the battery for this computer model!
So, after 1.5 years, having spent over $1,600, you decide to drop support for a product?!
I only have Dells, 2 XPS desktops, the XPS 15, and I just bought an Inspiron 15 5000 on June 3, 2017.
How about some help?
This is the battery that is currently installed and my system info:
Last Scan: Battery (Manual) Monday, July 24, 2017 8:01 :54 AM
Microsoft ACPI-Compliant Control Method Battery
Battery Name: DELL 1 P6KD54
ePPID: CN01P6KD717695AHK1KAA00
Manufacturer Name: SMP
Manufacture Date: 10-17-2015
Battery Serial Number: 1409
Designed Capacity Percentage: 83
Current Charge Percentage: 100
Current Charge: 84 Wh
Full Charged Capacity: 70.04 Wh
Designed Capacity: 84 Wh
Voltage: 12.97 V
 
Product XPS: 15 9550
Service Tag: <Service tag removed>
Express Service Code: <Express service code removed>

A:Dell XPS 15 (9550) Battery swelling, need replacement but none offered on Dell Site

Thank you! I will check online and order a new battery...

Read other 6 answers
RELEVANCY SCORE 53.6

I recently purchased the Dell USB-C to VGA/HDMI/USB/Ethernet Adapter (Dell 470-ABQN) to use as a dock with my XPS 15 9550. Unfortunately while using this adapter the fans run at a very high speed, approximately 80%, and are therefore loud and disturbing during meetings and desk work. I have it connected to only an HDMI monitor and a USB mouse receiver. The fans also run constantly when using the built-in USB and HDMI ports, but at a tolerable level. I will have to return this item without a fix, so could someone at Dell please advise if there is a solution or if this is a known issue that will be reviewed? I have updated both the Thunderbolt firmware and software and applied all Windows Updates. Thanks

A:Dell XPS 15 (9550) Fan Speed w/ Dell USB-C to VGA/HDMI/USB/Ethernet Adapter

I have the same problem here. I connect a usb-c ethernet adapter in my case. The fan keeps running when the adapter is connected. 

Read other 43 answers
RELEVANCY SCORE 53.2

I've bought TB16 and update all drivers (Dell Assist does it) and after lowing network settings to 75% my DELL monitors flickering less but now I have major issue since my Dell Adapter - USB-C to HDMI-VGA-Ethernet-USB stop working completely. When I plug in nothing happens (yes, adapter is working properly and yes cables are correct)
In first few days, randomly, Windows was enable to turn on output to adapter (after hour of plugin, plug out same adapter).
Now, it's completely useless. 
Can anyone help, any suggestion ?

Read other answers
RELEVANCY SCORE 53.2

So basically - as the subject says - 
Having a brand new Dell XPS 15 9550
with most recent Dell Wireless 1830 802.11ac drivers
cmd command "netsh wlan show drivers"
shows that current driver does not support hosted network,
meaning, that i am unable, for example, to share my ethernet internet connection Over wifi to other devices - i am unable to make my laptop a hotspot.
Which is ridiculous in 2016 and for a laptop of this level and is basically a prerequisite to be Windows 10 approved.
So my question is DELL, what the ***? When do we get normal drivers?
Anybody has the same issue - knows the workaround? Thanks.
I could not have expected that 2000$ laptop would not be able to do that. this is soul crushing.

A:Dell XPS 15 9550 - Dell Wireless 1830 802.11ac - Hosted network supported : No - cannot share Ethernet connection over WiFi

same here. :( XPS 13 9350..

Read other 4 answers
RELEVANCY SCORE 50

Hello everyone. after my last "dell update" ive had some SERIOUS issues with the battery.. i can charge it to 100% shut down the screen lid, and its discharged next morning when i wake up. 

i live in Denmark, and the warratny rules are propably different here in other countries, but here we can call the sales place, and open up a warranty case, here at dell it seems that we are FORCED to go through a lot of different steps before being able to open up a warranty case. isnt there any way to avoid all those "trouble shotting" with AI bots they have hired to filter out the customer's wanting to open up a warranty case

i have paid for premium support, but when i called the last night they wanted me to call back, but for whatever reason it was, i dont know
I now have a spacebar that is squeaky, a battery that is discharging, and a monitor that randomly starts blinking. oh yeah and if you have the dell sound software turned on and you try to dim the light on the monitor by using FN+ F11 or 12 you get a lot of statis noise in the speakers.

Pls can someone help me, and the regular warranty is about to run out in 17 days, and i want this resolved asap. I am afraid that dell might postpone this to make the warranty run out :(
im new to using Dell services and dell forum's but it seem like a very big job to open up a simple warranty case

Regards

Read other answers
RELEVANCY SCORE 49.6

Hi,
I have recently bought the 2016 Dell XPS 15 (9550) and for some reason it does not connect to enterprise networks, specifically 802.11k and 802.11r. I cant find a fix and neither can Dell support or the "IT guys at school". Im just wondering if anyone has any bright ideas. Thanks

I have all the latest drivers, BIOS and everything.

Read other answers
RELEVANCY SCORE 49.6

HI All,
i have the same issue, my new Dell XPS 15 9550
it was working just great for two weeks, then suddenly one day, its temp. gets too hot even when i'm not working on it,
any help guys,
i'm getting carzy

Read other answers
RELEVANCY SCORE 49.6

I have the XPS 15 with 32 gb SSD + 1tb HDD. I was planning to unraid both drives and swap the 32gb SSD with a 512 gb one. However, after some digging, I found that the ssd slot is for m2 SATA which is quite slow compared to NVMe SSD. So, I just wanted to know. Can the samsung 960 PRO (NMVe PCIe) fit in this or do I have to get an m2 SATA SSD like the WD blue SSD?  

A:Dell XPS 15 - 9550

Which generation, 9550, 9560? Both support m.2 NVMe, 960 EVO or PRO should be fine. With the PRO you must use a thermal pad to take some heat to the case (2mm thick but soft fluffy standard type, not some dense world-class-thermal-conductivity kind) - doesn't harm with the EVO either.

Read other 2 answers
RELEVANCY SCORE 49.6

I have a Dell XPS 15 and a Dell Dock WD15 which has been working fine for a long time but recently the WD15 dock has been acting up after it is re-docked to the laptop.
Everything works fine if I start the laptop with the dock plugged in but after re-docking the USB ports and Network (cabled) stops working. Everything seems fine with the drivers and as said it only happens after re-docking.
I've tried to rollback drivers and even downgrade the FW on the dock but the problem remains. The only way to "fix" it seems to be to restart the laptop after re-docking.
Running Win10 64-bit.
Any suggestions?

Read other answers
RELEVANCY SCORE 49.2

I know this has been mentioned on here multiple times but the fan noise from my laptop when its plugged in is unbearable. When i play a game or watch a video on battery power the laptop stays nearly silent and is a joy to use, as soon as i plug in to charge the battery the fans go crazy.
I can't even play a on graphics hungry game like FM 2017 without the fans running at over 80% power at low temps.
Do i need to return the laptop or is there a fix for this?

Read other answers
RELEVANCY SCORE 49.2

Hi. I just want to know if anyone has used the dell xps 15 9530 skin from skinit and applied it onto the new 9550 model? Will it fit fine? I don't like any of the skins for 9550.

Thank you!

Read other answers
RELEVANCY SCORE 49.2

The FHD screen has a bit of a color issue. When I am on a white page, much like this one, I can see that the left half of the screen is a darker tinge of red. Why is this, I know it isn't a driver issue and I can't seem to troubleshoot the problem. I have only seen one other poster who claimed they had this issue on another website. Now this color change is hardly noticable when in a video but it is quite bothersome when I am browsing the internet. Anyone know a fix or why this is happening?

Read other answers