Over 1 million tech questions and answers.

lenovo Y520-15IKBN external display problem

Q: lenovo Y520-15IKBN external display problem

Hi all,I have one dell S2340L which is tested and working complete fine on another lenovo laptop, but when connected to my new Y520-15IKBN, it is not working at all. the Y520-15IKBN is windows 10, and it detected this LCD in OS, i can duplicate and extend it, but nothing shown on this dell lcd. things i have tried, -reinstall all latest intel and nvidia driver-change all possible resolutions and refresh rate. i cannot reset this OS because i have a lot of important working documents in it, please guide what else i can try.

Read other answers
RELEVANCY SCORE 200
Preferred Solution: lenovo Y520-15IKBN external display problem

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 97.2
RELEVANCY SCORE 97.2

Hey everybody, I am trying to install Windows 10 x64 over USB (Created with Microsoft tool).BIOS version: 4KCN43WWWhat I want is to install Windows in UEFI Mode (Not legacy), but when I set everything in BIOS I can?t see USB on boot menu.I can use it and install it when I set: Boot Mode: Legacy SupportBoot Priority: UEFI First But that is not an option, I don?t want my Windows to be on Legacy mode.I am not able to install it like that and switch to UEFI after, keep getting error that HardDrive cannot be found.SATA Controller Mode is on ACHI.OS Optimized Defaults is on ENABLED.Secure Boot is DISABLED.Fast Boot is DISABLED. If anyone has any solution that I didn?t try it would be great.

Read other answers
RELEVANCY SCORE 96

Hello all. I am about to buy the Legion Y520-15IKBN. It's the i7-7700HQ, GTX 1060  version. I have 2 questions though before I buy it.  1. I have a Seagate Barracuda 5TB 2,5" HDD, a Samsung 960 Evo NVMe 500GB and a HyperX Impact 16GB DDR4-2400 laptop RAM. Can I install them on this model or if I open it it will void the warranty?  2. The laptop comes with no OS. I have Windows 10 on my desktop PC. Since Windows are connected to the Outlook account (I think), will I be able to install and activate them on the laptop or I have to buy new? Thank you very much for any answers

Read other answers
RELEVANCY SCORE 95.2

First of all I am sorry for my english but i don't know what to do.I've bought new lenovo legion y520 laptop month or two ago (with i5-7300HQ, GTX 1050 2 GB VRAM, 6 GB RAM, 1 TB HDD) and my gaming experience is pretty bad so far.I tried some games and my fps are the same like on my old desktop PC (more than 6 years old) with i3-2130, amd radeon HD7770 1 GB VRAM and 8 GB RAM. I've tested for example Assassin's creed black flag (same settings on both devices) and my fps were nearly the same on both (around 45 FPS).Then I've tried Battlefield 3, Subnautica and few other games but my biggest issue is with Star Wars Battlefront 2. I checked the minimal system requirements and I should be able to run it quite well atleast on low settings but the game is stuttering so terribly. It is unplayable. But my old PC that don' t enven have minimum requirements runs it better and pretty smooth with MSI afterburner keepin fps at 30-50.I didn' t expect any wonders from this laptop (smooth 40 fps is fine for me) but I've expected that I'll be able to play atleast some older games pretty well. The question is: Is it normal or something is not allright with my laptop?I tried installing all drivers from lenovo website (install them manually), reinstall windows 10, celan install windows 10, find newest Nvidia drivers, change graphic driver settings but nothing helped.I've also noticed that while playing star wars battlefornt 2 on old desktop my graphic card usage is quite stable but while playing o... Read more

Read other answers
RELEVANCY SCORE 95.2

Hello Lenovo community!I'm newbie here, have searched how to post a new topic for about 10 minutes i think.. -.-, but came here with a serious question. Believe me, i searched whole youtube, this forum, and couldn't find anything to help me, so i decided to try to ask for help by myself. (sorry for my bad english btw.) I feel pleasure, thinking why i didin't done this before, i will talk with a REAL PROFESSIONAL's HERE! Im very exited ^^ excuse me, im just very emotional type of guy.. So lets stick with the topic. All i want, is undervolt mine Lenovo Legion Y520 laptop.Spec : CPU - I5 7300HQ            GPU - Nvidia Geforce 1050 (2GB version)            Windows 10 Professional 64bit            Samsung 960 EVO NVMe SSD 256 GB            HDD - Seagate 1TB            RAM - 16 GB DDR4 2400MHz Have anyone tried it? with the same laptop as mine? my goal is to lower temperatures, and increase FPS stability in games. After christmas, i will buy new thermal paste (Thermal Grizzly Kryonaut) and will change the original one with that one, also i will clean all the dust possible. After it, i want to undervolt it, but there is problem. I dont know how. All i know, that for the CPU i should use XTU software, for a GPU (MSI Afterburner), but what to do next.. is a pain for me. I've bough this laptop, it was expensive for me, i really love ... Read more

Read other answers
RELEVANCY SCORE 95.2

Hi all, sadly my legion has stopped working. When it happened : short story is, when I was gaming. My headphones died, wireless through usb.  And in that same moment when they died. My laptop shut off without warning.  Also had mouse and charger plugged in.  Now, when I hit power button the power light on the side turns on. But   no power to the   screen    or     fans.  (Edit: Forgot to mention my keyboard does not light up either. ) When i plug charger in the charging light works also.  I don?t really know too much about this Subject sorry.  My warranty expired back in May this year. So I wanted to see if anybody had similar problems, or even had a solution to this.  Anythign helps. Thanks for taking the time to read and help. 

Read other answers
RELEVANCY SCORE 95.2

Hi everyone,I've got a Lenovo Legion laptop with a year old BIOS. I need to update it however on the website with the driviers the BIOS update is missing and I can't find it anywhere else. My PC is having serious issues with performance in games and after contacting Nvidia I was told to update my BIOS first. I need this update as fast as possible because I basically can't use the laptop without it. Also I can't contact any sort of support or chat because my product is apparently "not supported" and no one has replied to my emails a week now. Thanks in advance! 

Read other answers
RELEVANCY SCORE 94

Good morning! I was hoping someone might be able to give me the benefit of their experience(s) between these two wireless card options: Lenovo AC Wireless (1x1) vs. Lenovo AC Wireless (2x2). In configuring my specs for the model I'm considering, I was not given the option to change to (2x2), although both are "Lenovo AC Wireless" ( which I assume is ac wireless capability). Will I regret having to go with (1x1)--or will there be no significant slowdown or issues with this difference? Thank you for any information you can offer!

Read other answers
RELEVANCY SCORE 92

HelloI have Lenovo Legion Y520 15IKBN LaptopSpecs:Intel Core i5-7300hq (2.5ghz, turbo 3.5ghz)GTX 1050 4gbRAM 8gb 2400mhz dual channel1TB HDDWindows 10 Pro 64bit I have a problem with the cpuMy cpu run at 2.4ghz while i playing games (ex: GTA V, Far Cry 5, Mass Effect Andromeda, etc)The temps is fine around 60-73'cI can't understand why my cpu stuck at 2.4ghz speedPlease help me!

Read other answers
RELEVANCY SCORE 91.2

Dear all, I have this gaming laptop some time ago and now would like to change the 128Gb with a 500Gb or 1Tb. Which Samsung or Crucial SSD are compatible to fit in my Laptop? Regards 1 screenshot 

Read other answers
RELEVANCY SCORE 88.4

Hi allLegion Y520After one month white spot on the right corner at bottom, after driver upgrade in July, flickering and ghost effect on the screen.Via hdmi to external monitor no issue.I did downgrade of video drivers but nothing happen.Nobody had and solved same problem?Tried different solution found on forum but no effect, very disappointed, thx for help 

Read other answers
RELEVANCY SCORE 84.8

Debasmita from LENOVO threatening me that she will see how my issue will get resolved if I don?t listen to her. Lencare ID# C180312002 || S/N# PF0VK59K || SO# 7008546861 I purchased my laptop four months? back and on March 7th I registered a complain of Laptop Screen is dead and if I connect to HDMI port to another screen it works. The engineer visited to my place on 10th March and replaced the display screen, while opening the laptop the screen packing was loosen up even after my request the engineer kept saying nothing will happen to the new gaps which were formed after display screen replacement. After few hours of service, the screen started flickering again and got completely dim, now the display works sometimes and sometimes it won?t.I register the complaint again on display screen, they sent an engineer after two days and opened the laptop again to check the same display issue, engineer not only opened display Screen but also back panel of the laptop.The display screen issue he confirmed the display will need to replace with one cable and Basel, total three parts. He took pictures of screen frame gap and noted the same in service slip that the laptop packing is gone off and will require new packing. After he went off I observed that now my laptop?s touch pad light has switched off completely.There was only one issue with display but LENOVO service support has introduced few more issues now 1-  DISPLAY ISSUE was introduced - Reason (Auto... Read more

Read other answers
RELEVANCY SCORE 76

Hallo zusammen, ich habe gestern meinen neuen Legion Y520 15IKBN bekommen. Es hat kein Betriebssystem mitgeliefert, daher wollte ich von einer bootfähigen externen Festplatte Windows 10 installieren, aber irgendwas hat mit dem ISO-Abbild oder der externen Festplatte nicht gestimmt, sodass die Installation noch recht am Anfang abgebrochen wurde. Der Laptop hatte dann einfach einen Lila-Screen gehabt und auf nichts reagiert, daher habe ich ihn mit der Power-Taste ausgeschaltet. Heute habe ich mir einen USB-Stick besorgt und wollte die Installation nochmal versuchen, aber als ich den Laptop einschalten wollte, passierte nichts, außer dass die Tastaturbeleuchtung anfing zu blinken. Es sind auch keine Lüftergeräusche zu hören oder sonstiges. Ich habe bereits versucht das Akku-Kabel zu entfernen und die Power-Taste 20 Sekunden lang zu drücken, das Blinken hört dann zwar auf, aber wenn ich die Power-Taste wieder drücke, blinkt die Tastatur wieder. Die Novo-Taste reagiert ebenfalls nicht. Was könnte ich denn noch versuchen? Viele Grüße

Read other answers
RELEVANCY SCORE 75.2

As I see this machine has three fan speed level. Let's just say low, medium, high. My machine is about 2 months old and since I bought and installed the system I cannot go on this loudness. I read several reviews before buy and lot of mentioned this but I thought it's not as noticeable as they say. Now I see that this is definitely annoying. No matter if the machine is just idling in a COOL (about 18-20°C room) environment the fan will switch to medium after a short time without no reason. Checking with AIDA I don't get it why is it neccesarry to spin up the fan when the hottest part is the CPU and it's running on 40-45°C. No activities, no stucked services or applications. A few idling opened application should not cause this and I'm sure it's not a hardware failure. Everything works properly. I guess it's just not finetuned. So are there any way to tune the fan to not get a headache when just simply browsing? Or BIOS tweak? Or maybe an update?

Read other answers
RELEVANCY SCORE 75.2

We have a Legion Y520 15IKBN in the family.Our fastest computer, but with some big problems.  Our legion have only 1 harddrive:  The SSD is split into C: and D: After some problems we reinstalled fresh Win 10 from the pin-Button, System Restore, Recycle option. New problems appeared:  Admin users have no access to C:  Message:  ACCESS DENIED And Task Manager refuse to run.  We may enter Control Panel, but Device Manager refuse to run.  I have never seen any computer like this.  I'm lost. Is there any settings in BIOS that can may this computer act like a normal computer? Please help us. Thank you.   

Read other answers
RELEVANCY SCORE 72.8

Hi there, I did buy this Laptop 10 days ago , and i have a problem with Display.  I have a white color in the right of Display.Can u helo me whats is this , its any problem or what ?I'm waiting for your ReplayBest Regards

Read other answers
RELEVANCY SCORE 72.8

I got Lenovo Y520, and after installing Windows10 professional edition, and all of dirvers from Lenovo official website, I got some blurred screens like:  Is this normal? if not, how can I solve this?

Read other answers
RELEVANCY SCORE 72

I did buy this Laptop 10 days ago , but in the right of Display are some white color's bleeding . I dont know what is that?I need to help me somebody what to do.Best Regards

A:Lenovo y520 Display white Bleed

Hi lumriver,
 
Welcome to the Commmunity Forums.
 
You can call technical support or the store and have them informed so they can provide you options to proceed.
 
Regards

Read other 1 answers
RELEVANCY SCORE 69.2

[email protected], hopefully someone can help.  I got a Lenovo Yoga 3 Pro 13 80HE004LGE for half a year.  Intel Core M-5Y70 1.1 GHz + Intel HD Graphics 5300, Kerntakt: 100-850 MHz, Dual-Channel, 20.19.15.4444 I used it with an external DELL 24" screen in extension setup WUXGA 1920 x 1200 pixel. Worked without any problem. Now changed the screen: DELL 27" (Dell U2713HM) . This screen should be able to provide WQHD 2560 x 1440 pixel but max I can choose in the set up (Win 10) is Full HD 1920 x 1080 pixel. I did the full program; 1. deleting drivers (Graphic and Monitor) reinstalled newest versions provided from Lenovo/Dell website,2. tried 3 different cables (HDMI and DVI), no differences :-(3. Installed Dell SetUp tool4. Installed intel set up tool (Could enter the high resolution manually here as personal setting, but does not work either) Nothing helped :-( screent stays on 1920 x 1080 :-( This 27" screen was running connected to a MacBook Pro without any problem in max. resolution 2560 x 1440 before.  Due to my research the Intel HD 5300 should be able to handle 2560 x 1440. Looking forward to helpful repliesDennis 

Read other answers
RELEVANCY SCORE 64.8

Hello everyone! I've got a problem with my Lenovo y520, bought about 3-4 months ago, I noticed that sometimes one white line at the bottom of the screen may appear out of nowhere (see screenshots), though it usually appears when I'm playing games. The line stands just at the bottom part of the screen, more exactly at the bottom part of the task bar. I must say that this problem didn't start to occur when I bought it, but after a while. Also, I noticed that while I'm playing video games, the screen would flicker (like a very short shut down) for 0.1 seconds, if you blink you'll literally miss it, and then the line appears. Sometimes, the screen flickers again and the white line would disappear. This problem doesn't occur everytime I play, but sometimes. The white line remains still, unless I restart the laptop. Now, I'm asking you for help, what is the cause of this problem and how can I solve it resulting in no appearances of such weird lines on my laptop's screen?Thanks.

Read other answers
RELEVANCY SCORE 64.8

Hey all,  Just recently bought a Lenovo Y520 gaming laptop. Overall very satisified with it! Last week I added an SSD drive to it and decided to do a fresh reformat from the BIOS so the laptop would run at full power without any bloatware holding it back.  Did the reformat sucessfully, installed all drivers, and now the laptop is running perfectly, except for one thing.  Since the reformat, Wifi has been giving me constant problems. I've tried just about every solution available on the net but so far have had no luck. It's main issue is: when I go to power on the laptop after being turned off for an extended period of time (at least 8-10 hours), there's no wifi at all whatsoever. Windows doesn't detect my wifi at all, even under network adapters! I've downloaded the latest drivers directly from Lenovo and even took it one step further by getting direct drivers from intel themselves. In this condition, it only detects my ethernet port, so when I go to diagnose it, it doesn't consider Wifi an issue because it doesn't think it exists.  The ONLY solution to get Wifi to work for me is to restart the computer at least once, load up the BIOS, go to the Configurations tab and disable/re-enable Wireless Lan. After that, I boot it with the saved changes and boom, Wifi suddenly works again. Thing is, I shouldn't have to do this every time to get Wifi to work. Before the reformat, the Wifi was working absolutely fine with no issues whatso... Read more

Read other answers
RELEVANCY SCORE 64.8

My legion y520 will run a game for a little bit then crash then all my games will stop working and give me various errors such as unable to start 3d acceleration and other directx related errors. Also geforce experience keeps telling me something went wrong try restarting geforce experience over and over

Read other answers
RELEVANCY SCORE 63.2

Hi! My name is Greg and i have a huge problem with my freshly bought SSD. Its a WD Blue M2 Sata, i did research before i bought it so that its truly compatible with my lenovo y520. After i removed the back cover, i put it in place in correct way. I started the laptop, but the SSD cannot be recognized nor in BIOS nor in Disk Manager. I did so many forum research, i also reinstalled my windows 10 in AHCI mode. Nothing helped. Please if someone have a solution i would be so thankful.Yours SincerelyGreg

Read other answers