Over 1 million tech questions and answers.

X390 multiple 4k display issue with Thunderbolt 3 dock gen2

Q: X390 multiple 4k display issue with Thunderbolt 3 dock gen2

I am attempting to conenct multiple monitors to my x390 through the thunderbolt dock. The first monitor comes up fine with 3840x2160 resolution. However when I connect the second monitor it comes up as 800x600. I do not have the option for the second display to change resolution. x390 s connected to dock via Thinkpad TBT cable 40G I have ran lenovo software updates and I am at the latest software version for everything. I tried the windows display app and the Intel display app and both are showing the same behavior for the second monitor. I have tried reversing the order of connecting the monitors. The first one to connect always goes to 4x, where the second one connected always reverts to 800x600 without the option to change, I have tried turning off the built-in-display to see if that would change anything, but it didn't. I have tried swapping the port on the dock that the monitors are connected to. The first monitor always correctly displays at 4k and the second is set to a much lower resolution typically 800x600 without any options to change. The intel app has an option to change the refresh rate, so I tried changing to a few different refresh rate to see if that would change anything, and it didn't help. I had the monitors connected via hdmi, so I switched both to display port and now I get 3 options, but the max is 1280x720. I still do not get the 4k option. I then tried one connected via hdmi and one display port, with same results as both hdmi. Still no 4k option on 3rd display. Any ideas of how I can get to external monitors to run at 4k with Windows 10 and yoga x390? Environment:Brand new yoga x390core i7 8th gen2 qty - LG HDR 4kThunderbolt 3 Dock Gen 2 with 135W power cordIntel 620 dispay driver: 26.20.100.7262?Windows 10 enterprise: 10.0.18362

Read other answers
RELEVANCY SCORE 200
Preferred Solution: X390 multiple 4k display issue with Thunderbolt 3 dock gen2

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 107.2

Hi, I'm having issues with my external 4k display to only be able to operate at 30Hz. I have my laptop connected to a generation 2 Thunderbolt 3 dock via the provided cable, and from there I have tried both DisplayPort and HDMI cables (several) to connect to my display.All the technical information I have seen says that my laptop plus the dock should be able to operate at 60Hz even at this resolution, but I'm unable to lock down the settings that enable me to do that. I have pulled the latest BIOS, TB3 FW, display drivers, Intel chipset drivers from the product page.My screen is: AOC U3277FWQ if that matters. I'm running Windows 10 Pro 1809. Has anyone battled with the same issue? I'm running out of ideas on how to solve this. The HDMI port on the side is apparently only 1.4 so this would only support the [email protected], but I'm not using it at the moment. If I set the screen to 1920x1080, I can set the resolution to 60Hz. Best regards,_tero

Read other answers
RELEVANCY SCORE 104.8

Hello, I am using the x1 carbon 7th gen 20QD and trying to get ethernet to work through the thunderbolt docking station.  I have installed all the drivers from the lenovo site for the gen1 and gen2 thunderbolt dock and ethernet still does not work through either thunderbolt docking station.  Ethernet works fine with the usb-c travel hub and the ethernet adaptor that plugs in next to the USB-C works as well.   I have also swapped the dock out with the thunderbolt dock on my yoga 370 and ethernet works through the dock on the yoga. Any ideas? 

Read other answers
RELEVANCY SCORE 95.2

Hello, I've got a X390 Yoga and a ThinkPad Thunderbolt 3 Docking Station. The Problem is that the Docking Station isn't working. The on/off switch works, but my Monitor/Mouse/Keyboard/LAN/Printer that are connected to the Docking Station don't work at all and can't be detected. I already updated all drivers with the Lenovo Vantage App. I also tried updating the Firmware of the Docking Station but the Installer doesn't find the dock. Thank you for your Help.

Read other answers
RELEVANCY SCORE 92.4

Hello everyone.   We are fairly new to the Lenovo community and have started to deploy the Yoga X390 to some of our more travel heavy employees.   A couple of them have come up to me with this odd problem.   Let me set it up for you... User has 2 external monitors plus uses his laptop screen.   In the case of the screenshot below, he had MS Teams open full screen on the laptop screen.   He disconnects from the dock and this artifact of Teams (In the red box) stays on the screen until he reboots.    This will happen with whatever application is open on the laptop screen when disconnected from the doc.   We have updated the display adapter driver with no change in result.   We pushed the Thunderbolt updates when they were announced late last year and confirmed success.   Any ideas?  

A:Yoga x390 screen artifiact when removing from Lenovo ThinkPad Thunderbolt 3 Dock Gen 2

Hi WildWildBil!
 
Welcome to our forums community.
 
Does it happen even if the external display is directly connected to the laptop? Does was this add on attached? Is it from the Calendar app? Have you tried removing the add on and reinstalling it back? Let us know.

Read other 1 answers
RELEVANCY SCORE 92.4

Hello everyone.   We are fairly new to the Lenovo community and have started to deploy the Yoga X390 to some of our more travel heavy employees.   A couple of them have come up to me with this odd problem.   Let me set it up for you... User has 2 external monitors plus uses his laptop screen.   In the case of the screenshot below, he had MS Teams open full screen on the laptop screen.   He disconnects from the dock and this artifact of Teams (In the red box) stays on the screen until he reboots.    This will happen with whatever application is open on the laptop screen when disconnected from the doc.   We have updated the display adapter driver with no change in result.   We pushed the Thunderbolt updates when they were announced late last year and confirmed success.   Any ideas?  

Read other answers
RELEVANCY SCORE 91.2

I am having an issue with the Thunderbolt 3 dock with my Gen 5 X1 (20HR). Upon purchasing the correct replacement (Lenovo Recommended)  cable for length reasons. I cannot use the dock. The port one the dock heats up and the cable cycles on and off. Thus giving me undesired results. I've tried 3 different cables now and still the same results. The computer acts as if I've disconnected and reconnected the cable over and over. Until it is disconnected. What should we do?

Read other answers
RELEVANCY SCORE 90.4

Dear helpy helpers, I am experiencing a heap of trouble when using T490 and Thunderbolt 3 Dock Gen 2 together.When we recieve a new machine, we reinstall it, with a clean latest version of Windows, and run TVSU for the lastest drivers. Software wise, they get Office, Visual Studio, ReSharper, SQL Server Management Studio and Symantec. Nothing fancy. The last 3 machines hav had issues with the docks. The docks are 135W (cable plugged in the correct power port on the dock). Cable for the PC is on the back and not the front. Screens that wont run full resolution, no ethernet, no charging and the like. Checking the Thunderbolt Control Panel, the dock is connected. Reinstalling wont solve the issued, but getting new motherboards for 2 machines worked somewhat. I've been managing Lenovo laptops for 10 years now, and though i don't see myself as an expert, I have seen quite a few different models, and experienced different issues with docking solutions. Though. Nothing. Like. These. Thunderbolt. Docks.  Is anyone else having trouble, or am I the only one fighthing this? I am thinking about running back to Windows 10 1809 instead of 1903, but I dont really like having to be vary of backwards compatibility with a simple setup as above.  Any help would be hawt!

Read other answers
RELEVANCY SCORE 80.4

I have a P1 GEN2 OLED. While the internet is flooded with complaints of the OLED screen itself, the thunderbolt 3 port of my P1 GEN2 magically stopped working for no reason.  I have been using the laptop with an external display ever since I got the laptop. All went well. Suddenly from yesterday, the external display starts turning into a blue sreen with "NO SIGNAL" shown on it.  I had a windows cumulcative update (KB4532693) and windows security update (KB4524244) yesterday and I suspected that the update might be the culprit. I rolled back the OS. No change. Still NO SIGNAL.  I searched this Forum. Played with Thunderbold 3 menu in the Bios. Everything was enabled and every single option of "security level" was tried. Still NO SIGNAL.  I checked Intel Mangaement Engine software. It is already the latest version. Reinstalled it. Still NO SIGNAL.  I checked Nvidia driver. Latest version already.  In sum, the problem is: the thunderbolt port is still able to power the extenal display but just simply does not pass signal to the external display. HDMI port, however, still passes signal if use an HDMI cable.  I want to give it a shot here to see if anyone has experienced similar issues and how they sovled the problem before I call Lenovo technical support, the staff of which does not seem to know more than some people here on this Forum. 

Read other answers
RELEVANCY SCORE 77.2

Issue 1I purchased the ZBook Studio G3 + 2 months wait on the Thunderbolt 3 Dock to primarily connect 2 4K Samsung monitors.  When connected via the display port one will display at 4k while the other will only display @ 2560X1440.  I had bought a a couple of CableMatters thunderbolt 3 X display port adapters while waiting on the dock.  If I plug one of the monitors in using the adapter and the other into the display port both will display 4K.Anybody else having this issue? Issue 2After the computer goes to sleep only one monitor will wake up.  The NVDIA control panel still shows both connected.  Only way to get the second monitor awake is to shutdown and reboot. Issue 3I have the displays configured to go blank after 1 hour.  Once this occurs and I enter my password all of my open programs are displayed on one screen rather than on both.  This would be normal if you have undocked and re-docked a laptop. Issue 4If the laptop is opened while docked. One display goes blank and one is duplicated with the laptop screen.  This is not typical docked behavior.  I moved from an  Elitebook 8540W with dock.  I'm really questioning my whether this was an upgrade.

Read other answers
RELEVANCY SCORE 76.8

Just started using TB3 Workstation dock (40AN0230EU) with P1 gen2 (20QTS06300) and ran into some issues.Hopefully someone can help as this is geting annoying really fast. Dock is flashed with latest firmware (3.1.64).P1 gen 2 is flashed with latest BIOS (1.26).230W and 135W power supplies are connected to the dock.P1 is connected to the dock via the provided absurd power+tb3 cable (if need to connect 2 power suppllies, one of which is bigger than the dock itself, wasn't absurd enough).P1 BIOS TB3 security is set to no security, TB3 BIOS assist is set to disabled, gfx is set to discreete, monitor to external. I have 3 monitors connected to the dock. After a cold reboot everything is more or less fine for a few minutes, then all the displays go blank for the moment and windows pops up a notification about slow charger being connected. This keeps going on every now and then again and again. I thought the entire point of using this absurd cable is to overcome the TB3 100W power delivery limit?

A:P1 Gen2 + TB3 Workstation dock - slow charging issue (Win10)

There was an issue with the P1 and BIOS 1.23 which had the same issue, but this was corrected with BIOS 1.24. It sounds like the same issue is present in the P1 Gen2.

Read other 1 answers
RELEVANCY SCORE 76.4

Hi All,  I recently got two 1920x1080 monitors and have been attempting to hook them up to my Thunderbolt 3 dock and X1 Carbon with no success. All firmware has been updated, and the dock detects each display individually, when the other is disconnected and reconnected. Everything else works on the dock with no issues.  Thanks.

Read other answers
RELEVANCY SCORE 76

I used the Lenovo System Update (v5.07.0074) and was prompted to download and install (was listed as Critical Update) the Firmware to my Dock.  As always, I closed all applications and sat as the Firmware downloaded. I got the expected prompt to ensure I was plugged in. I then watched as the upgraded prompted me to install. Installation completed and everything appeared to be fine.  I powered down the thinkpad and disconnected. Worked from the living room, then went back to the dock. Connected, and noticed that before I connected the White light on the power button was illuminated. Shrugged, and pushed the power button. Nothing. I un-plugged the Dock, got a cup of coffee, returned and plugged it back in. Nothing. I then noticed that none of the pass-through power was working on the dock.  So, I unplugged it again.  Unplugged everything connected to it, and held the power button down for 15 seconds in an effort. All of this at the recommendation of Lenovo Support. Who, by the way, was very nice and well spoken. Nothing we did worked. I happened to have another Thunderbolt 3 cable in my bag, and no change. I powered up my new X1 Yoga, and connected the cable. No power. This wasn't passing power at all. I confirmed the Intel Thunderbolt app was running, and confirmed that Windows was not even detecting the Dock.  Lenovo is sending me a replacement. I had this one all of a week. Did I miss any other steps while I wait for it to be repl... Read more

Read other answers
RELEVANCY SCORE 75.6

I just started having this problem today.  Updated to the latest firmware a few days back on this 150w Thunderbolt Dock P5Q58UT#ABA per the e-mail "Critical Driver Alert - Apr 12 2017 HP Thunderbolt 3 Dock Firmware (ver 1.12 Rev.A)".  Today when plugging in my secondary display is corrupted.  To note I have two of the same docks, one at home and one at work with different monitors in each location.  I'm getting the same issue in both locations.  I don't think two docks went bad and the thunderbolt ports appear to be functioning.  Is there a way to rollback the firmware on these docks to see if that's the issue?   If not what are the next steps to resolve, any advice?  The normal troubleshooting steps on HP.com don't appear to address this.  Pics attached.  

A:Corrupted Display on 150w Thunderbolt 3 Dock / Zbook G3 15

After naviging through HPs cryptic support website I found one firmware that was out of date.  After I updated the  Thunderbolt 3 Dock firmware the monitor started working right for now.  We will see...

Read other 1 answers
RELEVANCY SCORE 74

Has anyone had experience with this. I just purchased an XPS 15 9560 with a TB16 dock and I'm hoping to use the dock and my old Apple Cinema display, but I can't seem to get the monitor to work in the dock. I purchased an Apple Thunderbolt 3 to 2 adapter and the screen works fine when I hook it directly into the laptop, but I get a USB malfunctioned error when I hook it into the dock. Any information or tricks anyone else has found would be helpful. Thank you in advance.

Read other answers
RELEVANCY SCORE 74

Hi, I'm using the new ThinkPad Thunderbolt 3 Workstation Dock which came out with the P52 with my P1. So far it almost works fine when you boot up, but whenever I disconnect the machine from it after sending it to sleep or hibernation (like overnight)  and plug it in the other day the mouse and keyboard are not detected.I need to reboot the laptop to use them again with the dock. Thats really annoying. I thought it might be a driver issue but after updating to the newsest drivers from lenovo the problem persists. Has anybody a solution for that? Of course all other updates from Lenovo side are in  place..and I'm still using windows 10 1803.the mouse is a razer deathadder and the keyboard a Filco majestouch 2.Is that the typical glitch of a new product we always have to face as beta testers :-) Merci A

Read other answers
RELEVANCY SCORE 74

Hi, i have a T470 that connects to a UCB C Lenvo thunderbolt dock, occasinly it requires the firmware to be updated (i done this last month) however it is erroring again saying i need to conncact my pc manufacturer for new firmware, i have just checked and there is no new firmware on the lneovo website, i installed all the latested packages that were there, does nayone know where i can get the new firmware and if there is any workaround? The dock is not showing as connected in the dock software window, however the dock light goes from yellow to white when i polug it into the laptop, so it does see the connection they just cant talk to each other. Thanks 

Read other answers
RELEVANCY SCORE 74

Hi! I´ve just bought 2 new Full HD monitors to feed them using a Thunderbolt 3 Dock. My problem: one of the monitors has a colour issue showing purple instead of green. Sometimes the right one, after restart the left one a.s.o. - I changed cables from DP to HDMI and VGA: ever the same- I´ve tried the second thunderbolt port of the docking station Once even the laptop´s display itself showed the wrong colours but it now works fine again.I´m not able to get the tweo external monitors working together with the right colours. Neither including the Yoga´s display nor when Yoga´s display is turned off. What to do...? Best regards!













Solved!

Go to Solution.





















IMG_4593.JPG ?739 KB

A:Yoga 370 & Thunderbolt 3 Dock monitor issue

Solution: Settings were changed in the Intel graphics settings AUTOMATICALLY for one display - one colour value has been set to a wrong value. As I´m the only one working with this machine it´s kind of weird - I´ve nevr been to the additional intel graphic settings before.

Read other 1 answers
RELEVANCY SCORE 74

Hi! I´ve just bought 2 new Full HD monitors to feed them using a Thunderbolt 3 Dock. My problem: one of the monitors has a colour issue showing purple instead of green. Sometimes the right one, after restart the left one a.s.o. - I changed cables from DP to HDMI and VGA: ever the same- I´ve tried the second thunderbolt port of the docking station Once even the laptop´s display itself showed the wrong colours but it now works fine again.I´m not able to get the tweo external monitors working together with the right colours. Neither including the Yoga´s display nor when Yoga´s display is turned off. What to do...? Best regards!


























IMG_4593.JPG ?739 KB

Read other answers
RELEVANCY SCORE 74

Hi all Recently got a Lenovo X1 Carbon (gen 6) and today got a Lenovo Thunderbolt 3 dock, part number 40AC0135AU . I have two 1080p monitors plugged into the dock, however, when the laptop is plugged in via the single TB3 cable, the laptop's fans constantly spin-up loudly for about 10 seconds, then turn off. It repeats this constantly. I have run all Windows Updates (on 1903), Lenovo Vantage updates, and updated all firmware and drivers (that I know of), but it's still doing it. Has anyone got any experience with this, as I can't focus on work with the fans constantly interrupting I don't want to send the laptop and dock back, but it's not suiting my requirements as is. Appreciate any assistance!

Read other answers
RELEVANCY SCORE 74

Hi 
I Just bought TB15 and stated using it.
The problem, however, is that my XPS 13 becomes pretty hot when it is connected to the dock.
It becomes hot and operates fan even for normal light uses like web surfing or listening music.
Is it normal issue that all the user have or abnormal?
Thanks!
----------------------------------------------------------------------------------------------------------------------------------------
Additionally, when i connect intel realsense camera to TB15, all devices connected to TB15 is disabled and does not work. The laptop must be restarted to be operated normally.

Read other answers
RELEVANCY SCORE 73.2

Hello I seem to have a problem on my P53 laptop, as the external displays, connected on the two HDMI ports on the Lenovo TP Thunderbolt 3 Workstation Dock(Product nr.: 40AN0230EU), they just randomly turn on on the first try. If they not turn on, on the first try, I have to put it back to sleep and then awake again at once. I always use the power button on the dock.So where can I see what firmware version I have for my Thunderbolt 3 Workstation Dock. I se that I have controller driver version 1.41.648.4.I've also search on Lonovo's site to find a download, but can only find this site: https://pcsupport.lenovo.com/us/en/products/accessory/docks/thunderbolt-3-workstation-dock/40an/down... but I can not see the workstation dock listed, just the Thunderbolt 3 dock, but maybe that cover's both? The version listed is: V1.0.0.20 of 07 Aug 2019. I'm also very confused about what dock I really have, is it the:  ThinkPad Thunderbolt 3 Workstation Dock, ThinkPad Thunderbolt 3 Dock Gen 2 or the ThinkPad Thunderbolt 3 Workstation Dock Gen 2 , or are they all the same as they seem to use the same driver if you look at this site:  https://pcsupport.lenovo.com/us/en/downloads/DS505148  , here the latest driver version are : V10015 of 23 Sep 2019. It's also odd that the Sep version(10015) has a lover number that the Aug version(10020)?  I'm also very confused as if the terms firmware and driver's are used correctly, and are there really 3 different... Read more

Read other answers
RELEVANCY SCORE 73.2

Hi, I  got Yoga 920 with Lenovo Thunderbolt 3 Dock that is connected to two 4k Samsung monitors. Just recently when I put Yoga 920 to sleep the monitors will switch off, but in 10-15 sec start looking for a signal.Basicaly screen goes to black (looks like monitor is off) and then in 10 sec it switches on a show blank screen with input name on (DisplayPort) and than it goes off and in 10 sec on with input name ..... this keeps cycling on and off. This is happening on both monitors. It's strange as it used to work fine untill recently (apropox 1 week ago). Im on latest bios with Yoga 920 and latest firmware for Thunderbolt 3 Dock and Lenovo Vantage says my system is up to date. The windows recently updated to Windows 10 (1709), not sure if that is related. Any help how to fix this issue?  

Read other answers
RELEVANCY SCORE 73.2

Hi all, We bought about 10 HP X2 Elite 1012 G1 along with Thunderbolt Docking station. I setup the laptop then installed the drivers for Intel Management Engine and Thunderbolt dock. Updated the firmware for Intel chipset as well. Since we setup these laptops user complain about the dock not getting detected by laptop. No matter how many times they restart. I went through each laptop and observed the following issues: 1- When I open the Thunderbolt software, it shows multiple HP docks in the attached devices with cross sign (which means the device is disconnected). It seesm that the Thunderbolt software creates multiple entries of the same dock then fails to detect it 2- When the laptop goes to sleep mode, the dock gets disconnected and then it doesn't get detected at all, even after reboot.  So far the only fix is as below: (which worked 90% of the time) 1- Uninstall both Intel management Engine driver and Thunderbolt Secure connect driver2- Install both Intel management Engine driver and firmware + Thunderbolt Secure connect driver BUT, this can't be a proper fix because in a corporate environment we can't go through this every single time. It's a total waste of time/money for a corporate. On top of that, users get frustrated by this issue that is ahpenning constantly. HP PLEASE FIND A PROPER FIX. PLEASE ALLOCATE YOUR IT PROFESSIONALS AND DEVELOPERS TO DIG THROUGH THIS ISSUE. We bought more than $2m ... Read more

Read other answers
RELEVANCY SCORE 72.4

I'm trying to work with support on this one as well. We have a fleet of ~30 6th gen x1c thinkpads, many hooked up to the Lenovo Thunderbolt 3 dock, model 40AC. Recently, we've had a rash of issues with USB connectivity through the dock. All of sudden, USB connectivity through the dock stops working. Any USB peripherals plugged into the dock no longer function. The resolution is to shut down the computer and use a paper clip to press the hard reset button on the bottom of the computer. If it's a one time thing that's fine, but I have no proof this won't reoccur. I'm brining each machine's drivers up to date with TVSU as I hit the problem, but most are pretty current.  Anyone run into this? Any ideas?

Read other answers
RELEVANCY SCORE 70.8

Got my T580 in 2019 May but still it is NOT my no.1 PC, I still rely on my 5yr old lenovo thinkcentre M93p. 1. The SD card reader will disconnect itself after 2 hours UNLESS you update to the latest driver version.At first I used my T580 air gapped, so this used me a lot of TIME to trouble shot. (ps now it's NORMAL,it's stable) 2. thunderbolt 3 seems is NOT matured enough for mission critial deploy.I always power on my PC for 48hr and then rest 10min, then turn on another 48hr.But my T580+ TB 3 dock gen 2 WONT wake up after my 8hr sleep.(even I press the T580's keyboard or touchpad) and haveto power off it intentionally--> lost of data, lost of UNKNOWN data. How do I know which document is not saved last nite?(in windows, monitor is set to turn off after 1 min, PC sleep set to never.)There are new TB3 driver/firmware last week, but I am a lab rat for drug testing now.  This T580 completely bad imaged lenovo for me,for which M93p is much more reilable.both running win10     

Read other answers
RELEVANCY SCORE 70.4

Hi all, In the past few days my laptop slowly degraded, starting with docking station connectivity not working (but does work with other laptops), then HDMI port not working (HDMI screen and cable works with other laptops), and now system no longer charges. Current status is that all USB-C ports (including charge) and HDMI port and not functioning. Computer doesn't charge when it is off, too.  I've looked at multiple solutions and threads on this website without any real solution. I've already tried - - run Lenovo Vantage a few times to check updates. Did the same on the Lenovo product website (using auto-discovery of serial #), everything is fully updated- Turned on/off Thunderbolt Service (on the Windows 10 control panel) - I turned it on and automatic but it always returns to Manual- Searched in the Device Manager for Thunderbolt (anything) - it's not there- Uninstalled and re-installed Thunderbolt software from the Lenovo website (both controller driver and FW, file names n1nta05w.exe and n1nth08w.exe)- Went to the BIOS/Configuration - enabled and disabled again all Thunderbolt related options - Used Paperclip to do hard reset using the emergency reset button Any ideas what left to be done?  Thanks!  

Read other answers
RELEVANCY SCORE 69.6

Hello My dear Lenovo Community I'am a new user of the Lenovo X390 Yoga and I'm really Happy with it. But I have 3 Imporant questions. Can I use this set to have a new tip on my Pen ( The one which comes standard with the Notebook)https://www.digitec.ch/en/s1/product/lenovo-pen-tips-styluses-10048632 Which of the 3 Lenovo Thinkpad pen pro is it? The 1, 2 or 3?Example for the 2https://www.digitec.ch/en/s1/product/lenovo-thinkpad-pen-pro-2-styluses-6011579 and here for the 3https://www.digitec.ch/en/s1/product/lenovo-thinkpad-pen-pro-3-styluses-5785544   Second, Is it possible to connect the usb C Thunderbolt with a Egpu likehttps://www.digitec.ch/en/s1/product/gigabyte-aorus-geforce-rtx-2070-gaming-box-external-cases-10719... (For me a Gpu like Gtx 1070 is enough) Because it stand it's Thunderbolt 3 but only wit 20 gb/s in  the description. I would be happy if there are any people who can help me.  

Read other answers
RELEVANCY SCORE 68.4

Hi,which 2m cable is compatible with the thunderbolt 3 dock gen 2?We tried the Belkin Cable (https://www.belkin.com/de/p/P-F2CD085/) with a Yoga X390.But it does not work. 

Read other answers
RELEVANCY SCORE 68.4

Hello everyone, I recently bought a Thinkpad X1 Extreme and I am now locking for a suitable Thunderbolt 3 dock. Although I've read a lot of posts about various docks I am still a little consfused about which one to choose. It seems like the following ones would all work with the X1 Extreme:1. Lenovo ThinkPad Thunderbolt 3 Dock Gen 2 135W:https://www.lenovo.com/ca/en/accessories-and-monitors/docking/universal-cable-docks-thunderbolt/Thun...2. ThinkPad Thunderbolt 3 Workstation Dock (170W):https://www.lenovo.com/ca/en/accessories-and-monitors/docking/universal-cable-docks-thunderbolt/Thun...3. ThinkPad Thunderbolt 3 Workstation Dock (230W):https://www.lenovo.com/ca/en/accessories-and-monitors/top-tech/Thunderbolt-WS-230W-dock-US/p/40AN023... Please correct me if I am wrong but to me it seems as if the only difference between these docks is that the workstation ones come with two AC adapters each and a special Thunderbolt/Power cable to avoid using two different cables. Or are there any other technical differences? So if I am okay with a two cable solution couldn't I just use the Lenovo ThinkPad Thunderbolt 3 Dock Gen 2 135W and connect it via Thunderbolt while at the same time use my 135W AC adapter to charge the laptop? Thanks a lot in advance.

Read other answers
RELEVANCY SCORE 68

Hello All, I am sure this has been mentioned in multiple ocassions here, I am trying to find the holy grail of docks, ideally lenovo branded that allows me to connect 2x 4k60Hz displays, I have T480 with TB3 and USB C port, the TB3 should be able to push this kind of bandwith.It also has MX150 + The intel HD card. Anyone knows which of the lovely Lenovo docs can do so ? Thanks

Read other answers
RELEVANCY SCORE 68

Hello everyone, my much-used and beloved Gen2 X1 Carbon (touch) starts to show broken areas on the screen (see attached image).The region's not always gray, and it's occuring depending on the angle at which the display is opened. Slight pressure on the bottom border of the screen changes its occurrence. Mostly, after a while and after finding the right angle, the issue resolves, and it's working fine again. Most of the time it's worse after travel - an external display always works fine. My guess is, the display's still working fine, but the cable is to some extent damaged? Is there a way to exchange the cable easily, ie without replacing the whole display? Or might it be any other issue after all?Thanks for any replies,Benedikt   

Read other answers
RELEVANCY SCORE 66.8

Is anyone succesfully bulk imaging T490s or X390 ThinkPads via the USB-C dock ethernet? I would like to discuss the WinPE environement you are using (what driver or drivers did you use for example). We are using the latest realtek NIC driver from Lenovo and I have added the Thunderbolt controller drivers. This did work with previous models. We are imaging the T490s (20NY) and X390 (20Q1) systems via PXE using an SCCM OSD task sequence. Previously we had done the T480s in this manner. The T490s and X390 randomly fail to complete the installation process, losing communication with the SCCM Management Point during the WinPE image/driver application phase. I can supply SMSTS.LOG examples, but in summary the driver download for the model occurs, the task sequence driver installation operation commences (and succeeds, per the logs) and at some point following the driver download we have lost communication. Following the driver/DISM operation the system should report success to the MP, however from that portion of the OSD process we have no communication.  The failure is random - we can run 10 and get 8 to go and then run 10 and get 4 to go. The same system will be rebooted, restart the imaging, and work. We run M920/M720 desktops and older T480s laptops on the same benches and they worked 100%. We have been using the USB-C dock in our imaging since Spring 2018, with several hundred T480 & X380 passing thru the imaging process with 100% success in the imaging proc... Read more

Read other answers
RELEVANCY SCORE 66

I'm not able to use an external display during the boot process + Bitlocker Screen. T480s on a USB-C 40AF Dock. This functionality exists with T470s and the 40A2 Ultra Dock. There is the proper Display On Dock BIOS setting avaible. This funcitionality exists with the P52s and the USB-C 40AC Dock. It seems like the T480s is missing this functionality, and I want to know if there is a planned BIOS update to fix this issue. I've tried every other possible BIOS configuration, and both USB-C ports on the T480s, there is no way to get an external montior to display during boot when that external display is plugged into a USB-C dock. Please let me know. Thanks!

Read other answers
RELEVANCY SCORE 64.8

When I have my WiFi connected to a 2.4GHz wireless router my display (connected to Thunderbolt 3 StarTech HDMI connector) disconnects frequently.  Both the monitor connected to the Thunderbolt 3 and the laptop monitor flash 2-3 times and then comes back and starts working again.  And then it repeats again minutes later... and again... and again
If I change to a 5GHz wireless router... then everything works great.
Please help

Read other answers
RELEVANCY SCORE 64.4

I have Dell E5540, Dell E-Dock Plus, Dell U2412M, Dell S2240T.  The U2412M is using DVI-D and S2240T is using VGA.  Windows 8.
I can only get U2412 (primary display) to 1920x1080 not 1920x1200.  Can someone help explain to me how to get to 1920x1200 on U2412 please?

Read other answers
RELEVANCY SCORE 63.6

Yoga 260 could not wake up from sleeping mode when it is connected to Onelink plus dock.Yoga 260 is connected to a Onelink plus dock and one external montior is connected to the dock using DP cable. Yoga 260 goese to sleeping mode when user closes its lid, but it could not wake up when user opens its lid - there is no display on both screen. However, if we disconnect the laptop from the dock right away and open the lid, there is display on the laptop screen, further, if we connect the laptop back to the dock, both screen will have display.  We have updated drivers on the laptop and changed Onelink plus dock. But the problem is still there.  Any one had the same? thanks,

Read other answers
RELEVANCY SCORE 63.6

I have a P40 Yoga attached to an Ultra Dock 3.0 USB.  I have/had an HDMI cable coming off the dock to a ViewSonic monitor.  I am getting a maximum resoltion of 1920 x 1080 and colors are not displaying correctly or in some cases not displaying at all.  I found mention on the ThinkPad site that 4K is only supported via the DP off the dock.  So I tried a DP to HDMI cable and that does the same thing.  If I plug the monitor directly into the HDMI port on the laptop everything works great. Why doesn't the dock work as advertised and expected?  Is there a different setup required?

Read other answers
RELEVANCY SCORE 63.2

The TB3 workstation Gen2 dock now only comes with the 230W PSU while the previous version came with the 230W PSU + 65W PSU. My P53 came with a 230W PSU because of the RTX5000 GPU. My question is: The new dock has a power splitter that splits the 230W power into 170W and 65W according to the manual. Will this dock be compatible for my system given that it came with the 230W PSU? I'm not understanding why the reduced power input of 170W to the system is acceptable, but not the 170W PSU as an alternative to the P53 230W PSU.

Read other answers
RELEVANCY SCORE 63.2

Does the usb-c port in this model support charging from powerbanks or usb-c wallchargers and what are the speed characteristics ? 

Read other answers
RELEVANCY SCORE 62.4

We just received our first two X1 Yoga 4th Gen laptops and two USB-C Dock Gen2 and are experiencing some Ethernet driver issues. While the laptops PXE boot just fine into their Windows boot image, Windows itself is not able to load the correct network card driver. I have already injected the updated Intel Chipet and Thunderbolt drivers as well as the Ethernet drivers from the dock into our boot image., but still nothing. Is there another driver I am missing here? I thought the USB-C dock driver installer had more than just the Audio and Network drivers, but from that's all I see when I extract that driver package.  

Read other answers
RELEVANCY SCORE 61.6

Hi there, i have a new X1 Carbon 7th Gen with the new USB-C Dock Gen2. I have 3 Monitors connected with 1680x1050 native Resolution. I get only 2 working with this resolution. The third one will only get 576p. No matter if its connected to DP or HDMI. The last one doesnt get the full resolution.  I made a second test with a Lenovo ThinkVision P27h-10. I dont get it working over DP with 2560x1440 and a secondary monitor over DP. The ThinkVision Monitor falls back to 1920x1080.  All drivers are installed and the latest firmware of the Gen2 Dock is installed.  When i have connected 2 monitors to the dock and open the X1, the monitor of the x1 will get 1920 resolution. Whats wrong? I cannot belive that this new laptop isnt able to power 3 Monitors with 1680x1050 resolution. 

Read other answers