Over 1 million tech questions and answers.

Synaptics UltraNav Driver causing WmiPrvSE.exe cpu usage

Q: Synaptics UltraNav Driver causing WmiPrvSE.exe cpu usage

Hello, recently I noticed that on my up-to-date Windows 10 (Creators Update) there is a process called "WMI Provider Host" (WmiPrvSE.exe) constantly using 1-3% CPU no matter what you are doing. I've been observing this behaviour just recently (maybe 1-2 weeks). So I started with a fresh (completely clean) Windows 10 installation on my Thinkpad X260. I observed this behaviour instantly after Windows finished its instalation and update process without installing any custom software from Lenovo website. When I try to kill this WMI host instance, it is restarted imidiatelly and problem continues. I attached threads output from ProcessExplorer. I looks like the thread execution is deadlocked or something similar. So I started digging which application is causing this WMI host cpu usage. After disabling Synaptic Pointing Device service called "SynTPEnhService" this behaviour disappeared. So I started digging around Synaptic executables. I was able to find out, that process causing this cpu usage is SynTPEnh.exe, which I believe is some kind of main (parrent) process for Synaptic driver functions. When I kill this particular process, then I am able to pernamently kill the WMI host causing those troubles. Well, it actually restarts again, but has no cpu usage. I am using latest version of Synaptic drivers available, which is 19.3.4.83. Is anybody else observing such behaviour? What is the solution for this problem? By disabling SynTPEnhService you loose your trackpoint and touchpad setup. Thanks for help,Milan


























wmi_host.PNG ?81 KB

RELEVANCY SCORE 200
Preferred Solution: Synaptics UltraNav Driver causing WmiPrvSE.exe cpu usage

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

A: Synaptics UltraNav Driver causing WmiPrvSE.exe cpu usage

I noticed the same with the 5/29 bios update and the recent trackpoint firmware as well using the more recent 19.3.4.86 Synaptic drivers.

Read other 1 answers
RELEVANCY SCORE 90.8

I can't seem to install the latest Synaptics UltraNav (219.3.4.219) driver for my X1C6. I'm running W10 (1803) with all the latest updates installed. Anybody have any idea why it won't install?

Read other answers
RELEVANCY SCORE 90

FYI,
 
The URL below states that the driver being installed is 19.3.4.17
 
http://support.lenovo.com/us/en/products/Laptops-and-netbooks/ThinkPad-P-Series-laptops/ThinkPad-P70...
 
However, the actual driver which is installed by the package is: 19.3.4.37! This is not the first time where the package description(s) are inconsistent with the contents.
 
 

Read other answers
RELEVANCY SCORE 90

Lenovo Ultranav stoped working wen installed windows 10. SolutionsPleaseInstalation of Synaptics ThinkPad UltraNav Driver ThinkPad T440p under Windows 10, failed!!

Read other answers
RELEVANCY SCORE 90

Lenovo has rolled out new driver today, but i have problem installing it. Any advice at all please? It's annoying cause my the touchpad has been playing up for a bit since it released. 

Read other answers
RELEVANCY SCORE 88

I installed and activated Windows 10 on a pair of X-series laptops, an X220 and an X201.  Everything was just fine except that the touchpad does not control the cursor well, either freezing it or bouncing around madly.  I finally solved the problem by changing the UltraNav driver to PS/2 Mouse driver, less functional, but it actually works.  When I ran the Windows 10 update, it reinstalled the UltraNav driver, so I had to revert back to the PS/2 driver and reboot.  (The UltraNav driver downloaded from the Lenovo site is equally defective.) Yes, I know these are older systems, but can't Synaptics do a working driver?  Or maybe Microsoft could install the basic PS/2 Mouse driver as the default?  I must be dreaming.  Anyway, the problem of a properly function touchpad has a solution.

Read other answers
RELEVANCY SCORE 86.4

Thus far I failed to identify the circumstances in which the touchpad stops working. It seems to sometimes happen when it checks for an update. What is also curious that the cursor will sometimes mess up such that the text cursor will be displayed as the context menu cursor. Not sure if this is related. The touchpad works again after restart. Everything is up-to-date, running Windows 10 (1909). The TrackPoint is unaffected by this.

Read other answers
RELEVANCY SCORE 74

I want to uninstall Synaptics ThinkPad UltraNav Drivers and files and registry t440p windows 10.Does anyone has al the instructions. The way from the controlpanel does not work....

Read other answers
RELEVANCY SCORE 62.8

I am running Windows 10 on an Acer and recently downloaded and installed the update for the Synaptic touchpad (January 17, 2017).  After rebooting my laptop, I can use the touch pad to move the cursor when logging in, but once the system as loaded,
I cannot move the cursor using the touch pad.  I can left-click and right-click, and shrink and expand on the touch pad, but have no control over the cursor.  I currently have a mouse attached to the computer in order to move the cursor.
When I click on the link for more information about the update, there currently is no information.  Quite frustrating.
Please advise as how to resolve this issue.
Thank you.

Read other answers
RELEVANCY SCORE 62.4

I have a Windows 7 32bit HP laptop.   Lately i noticed that WMIPRVSE.EXE is using 20-100% of the CPU.   I cant figure out why.  I have cleaned the computer, run malwarebytes and use Norton360.   Any help is appreciated.

A:WMIPRVSE.EXE causing Performance Problems

Hi Matt If you go in the Task Manager, right-click on WMIPRVSE.EXE and select Open File Location, where is that file located? Can you copy and paste the path here?

Read other 28 answers
RELEVANCY SCORE 61.6

I have been experiencing high cpu usage on my computer since I first got it. Looking at the task manager the process that is consuming all the cpu is wmiprvse.exe and the user name is network service. This process starts up when I boot the computer and bogs the system down. I sometimes am able to end the process and it will start up again and behave. Other times it will not. I have contacted microsoft and was told to go to the command prompt and type "net stop winmgmt" to stop this problem. This does work but the next time I start the computer again the whole process begins again. Microsoft suggested I reload the computer but I do not want to do that for obvious reasons.

Can anyone help?
 

Read other answers
RELEVANCY SCORE 61.6

I have a pc running xp home w/all current updates. when the print spooler is started cpu usage immediately jumps to 100% with wmiprvse.exe taking 39-60%, spoolsrvc takes 6-19% and csrss.exe takes up to 30%. have run adaware, spybot, windows defender and a-squared spyware removers as well as virus scan - nothing found. when i stop spoolsrvc cpu usage drops to <50% usually between 0-15%. restored to a date b4 this started - no change. the wmiprvse.exe file is in win/sys32 folder as well as i386 and in a windows update (don't have the number). i am baffled.
 

A:wmiprvse.exe and 100% cpu usage

you mean that i have stumped everybody on this forum? not one answer - not even a wrong one
 

Read other 3 answers
RELEVANCY SCORE 61.6

OK... I have three different desktop computers with this prob. 2 are Gateway E6000's, 2.4 Gig, and 1 is an IBM M50, 3 Gig. All have .5 - 1.5 Gig RAM. The Total and Peak Commit charge is well below the Total Physical Memory. All are on the same subnet. All have WinXP Pro SP2 with all updates - updated and ran McAfee 8.5 Enterprise - No Probs - updated and ran Adaware SE Pro - No Probs - updated and ran Spybot 1.5.2 - No Probs.

Happens to both the Local Admin and the User (Power User) alike.

I've Ended the Process and it comes back within an hour or so. I've stopped all Start Up (msconfig) programs except for McAfee and a DriveMap.Bat. They went down to a solid 50% CPU Usage. I checked the next day and they are all back to 97% - 100%. <Deep Sigh>

I've been all over MS TechNet and found lots of wmiprvse.exe fixes for SMS Server, Small Business Server and Server 2003... Nothing for the workstation!
I work for a local police dept... you know... angry people with guns! Plz help!
 

A:wmiprvse.exe & 100% CPU Usage

Read other 7 answers
RELEVANCY SCORE 60.8

Issue :Im using T470s with Windows 7 OS, 1st - When im using Cisco Jabber to have a video chat\confrence the application will crash. Im suspected it due to the the intergrated camera driver. However when i go to Lenovo site, for T470s i can only found camera driver for Windows 10. 2nd - There is no Synaptic UltraNav available and when go to Lenovo site, for T470s i can only found driver for Windows 10. Question :Is there any Win 7 camera and UltraNav driver from other T model that compatible with T470s? BRMiqdad

Read other answers
RELEVANCY SCORE 60.8

I just developed a problem with WMIPRVSE.EXE. It consumes about 50% of a dual CPU for about 14 secs and drops back to normal for about 9 secs. System ran fine until today. Last updated Apple software and Java yesterday. Restored from backup of a few days ago without any change. Any help would be appreciated.
 

A:Windows 7 WMIPRVSE.EXE CPU usage

I removed both updates and problem continues. After rebooting, it appeared OK until I fired up IE8 (timing?). Sometimes, it appears to affect IE8, cannot access site on first try, but can later.
 

Read other 1 answers
RELEVANCY SCORE 60.8

when first turning my computer on it it really slow. look at processes and wmiprvse.exe is cause the cpu usage to spike to 100% i end the process. when going on to the internet it will sometimes spike this back up and slow everything down. i have checked for viruses using Symantec antivirus and it found nothing wrong. i have also used spybot s&d to check for any adware or spyware and have found nothing. what should i do to end this from spiking?

Read other answers
RELEVANCY SCORE 60.8

Hello Seven Forums members. First of I am sorry if this post is in the totally wrong category or if there is already a solution for this but I am not sure if the solution for this applies to every laptop/pc. My sister is asking me to help her fixing her Laptop which is really slow. I opened up the task manager while leaving the laptop in idle state and found out that some process is using up to 30 % of the CPU. So I clicked on the "show processes from all users" button and I could see the culprit: WmiPrvSE.exe.
I assume it's a vital process for Windows to run so killing the process wouldn't work. Therefore I opened up the services and looked for the service that is associated with it. Pausing the "Windows Management Instrumentation" service made the CPU usage go to normal. I went to the properties of this service to look up the dependencies but it showed me nothing. Furthermore, other services didn't show any dependencies either. After a while it showed this window:"Windows:Server execution failed".
But back to the actual problem: What can I possibly do to fix this service or process to make the CPU usage normal again?
If there is any more information required I will edit this post as fast I can.

A:WmiPrvSE.exe cause high CPU usage

There is some info here and a link to another post that may help: WmiPrvSE.exe causing high CPU usage? - Microsoft Community

Read other 9 answers
RELEVANCY SCORE 60.4

WMIPRVSE.EXE constant CPU usage: Seems to have begun after last power management update but can't be sure. Errors in event viewer for wmi activity do not correspond to an active PID in task manager (no luck). Restarting the WMI service seems to solve the problem until next reboot... advise appreciated, tnx

Read other answers
RELEVANCY SCORE 60.4

Hello Techguy,

i'm currently using Window 7 starter edition, running on a Sony VAIO laptop, dual core cpu.
Found out that the WmiPrvSe.exe (NETWORK SERVICE) is taking about on average 50% of both cpu core utilization.

I ran the following command:
tasklist /M /fi "imagename eq Wmiprvse.exe"
and
tasklist /SVC /fi "imagename eq Wmiprvse.exe"

BUT, for both command, under the "Modules" and "Services" column, it just shows "N/A".
So I am unable to determine which processes is using the wmiprvse.

My lap is not connected to any physical LAN, and I also tried turning-off/disabling both Wifi/Bluetooth, but that also does not bring the cpu utilization down.

Have also verified that the wmiprvse.exe is correctly pointing to the c:\windows\system32\wbem\wmiprvse.exe, and even the file timestamp seems the same as the rest of the *.exe files within the .\wbem directory.

Would anyone have any idea what actually could be the cause?
 

A:Win7 WmiPrvSe.exe high CPU usage

is a common virus with same/similiar name,also multiple instances can ruun especially if not logged off an account suggest running your anti vi scan and install/use to look up/save log post back
http://www.hijackfree.com/en/
 

Read other 3 answers
RELEVANCY SCORE 60.4

I recently experienced strange CPU usage from two processes I never heard of before, namely:
C:\Windows\System32\services.exe
C:\Windows\System32\wbem\WmiPrvSE.exe
This processes are taking 5%-15% for the former and 5%-10% for the later, which was not the case for any of them before.

Never had this problem in the past but I suspect it began sometime when I installed AVAST free version, MySQL 5.6 community edition and Visual Studio Community 2015, all them the day before this writing. (Need all this programs for a project at work).

My laptop is an TOSHIABA satellite S75-B and my OS is Windows 7 Professional Service Pack 1.
I wish I could give more details about the processes but I don't know too much about computers. So any suggestions will be appreciated.

Thanks in advance.

Read other answers
RELEVANCY SCORE 60.4

WMIPRVSE.EXE constant CPU usage: Seems to have begun after last power management update but can't be sure. Errors in event viewer for wmi activity do not correspond to an active PID in task manager (no luck). Restarting the WMI service seems to solve the problem until next reboot... advise appreciated, tnx

Read other answers
RELEVANCY SCORE 60.4

Hey everyone.

I have had problems for some time now, but only recently decided to take an actual look at it.

When I play a 3D game, I have a nice performance, but every 5-10 seconds, depending on the game, massive drop of FPS occurs.

First, I asked for help on the particular game forums that had this happening most often, and they helped me find out why my games were running that way.

I spotted, at the Task Manager, that every 5-10 seconds, even without playing a videogame, CPU total usage spikes to 100%, and at the same type, this process called WmiPrvSE.exe also uses nearly 100% of that total usage.

During the break between spikes, that process just sits there doing nothing, then BAMM! it goes wild again.

I suspect this has affected my internet connection as well, since when I input any text into any textbox on any website, some letters aren?t inputted. I have to write this post on MS Word so I don?t have to correct half of my words. Also, general connection slowness and total loss of connection from time to time.

I am so convinced WmiPrvSE is doing it. What can I do about it? Why is WmiPrvSE going wild now if he never had before? Virus? Please help ASAP. Thanks in advance.

A:WmiprvSE causes huge CPU usage spikes

Hello!

The wmiprvse.exe file is located in the folder C:\WINDOWS\System32\Wbem. In other cases, wmiprvse.exe is a virus, spyware, trojan or worm!

Update your Anti-Virus and run a scan.

Read other 5 answers
RELEVANCY SCORE 59.6

First time posting trying to fix this, but I noticed that for the past couple days my CPU usage jumps 30-50% (sometimes even higher) every minute or two at irregular intervals, regardless if the internet is connected, antivirus is on, or if the system is idle or if I have another application open. They last from anywhere between 3 and 20 seconds.

I first noticed this while playing games, since the jump of 50% CPU would cause hard lag in game. I performed a few Windows Updates in the past week, and there seems to be no other issues besides these CPU spikes, but I think I've had these jumps for the past month or so without me noticing (I'm very new to this).

After looking at other forum posts, I have used Process Explorer to observe the CPU spikes, as well as recording the CPU for Windows Performance Analyzer. I have also enabled logging for WMIPrvSE.exe in the Event Viewer.

Everything shows that the System and WMIPrvSE.exe processes are the culprits and that they cause two separate CPU spikes (I don't know if they are related or not).

The CPU spikes look like this in Process Viewer and WPA (filtered to show the trouble processes):

I've tried tracing down the stacks for each process in WPA, but I don't know what I'm looking for.

I have the .etl file ready to send if anyone wants to help me figure out the root of this problem.

Does anyone know what could be causing these CPU spikes?

Read other answers
RELEVANCY SCORE 59.6

Hello!

I had svchost eating into my CPU usage a lot for the past month. I usually got by by killing the process (I shouldn't have had, should I? =X). Recently, this other service wmiprvse has joined svchost in wreaking havoc in my computer.

I've read some other similar forum posts, but the solutions seemed to be vary from case to case, so I thought I'd ask for help directly. Could anyone here be kind enough to offer some advice? My comp specs follow:

-------------
Tech Support Guy System Info Utility version 1.0.0.2
OS Version: Microsoft Windows 7 Home Premium, 64 bit
Processor: Intel(R) Core(TM) i5 CPU M 460 @ 2.53GHz, Intel64 Family 6 Model 37 Stepping 5
Processor Count: 4
RAM: 3894 Mb
Graphics Card: Intel(R) HD Graphics, 1723 Mb
Hard Drives: C: Total - 431937 MB, Free - 34884 MB; D: Total - 29690 MB, Free - 21940 MB;
Motherboard: LENOVO, Base Board Product Name
Antivirus: AVG Internet Security Business Edition 2012, Updated and Enabled
--------------

Please feel free to ask for any other information!

Thanks!
 

A:svchost.exe and wmiprvse.exe dominating CPU and memory usage

I'm guessing you've already got Task Manager open if you're killing processes.

SvcHost's job, as the name might imply, is to host services running on your computer. Some services don't have executables, rather they use .dll's and SvcHost to cut down on overhead.

If you right-click the process and then click on Go To Service(s), you'll see all the services that this particular instance of SvcHost is hosting.

Rather than nuke SvcHost blindly, determine if these services are necessary and disable them via their respective programs, if possible, or the Services Management Console (Start, Run, services.msc).
 

Read other 1 answers
RELEVANCY SCORE 59.2

Hello all,  I decided to install a different version of the Ultranav driver on my ThinkPalled ad x220 laptop. I deinstalled the Ultranav driver using Programs and Feures, and then proceeded to install the Ultranav driver by running the executable I downloaded from thealla lenovo page at http://support.lenovo.com/nl/fi/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x22....  The installation goes on fine up to the point when the driver has to be actually copied/installed, and then I get the error message "You have to run the 64-bit version of DPInst.exe on this machine. Contact the vendor that provided you this package."What to do? The machine, as it is now, is nearly unusable, unless I use an external mouse. 

Read other answers
RELEVANCY SCORE 57.6

I reset my laptop back to factory default (from windows 10 64 bit to windows 7 64 bit), and now my included trackpad and eraser head mouse are not working as well as the mouse buttons (right, left, and middle click), and when I click fn + f8 I get a popup saying that "ultranav driver is not installed" with no option other than "ok" I installed the ultranav drivers from https://support.lenovo.com/us/en/downloads/migr-67226 I get a successful installation notification, but I still do not have a functioning mouse. I reboot the laptop, do a full shutdown, and still no dice. Any ideas on how to fix it?

Read other answers
RELEVANCY SCORE 57.6

Hi all, The latest version of the touchpad driver for the T440 disables my trackpoint and removes the option to re-enable it from the Mouse Properties menu. Has anyone else had this issue? I'm on Windows 7 and the original driver on my computer is v18.0.7.40, for reference. Removing and re-installing the new driver did not fix the issue. I'd like to keep the new driver installed (due to behavior issues from my touchpad on the old driver), but lack of trackpoint functionality is a dealbreaker for me. Thanks in advance.

Read other answers
RELEVANCY SCORE 57.6

Hi Mark_lenovo or other thinkpad expert, I will ask for your help in finding a driver for the UltraNav 2(ALPS) on the Thinkpad X300 for windows 10(64bit). Currently I use the latest driver for windows 7 (7.202.1616.206):
 
https://support.lenovo.com/jp/en/downloads/migr-72368
 
But that one has issues with the metro/Modern parts of windows 10 UI: Touchpad scroll works in Internet Explorer, Firefox, File Explorer, Device manager, Help, Services.msc and some other places, but it does not work in Start menu or any menu under system, Control panel, Edge or Windows Store.
 
Most likely it's because the programmers didn't know about the modern UI when they made the driver and therefore it does not support it, and that is why scroll is not working in those parts of the UI.
 
The synaptics touchpad on some Thinkpad models works fine with driver version 17.xx.xx.x but as soon as it is updated scroll function seize to work again - mine is ALPS Ultranav 2 touchpad - is it possible to "cheat a bit" and use the ultranav utility in combination with the synaptics driver or can synaptics driver replace the ALPS driver totally(I tried this on my R500 and it didn't work, the touchpad were disabled after restart)?
 
Do you know of any other thinkpad models with same Ultranav 2 touchpad(Palmrest FRU# 42X5021) that has a newer driver and will work with the X300 and windows 10 Modern UI? Could you find out?
 
I already tried most of the series 8 drivers I could find o... Read more

Read other answers
RELEVANCY SCORE 57.2

I did a search to see if this was already posted but didn't find it.  So, here's my story. I have a P40 Yoga that's about a year old.  A couple of weeks ago, I received a pop-up from Lenovo Vantage saying there was a system update.  Like a good user, I said OK.  I didn't notice it right away (because I use an external mouse) but the trackpad, left/right click buttons and the "trackpoint" center button all stopped working.  I did a lot of searching to see if there was a resolution but couldn't find one. Eventually, I went into Control Panel | Device Manager | Mice and other pointing devices | ELAN pointing device | Driver and saw that there was a recent update.  Fortunatly, there was a "Roll Back Driver" option which I figured couldn't hurt anything.  After a reboot, the driver is back to one dated 2/13/2017 version 11.21.9.3.  All mouse accoutrements are once again working. What prompted me to post today is that the Lenovo Vantage pop-up appeared again telling me there's an update and it wants to put the bad driver back. Irconically, the pop-up says: "Lenovo recommends that you install these updates to optimize your computer" Yah, right!  Now I'm sceptical about ever doing another update.

Read other answers
RELEVANCY SCORE 56.8

I must have opened something online or downloaded something I shouldn't have because these two issues are brand new and they're pissing me off! I could use some help. About to go to bed because I've spent too much time tonight trying to figure it out and coming up with nothing.
 
Anyone have any idea about either of my fun new issues?
 
 

Read other answers
RELEVANCY SCORE 56.4

Hi everyone, My trackpad stopped working, and I've been trying to troubleshoot the issue. Everytime I try to enable the trackpad with Fn+F8, I get the message "UltraNav driver is not installed." The Lenovo systems updates says that I have an UltraNav driver update available for my computer, but everytime I install it and reboot, I get the same message. Everytime. I can find where the driver has been downloaded on my computer, but the computer still says that "UltraNav driver is not installed," and the driver update still remains available on the system updates. I've tried downloading again and again, only to re-write and reinstall the download, with no effect. I've also tried going directly to the Lenovo website and downloading the driver from there to the same effect. Any advice?

Read other answers
RELEVANCY SCORE 56

*Please read in entirety before replying*The situation is as follows: - Purchased new X1 Thinkpad Yoga 3rd Gen in Jan 2019; Windows 10 64-bit- Bought with the MISTAKEN belief that the track pointer stick would have "press to select/click" capability. Not having this feature is an absolute DEAL BREAKER for me.  - Steps taken in attempt to resolve the problem: 1. Uninstalled driver for Synaptics Pointer in Device Manager 2. Installed most recent version of Ultranav Driver3. Result: NO CHANGE  - In MOUSE PROPERTIES, there is no option for "press to select" - only choices are to use for scrolling or as middle click. Question 1: Is there ANY WAY possible to incorporate the press-to-select option for the pointing stick on this model?Question 2: If it is not possible, which Thinkpad models currently DO include this option?  Thank you in advance... 

Read other answers
RELEVANCY SCORE 55.2

I just want to report that the newest touchpad driver brakes native windows middle-click scrolling. What I'm talking is this:1. Swich off all advanced features in the TouchPoint setting to get back a middle button. BTW, how on earth it is possible that the default setting "steals" the middle button. Going for the Nr. 1. PC maker and forgetting a stupid default settings in a Synaptics driver is a joke.  2. Now, try scrolling in any native windows application like Chrome, Firefox, etc. The quick way of scrolling is to push the middle button while scrolling. It had always worked before.Now this way is broken.Now, the only way for scrolling is to the:1. push middle button to enter scolling mode2. move mouse3. push again to exit scrolling mode This scolling mode has never been a good way to scroll, but the quick way is broken with the latest driver. I'm using a W520 with Windows 7, 64-bit. Broken driver: Version 16.2.5.0   

A:Newest UltraNav driver brakes native windows middle-click scrolling

I have a similar problem as the OP: after today's update, my Touchpad is not functioning properly anymore. Scrolling of any sort on the Touchpad seems to have been disabled. As I do not have a mouse attached, I am forced to use the Trackpoint set's middle button and then move my cursor around to scroll. I checked my Control Panel settings and both two-finger and single-finger Touchpad scrolling are enabled via the settings. Also I don't know if this is relevant, but it seems like the option to double-tap to bring up Lenovo SimpleTap has also randomly been disabled... W530, Windows 7 x64.

Read other 9 answers
RELEVANCY SCORE 54.4

Just got an X1 Yoga 2nd Gen.  Pretty great except I see that WmiPrvSE.exe is constantly using 1-4% CPU in task manager. After digging I discovered this is due to the following query being executed by SynTPEnh.exe when it starts up: SELECT * FROM __InstanceCreationEvent WITHIN 1 WHERE TargetInstance ISA 'Win32_Process' This query string can be seen in the SynTPEnh.exe binary file via SysInternals procexp or strings tools. The query executes once every second indefinitely.  This seems minor but bad for battery life, but also seems unnecessary for touchpad functionality. I took a look at the reference SynTPEnh.exe that comes from Synaptics own website.  It does not contain the query string and so presumably does not rely on WMI for any functionality.  However the software on Synaptics appears to be old, from August 2015, so it is unclear if Lenovo or Synaptics has added the query since. What's up with this?  I'd like to not have my CPU used every second always, but I would also like my touchpad to function correctly. 

A:Synaptics Touchpad software makes 1 sec polling WMI query causing constant CPU utilization

Thank you for this problem report and sorry that I didn't notice it earlier.  We will check on this.  Sorry for the inconvenience.

Read other 1 answers
RELEVANCY SCORE 54.4

I have regualrly run a System Update for my computer via Lenovo Companion and I've managed to have all updates successfully completed - all except for one. Lately, I have runs of Updates where I encounter an update for Synaptic UltraNav Driver, run it, but comes up as being unable to download and install - in spite of a successful initial download. Since its encounter a couple of weeks ago, I have been unsuccessful in fully downloading and installing this specific Driver for my computer. Is there any indication of issues for this Drive? And what should I do to resolve it? Also, if the Driver can't be properly updated, what is its purpose for my system? Any form of help concerning this Driver update issue would be appreciated.

Read other answers
RELEVANCY SCORE 52.4

Good day.

I was re-directed here from Microsoft Communities. I'm posting in the Networking category, but if there had been a WMI category I would have picked that. For full history please see:
https://communities.intel.com/thread/117723
https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/wmiprvse-crash-with-newer-intel-network-driver/4e790f9b-5114-42cd-a4a1-311a04280f82
The problem:
I (and at least one other guy) are having a problem with WMIPRVSE and newer Intel Network Drivers.
Basically, I have User-Mode dumps enabled, and whenever I update my network drivers to a newer version, WmiPrvSE starts to crash regularly. You can see this in Event Viewer but I can also see it because a dump is created. Reverting to a previous version
of the Intel Network Driver corrects the problem. Intel does not want to analyze the process dump to see where the problem lies, they asked me to ask Asus for support, but of course I'll never get to talk with an Asus engineer, all they can do is give me another
motherboard. So I am turning to Microsoft; WMIPRVSE is after all a MS process.

The crash event is (CoreAgnt.dll is an Intel DLL) ->

Faulting Application Path: C:\Windows\System32\wbem\WmiPrvSE.exe
Problem Event Name: BEX64
Application Name: wmiprvse.exe
Application Version: 6.3.9600.16406
Application Timestamp: 5244fd73
Fault Module Name: CoreAgnt.dll_unloaded
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 58fe61c5
Exception Offset: 000007f... Read more

Read other answers
RELEVANCY SCORE 52.4

I am using a Lenovo ThinkCentre, and recently I had this problem when I acess 'Mouse' in Control Panel, and it comes up with an error saying 'Unable to connect to the Synaptics Pointing Device Driver' I press OK, then it goes to the Mouse Properties. But I think this is affecting the SetPoint settings for my Logitech Performance MX mouse that I am accessing through the mouse properties. How can I fix this?


























Capture.JPG ?16 KB

Read other answers
RELEVANCY SCORE 50.8

Hi, can you help me to find a signed GENERIC Synaptics driver for Windows 8 32-bit - not released by an OEM but released by Synaptics itself. The latest one v17.0.19 is not properly signed so I am looking for another one.
Thanks!

A:Synaptics driver

Hello Werty,

I've found an older 16.2.21 Synaptics touchpad driver version that'll hopefully work for you.

Download Synaptics TouchPad Driver 16.2.21 for Windows XP, Windows Vista, Windows XP 64 bit, Windows Vista 64 bit, Windows 7, Windows 7 64 bit, Windows 8, Windows 8 64 bit

Read other 8 answers
RELEVANCY SCORE 50.8

I have a Lg Xnote Laptop, and I'm looking for a vertical scrolling driver. I have a synaptics driver now, but under settings it does not allow me to turn on vertical scrolling (nor is it even a visible as an option).

I've tried installing another synaptics driver a few times, but so far I've had no success.

This is my first time to the forum so I appreciate all and any help you can offer me.

Thanks!

A:Help me for Synaptics driver!

Which Xnote and what country? Why do you think it is a synaptic touchpad?

Read other 4 answers
RELEVANCY SCORE 50.8

Could someone please help me find Synaptics driver version 15.1.22.0 dated 29/10/10.
Thanks.

A:Old synaptics driver

Hello!

Difficult question. The closest I can find is 15.1.22.2C: Synaptics TouchPad 15.1.22 - WikiDrivers - Wiki-style resource and guide for device drivers

Is that not close enough? I think that it may be the closest you can find though.

Richard

Read other 4 answers
RELEVANCY SCORE 50

My laptops touchpad keeps making the cursor jump across the screen or just not move at all. I've tried reinstalling the drivers and cleaning the touchpad. I don't know what esle I could possibly do. Any help would be much appreciated

A:Synaptics driver issues

What is the make and model# of your laptop?
Go to the Manufacturers Support/Download Drivers site and type in your make and model # or Service Tag# of your computer and download the Touchpad driver for your model.
Go into Control Panel/Mouse (Touchpad) and adjust the sensitivity.

Read other 5 answers
RELEVANCY SCORE 50

Just Installed (clean install) Windows 7 64 bit on my laptop today, what a pain, tried an update first on my 32 bit but had problems so I decided to go ahead with installin 64 bit as my computer was compatible.

Anyway, got it installed and I'm re-installing my software.

Main problem is I can't seem to get a driver for my touchpad on my laptop which is a Fujitsu Siemens just over a year old. Fujitsu do not have 64 bit drivers but I got one from Synaptics.com which is supposed to be compatible and signed but when I try to run it I get the error message that it is not a Win32 app.

Anyone got an answer for me.

A:Synaptics Touchpad Driver

OK. Managed to find a driver which seems to work.

Read other 3 answers
RELEVANCY SCORE 50

I just upgraded to Windows 10 and upgraded my synaptics driver to their windows 10 version. Only trouble is the little red light in the corner is always on. The light is only supposed to come on if the trackpad has been disabled but the trackpad is working and the light is on. On top of that the double tap the corner function that turns the trackpad on and off doesn't seem to be an option with this version of the driver.

I managed to find a registry hack to get chiral scrolling to work again but can't seem to find/enable the corner double tap and rid myself of this stupid light.

ETA: Okay weirder still the light is reversed, when I plug in my USB mouse the light goes out and the trackpad is disabled.

Read other answers
RELEVANCY SCORE 50

The two latest drivers have broken some functionality, I would like the driver used before April, where do I find it?

Read other answers
RELEVANCY SCORE 50

i have toshiba 2007 sattilite lt.it has version 15.2.20 drivers for synaptics touch pad.are these good or should i update drivers.i'm still running vista.

A:vista/synaptics driver

If your computer is running fine I wouldn't update the driver as it is not a security issue

Read other 2 answers
RELEVANCY SCORE 50

I'm having a problem where my mouse doesn't move while a key is pressed. In Settings>Mouse & Touchpad, under the "touchpad" heading, the "Delay before clicks work after typing (paraphrased)" settings is set to No Delay (always on). From the above screen>Additional mouse settings>smartsense>settings cog next in smartsense bar:The top setting is all the way left on the "off" selection of a ticked bar.The second bar labeled "tapping disabled time after keystroke" is all the way left.The third bar labeled "pointing disabled time after keystroke" is all the way left.The first top bar being set to "off" causes the bottom half of the setting screen to be grayed out. From the searching I did, apparently the settings are correct(?), but it's not disabling the feature.A solution that worked for a few people was to install a previous driver and set it to not automatically update it. After a good bit of searching around on this very confusing-to-me site, I was unsuccessful at finding the driver I need. My current driver installed is:Synaptics TouchPad Driver (Windows 10 v1607)19.3.11.37 Rev. ASep 12, 2016 

Read other answers