Over 1 million tech questions and answers.

(Solved)Lenovo Y520 Micro stutter

Q: (Solved)Lenovo Y520 Micro stutter

Read other answers
RELEVANCY SCORE 200
Preferred Solution: (Solved)Lenovo Y520 Micro stutter

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 128

Solved: All i had to do was unplug my laptop whilst starting up the game. Seems to be working fine like that. Im really on a pickle with this one.Basically long story short.. I start up Rocket League.. First 3 minutes of the match okay ( after restarting), and then the micro stutter happens.. Like in every 1.5 secs it will "freeze"and its annooying as hell. Tought i was only RL at the time. Turns out all the ohter games do so... Tried reinstalling windows, all of my drivers, did ram check, uninstalled Discord.Nothing seems to be working .. temps are normal.. (50 ish, Celcsius) Any ideas mates? Video of the stutter: https://www.youtube.com/watch?v=xIaWtL_YvII

A:(Solved)Lenovo Y520 Micro stutter

Solved... Seems like only thing i had to do was unplug my laptop whilst starting the game.

Read other 1 answers
RELEVANCY SCORE 118.8

Im really on a pickle with this one.Basically long story short.. I start up Rocket League.. First 3 minutes of the match okay ( after restarting), and then the micro stutter happens.. Like in every 1.5 secs it will "freeze"and its annooying as hell. Tought i was only RL at the time. Turns out all the ohter games do so... Tried reinstalling windows, all of my drivers, did ram check, uninstalled Discord.Nothing seems to be working .. temps are normal.. (50 ish, Celcsius) Any ideas mates? Video of the stutter: https://www.youtube.com/watch?v=xIaWtL_YvII

Read other answers
RELEVANCY SCORE 87.2

Greetings, Since installing a Plextor M8Pe 128 GB m.2 PCI-E Gen3x4 SSD on the Y520, I have been experiencing random stuttering and freezes in both games and general usage. Even with light tasks, such as playing music, there are random freezes with cracking / popping sounds. Both the Y520 and the SSD appear to be healthy. The Y520 did have the motherboard and display replaced under warranty and the service centre now claims there is no hardware fault. The BIOS is set to UEFI and AHCI, as the Windows 10 setup was not detecting the SSD with the default Intel RST Premium setting. Any suggestions are welcome. Thank you.

Read other answers
RELEVANCY SCORE 64.8

Hi all. I was wondering what everyone's experience was in regards to the best GPU in terms of smoothest performance. I keep hearing that GPU's in sli/crossfire suffer from microstuttering and that can really distract from the experience. However, I've also heard that this is really only a major issue with lower end cards and that higher end cards like the GTX 780 or titan in sli work very well. What are your guy's thoughts?

This question has stemmed from the fact that I have a OC GTX 770 right now for a 1080p monitor. I guess I'm wondering if in the future I want to upgrade should I try another 770 in sli or just go with a single GTX titan or 690 (even though I've heard the 690's multiple gpu setup can experience microstuttering as well, however much that is). I know everything will give me high fps but I really want a smooth ultra setting experience with future games like BF4.

P.s. sorry I seem like a NVidia fanboy. I also like video editing which I've heard NVidia's cuda cores are good for that. Also, lets say money isn't a problem. These are my computer specs

i7 4770k
750w xfx power supply
asus sabertooth z87 mobo
Cooler master HAF912 ATX case
 

A:GPU's and micro stutter

Micro stutturing has largely been addressed fairly well by NVidia. Currently, NVidia cards in 2 way SLI do a great job of both scaling and keeping stuttering quite low.

ATI cards have been derided very much these past few years since NVidia brought the issue to light and fixed it up on their cards, but the latest 13.8 beta drivers show that ATI has come up with a decent solution to stuttering.

TL;DR, it's not really a problem from now on.
And yes in the future a second GTX770 is probably going to be a good choice.
 

Read other 29 answers
RELEVANCY SCORE 64.8

This is really a good read and inside look at 'micro-stutter'
http://techreport.com/articles.x/21516
 

Read other answers
RELEVANCY SCORE 64

Hi all. I'm hoping somebody with a bit more technical understanding than myself can help me clarify the issue.

I have recently upgraded my ram and HDD in my PC. I used to have 6GB of PNY DDR3 ram and a crappy 320gb HDD connected via SATA 1 cable. This HDD was the only original component in the PC since I first bought it, as everything has been improved upon over time.

I now have 16GB Kingston HyperX DDR3 1600MHz ram and a WD 1TB 3.5" SATA III 6Gb/s Caviar Black 7200rpm 64mb cache HDD.

Since upgrading I have been encountering micro stutters - literally only about one second long. Everything freezes and the sound stutters, sometimes making a "zzzztttt" sound. Then it just catches up. Sometimes games have been minimizing to desktop when it happens, but not always.

I have tried quite a few fixes such as upgrading all drivers, reverting to old drivers, checking temps, changing ram voltage. But it seems like this may be related to the new HDD.

I have put the old 320gb HDD back in and although it is noticeably slower compared to the new one, I haven't had any micro stutters yet after an hour of testing on various games with other programs running in the background.

Specs:

Geforce 660ti
i5 2500k 3.30ghz
16GB Kingston HyperX Genesis DDR3 1600MHz
ASRock P67 Pro3 SE Mobo
WD 1TB 3.5" SATA III 6Gb/s Caviar Black 7200rpm 64mb cache HDD
Windows 7 Home Premium

It has to either be the ram or the hdd that's causing the problem, as I didn't hav... Read more

A:Possible HDD micro stutter issue

It's not relevant, but are you using Win7 64bit? I assume you are, otherwise, all of your RAM is not available (or even needed for that matter).

Have you checked Windows Event Viewer to see if Windows is logging any errors? Have you tested the HDD using the drive manufacturers disk tools?
 

Read other 2 answers
RELEVANCY SCORE 56

Hey everybody, I am trying to install Windows 10 x64 over USB (Created with Microsoft tool).BIOS version: 4KCN43WWWhat I want is to install Windows in UEFI Mode (Not legacy), but when I set everything in BIOS I can?t see USB on boot menu.I can use it and install it when I set: Boot Mode: Legacy SupportBoot Priority: UEFI First But that is not an option, I don?t want my Windows to be on Legacy mode.I am not able to install it like that and switch to UEFI after, keep getting error that HardDrive cannot be found.SATA Controller Mode is on ACHI.OS Optimized Defaults is on ENABLED.Secure Boot is DISABLED.Fast Boot is DISABLED. If anyone has any solution that I didn?t try it would be great.

Read other answers
RELEVANCY SCORE 56

Hello, I own a Lenovo Legion Y520 (the one with 2tb HDD) and I would like to add an SSD to it as well. From what I've read, if I want to keep my HDD and add an SSD, I will need an M.2 type SSD. Also, I have found an SSD that I think would be compatible with my Y520, but I wanted to ask here before buying it. The SSD I'm talking about it the SSD WD Black 256GB PCI Express 3.0 x4 M.2 2280. I will also attach a picture of it, so if anyone could tell me if it's compatible, I'll be very thankful.This is the one 

Read other answers
RELEVANCY SCORE 56

Hello people, i have a big problem,bought a brand new laptop few days ago its Lenovo y520 i7-7700hq/16gb rams and gtx 1050ti 4gb, and i cant play games at all,tried tom clancys the division i have 15-10 fps there and the rust on medium settings have big laggs i dont know what to do,tried to set my battery settings to high performance still the same thing...Please help.

Read other answers
RELEVANCY SCORE 56

Hi.My Lenovo have a 1tb hdd.I want to know if I can buy a ssd and the both disks.And if so what sdd can I buy MTM:80wk00mmpg

Read other answers
RELEVANCY SCORE 56
RELEVANCY SCORE 56
RELEVANCY SCORE 56

For example this:http://eu.crucial.com/eur/en/bls8g4s26bfsdk I want to use in dual channel so i want to buy two.

A:Lenovo Y520 Can i use 2666mhz ram?

yes but it will run on your mother board maximum allowes 2400mhz

Read other 2 answers
RELEVANCY SCORE 55.6

I got Lenovo Y520, and after installing Windows10 professional edition, and all of dirvers from Lenovo official website, I got some blurred screens like:  Is this normal? if not, how can I solve this?

Read other answers
RELEVANCY SCORE 55.6

Hey all,  Just recently bought a Lenovo Y520 gaming laptop. Overall very satisified with it! Last week I added an SSD drive to it and decided to do a fresh reformat from the BIOS so the laptop would run at full power without any bloatware holding it back.  Did the reformat sucessfully, installed all drivers, and now the laptop is running perfectly, except for one thing.  Since the reformat, Wifi has been giving me constant problems. I've tried just about every solution available on the net but so far have had no luck. It's main issue is: when I go to power on the laptop after being turned off for an extended period of time (at least 8-10 hours), there's no wifi at all whatsoever. Windows doesn't detect my wifi at all, even under network adapters! I've downloaded the latest drivers directly from Lenovo and even took it one step further by getting direct drivers from intel themselves. In this condition, it only detects my ethernet port, so when I go to diagnose it, it doesn't consider Wifi an issue because it doesn't think it exists.  The ONLY solution to get Wifi to work for me is to restart the computer at least once, load up the BIOS, go to the Configurations tab and disable/re-enable Wireless Lan. After that, I boot it with the saved changes and boom, Wifi suddenly works again. Thing is, I shouldn't have to do this every time to get Wifi to work. Before the reformat, the Wifi was working absolutely fine with no issues whatso... Read more

Read other answers
RELEVANCY SCORE 55.6

Hey guys, I just bought this computer today and I have encountered this problem. When I go to control panel -> display / dxdiag / AIDA64, I can only see Intel HD 630, but not my GTX 1050. I have tried reinstalling latest drivers and I changed the settings in NVIDIA control panel. I am using Windows 10 Pro. Thank you  

A:Lenovo Y520 dedicated GPU not showing

Hi Adomce123, 
 
Welcome to the Community Forums. 
 
Have you tried running dx diag with a high graphic application software running alongside?
 
The automatic switch from Intel to NVIDIA would happen when there is demand for it thus you were allowed to re install NVIDIA drivers and use the NVIDIA control setting since it was available in your system. This can also be checked in your device manager as well as lenovo diagnostics to confirm if the NVIDIA device if available.
 
Try going in the BIOS and verify options under Configuration Menu for graphic device to run on Discrete or UMA only as option. F10 to save setting before exit.
 
Update us how it goes.
 
Regards
 

Read other 1 answers
RELEVANCY SCORE 55.6

I have recently purchased a brand new Lenovo Legion Y520 15IKBM (Specs: i7 7700HQ, 16GB RAM, 128gb SSD + 1TB HDD, GTX 1060) and I'm liking it so far. It would be perfect for me if it wasn't for a couple issue that have been plaguing me. First: sometimes the system takes relatively long to boot. Usually it'll just show me Lenovo's logo for a couple of seconds and take me straight to the login screen, but sometimes it would stay on the logo for 10-15 seconds (without even showing the circling "loading" dots), then the screen would go blank for a few extra seconds and only then I would be on the login screen. And when it does that, the system continues to be considerably slower than usual even after login. Rebooting the system (sometimes twice) fixes the issue entirely. This happens regardless of whether or not the laptop is plugged in, but it seems to happen consistently on the first time I turn on the laptop after unplugging it. There are also times where, when I turn off the laptop, the screen turns off but the keyboard, power LED and fans are still powered for a LONG time. The second issue would be the system freezing seemingly at random, no matter if I'm playing a game or doing lightweight work. The whole OS would just lock up and either unfreeze after 10 to 30 seconds or straight up bluescreen with a KERNEL_DATA_INPAGE_ERROR. I would provide a memory dump, but apparently the system is set by default to not create any. That, and sometimes it would just bluescreen ... Read more

A:Lenovo Y520 stability issues

Hello there!I came here to share these same issues with my own Y520, when I saw your post. The difference is that MY Legion don't even let me to factory reset it, or run chkdsk, but beside these, I've tried everything. This is a pretty good laptop, but if it continues working like this, I will have to take it back, because I can't work on it properly like this.

Read other 2 answers
RELEVANCY SCORE 55.6

Hello all. I am about to buy the Legion Y520-15IKBN. It's the i7-7700HQ, GTX 1060  version. I have 2 questions though before I buy it.  1. I have a Seagate Barracuda 5TB 2,5" HDD, a Samsung 960 Evo NVMe 500GB and a HyperX Impact 16GB DDR4-2400 laptop RAM. Can I install them on this model or if I open it it will void the warranty?  2. The laptop comes with no OS. I have Windows 10 on my desktop PC. Since Windows are connected to the Outlook account (I think), will I be able to install and activate them on the laptop or I have to buy new? Thank you very much for any answers

Read other answers
RELEVANCY SCORE 55.6

Hi, I've recently bought this laptop and I'm already getting an error message upon booting up.This one: I have ran sfc /scannow in cmd: However, the error upon booting up still persists. What should I do next?  

Read other answers
RELEVANCY SCORE 55.6

Hi there, I did buy this Laptop 10 days ago , and i have a problem with Display.  I have a white color in the right of Display.Can u helo me whats is this , its any problem or what ?I'm waiting for your ReplayBest Regards

Read other answers
RELEVANCY SCORE 55.6

Everytime i charge my device to 100%The battery FULL CHARGE capacity seems to degrade a littleBtw, my laptop is only couple months oldThe battery report : https://drive.google.com/open?id=1XB2Xoj88xx1fXaV_vKE4J45g3Q0YUz8_

Read other answers
RELEVANCY SCORE 55.6

Hello everyone! I've got a problem with my Lenovo y520, bought about 3-4 months ago, I noticed that sometimes one white line at the bottom of the screen may appear out of nowhere (see screenshots), though it usually appears when I'm playing games. The line stands just at the bottom part of the screen, more exactly at the bottom part of the task bar. I must say that this problem didn't start to occur when I bought it, but after a while. Also, I noticed that while I'm playing video games, the screen would flicker (like a very short shut down) for 0.1 seconds, if you blink you'll literally miss it, and then the line appears. Sometimes, the screen flickers again and the white line would disappear. This problem doesn't occur everytime I play, but sometimes. The white line remains still, unless I restart the laptop. Now, I'm asking you for help, what is the cause of this problem and how can I solve it resulting in no appearances of such weird lines on my laptop's screen?Thanks.

Read other answers
RELEVANCY SCORE 54.8

Hello, I recently bought a lenovo y520 and every couple of days i get the warning ''Critical low battery'', even though the battery is fully chrarged and the charger is plug in. Any advice on how to fix this problem?

Read other answers
RELEVANCY SCORE 54.8

Heloo i just bought this new y520 legion laptop with specs:Core i7 77008GB Ram1060 3GB Max Q1 TB Seagate Hdd 5200 Rpm I installed windows 10 from microsoft website downloading iso and put it on USB drive I installed all drivers Updated Bios also. When i try to install Lenovo Nerve Center i get the error in the picture: An error occured while trying to copy file:The source file is corrupted.I downloaded it again same problem Same thing when i try installing Gta 5 Installed Assassind creed black flag and NFS Hot Pursuit with no problem. I cheked the Hard Drive for errors none were found.Cheked the RAM Memory no errors found.Reinstalled windows Updated firmware of the HDD If someone can help me i would apreciate it thank you 

Read other answers
RELEVANCY SCORE 54.8

Hi, I'm thinking of buying a new laptop and am deciding to go with the lenovo y520 80WK004UMH.Before I want to buy the laptop, I want to know a few things: - Is in mine model an m.2 slot available for an SSD upgrade and is it available in every lenovo y520 model?- Does any upgrades void the warranty?- What do you think of the gtx 1050 4gb card? Is it good enough to run most modern games on it, I don't expect them to play everything at ultra mode, but I'm pretty satisfied to play most games 60 fps on medium to high.- Has the i7 7700HQ a huge benefit for increase in gaming performance or is the i5 7300HQ fine? And yes, the more you spend, the better you'll get, the more future proof your laptop is. I'm kinda short on money, so I won't be able to go over ?1000,00 euro's. Thank you! Best regards, TheClient 

Read other answers
RELEVANCY SCORE 54.8

Hi all, I have run into a BLuetooth problem recently after trying to use some headphones which I have used before on this laptop. (Lenovo y520 15ikbn) Suddenly there appears to be no Bluetooth whatsoever on my laptop.When I run the Bluetooth troubleshoot in Settings, I get a message saying "Device does not have Bluetooth".There are no Bluetooth icons anywhwere, and in the Settings menu there is no "slider" to turn it on or off. Any suggetstions what could be the problem?  I am happy to post any info that might be neccessary to get to the bottom of this issue, please let me know! Thanks in advance, Tom

Read other answers