Over 1 million tech questions and answers.

Lenovo Dock Ultra no display output with most recent firmware update (fwdphb07)

Q: Lenovo Dock Ultra no display output with most recent firmware update (fwdphb07)

Hi, I installed the most recent firmware update (fwdphb07) and run into problems with my T450s: My displays (two attached via DP, the main display with DP 1.2) stay blank until the windows login screen shows up (no windows is starting screen). The problem is that I have a SSD password so the password dialog is not shown on the external screen. I downgraded the firmware to fwdphb06 (installed fwdphb03 before, because fwdphb06 does not allow for a direct downgrade) and everything works fine again. @Lenovo: can you please fix this issue - if you need more information please contact [email protected] users with the same issue: try to downgrade the FW Have a nice dayMichael

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Lenovo Dock Ultra no display output with most recent firmware update (fwdphb07)

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 102.8

Hello, is it possible to update the Lenovo Ultra Dock Pro to the latest version without a Windows Operating System? https://support.lenovo.com/de/en/documents/ht081248 A bootable ISO for this would be perfect. I use Linux as Operating System installed on a T440p, so a Windows based update is not possible for me. Thanks in advance! Best regrads, Michael

Read other answers
RELEVANCY SCORE 100

Hi guys, I'm hoping someone here can help me with my ever annoying problem. I have a T450s running on Windows 10 64-Bit. Latest Intel Drivers. I have an 40A2 Lenovo Ultra Dock. The following configuration is coming out of the dock into the monitors. Channel 1 - DisplayPort (dock) to Mini-DVI (monitor 1)Channel 2 - using DVI (dock) to DisplayPort (monitor 2) Channel 2 is not outputting any video signal at all. Intel's software is not recognising another monitor at all. Their DisplayPort Topology is showing 1 DisplayPort (this could be because the other is not connected). I've tried both display ports and they both work on either channels. I will be bringing in a DisplayPort to DisplayPort cable shortly to try, but shouldn't my DVI to DisplayPort. Something is amiss and it's driving me nuts. Thanks,Ron

Read other answers
RELEVANCY SCORE 86.8

I have a W541 and it always worked well with the dock and dual external monitors, that is until the firmware was updated by Lenovo System Update to the Latest Version: 2.33.000 about a week ago. Now when you boot the laptop in the dock, the post shows on the two external monitors then they go black and seem to disconnect as the power saving icon shows on both monitors. If you undock the laptop at this point and immediately re-dock, the two monitors light up and no more issues. While this isnt a huge issue, it is very annoying since it always worked properly before the update. Any suggestions on a possible fix are much appreciated. Thanks in advance.

Read other answers
RELEVANCY SCORE 86.4

Allright, I've been banging my head all morning on this wonderful monday mystery. We have got T460s i5 6200u specced machines for our clients that typically need docks, either the Pro or Ultra's.  We have had no issues with monitor output on the docks with Windows 10 enterprise 64bit with Anniversary. However, we are now starting to roll out our the imagages on the T460s laptops with  KMS server Enterprise Windows 10 with Creator Update. Since then, I have not been able to get any new T460s to reliably output via VGA, Displayport or DVI through an ultra or pro dock.  With the laptop lid closed and with full power running, and just the LCD laptop screen off, the docks refused to output to any monitor. Only when you slightly open the lid will the monitor output on the docks "wake up" finally up.  Monitor output does work if you have the laptop lid open when docking but neither are a real good solution The lenovo update has been run and  everything is updated included dock firmware.  I've disabled sleep mode just to make this easier with docking and undocking

Read other answers
RELEVANCY SCORE 86

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version always restart Windows Cellular service when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It works like the Fibocom WWAN L830-EB is DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 86

The title says it all. I'm very frustrated with this problem since I really need to connect my laptop to an external monitor for work. I've read and tried all relative topics in this and intel forums (e. g: https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-920-can-t-connect-to-any-external-mon...), have done all steps mentioned (including firmware, bios and windows update, windows reset, ...) but the problem still persists. Apparently, most users that had faced the same problem been able to get it worked after installing "Type C Firmware for Windows 10 (64-bit)" or the BIOS update provided by Lenovo. I installed them successfully but nothing changed. I am sure it is a software issue since there is no sign of any hardware one (all devices are fine as device manager shows and diagnostics app found no problem). It was just working fine until suddenly stopped working (probably after some recent windows update). I would greatly appreciate any help.

Read other answers
RELEVANCY SCORE 84.8

I cannot specify the cause, but recent firmware upgrade 1.51.1.24 might cause hang before entering Windows.It stucked at Lenovo logo, then I unplug the dock cable, it successfully moved to the windows loading animation(dot circling). When I plugged and turned on the laptop, it eternally stucked on logo screen. It worked fine weeks ago.All provided drivers  from Lenovo companion system upgrade are fully upgraded. I downloaded dock firmware but it gives alert that already upgraded. Note that Windwos 10 Home is installed.

Read other answers
RELEVANCY SCORE 77.6

I'm considering to upgrade my workstation. It would be a T470p w/a 2560x1600 display, 940mx and 4G support. The screen is a Dell Ultrasharp U2718Q. Do anyone know if it supports HDR through the Ultra Dock?

Read other answers
RELEVANCY SCORE 77.6

Hello,  I've been having a hard time finding this exact issue. We use T480s with the ultra dock 40AJ0135US. 98% of the machines dock without issue but I have a small stack where the display on the T480s with go dark with a slight flicker as soon as its docked. No external connections are activated and I'm not able to do anything until I undock and the screen goes back to normal. Specs are below.  Intel i5-8350U CPU 1.70GHzIntel UHD Graphics 6201703 office build

Read other answers
RELEVANCY SCORE 77.6

I have a P40 Yoga attached to an Ultra Dock 3.0 USB.  I have/had an HDMI cable coming off the dock to a ViewSonic monitor.  I am getting a maximum resoltion of 1920 x 1080 and colors are not displaying correctly or in some cases not displaying at all.  I found mention on the ThinkPad site that 4K is only supported via the DP off the dock.  So I tried a DP to HDMI cable and that does the same thing.  If I plug the monitor directly into the HDMI port on the laptop everything works great. Why doesn't the dock work as advertised and expected?  Is there a different setup required?

Read other answers
RELEVANCY SCORE 76.4

I've been having some issues with dual display with a T440s and a 40A2009US Ultra Dock. OS is Windows 7 64 Enterprise. I two identical Dell LCDs connected to the dock. One via VGA and the other DVI. Both displays are being mirrored and I can't seem to change it. There is only one monitor listed in Device manager.Both external monitors will only display an image if the PC is started closed from the docking station power button. Removing the laptop and replacing it on the docking station does not wake the monitors and there is no image until the laptop is manually shutdown and restarted. I have updated graphics drivers, as well as any driver related to the dock (USB3.0 etc). I have tried a displayport to DVI connector as well, no go. After some research I discovered the firmare may need to be updated. The synaptics package from the lenovo support downloads site gave me the message that my firmware was already up to date. The other fwdphb06.exe that is recommended elsewhere would not update. When I double-click the package there is no install prompt or process being run. There is an external monitor connected to the dock. I have swapped the dock for another, as well as the power supplies for each. I'm stumped. Any idea what my issue may be?

A:T440s+Ultra Dock Dual Display issues

I have the same problem and worse, when resuming from sleep it will often fail to bring up one or both of my monitors and I have to manually unplug their power cords to revive them. Worked fine with my old Thinkpad and dock. Trying the firmware update now... Lto 3 tapes

Read other 1 answers
RELEVANCY SCORE 75.6

I have a T460 with Windows 10 Pro. It is normally docked in an Ultra Dock. I have an external 4K monitor connected to the Display Port on the Ultra Dock. A week or so ago the display suddenly changed to vertical lines in strange colors. I have determined that the problem is not the cable or the monitor. I changed the DP cable, and the problem remained. When I connect the monitor directly to the mini DP on the T460 it works correctly. This seems to exclude the monitor, the display drivers and the DP driver in the T460 When I connect the monitor to the HDMI connector on the T460 it works correctly. This seems to exclude the monitor, the display drivers and the HDMI driver in the T460. When I connect the monitor to the HDMI connector on the Ultra Dock it works correctly most of the time, but I see occasional flashed of the vertical lines. When I tried a replacement Ultra Dock with the DP connector, the problem remained, but the connection between the T460 and the Ultra Dock was not secure. I returned the second Ultra Dock. All this seems to point to something in the T460 after the DP hardware but before the connector to the Ultra Dock.  Has anyone else seen this problem?   

Read other answers
RELEVANCY SCORE 74.8

Good day everyone: I'm experiencing an issue with my Lenovo E570 ThinkPad(Windows 10 Professional)/Ultra dock USB 3.0 combo when using either DraftSight or Sketch Up .  I have two ViewSonic monitors, one plugged into the Display Port and one into the HDMI port.  When I open DraftSigh or Sketch Up the drawing enviroment is displayed in gray colour only.  The tool bars surrounding the drawing enviroment are displayed correctly and are fully active.  When the cursor is moved over the drawing area it disappears from view however the program is still aware of the location of the cursor as the corordinate system tracks its movement in the drawing enviroment.  This issue persists when a known good drawing is opened.  If I unplug the Thinkpad from the dock and plug one of the external monitors into the Thinkpad directly both DraftSight and Sketch up funtion normally.  I believe that I have the driver updated to the most recent vesion as per the Lenovo support site and various fix posts, see screenshot below.  My Lenovo set up is only a few weeks old.  My previous laptop/docking station combo (non-Lenovo) drove the twin viewsonics and diplayed DraftSight and Sketch Up correctly.  Has  anyone had a similar issue that they have been able to correct or does anyone have any thoughts on what could be causing this issue?   

Read other answers
RELEVANCY SCORE 74.8

I have a W540 and ultra dock, have been using it with a U2713HM and sometimes also a U2412 on the dock's displayport outs, no problem. I just bought a 2nd U2713H (2nd hand - I wanted them to match, thoughHM and H models are subtly different), and for the life of me I CANNOT get the new monitor to work with either DP output on the ultra dock...  (just by itself, using either port output and either of 2 cables I have... while the original 2713HM works either display port out with either cable) basically windows shows a 2nd monitor is attached, and at the right resulution... and the monotor shows that it knows it's plugged in, but claims it's not being sent any video. so it's just black... But I did get it to work via DVI cable out of the dock(though at limited resolution) And I did get it to work with the miniDP out on my actual W540 using an old mini DP to DP connector (while also using the dock's displayport out with my other U2713.Can someone let me know what on earth is going on?? While it's releiving to at least be able to see my new monitor running alongside the old one for 2 x 2560x1440, I need that port on my laptop free for other purposes (it's a DP/thunderbolt port and I use it for thunderbolt too!) so I need this fixed or I have wasted money buying a 2nd monitor..  

Read other answers
RELEVANCY SCORE 74

My company has issue me a Lenovo T470s and an Ultra Dock to replace my existing equipment. I have two external monitors connected to the docking station with display port cables. The problem that I am experiencing is that if the laptop is docked and the cover is open, I get video on the laptop display and one external monitor. The other external monitor gets no signal and goes to sleep. If I close the laptop cover, I get video on both external monitors. A co-worker told me that this was working as designed and that the solution for getting video on all three monitors was to connect one external monitor to one of the display ports and the other to the DVI port. (He hadn't tested this configuration and is using two display ports with the laptop cover closed.) I tried my coworker's suggestion and got the same result but prior to switching to DVI, I downloaded and installed the latest(?) driver for the HD Graphics 620 adapter from this website (lenovo.com) and that seemed to solve the problem (when using two display ports) but after shutting the laptop down, I had the same issue the next day. What I want, is to have the laptop cover open and still be able to use two external monitors and get optimal resolution on all three monitors. What's the best configuration for achieving this? (Don't guess, like my co-worker. Give me something you've tested and that you can confirm that it works.)

Read other answers
RELEVANCY SCORE 74

I am trying to connect two Sceptre U27 4k monitors via display port to the Thinkpad Ultra Dock 40A2 and i'm not having any luck. With a Thinkpad x470s) I can get 1 working but the other monitor just doesn't see a signal. The only setup i've gotten to work is one monitor at 4k @ 30hz on a Display Port and the other at 1920x1080 via DVI I have tried:both display port, 4k @ 30hz (<--- what i'd like to get working since both at 60hz isn't an option with this dock I don't believe)one display port, 4k @ 30hz, one hdmi 4k @ 30hz (via hdmi on the back of the dock)one display port, 4k @ 30hz, one hdmi via hdmi port on the side of the laptop Is anyone familiar with what magic combination of cables and ports would allow me to run both 4k monitors at 30hz, via the two display ports at the back of this dock? I would think updating the docks firmware may help ( https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/ThinkPad-Pro-Dock-ThinkPad-Ultra-Dock-or-Thin... ) but there inlies another issue.  Our corporate image on these laptops is RHEL 7.5 and I do not see an option to flash any firmware available from linux unfortunately. Any help would be greatly appreciated. 

Read other answers
RELEVANCY SCORE 74

I am trying to connect two Sceptre U27 4k monitors via display port to the Thinkpad Ultra Dock 40A2 and i'm not having any luck. With a Thinkpad T470s) I can get 1 working but the other monitor just doesn't see a signal. The only setup i've gotten to work is one monitor at 4k @ 30hz on a Display Port and the other at 1920x1080 via DVI I have tried:both display port, 4k @ 30hz (<--- what i'd like to get working since both at 60hz isn't an option with this dock I don't believe)one display port, 4k @ 30hz, one hdmi 4k @ 30hz (via hdmi on the back of the dock)one display port, 4k @ 30hz, one hdmi via hdmi port on the side of the laptop Is anyone familiar with what magic combination of cables and ports would allow me to run both 4k monitors at 30hz, via the two display ports at the back of this dock? I would think updating the docks firmware may help ( https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/ThinkPad-Pro-Dock-ThinkPad-Ultra-Dock-or-Thin... ) but there inlies another issue.  Our corporate image on these laptops is RHEL 7.5 and I do not see an option to flash any firmware available from linux unfortunately. Any help would be greatly appreciated. 

A:T470s and Ultra Dock 40a2 dual 4k display port monitors not functioning

I'm thinking my best bet may be to use a Display Port to USB-C/Thunderbolt 3 cable for one monitor and the docking stations display port for the other.

Read other 1 answers
RELEVANCY SCORE 74

A week ago at regular system update request I installed the offered "Lenovo SSD & HDD Firmware Update Tool"  10.3010 on P50 running Windows 7/64. Message appeared that I needed to remove password on (only) the factory 500GB HDD. Passwords also exist on the two SSD's but no action requested re them. I presumed the SSD updates were installed and I would have to later temporarily remove HDD PW and run the update again. So I removed the HDD PW just now and went to System Update online but message then was that there was nothing for my machine. How do I force installing the update again, if that is the right way to do it. Is there any way to see if it somehow took care of the problem automatically as soon as soon as I removed the PW? Thanks.

Read other answers
RELEVANCY SCORE 73.6

Hi guys, I'm requesting Lenovo to please add on lvfs (https://fwupd.org/lvfs/) firmwares for the docking station 40A2 The issue I'm having is https://support.lenovo.com/us/en/solutions/ht101460 this "User is experiencing intermittent video loss on external monitor" yes, with 2 different 40A2 currently running Fedora 29 on kernel 4.20 thanks

Read other answers
RELEVANCY SCORE 73.6

Hi there, my Helix laptop (purchased a few years ago) is giving me the "Keyboard Dock Fan Error" at startup. I am then unable to use the keyboard and mouse pad. I previously had this same error a couple of years ago and had solved it using the Firmware update.Now I tried:- BIOS update. Done updated to the latest BIOS version.- Tried doing again the firmware update (although I had done it a couple of years ago) but now I have Windows 10 and the firmware update executable on the Lenovo site says it is for Windows 8 or below. I tried it anyway but it gave an error saying: "This tool and EC firmware mismatch, or communication error is happened.".  Your help is much appreciated.- Najib

Read other answers
RELEVANCY SCORE 73.2

Hi,I have L450 NB and Pro Dock station.I have question. Can I plug in and use two monitors (1 - DVI, 2 - displayport)?In this link (https://support.lenovo.com/cz/cs/documents/pd029622) is write:3 - any combinationWhat does it mean?If I connect DP and DVI in same time, than is video ouput only on DP.Is possible to use both monitors on digital output?Tomas











Solved!
Go to Solution.

A:Lenovo L450 Pro Dock video output DVI and DP in sa...

maniakum wrote:Is possible to use both monitors on digital output?
No, the DisplayPort and the DVI port of the Pro Dock can't be used at the same time. Thus, you need the Ultra Dock.

Read other 2 answers
RELEVANCY SCORE 72.8

Hi, i have a T470 that connects to a UCB C Lenvo thunderbolt dock, occasinly it requires the firmware to be updated (i done this last month) however it is erroring again saying i need to conncact my pc manufacturer for new firmware, i have just checked and there is no new firmware on the lneovo website, i installed all the latested packages that were there, does nayone know where i can get the new firmware and if there is any workaround? The dock is not showing as connected in the dock software window, however the dock light goes from yellow to white when i polug it into the laptop, so it does see the connection they just cant talk to each other. Thanks 

Read other answers
RELEVANCY SCORE 72.8

Hello every oneI've problem with my lenovo l560 and try describe my problem. 1. When i connected laptop with close cover to the dock station i will get screen on the external monitor.2. When i connected latptop with open cover i've screen on external monitor and on the laptop Problem starts when i connected my laptop with close cover to the dock station then open them. I've only screen on the laptop but none on external monitor. I must use  keys combination like "windows + p" and choose  extent screens to display screen on laptop and external monitor but when i disconnected laptop from dock station and connect again that the same problem. What can i do to solve this problem?My configuration:intel core i5-6300U 2.4 GhzIntel HD 520Windows 10 pro   

Read other answers
RELEVANCY SCORE 72

I currently own a Thinkpad Helix, bought about two months ago. Up until now it has been well worth the price, and worked almost flawlessly. Just this morning, out of nowhere the keyboard and touchpad stopped working. I tried my usual solution, detaching and reattaching the dock, but it did nothing. I tried restarting my computer, and found that while it was plugged into the dock, I got a "Keyboard Dock Fan Error" and it would fail to start. I started looking around on these forums for answers, and it seems many people had the same problem I did. On one thread there seemed to be a link to this firmware update designed specifically to get rid of the problem I had. Upon installing it and running the application, it would freeze for about 5 seconds and then display this strange error message, "This tool and EC firmware mismatch, or communication error is happened." I can assure you I was connected to the internet at the time. So i looked at the readme, and it suggested updating the bios. When I tried that, it told me I already had the latest bios installed, and running the firmware update again afterwards gave the samw results. I don't know what to do, and i'd love some help on the matter.

A:Enhanced Keyboard Dock Firmware Update Problem

Can you verify what bios and keyboard firmware you have installed now? 
The latest bios is version 1.14. 
 
You can check this by rebooting and hitting F1. The versions should be listed. The keyboard firmware is listed as MPU I belive. Then just hit F10 to close it once you're done.

Read other 9 answers
RELEVANCY SCORE 72

I have a T460 Thinkpad on a Lenovo Pro Dock 90w with LG 29UM68-P ultrawide monitor running at 2560x1080.  My docking station was manufactured in December 2016 & I am using the included 90w power adapter.  My monitor has built in speakers (using Intel Display Audio drivers), so my DisplayPort cable is carrying both audio & video. I have two symptoms of signal loss:  audio cuts out intermittently when playing music (or watching videos w/ sound) & the screen will periodically go dark with a "no signal" message.  The video signal restores itself after about 3-4 seconds. I have already tried updating the ThinkPad's BIOS to the latest version, updating Intel graphics drivers to latest version, as well as the Pro Dock 90w firmware (to version 2.33.000).  I also swapped out my DisplayPort 1.1 cable for a DisplayPort 1.2 cable. The monitor+speakers work beautifully when connected to a Dell laptop+docking station, so I know the problem is not with the monitor. Are there any other tricks I could try? 

Read other answers
RELEVANCY SCORE 72

Dear all, having just updated my the firmware of my Ultra Dock (40AJ0135EU) via Lenovo Vantage to V5.0.6.1, there is now something truly wrong with the power supply; on startup, I am greeted by the famous "low wattage" screen and when using windows, the battery is slowly drained (Lenovo Vantage claims that a 25 W USB-C adapter would be connected instead of the 135 W one). The issue never occurred prior to the firmware update and consistently shows up for any other power cable (trying several ones, including 90 W). So while the "low wattage" screen is annoying, the more severe issue is the constantly drained battery which makes using the dock basically impossible over time. Any ideas? I did not find a way to undo the firmware update - or is the recommendation to wait and hope for yet-another firmware update that (may) solve the issue? Maybe someone has a similar issue and a better / working solution Thx!

A:Low wattage issue T480 after dock firmware update

 By chance did airplane power mode get turned on? The only way I know to check this is in the Lenovo "Vantage" tool 

Read other 1 answers
RELEVANCY SCORE 72

Hey all! I can't seem to get my firmware to update....I just get this: Has anyone seen this and have any advice? I've consulted Google and the forums here and can't seem to get any leads. I'm running a T480 with the latest updates per the support site and the System Update 5 tool. Thanks in advance! 

Read other answers
RELEVANCY SCORE 69.6

Same issue. Latest Thunderbolt Firmware update made my HDMI output unusable. I can not connect to an external monitor. We need a fix ASAP! Dell technical support was unable to help so far...

Read other answers
RELEVANCY SCORE 68.4

Hello, We have a problem with 2 laptops (ThinkPad X270) that "freeze" on the LENOVO logo when using Lenovo Ultra Dock with monitor Dell UZ2715H.Display Dell is plugged by Display port ports and one USB 3.0 (9 pin - used for display integrated webcam) connected to ThinkPad dock.When notebook turned ON with connected USB 3.0, computer freeze on LENOVO logo (To interrupt normal startup, press Enter) and work only when USB 3.0 disconected, or turned OFF and again Turned ON. Firmware on Dock is 2.33.000 Any suggestion? 

A:Lenovo ThinkPad Ultra (Pro) Dock + ThinkPad X270 (20K6) + Dell UZ2715H

I am just going to guess that computer is trying to boot via USB, so you might try changing the boot order in the BIOS so that Windows Boot Manager or the HD is first.  

Read other 1 answers
RELEVANCY SCORE 66.4

I'm not able to use an external display during the boot process + Bitlocker Screen. T480s on a USB-C 40AF Dock. This functionality exists with T470s and the 40A2 Ultra Dock. There is the proper Display On Dock BIOS setting avaible. This funcitionality exists with the P52s and the USB-C 40AC Dock. It seems like the T480s is missing this functionality, and I want to know if there is a planned BIOS update to fix this issue. I've tried every other possible BIOS configuration, and both USB-C ports on the T480s, there is no way to get an external montior to display during boot when that external display is plugged into a USB-C dock. Please let me know. Thanks!

Read other answers
RELEVANCY SCORE 66

Hi, since a couple of weeks, system update prompts me to update my NVMe disk firmware. It downloads and runs Lenovo Storage Device Firmware Update Utility, but it always fails with the same error: Update Failed: Firmware update FAILED! RC=0x1 Stopped by a device reason.  This happens to me with the last version of the firmware update toot (FWNV29), but also has happened to me with previous versions. Also, downloading FWNV29 and running it independently from system update leads to the same error. Can someone help? Thanks. The log from fwwinsd.exe (fwwinsd.log) shows the following:[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - IN
[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - OS : Windows 6.2 Build 9200
[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - Current path : C:\Users\fpiris\Desktop\FWNV29
[2019/03/27 07:47:09]: CFWWinDlg::openProfile - IN - fwwinsd.pro
[2019/03/27 07:47:09]: CFWWinDlg::OnInitDialog - Profile verified to exist
[2019/03/27 07:47:09]: CFWWinDlg::disableAutoODDPowerOffFeature - IN
[2019/03/27 07:47:09]: CFWWinDlg::disableAutoODDPowerOffFeature - Open registry key : Software\Lenovo\PWRMGRV\Data
[2019/03/27 07:47:09]: CFWWinDlg::displayDrives - IN
[2019/03/27 07:47:09]: CATADrivesScanner::scan - IN
[2019/03/27 07:47:09]: CATADrivesScanner::cleanUp - IN
[2019/03/27 07:47:09]: CATADrivesScanner::enumerateDevice - IN : GUID=0x53f56307
[2019/03/27 07:47:09]: CATADrivesScanner::enumerateDevice - Device info se... Read more

Read other answers
RELEVANCY SCORE 64.4

I was wondering what's supported for having an external screen, preferable 2.I had done some research online but wasn't obvious.

Read other answers
RELEVANCY SCORE 64.4

 Has a solution ever been provided for this.  Several models are doing this.  https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Bitlocker-PIN-USB-C-Thunderbolt-dock/m-p...

Read other answers
RELEVANCY SCORE 64.4

Hi, Everyone. Got me a nice little x270 to replace my old x201.  Happy enough with the machine, but getting it connected to my accessories (monitor, keyb, mouse, ethernet) is a bit of a chore. This machine appears to have a "proper" dock port on the bottom.  Is there a compatible ultradock available for the model 20HN x270?  By proper - I mean, Not USB.  A nice dock I can simply drop the machine into when I'm at the home office.. Thanks!

Read other answers
RELEVANCY SCORE 64.4

I have read a lot and tried updating the firmware - nothing works.When I put the laptop in the docking station - it does not recognize the monitar and also says AC power is not connected when it is. Help appreciated!

Read other answers
RELEVANCY SCORE 64

Hi I have a T430 and yesterday (12 feb) it said that it needs to do a Lenovo firmware update. I ran through the installation and it finished and prompted me to reboot. I didn't think it at the time but I have never before seen a firmware update install unprompted (this was not a windows update it was a Lenovo Firmware Update and ran through some considerable command line output before finishing and then asking for a reboot). When it booted back up everything was fine but within a few hours I started to experience wifi problems. Connections would randomly drop and so on.  And I would get strange DNS errors such as DNS_FINISHED_NO_INTERNET. After a while the wifi became unusable. So I performed a windows restore to before the Lenovo firmware update and it fixed the wifi issues, the NIC connected again as normal. But then today the sound started to go crackily and jumpy.  This resolved itself on reboot however I am concerned that after having the laptop for about a year (refurbished) with no issues (except a keyboard issue which  I will write another post about) that I then have 2 hardware issues hours after the Lenovo firmware update.So my 2 questions are: Is the Lenovo firmware update legitimate? if so it known to have caused issues to anyone else? and depending on the answer to them questions is there any advice I should be following? Official or otherwise.ThanksDamian

Read other answers
RELEVANCY SCORE 63.6

I installed a game. trouble with it so installed new updates. My computer restarted with less space and poor color. I then deleted a copy of this huge folder I made to see if that was the problem, it wasn't. When I go to change the display and hit apply it goes black and goes back to how it is now. What is wrong and how do I fix it>

I dled a new nvidia driver I think that might have something to do with it.
 

A:recent update caused problems with display

Read other 7 answers
RELEVANCY SCORE 63.2

Lenovo Vantage is showing as a "critical update" the "Lenovo SSD and HDD Firmware Update Tool".  It would be nice to check the firmware on my Thinkpad's SSD, which, being OEM, can't be updated through the SSD manufacturer's tool.  However the Lenovo tool now offered occupies 635 MB on the drive, which is an unacceptable bloat.  I have only my one drive, and a firmware updater should be very much smaller than 635 MB. What to do?  Is it possible to uninstall the Lenovo tool after using it once?  That depends on how it installs.  But then can it be reinstalled many months later to recheck the currency of the firmware?  The installation file is just 95 MB, and it would be fine to keep that for later.  But do we get the installation file when we let Lenovo Vantage install the Tool?Advice appreciated. 

Read other answers
RELEVANCY SCORE 63.2

Hello Everyone, I have a simple issue. I could find thinkvantage system update for windows to download all the updates and firmware for my thinkpad x1 carbon. I have another laptop T530 running linux. I need to update the firmware for my docking station. I could not find any resources to do so. If anyone has any idea please direct me there. Thank you

Read other answers
RELEVANCY SCORE 63.2

The download page for this update is up since a few days but there is no download available: http://support.lenovo.com/fr/en/products/laptops-and-netbooks/thinkpad-edge-laptops/thinkpad-e555/do... And when you switch to another language like German or French the older version 1.14 is offered as downlaod. These bugs in your driver download section happen a lot, please fix them!

Read other answers
RELEVANCY SCORE 63.2

After updating to the windows 10 fall release I can no longer use my thinkpad usb-c dock.  It will not display on the external monitors.  I uninstalled the display link software and updated to the most recent release available with no luck still.

Read other answers