Over 1 million tech questions and answers.

Low wattage issue T480 after dock firmware update

Q: Low wattage issue T480 after dock firmware update

Dear all, having just updated my the firmware of my Ultra Dock (40AJ0135EU) via Lenovo Vantage to V5.0.6.1, there is now something truly wrong with the power supply; on startup, I am greeted by the famous "low wattage" screen and when using windows, the battery is slowly drained (Lenovo Vantage claims that a 25 W USB-C adapter would be connected instead of the 135 W one). The issue never occurred prior to the firmware update and consistently shows up for any other power cable (trying several ones, including 90 W). So while the "low wattage" screen is annoying, the more severe issue is the constantly drained battery which makes using the dock basically impossible over time. Any ideas? I did not find a way to undo the firmware update - or is the recommendation to wait and hope for yet-another firmware update that (may) solve the issue? Maybe someone has a similar issue and a better / working solution Thx!

RELEVANCY SCORE 200
Preferred Solution: Low wattage issue T480 after dock firmware update

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

A: Low wattage issue T480 after dock firmware update

By chance did airplane power mode get turned on? The only way I know to check this is in the Lenovo "Vantage" tool

Read other 1 answers
RELEVANCY SCORE 90.4

Hi I cant seem to locate a fix for my lenovo t480. I cannot get any usb ports to register through the dock. I have tried reinstalling usb drivers through device manger, updating dock firmware, updating all lenovo system drivers , changing power adaptor through the dock and re seating it multiple times. I have other t480's that work on this dock. The usb's work fine on the actual laptop just not the dock. Any help would be apreciated. Thank you!

Read other answers
RELEVANCY SCORE 90.4

I am using a T480 with the TB3 dock and 2 external monitors.My problem is my screens go black for a couple of seconds every x amount of time. I've updatad all drivers found under the Display and Video graphics section Drivers T480I remember when updating to Intel Thunderbolt Software for Windows 10 (64-bit) - ThinkPad T480, T480s, X1 Carbon Gen 6 - 1.41.565.0I received the following screen:(I did get 2 Thunderbolt SW apps in my start menu and uninstalled the one which was visible via add/remove programs) These updates did not resolve my monitor issue.I later on noticed there is a new TB3 Dock FWWhen I wanted to make the update I got the message the TB SW had to be above 17.4.77.400. (the version insalled and active was 1.41.565.0) I reinstalled TB SW 17.4.78.500 and performed the TB3 dock FW upgrade. Now I am in the situation I do not have a Thunderbolt SW application to allow/select TB devices to connect.V1.41.565.0 seems to be a new DCH driver. reverting back to the legacy driver 17.4.78.500 is not somethig I should have done.It seems the DCH driver came with it's own Thunderbolt SW application, which is no longer available. Is there a procedure to completly reinstall the DCH driver including the Thunderbold SW or revert back to the legacy driver with Thunderbold SW (which now states the application is not in use anymore) Thanks!

Read other answers
RELEVANCY SCORE 90

Hi, i have a T470 that connects to a UCB C Lenvo thunderbolt dock, occasinly it requires the firmware to be updated (i done this last month) however it is erroring again saying i need to conncact my pc manufacturer for new firmware, i have just checked and there is no new firmware on the lneovo website, i installed all the latested packages that were there, does nayone know where i can get the new firmware and if there is any workaround? The dock is not showing as connected in the dock software window, however the dock light goes from yellow to white when i polug it into the laptop, so it does see the connection they just cant talk to each other. Thanks 

Read other answers
RELEVANCY SCORE 80.4

I have a t480s, working fine for months. Just updated the bios today and now on boot when using my pro dock gives the dreaded ac adaptor has lower wattage than original. But of course this is the original AND it's on a dock. The error message started on bios update so clearly a BUG in the bios.  Does anyone from lenovo watch the forums and can work on getting this fixed? Thanks!

Read other answers
RELEVANCY SCORE 77.6

I can see support for the MZVLB512 and MZVLB1T0, but nothing for the 256Gb model. Why?https://download.lenovo.com/pccbbs/mobiles/fwnv25en.txt

Read other answers
RELEVANCY SCORE 74.4

Hi there, my Helix laptop (purchased a few years ago) is giving me the "Keyboard Dock Fan Error" at startup. I am then unable to use the keyboard and mouse pad. I previously had this same error a couple of years ago and had solved it using the Firmware update.Now I tried:- BIOS update. Done updated to the latest BIOS version.- Tried doing again the firmware update (although I had done it a couple of years ago) but now I have Windows 10 and the firmware update executable on the Lenovo site says it is for Windows 8 or below. I tried it anyway but it gave an error saying: "This tool and EC firmware mismatch, or communication error is happened.".  Your help is much appreciated.- Najib

Read other answers
RELEVANCY SCORE 73.2

Hello, is it possible to update the Lenovo Ultra Dock Pro to the latest version without a Windows Operating System? https://support.lenovo.com/de/en/documents/ht081248 A bootable ISO for this would be perfect. I use Linux as Operating System installed on a T440p, so a Windows based update is not possible for me. Thanks in advance! Best regrads, Michael

Read other answers
RELEVANCY SCORE 72.4

I have a T460 Thinkpad on a Lenovo Pro Dock 90w with LG 29UM68-P ultrawide monitor running at 2560x1080.  My docking station was manufactured in December 2016 & I am using the included 90w power adapter.  My monitor has built in speakers (using Intel Display Audio drivers), so my DisplayPort cable is carrying both audio & video. I have two symptoms of signal loss:  audio cuts out intermittently when playing music (or watching videos w/ sound) & the screen will periodically go dark with a "no signal" message.  The video signal restores itself after about 3-4 seconds. I have already tried updating the ThinkPad's BIOS to the latest version, updating Intel graphics drivers to latest version, as well as the Pro Dock 90w firmware (to version 2.33.000).  I also swapped out my DisplayPort 1.1 cable for a DisplayPort 1.2 cable. The monitor+speakers work beautifully when connected to a Dell laptop+docking station, so I know the problem is not with the monitor. Are there any other tricks I could try? 

Read other answers
RELEVANCY SCORE 72.4

I currently own a Thinkpad Helix, bought about two months ago. Up until now it has been well worth the price, and worked almost flawlessly. Just this morning, out of nowhere the keyboard and touchpad stopped working. I tried my usual solution, detaching and reattaching the dock, but it did nothing. I tried restarting my computer, and found that while it was plugged into the dock, I got a "Keyboard Dock Fan Error" and it would fail to start. I started looking around on these forums for answers, and it seems many people had the same problem I did. On one thread there seemed to be a link to this firmware update designed specifically to get rid of the problem I had. Upon installing it and running the application, it would freeze for about 5 seconds and then display this strange error message, "This tool and EC firmware mismatch, or communication error is happened." I can assure you I was connected to the internet at the time. So i looked at the readme, and it suggested updating the bios. When I tried that, it told me I already had the latest bios installed, and running the firmware update again afterwards gave the samw results. I don't know what to do, and i'd love some help on the matter.

A:Enhanced Keyboard Dock Firmware Update Problem

Can you verify what bios and keyboard firmware you have installed now? 
The latest bios is version 1.14. 
 
You can check this by rebooting and hitting F1. The versions should be listed. The keyboard firmware is listed as MPU I belive. Then just hit F10 to close it once you're done.

Read other 9 answers
RELEVANCY SCORE 72.4

Hey all! I can't seem to get my firmware to update....I just get this: Has anyone seen this and have any advice? I've consulted Google and the forums here and can't seem to get any leads. I'm running a T480 with the latest updates per the support site and the System Update 5 tool. Thanks in advance! 

Read other answers
RELEVANCY SCORE 72.4

I have ThinkPad Yoga X1 (Gen1) with Thinkpad OneLink+ dock.If something (anything, USB memory stick, USB keyboard, USB monitor) is connected to a dock or to a notebook, during powering on, it want pass the BIOS part and start booting Windows OS.It should be fixed long time ago, but same issue still persists.I have latest BIOS firmware - 1.31https://pcsupport.lenovo.com/hr/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-...The issue persis for a months

Read other answers
RELEVANCY SCORE 70.4

Hi, I installed the most recent firmware update (fwdphb07) and run into problems with my T450s: My displays (two attached via DP, the main display with DP 1.2) stay blank until the windows login screen shows up (no windows is starting screen). The problem is that I have a SSD password so the password dialog is not shown on the external screen. I downgraded the firmware to fwdphb06 (installed fwdphb03 before, because fwdphb06 does not allow for a direct downgrade) and everything works fine again. @Lenovo: can you please fix this issue - if you need more information please contact [email protected] users with the same issue: try to downgrade the FW Have a nice dayMichael  

Read other answers
RELEVANCY SCORE 64.8

Hello, I have Carbon X1 5th (20HR) running Windows 10 pro (updated).  Altought I followed the instructions here - https://pcsupport.lenovo.com/cy/en/downloads/ds120390 (This is the page for Lenovo users who wish to update TPM firmware) - and installed the "BIOS Update Utility for Windows 10" version 1.33, Windows still keeps telling me to update the TPM firmware driver.  In BIOS it shows that I have TPM ver 2.0, enabled. Since Windows kept telling me to update the TPM driver, thanks to Google I found out that there is a tool created by Lenovo called "TPM Firmware Update Utility -ThinkPad" (It is worth noting that this tool is not mentioned on the instruction page). I downloaded the tool, but can't understnad how to use it (assuming that I should use it at all, because this tool is not mentioned on the TPM instructions page). Could you please help me to solve the TPM issue described above? Is there a way to check what version do I have? Thanks in advance!  

Read other answers
RELEVANCY SCORE 64

I have a user with two LT3053s (2560 x 1600) and his previous T440 + Ultra Dock (I believe) supported the full resolution at 60 Hz (again I believe).  I upgraded him to a T480 and our standard Type-c dock that we deploy limited the screens to 1920x1080 @ 60Hz.  After this and complaints from the user of headaches from the drop in resolution we purchased a TB3 Gen 2 Dock and even after plugging the dock in to the actual TB3 port on the laptop (not the top type-c port) we are having issues with not all of his devices working, namely the kb+m. Any ideas here?  Right now we are running it with the 135W power adapter that it came with, but there is also another power adapter available that did not come with the unit we purchased.

Read other answers
RELEVANCY SCORE 64

Hi guys, I have a ThinkPad T480 combined with a Pro dock (side). I was hoping to use 3 external monitors (not including the laptop screen). The pro dock only has 2 display ports and the laptop has a HDMI port which i was hoping to all use to get my 3 displays.My setup is 2 VGA external monitors to display port adapters and 1 hdmi monitor to the laptops hdmi port directly. 2 display port monitors display fine, however the HDMI display goes black. If i un dock the laptop, the HDMI monitor works.Can i not output all 3 at the same time, i know the laptops chipset allows 3 monitors.I was thinking of buying a USB C to HDMI adapter for the 3rd monitor, maybe this would resolve it? thanks in advance

Read other answers
RELEVANCY SCORE 63.2

Any suggestions??

A:Update issue.. UEFI firmware issue

Is this path correct??

Read other 15 answers
RELEVANCY SCORE 63.2

I'm using a Razer Trinity mouse, and it works fine, as long as I plug it directly into the laptop's USB port. If I try to use any sort of USB hub or switch (I've tried three different hubs -- each with a different set of USB cables) the mouse cursor randomly freezes on screen for about one or two seconds at a time. I tried installing the Razer Synapse 3 software on the laptop, and turned off the mouse lighting (to reduce power usage and rule that out), but that didn't help. I've also: -updated all drivers/bios via System Update-installed all Windows Updates-tried all three Windows power profiles

Read other answers
RELEVANCY SCORE 63.2

Hi Guys,I have a T480 laptop with a pro dock docking station and 3 monitors i want to try to get working.2 of the monitors are working fine via a VGA > DP adapter. The 3rd i bought a USB-C to HDMI adapter, though i cannot get this to work, even with the other two monitors disconnected.If the laptops undocked and the 3rd monitor is connected to the USB-C port, it works. Has anyone had luck with 3 monitors on this docking station? I have been considering a display port hub, can we use adapters with these hubs ok or does it only work if the cable is solely DP Thanks guys

Read other answers
RELEVANCY SCORE 63.2

Hello,I've just bought T480 with Thunderbolt 3 Lenovo USB-C hybrid dock and my laptop is not charing when connected to dock. External monitor and other devices connected to dock work fine, but laptop even do not recognize dock as charger. It acts like it running completely of battery. Where can be a problem? Thank you

Read other answers
RELEVANCY SCORE 63.2

Hi.  Hoping that someone can provide a little guidance, and show me where I must be doing something wrong. T480 (20L5 model) running Windows 10 1709 (Core i5, 8th Gen Intel)Thunderbolt 3 Dock (40AC model)Installed Thunderbolt Software is:  17.3.74.400System BIOS is:  1.12BIOS Thunderbol setting:  Security Level - No Security When I connect the dock to the laptop via Thunderbolt 3 connector, the laptop DOES draw power.  So I know that it basically works.What it does not do is anything else.  Connecting ethernet, usb keyboard and mouse, or even VGA monitor has no results. Des anyone have any suggestions about what I might be doing wrong here?  Other settings to check?  Or am I possibly dealing with a faulty component? Thanks in advance for any suggestions. Chris

Read other answers
RELEVANCY SCORE 63.2

All, Can you use the T480 with the Lenovo Thunderbolt 3 Graphics Dock that has the external GPU.Look for the solution to attach 3 external 2560 x 1440 monitors (DisplayPort and/or HDMI) at 60 Hz. Also would the 40AJ0135US Ultra Dock allow me to use the 2 x DP and 1 HDMI at the same time. Thanks

Read other answers
RELEVANCY SCORE 62.4

Hi,  I am experiencing an issue with SSD FW update released on Mar 14, 2019 for X1 Extreme.  The program returns one of the following 2 errors.  1) Error pops up immediately after drive selected for update. Error code is RC = 0x2. 2) Error pos up after OS reboot. "software condition is not ready to update due to some reason". Last line in the cmd window  is "Get Storage information".  I am running Windows 10 v1809. Please advice. Thank you. 

Read other answers
RELEVANCY SCORE 62.4

Hello,I've got brand new T480 with ThinkPad Hybrid USB-C with USB-A Dock and I'm experiencing USB issues when docked.I have read related topics and they seems to be dead without any working solution. Description of problem:When I docked my T480 for the first time, all USBs (only mouse and keyboard) were working. I had left office for night and when I have returned and docked my laptop again, USBs seems to stop working. I?ve tried to reconnecting dock, powering dock off and unplugging devices or changing USB slots without any success.Only restart of computer seemed to get USBs working back again. BUT, there have been about 5 minute period when USB devices were randomly connecting and disconnecting without any warning.Problem appeared again when I left my desk for 30 minutes without turning off or putting laptop into sleep. USBs were dead again. Only restart helped and it was followed with 5 minute period of randomly disconnecting USB devices again.All other connected devices ? 1x FHD monitor via DP, 1x FHD monitor via HDMI and headphones via front 3.5mm jack are working without any problems and laptop is charging properly as well. My laptop is fully updated via Lenovo Vantage and dock in currently at only available FW. Is there any solution to this? It?s get pretty annoying for laptop that is meant to be docked! And it seems that problem occurs accros multiple ThinkPad Thunderbolt docks.. Thank you

Read other answers
RELEVANCY SCORE 62.4

I own a Thinkpad T480 (20L5: Intel UHD graphics, Core i5 8th gen) and since it supports Thunderbolt 3, I want to attach an external GPU and display for light gaming. I see that Lenovo itself has a "Lenovo Thunderbolt Graphics Dock" but does not offer that as compatible with the Thinkpad series. Nevertheless, as Thunderbolt 3 is a standard, I am wondering if the Graphics Dock works with the T480. Did anybody already try that?

Read other answers
RELEVANCY SCORE 61.6

I have a T480 with Windows 10 Pro connected to a Dell U3415W monitor via a DisplayPort to HDMI cable via a 40AJ0135US Ultra Dock (DisplayPort side connected to the docking station, HDMI connected to the monitor).  While using this setup, I will occasionally (sometimes quite frequently) get black-outs in the monitor for a few seconds and then the display returns without issue.  Its extremely annoying and interrupts my work.  Often, restarting the laptop will help resolve it for a while but it always returns in some fashion. I have run the ThinkPad Docking Station FW updater and it said everything is up to date.  Additionally, Lenovo System Update is 100% updated.  Any suggestions would be greatly appreciated.

Read other answers
RELEVANCY SCORE 61.6

I have a new T480 and Lenovo Thunderbolt 3 dock. I find that often when I close--but in no way shut down--the computer for the night, when I restart in the morning, it completely restarts, so I lose open tabs, unsaved work, etc. I can understand enough of the system event log to determine that the computer always goes to sleep when I close it, then, per the power plan, hibernates three hours later--or at least tries to. The first sign of trouble in the logs comes at the time of hibernation. For example, at 2:37:25 this morning there is the routine Information event, "The system is entering sleep. Sleep Reason: Hibernate from Sleep - Fixed Timeout." This is followed immediately by the warning, "6105 - deauth after EAPOL key exchange sequence". Over the next 5 minutes come two more warnings and eight errors. Then nothing until I start the machine in the morning. One of the first events on restart is the information message, "The last shutdown's success status was false. The last boot's success status was true." It appears to me that this only happens if the computer is plugged into the Thunderbolt 3 dock overnight. To the dock are connected a (gigabit) ethernet cable, a displayport monitor, a mouse, a keyboard, and a pair of headphones. Here is a fuller dump of the error log at the last time it was hibernating, or trying to: Level Date and Time Source Event ID Task CategoryError 7/30/2018 2:41:33 AM Microsoft-Windows-DistributedCOM 10010 None The server {3EB... Read more

Read other answers
RELEVANCY SCORE 61.6

What is the proper way to undock a T480 from ThinkPad Thunderbolt 3 Dock?Based on previous laptops I was expecting some sort of "undock" button, i.e., to safely remove hardware... Thanks in advance.BR

Read other answers
RELEVANCY SCORE 61.6

T480/40AJ0135US dock using Startech MSTCD123HD not working, does this dock support USV-C video out to 3 HDMI displays

Read other answers
RELEVANCY SCORE 61.2

When we have a USB Mouse and or Keyboard plugged into the laptop or the ThinkPad Pro Dock (M3F00) it will not boot, it will boot however if we turn off the USB UEFI Bios Support off, then we will have to use the laptop keyboard to logged in. Then the external mouse and keyboard will start working after that.How do we get this to work with the external keyboard and mouse. Seems to be a hit and miss issue with our organization.Added note...Mcafee Endpoint Encryption is also installed, and the system will lock up either before or at the McAfee login screen. Machine Type Model: 20L6S0SJ00Operating SystemWindows 10 (64-bit)Processor: 1x Intel Core i7-8650U Processor(Core i7-8650U)Memory: 2x 16GBDDR42400Operating System: Windows 10 Pro 64(EN:English)Hard Drive: 1x 512PCIeNVMeOPALWireless Network: 1x Bluetooth Version 4.1Ports: 1x RJ-45Camera: 1xGraphics: 1x Intel UHD 620Monitor: 14.0 FHDIncluded Service: Sealed Battery Replacement

Read other answers
RELEVANCY SCORE 61.2

Hello, Looking for recommendations for a docking station for Thinkpad T480, with Intel video,  that will support 3 external monitors (all) at 2560??1440 resolution. Thanks

Read other answers
RELEVANCY SCORE 60.4

I have two 27" 2560x1440 60hz monitors that are plugged into the new Pro side-connect dock (40AH) with a new T480 (Intel 620 integrated graphics) in Windows 10 Pro. I can get either monitor to work fine with the dock individually, but trying to run both simultaneously by extending or duplicating the desktop between them seems to fail as selecting either option under Display Settings just makes the primary monitor black out for a few seconds then come back - the secondary monitor stays black.  There's no error msg or popup that would help me investigate further unfortunately. I'm trying this with the T480's lid closed, and I'm running the latest 1.14 BIOS update and latest Intel HD graphics drivers. This setup worked fine on my old OneLink dock and X1 Carbon previously, so I don't think it's an issue with the monitors themselves. Anyone have a similar setup with the new Pro dock that's working?

Read other answers
RELEVANCY SCORE 60.4

So I just got a brand new Lenovo Thunderbolt3 Dock Gen2 to use with my lovely T480. The dock works ok but I have a big problem everytime I put my laptop to sleep at the end of the day. In the next day when I wake my machine (by pressing the power button on the Gen2 dock) my system wakes up fine but my external keyboard doesn't work.I have to reboot my laptop to get the keyboard working again. Anyone have dealt with the same problem with Lenovos docks? All drivers and firmwares are installed from Lenovos site and the Thunderbolt3 software (the older app not the new UWP) sees the dock fine. Tried to unplug and plug back the USB keyboard but still it doesn't recognize or work.

Read other answers
RELEVANCY SCORE 60.4

I've a problem with my T480 (non-s) with the Fibocom L830-EB after installing the newest firmware version 18300.1002.00.01.01.17 und driver.  Since this one new firmware, the L830-EB it is unusable for me due to connection dropouts and even due to L830-EB-device-whole-disappear-issues on system driver level, where only a device-disable-and-reenable on the device manager or a reboot helps then in these cases. The longest stable connection i have had since then is about one minute, after which the problems will occur, in other words it is completely unusable now. Please fix it, or alternately provide the old firmware with downgrade-option. My T480 is running with Windows 10 1809 and Arch-Linux (full-encrypted dual-boot).

Read other answers
RELEVANCY SCORE 60.4

I used the Lenovo System Update (v5.07.0074) and was prompted to download and install (was listed as Critical Update) the Firmware to my Dock.  As always, I closed all applications and sat as the Firmware downloaded. I got the expected prompt to ensure I was plugged in. I then watched as the upgraded prompted me to install. Installation completed and everything appeared to be fine.  I powered down the thinkpad and disconnected. Worked from the living room, then went back to the dock. Connected, and noticed that before I connected the White light on the power button was illuminated. Shrugged, and pushed the power button. Nothing. I un-plugged the Dock, got a cup of coffee, returned and plugged it back in. Nothing. I then noticed that none of the pass-through power was working on the dock.  So, I unplugged it again.  Unplugged everything connected to it, and held the power button down for 15 seconds in an effort. All of this at the recommendation of Lenovo Support. Who, by the way, was very nice and well spoken. Nothing we did worked. I happened to have another Thunderbolt 3 cable in my bag, and no change. I powered up my new X1 Yoga, and connected the cable. No power. This wasn't passing power at all. I confirmed the Intel Thunderbolt app was running, and confirmed that Windows was not even detecting the Dock.  Lenovo is sending me a replacement. I had this one all of a week. Did I miss any other steps while I wait for it to be repl... Read more

Read other answers
RELEVANCY SCORE 60

Hi,After recent update of Fibocom WWAN L830-EB firmware to version 18300.1002.00.01.01.17 faced an issue that occures on the go (literally in transport) when network is dropped (out of range) and then found again, as it seems. Win 10 troubleshooter returns:"Windows can't communicate with the device or resource (primary DNS server)"Report & logs are attached.Lenovo Thinkpad T480s (type 20L7, model 20L7001HRT)Windows 10 Pro, ver. 1803 Would someone please provide a link to the previous firmware ver. 18300.1002.00.01.01.14 ? Can I downgrade?------------Regards,Andrey Kuzmin

Read other answers
RELEVANCY SCORE 58.8

1.I update Fibocom WWAN L830-EB firmware in Dec,2018. 2.When I put in SIM card ,The Windows Settings -> Cellular network become to "No service",,than Advanced options can not be APN setting. 3.The 18300.1002.00.01.01.17 version repeated restart Windows Cellular Service  when I used my NB4.I tried to downgrade to 18300.1002.00.01.01.14 or 11.Still can not work.It is like the Fibocom WWAN L830-EB DEAD! If you can help us! Thank you very much! The same Issuehttps://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480-Fibocom-L830-EB-with-firmware-ver-1... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T480s-issue-with-Fibocom-L830-EB-after-u... https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Fibocom-L850-GL-not-working-in-T480s/td-...

Read other answers
RELEVANCY SCORE 58.8

Information to help anyone with a workstation dock ... Lenovo do not well advertise that firmware updates for the workstation dock exist. Eg. https://support.lenovo.com/gb/en/documents/acc100247 I found this by chance and most of my problems have gone away.  At boot up, or if my external screen blanked it usually took a screen power off/on cycle to get Windows to recognise it again. And .... Lenovo Companion / System Update do NOT detect the dock so you do NOT get offered new firmware updates.  Are you listening, Lenovo ??

A:P50/P70 Workstation dock firmware .... does not u...

Hi.
 
I think that your suggestion is very valid for the Lenovo Companion tool.
 
"Enable the Lenovo Companion Tool to also find updates for the Lenovo docks firmware".
 
There is a way to post some feedback to the Lenovo Companion team. The tool give you this link when you press the feedback button.
https://lenovocompanion.uservoice.com/
 
Regards
Martn.

Read other 7 answers
RELEVANCY SCORE 57.6

I was updating my drivers for my new Lenovo Yoga 920 laptop and I tried to use this driver: https://pcsupport.lenovo.com/no/en/products/LAPTOPS-AND-NETBOOKS/YOGA-SERIES/YOGA-920-13IKB-GLASS/do... However, the update keeps failing and the Type C ports do not work now. I can't charge my laptop. Luckely I am at 75%, so I have about 3-4 hours to fix this before I'm forced to take it to service. I tried this solution: https://www.gfisk.com/lenovo-yoga-pd-firmware-update-failure-ccg4-two-port-usb-c-controller/but it doesn't work for me. I'm getting desperate I'm supposed to press the power button for 8 seconds and the powering should be back on, but for me the lap top goes off after 3 seconds of holding the power button. I keep pressing the button of course to see what happens. But, when I turn back on, the battery still won't charge. And the firmware update keeps failing. I tried everything according to instructions, but with no avail. Please help! My laptop is off now, so I will wait for solutions here before I turn it back on.

Read other answers
RELEVANCY SCORE 57.6

hello
i have a weird issue that i lose the Bluetooth after an hibernate or dock de-dock of the laptop..

the bios is the latest A18.
we try to uninstall and reinstall the driver and application same thing.
we are running windows 10 OS

Thanks

Read other answers
RELEVANCY SCORE 57.2

I cannot specify the cause, but recent firmware upgrade 1.51.1.24 might cause hang before entering Windows.It stucked at Lenovo logo, then I unplug the dock cable, it successfully moved to the windows loading animation(dot circling). When I plugged and turned on the laptop, it eternally stucked on logo screen. It worked fine weeks ago.All provided drivers  from Lenovo companion system upgrade are fully upgraded. I downloaded dock firmware but it gives alert that already upgraded. Note that Windwos 10 Home is installed.

Read other answers
RELEVANCY SCORE 56

Hi!X1 Carbon 6th Gen, connected to two seperate (home/work) 40AH docks running different 4k monitors @ 60hz via DP has recently started to blank / lose sync to the connected external monitors after the recent firmware upgrade available via Lenovo Companion and matched here: https://download.lenovo.com/consumer/options/n20pf03w.exe Prior to this firmware upgrade, both docks and their respective monitors were functioning entirely normally. The firmware has been pinpointed as the ugprade occured at work first (which started exhibiting the fault) whilst home was OK, then when the firmware was applied to home the fault began to occur. There seems to be no reason as to why the screen blanking occurs, the monitors exhibit symptoms of a cable being disconnected for a short period and then reconnected. I can only assume there is an issue with the firmware on the DP component on the docks. The OS does not seem to record any connected hardware change in logs (as if the dock was disconnected via power/data) rather it seems only the output of the dock to the monitors is faulting. All other system upgrades have been applied via Lenovo Companion and/or via the website drivers list. The fault seems to be exhibited during fast video / screen switching within the OS (Windows 10). Although most frequently during large excel documents (lots of horiztonal and vertical scrolling) Seeking assistance and/or the ability to downgrade the DP firmware on the docks to return... Read more

Read other answers
RELEVANCY SCORE 53.6

Hi, I can't update my ssd firmware on my T480 with the zip package and following the attached instructions in the txt file.Windows udpate is 1809, fresh setup, unencrypted ssd, bios 1.19. Basically all latest update from System Update. Any idea of what could be a "device reason" or code RC=0x1? See attached screenshot.Edit:- my SSD is WD 512Go model SN720 (full description in screenshot)- my firmware is 10114101 and want to update to 10130101 thanks

Read other answers
RELEVANCY SCORE 52

We buy a lot of these, and are running into this issue sporadically. These have the Intel Wireless-AC 8265 cards in them. It seems to have issues connecting to our enterprise radius wifi. (cisco APs) Sometimes it will connect OK, but other times it will err out after a bit saying 'cannot connect'. Disable/re-enable of the card, then a reboot will sometimes get it to connect. I have updated the drivers, doesn't seem to help. It's difficult to troubleshoot because sometimes it does work.I've spoken to our network admin extensively on this, he sees no issue with the routers/config themselves. We have many other devices that connect with no problem. (phones, other laptops, etc.)  Anyone seen this and have any suggestions?

Read other answers
RELEVANCY SCORE 51.2

Hi, I can't update my ssd firmware on my T480 with the zip package and following the attached instructions in the txt file.Windows udpate is 1809, fresh setup, unencrypted ssd, bios 1.19. Basically all latest update from System Update. Any idea of what could be a "device reason" or code RC=0x1? See attached screenshot. thanks

Read other answers