Over 1 million tech questions and answers.

Lenovo y520 151BN M2 SSD not read in BIOS

Q: Lenovo y520 151BN M2 SSD not read in BIOS

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Lenovo y520 151BN M2 SSD not read in BIOS

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 147.2

Hi all, The laptop model is  y520 151BN  / 80WKI bought a cheap SSD called  -> Solid State Drive Intel E5400s, 120GB, M.2  I installed it in the laptop however BIOS or Windows 10 is unable to see it . Can you please let me know if this SSD is not compatible or what troubleshooting i could try ?

Read other answers
RELEVANCY SCORE 72

Hi everyone,I've got a Lenovo Legion laptop with a year old BIOS. I need to update it however on the website with the driviers the BIOS update is missing and I can't find it anywhere else. My PC is having serious issues with performance in games and after contacting Nvidia I was told to update my BIOS first. I need this update as fast as possible because I basically can't use the laptop without it. Also I can't contact any sort of support or chat because my product is apparently "not supported" and no one has replied to my emails a week now. Thanks in advance! 

Read other answers
RELEVANCY SCORE 70.8

I attempted to install the new Y520 BIOS release in hopes of addressing recurrent wake-from-sleep issues. The "System Update" function in Lenovo Vantage shows "BIOS update - 10 [64] V.4KCN41WW" but will not install it. The resulting message is "Failed installed on 1/25/2018 at 6:40 PM".

Read other answers
RELEVANCY SCORE 70

I updated the BIOS yesterday and after using it today, i realised that the laptop was heating up, even though i wasn't playing any games. Just watching some videos on youtube using Microsoft Edge. The bottom side of the laptop, the one below the keyboard, felt hotter than usual. Same for the part right above the fan, one where the power button is. Never had an issue before the update as it never used to get hot enough for me to feel it unless I was playing a heavy game. It only gets better if I use the extreme cooling feature, but that shouldn't be the case for regular browsing. Could this BIOS update be the reason for my laptop heating up? Please help. 

Read other answers
RELEVANCY SCORE 67.6

Hi,2 days ago I updated BIOS to 5XCN22WW on my Lenovo Legion.Then problems appeared:1. Windows 10 pro did not want to boot anymore(INACCESSIBLE_BOOT_DEVICE), bitlocker ON2. After fixing 1, the laptop does not boot if my Asus Gladius mouse is connected to any USB port. To be noted that I also have a mechanical keyboard attached, and mini display port connected and they don't create any issue. The laptop hangs on the Lenovo LOGO. If I detach the  mouse, restart, enter BIOS and then connect the mouse while in BIOS, the laptop hangs with the BIOS image left on it!3. If I enable secure boot in BIOS and leave the mouse connected, then I get a blue screen with info that Windows 10 wasn't able to boot correctly, press the restart button and then the laptop boots. Questions:1. Might this be related to this new BIOS? Because it just created a lot of problems to me after update. If you ask if I'm sure that I installed the correct BIOS then yes, it's correct, because the machine was detected by Lenovo service bridge, and also I checked the sticker on the back.2. I don't see any downgrade options on the support site. Only the latest BIOS. How to get previous BIOS versions?3. Shall I contact ASUS? I don't know what they will do though, because it seems that this is an issue with the latest BIOS, as with the previous version I had no such issues! Thanks!

Read other answers
RELEVANCY SCORE 59.2

My laptop (lenovo y700-15ISK) originally came with CDCN25WW BIOS. I thought why not update it and of course I was silly enough not to read to first flash CDCN35WW and flashed straight to CDCN37WW. Now, when I try to turn on Fast Boot in BIOS, I lose access to my Nvidia card (Windows has stopped this device, because it has encountered a problem, error 43). I am wondering if this is working as intended? Is there anything I should do? Should I try to get back to my previous BIOS and then flash to 35, then 37?  (: I am running Windows 10 Anniversary Update 64 bit.

Read other answers
RELEVANCY SCORE 55.2

Hi.My Lenovo have a 1tb hdd.I want to know if I can buy a ssd and the both disks.And if so what sdd can I buy MTM:80wk00mmpg

Read other answers
RELEVANCY SCORE 55.2

For example this:http://eu.crucial.com/eur/en/bls8g4s26bfsdk I want to use in dual channel so i want to buy two.

A:Lenovo Y520 Can i use 2666mhz ram?

yes but it will run on your mother board maximum allowes 2400mhz

Read other 2 answers
RELEVANCY SCORE 55.2
RELEVANCY SCORE 55.2

Hey everybody, I am trying to install Windows 10 x64 over USB (Created with Microsoft tool).BIOS version: 4KCN43WWWhat I want is to install Windows in UEFI Mode (Not legacy), but when I set everything in BIOS I can?t see USB on boot menu.I can use it and install it when I set: Boot Mode: Legacy SupportBoot Priority: UEFI First But that is not an option, I don?t want my Windows to be on Legacy mode.I am not able to install it like that and switch to UEFI after, keep getting error that HardDrive cannot be found.SATA Controller Mode is on ACHI.OS Optimized Defaults is on ENABLED.Secure Boot is DISABLED.Fast Boot is DISABLED. If anyone has any solution that I didn?t try it would be great.

Read other answers
RELEVANCY SCORE 55.2
RELEVANCY SCORE 55.2
RELEVANCY SCORE 55.2

Hello, I own a Lenovo Legion Y520 (the one with 2tb HDD) and I would like to add an SSD to it as well. From what I've read, if I want to keep my HDD and add an SSD, I will need an M.2 type SSD. Also, I have found an SSD that I think would be compatible with my Y520, but I wanted to ask here before buying it. The SSD I'm talking about it the SSD WD Black 256GB PCI Express 3.0 x4 M.2 2280. I will also attach a picture of it, so if anyone could tell me if it's compatible, I'll be very thankful.This is the one 

Read other answers
RELEVANCY SCORE 55.2
RELEVANCY SCORE 55.2
RELEVANCY SCORE 55.2

Hello people, i have a big problem,bought a brand new laptop few days ago its Lenovo y520 i7-7700hq/16gb rams and gtx 1050ti 4gb, and i cant play games at all,tried tom clancys the division i have 15-10 fps there and the rust on medium settings have big laggs i dont know what to do,tried to set my battery settings to high performance still the same thing...Please help.

Read other answers
RELEVANCY SCORE 54.4

Hello all. I am about to buy the Legion Y520-15IKBN. It's the i7-7700HQ, GTX 1060  version. I have 2 questions though before I buy it.  1. I have a Seagate Barracuda 5TB 2,5" HDD, a Samsung 960 Evo NVMe 500GB and a HyperX Impact 16GB DDR4-2400 laptop RAM. Can I install them on this model or if I open it it will void the warranty?  2. The laptop comes with no OS. I have Windows 10 on my desktop PC. Since Windows are connected to the Outlook account (I think), will I be able to install and activate them on the laptop or I have to buy new? Thank you very much for any answers

Read other answers
RELEVANCY SCORE 54.4

I have recently purchased a brand new Lenovo Legion Y520 15IKBM (Specs: i7 7700HQ, 16GB RAM, 128gb SSD + 1TB HDD, GTX 1060) and I'm liking it so far. It would be perfect for me if it wasn't for a couple issue that have been plaguing me. First: sometimes the system takes relatively long to boot. Usually it'll just show me Lenovo's logo for a couple of seconds and take me straight to the login screen, but sometimes it would stay on the logo for 10-15 seconds (without even showing the circling "loading" dots), then the screen would go blank for a few extra seconds and only then I would be on the login screen. And when it does that, the system continues to be considerably slower than usual even after login. Rebooting the system (sometimes twice) fixes the issue entirely. This happens regardless of whether or not the laptop is plugged in, but it seems to happen consistently on the first time I turn on the laptop after unplugging it. There are also times where, when I turn off the laptop, the screen turns off but the keyboard, power LED and fans are still powered for a LONG time. The second issue would be the system freezing seemingly at random, no matter if I'm playing a game or doing lightweight work. The whole OS would just lock up and either unfreeze after 10 to 30 seconds or straight up bluescreen with a KERNEL_DATA_INPAGE_ERROR. I would provide a memory dump, but apparently the system is set by default to not create any. That, and sometimes it would just bluescreen ... Read more

A:Lenovo Y520 stability issues

Hello there!I came here to share these same issues with my own Y520, when I saw your post. The difference is that MY Legion don't even let me to factory reset it, or run chkdsk, but beside these, I've tried everything. This is a pretty good laptop, but if it continues working like this, I will have to take it back, because I can't work on it properly like this.

Read other 2 answers
RELEVANCY SCORE 54.4

I got Lenovo Y520, and after installing Windows10 professional edition, and all of dirvers from Lenovo official website, I got some blurred screens like:  Is this normal? if not, how can I solve this?

Read other answers
RELEVANCY SCORE 54.4

 My machine: Lenovo Ideapad U310  Model 4375  I would like to know if I could replace my 500 GB HDD with a Crucial MX500 500GB SATA 2.5-inch 7mm Internal SSD.I read that mine is SATA 3.0, but that one is SATA 6. Would that work? And could it handle that storage space amount? Thanks!

A:Lenovo U310 (not y520) i7 hdd upgrade.

Good day and welcome to the community.As I understand it, the SATA standard is backward-compatible. An SATA-6 storage device should work fine in an SATA-3 slot, albeit at the slower speed, as long as it physically fits.Regards.
 
 
 
Mod's Edit:  Updated Subject line.

Read other 8 answers
RELEVANCY SCORE 54.4

Hey guys, I just bought this computer today and I have encountered this problem. When I go to control panel -> display / dxdiag / AIDA64, I can only see Intel HD 630, but not my GTX 1050. I have tried reinstalling latest drivers and I changed the settings in NVIDIA control panel. I am using Windows 10 Pro. Thank you  

A:Lenovo Y520 dedicated GPU not showing

Hi Adomce123, 
 
Welcome to the Community Forums. 
 
Have you tried running dx diag with a high graphic application software running alongside?
 
The automatic switch from Intel to NVIDIA would happen when there is demand for it thus you were allowed to re install NVIDIA drivers and use the NVIDIA control setting since it was available in your system. This can also be checked in your device manager as well as lenovo diagnostics to confirm if the NVIDIA device if available.
 
Try going in the BIOS and verify options under Configuration Menu for graphic device to run on Discrete or UMA only as option. F10 to save setting before exit.
 
Update us how it goes.
 
Regards
 

Read other 1 answers
RELEVANCY SCORE 54.4

I purchased a Lenovo Y520 last year and I had to send it in once already due to the dedicated GPU dissappearing. When I got it back it lost a couple of screws and wouldn't connect wirelessly without a hard restart every time. This is not only annoying but bad for my laptop. I'd like to know how to fix this without sending it in.SPECS: RX 560 4GB GPU 500gb HDD 1 TB SSD 32GB RAM i5-7300HQ 

Read other answers
RELEVANCY SCORE 54.4

Hey all,  Just recently bought a Lenovo Y520 gaming laptop. Overall very satisified with it! Last week I added an SSD drive to it and decided to do a fresh reformat from the BIOS so the laptop would run at full power without any bloatware holding it back.  Did the reformat sucessfully, installed all drivers, and now the laptop is running perfectly, except for one thing.  Since the reformat, Wifi has been giving me constant problems. I've tried just about every solution available on the net but so far have had no luck. It's main issue is: when I go to power on the laptop after being turned off for an extended period of time (at least 8-10 hours), there's no wifi at all whatsoever. Windows doesn't detect my wifi at all, even under network adapters! I've downloaded the latest drivers directly from Lenovo and even took it one step further by getting direct drivers from intel themselves. In this condition, it only detects my ethernet port, so when I go to diagnose it, it doesn't consider Wifi an issue because it doesn't think it exists.  The ONLY solution to get Wifi to work for me is to restart the computer at least once, load up the BIOS, go to the Configurations tab and disable/re-enable Wireless Lan. After that, I boot it with the saved changes and boom, Wifi suddenly works again. Thing is, I shouldn't have to do this every time to get Wifi to work. Before the reformat, the Wifi was working absolutely fine with no issues whatso... Read more

Read other answers
RELEVANCY SCORE 54.4

hi there, i have recently purchecd a new laptop from y520 suries with gtx 1050 gb.as i far as i knew when i bought this pc it met all the requerments i need in order to start VR expiriance by oculus rift.the problem started when i plugged the headset. after spending few days trying to configure why cant it recognize the headset it seems the hdmi port canot use the gpu system(gtx card) and it can only use the inner one that is built in and i cant use the headset this way.i need your help in order to configure it to work with the gtx card. please help my case its serius matter, this is why i bought this laptopt in the first place.

Read other answers
RELEVANCY SCORE 54.4

Hi, I've recently bought this laptop and I'm already getting an error message upon booting up.This one: I have ran sfc /scannow in cmd: However, the error upon booting up still persists. What should I do next?  

Read other answers
RELEVANCY SCORE 54.4

Everytime i charge my device to 100%The battery FULL CHARGE capacity seems to degrade a littleBtw, my laptop is only couple months oldThe battery report : https://drive.google.com/open?id=1XB2Xoj88xx1fXaV_vKE4J45g3Q0YUz8_

Read other answers
RELEVANCY SCORE 54.4

HelloI need to buy a new laptop and I found this one which people say it's suitable for games (and within my budget). Do you guys think it meets all the requirements for playing games, new games especially like assassin's creed odyssey? I'm no real expert when it comes to these kind of things . Will this configuration last long or it's going be old in a couple of years (in terms of gaming requirements I mean). And last but not least... is actually 16 the maximum ram supported?ThanksLENOVO Legion Y520-15IKBMProcessor: Intel Core i7Processor identification: - 7700HQ, Quad Core- GPU: Intel HD Graphics 630- Processor architecture: Kaby LakeClock speed (GHz): 2.8Max Turbo Frequency (GHz): 3.8Third level cache (MB): 6Chipset brand: IntelRam MemoryRAM: 16 GBType of RAM: DDR4Maximum Ram Supported: 16 GBTotal RAM slot number: 2Hard DiskHDD: 1000 GBHard Disk Type: HDDSSD: 128 GBGraphic cardGraphics: nVidia graphicsGraphic model: - GeForce GTX-1060Memory Graphics Card (MB): 6000Other features of the graphics card: - Dedicated- GDDR5Operating systemOperating system: Windows 10 Home (64bit)DisplayDisplay size: Display 15.6 ''Display ('): 15Convertible: NoHD: Full HDDisplay resolution: 1920x1080 pixelsScreen format: 16: 93D: NoAnti-reflective display: YesIPS display: YesOptical UnitOptical drive: NoAudio cardSound card: Audio by HarmanSpeakers: 2 x 2.0 WConnectivityEthernet: YesEthernet type: 10/100/1000Wi-Fi: YesBluetooth: 4.1InterfacesUSB 2.0: 1USB 3.0: 2Number of usb type 'C' ports... Read more

Read other answers
RELEVANCY SCORE 54.4

Im really on a pickle with this one.Basically long story short.. I start up Rocket League.. First 3 minutes of the match okay ( after restarting), and then the micro stutter happens.. Like in every 1.5 secs it will "freeze"and its annooying as hell. Tought i was only RL at the time. Turns out all the ohter games do so... Tried reinstalling windows, all of my drivers, did ram check, uninstalled Discord.Nothing seems to be working .. temps are normal.. (50 ish, Celcsius) Any ideas mates? Video of the stutter: https://www.youtube.com/watch?v=xIaWtL_YvII

Read other answers