Over 1 million tech questions and answers.

Firefox Autocomplete

Q: Firefox Autocomplete

I’m having a problem with Firefox’s autocomplete function in Google.

For Google I use Google.com//webhp?complete=0&hl=en.
This turns off Google’s automatic query & fill function, and then lets me use the autocomplete of searches I've done before.

But it stopped working yesterday for no apparent reason. Maybe I accidentally hit a certain key, I don’t know. And it will not remember any new search words that I enter either.

But if I use Firefox’s Help > Firefox Help and start entering a word in it’s search box, my previous searches show up. And it will remember new search words that I enter. IOW my data is still on the PC, just not accessible via Google like it was.

When previously transferring programs & files to a new computer I found the autocomplete form data stored in a Firefox profile file named Formhistory.sqlite. And this file is still there.

All the settings in Firefox appear to be correct. Again, autocomplete still works in Firefox Help but stopped working in Google.

Any idea how to get it working again?

Preferred Solution: Firefox Autocomplete

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

A: Firefox Autocomplete

I'm having the same problem on chrome. The only thing I can imagine is that Google changed something again. I hope there's a workaround again though as that's how I get to most of the sites I go to.

(Yes I know it'd probably be easier to bookmark everything or start typing the url, but I'm more comfortable with typing in the first few letters of my favorite sites, clicking the autocomplete and hitting "I'm feeling lucky")

Read other 7 answers

I have a firefox autocomplete ? it can remember what you've entered in forms on web pages, also known as text fields. After you've entered something into a form on a web page (such as a search box), the next time you visit that page, your previous entry will be available to re-use

Where do I delete everything in forms on web pages, also known as text fields. dose this inclue save passwords will be deleted also ? get back to me please

Read other answers

This may belong in the other software forum and if so I appologize but I was wondering if there was a way to access the information firefox stores for auto complete for forms. I know theres a way to view saved passwords through the tools>options menu, is there such an option or perhaps a settings file that would let me do the same for all the auto complete data?

Read other answers

To turn on inline autocomplete in the Firefox web browser...

1. Enter about:config in the URL field
2. Right-click on the page and create a new Boolean value
3. Enter browser.urlbar.autoFill as the preference name (note, case-sensitive: 'F', not 'f')
4. Set the value to true

Read other answers

The only thing I want autocomplete set on is for my address bar and for usernames and passwords. I don't want it with search bars and things like that. Is this possible to customize it this exact?

A:Is there a way in Firefox to set to only use autocomplete with logins?

Sorry, the Saved Forms tab of Firefox Options says:
Save information I enter in forms and the Search Bar.

-- Tom

P.S. You should visit Firefox support and post a question to see if there is an extension that does what you want.

Read other 1 answers

To turn on inline autocomplete in the Firefox web browser...

1. Enter about:config in the URL field
2. Right-click on the page and create a new Boolean value
3. Enter browser.urlbar.autoFill as the preference name (note, case-sensitive: 'F', not 'f')
4. Set the value to true

A:How to turn on AutoComplete in FireFox

mine did it on default .....

Read other 3 answers

hi guys
i have firefox 16.0.2
and i want that when i am typing the name of a site that is in my history of browser , the address bar does not complete the addrees but show the adddresses of history below that.
when i turn of autocomplete from privacy , it does not appear any suggetion for domains.i want that just delete autocompletion in address bar

A:turn of autocomplete in firefox

Navigate to options>'Privacy' (the tab)
On the bottom in the dropdown, select 'nothing'

That's obviously not what you are looking for. Instead, you can delete the suggestions by deleting your history. You can also configure by the option above to only use your history or your favourites.

Read other 3 answers

I have installed Firefox 3.1.10 and when I type www. into the address bar a dropdown list appears with previously visited sites. How can I delete this and disable it.

A:Solved: Autocomplete in Firefox

Hi xblackrat,
Apparently in Firefox 3 autocomplete is an automatic feature that cannot be turned off, however you can delete stored autocomplete entries so that the autocomplete list does not drop down. Check out the following link -> Firefox Autocomplete Info

Read other 3 answers

In IE 6 I could set my AutoComplete not to track/keep my URLs in the Address Box. I can't seem to find that option in Firefox. I prefer not to keep the history in the Firefox Location bar.

A:Firefox AutoComplete process?

Tools>>Options>>Privacy>>Saved Form Information

Read other 1 answers

I have a firefox autocomplete ? it can remember what you've entered in forms on web pages, also known as text fields. After you've entered something into a form on a web page (such as a search box), the next time you visit that page, your previous entry will be available to re-use

Where do I delete everything in forms on web pages, also known as text fields. dose this inclue save passwords will be deleted also ? get back to me please

A:firefox autocomplete? (Moved from Windows 10)

Here you go:

Read other 1 answers

Have been researching Firefox for needed improvements and this is two of them
the third is adding more speed to the browser. http://autofill.mozdev.org/

To turn on inline autocomplete in the Firefox web browser...

1. Enter about:config in the URL field
2. Right-click on the page and create a new Boolean value
3. Enter browser.urlbar.autoFill as the preference name (note, case-sensitive: 'F', not 'f')
4. Set the value to true

The speed thing gets it very near DSL, I'm running it on this computer.
Will post it later.

A:Found a Autofill, Autocomplete for Firefox


Hi Dr Dave,

I used your advice of speeding up Firefox--it worked, as they say, like a charm. Thank you very much. Not long ago I discovered this browser and fell in love with it. You obviously also use Firefox. Thus you are the guy to ask about the following problem: I'm unable to download anything using this browser because it, in a grip of paranoia, blocks all downloads. So far I haven't found any way to fix the problem. I will appreciate your help.



Read other 2 answers

Win XP Pro SP2
Firefox 1.0.7

address bar autocomplete is "on". I want to disable this "feature".

FF > tools > options > privacy > "save information . . " is unchecked

2. userChrome.css
This file sets the display rules for various elements in the Firefox user interface and is located in the sub-folder called chrome in your profile folder. As with user.js, this file does not exist by default, so you need to create it before you can start adding your preferences. There's actually an example file that exists by default, called userChrome-example.css. Basically, you can just rename that file by removing the -example part

I created userchrome.css, as above & added
/* Hide auto-complete in address bar */
#PopupAutoComplete, .autocomplete-tree { visibility: hidden !important;
display: none !important; }

/* Remove arrow from Address bar */
.autocomplete-history-dropmarker { display: none !important; }

My userchrome.css contents:
* Edit this file and copy it as userChrome.css into your
* profile-directory/chrome/

/* Hide auto-complete in address bar */
#PopupAutoComplete, .autocomplete-tree { visibility: hidden !important;display: none !important; }

/* Remove arrow from Address bar */
.autocomplete-history-dropmarker { display: none !important; }

* This file can be used to customize the look of Mozilla's user interface
* You should consider using !important o... Read more

Read other answers

I'm not sure this is the right forum for this.

Well, that's the problem. It had been working fine. I have Windows xp Home. In Firefox Options>Security I have a check for Remember passwords for sites. In the Privacy tab I have a check for Ask me before clearing private data. Is there some place else I should check? How can I get it to work again? Thanks, grandpaw

A:Solved: Firefox AutoComplete quit working

When you go to Options > Privacy tab > Settings, make sure the box is not checked next to Saved Passwords.

Read other 2 answers

Steps to reproduce:

1. Create a basic form with an input element for email
2. Add autocomplete attribute with value "email" and name attribute with some random value (not email).
3. When filling this form, autocomplete doesn't work(no previously used values of emails are listed).

Actual results:

No previously filled values of email are listed even though we have provided autocomplete attribute as email.

Expected results:

Previously used values of emails should have been listed as we have provided the autocomplete attribute as email.

Read other answers

Hi everyone.

I have been trying to clear my address bar info as I browse using Firefox.

I have tried 'clear private data' but cannot clear the drop-down bar as I can using IE when I go to

Internet Options>Content>AutoComplete>Clear web addresses(etc).

Is there a similar function in FF that will clear my address bar?

Thanks in advance. lennon:

A:IE "AutoComplete" option for Firefox?

Your Address bar? as in your history?

- Go to the Clear private data section as you previously did
- Press "Settings"
- Ensure "Browsing History" is checked
- Clear your private data again

If you're running FF3 (Everyone should be now, it's amazing) then i think you may be referring to the dropdown box which displays your bookmarks. To clear this you would have to clear your bookmarks, You may also have a bookmark history or "recently bookmarked" section in your Bookmarks menu, to disable this i belive you can delete it.

Also you may have a "Smart bookmarks" folder on your bookmarks toolbar, it bookmarks recent pages... To stop that delete the folder...
(or the entire contents of the folder)...

If you want rid of the bar completely i've found something which will be of interest:


Go to about:config

Search: browser.urlbar.matchOnlyTyped

Set to true
Search: browser.urlbar.maxRichResults

Set to 0

From: http://forums.mozillazine.org/viewto...38765#p3438765

Hope one of these helps,

Read other 1 answers

Ok, this question is for a friend, so it will be a lot of relaying the info.

IE remembers the address I've typed in (autocomplete) even when I turn autocomplete off and clear my cookies. It makes going to the site a lot slower when I have to do down past a bunch of the same site addresses. How can I manually remove them from the drop down menu in the address bar?

So someoen told him "go to tools-> internet options and change the days to keep things in history to 0."

I already have that, and this happens even if I've just cleared my history. Some sites are just permanently on the drop down menu when you type the first letter of their address.

He also did Start Settings Taskbar & Start Menu Properties Advanced Clear and that didn't work either.

It clears all other sites, but http://boards.ign.com ones.


A:Autocomplete links turned off.... yet they still "autocomplete" the links!

Read other 13 answers

I know how to set AutoComplete but ever since Office 2007 has been installed I have to recheck these boxes every time I open up a the browser. It works fine after that but after shutting down each day I need to go to tools etc and recheck the boxes. How can I keep these settings?

Read other answers

Further to this topic but 180 degrees
I want to get rid of the autocomplete nag
boxes cleared under advanced "use autocomplete"
boxes cleared under ie tools content autocomplete settings..
However; the one box..."prompt me to save passwords" is grayed
I can't uncheck
Is there somewhere that I can completely remove autocomplete
The nag appears every few times when entering a website...not everytime ???

Read other answers

Today, I had need to log on to a server at work. Our IT guy told me what to type in Start/Run. To log on to the server, there was a request for Username and Password. The username had a dropdown arrow. On pressing this, one of my personal email addresses filled the box. Deleting it didn't work, it just appeared next time. I looked it up on the net, and everywhere said it was in the Options in Internet Explorer. I cleared the settings, but it's still there. Any ideas how I can clear it. I do use firefox as well, but I can't see how this should affect Windows remembering Usernames on forms.


Internet Explorer Users
Left click Start, then Settings, then Control Panel.
Double left click the Internet Options icon. The Internet Properties window will open.

Left click the Content tab.

Left click the AutoComplete button.

Now click the Clear Forms button. This will remove all form data stored except for passwords.
If you use the Clear Passwords button you will find that you will need to enter your password in forms (such as login forms) and that Internet Explorer will no longer be able to pre-fill those items for you. Because of this it is not recommended to use this button unless you have an explicit need to do so.

If you decide that you no longer wish for Internet Explorer to use its autocomplete functionality you can stop this by unticking any of the checkboxes in this window. Should you change your mind you can turn this functionality back on by simply reticking the checkbox(es).

Mozilla Firefox Users
Open your Firefox browser.
Left click from the top toolbar Tools and then Options. The Options window will then load.

Then left click the Privacy icon from the left pane of the Options window.

From the right pane click the Clear button next to "Saved Form Information".
If you decide that you no longer wish for Firefox to use its autocomplete functionality in the Search bar you can stop this by clicking on the plus sign next to "Saved Form Information". Then untick the checkbox entitled "Save information I enter in web page... Read more

Read other 1 answers

how do i turn off the auto complete feature in the web address bar in internet explorer. ie: it is trying to guess the web address i am going to based upon the things it has stored in the drop down.


I think you can go to tools > Internet Options> then open the content tab and go to AutoComplete and uncheck the web addresses box.

Read other 1 answers

I had 2 computers that I did my web surfing from. They were windows 98 and windows 2000.
I never knew about the autoComplete "forms" then ...

... so I never deleted them.

I only found out about AutoComplete FORMS when I started using windows XP.

Which IE version first had the autocomplete feature and what year and month did they come out?

I did a lot of searches in those computers and I'd hate for anyone to find out what searches I made.

A:when did autoComplete come out?

That would be IE 4...

4.0B1 Apr. 1997
4.0B2 Jul. 1997
4.0 Oct. 1997
4.01 Nov. 1997

And that shipped with Windows 98.

Hope this helps ya.

BTW, what DID you search for?!?!?

Read other 2 answers

I am having a problem, whenever I go to a certain webpage ( www.us.army.mil ) and go to log in, a popup box appears asking for name and password, within this box there are two login names that I would like to have removed, I have tried everything that I can possibly think of... Autocomplete is turned off, I have repeateldy cleared IE for history, cookies, etc... I have manually deleted the temp folder, used reg cleaners, a program called IEpurge, etc... the only thing I can think of to do further is to reformat the HD...and thats really not an option...I am in the US Army, and am currently 7000 miles or so away from the install disks...

Any guidance you guys can give me, I would really, really appreciate it.
if you want to see a picture email me, for some reason, it won't let me attach it.

A:I need help with autocomplete (I think)

Read other 16 answers

I have Windows XP and I use MSN 9. When I first got my computer whenever I typed in a username and password on a website the computer would prompt me to save the username and password so I wouldn't have to tpye them in again. Now, it doesn't work when I am using MSN and it used to. I didn't update or anything and I don't know how to turn the option back on. I found it in the Internet Explorer options and now I get the prompt when I am using IE, however I always use MSN and it's annoying how I have to type in my passwords and stuff again. If anyone has any suggestions, please let me know. Thanks!


Read other answers

I've followed the directions for setting autocomplete, but it doesn't seem to work.


more info would help out with more input for your problem.... ie, basic info on your computer system and what windows you are using, and briefly what led up to 'autocomplete' found to be not working.

Read other 2 answers

Hello folks,
My problem is this, after optimizing one of my home pc,s(xp sp2) i find that autocomplete no longer works in internet explorer even though it is set to do so, can someone(s) please let me know how to return to the default settings for autocomplete so that i may be able to solve this annoyance, or any help/advice will be very much appreciated. Thanks in advance.

Sincerly Bill.


Read other 11 answers

please forgive me if this is in the wrong section,i am missing the option of typeing in lets say the letter "b" and all the previous sites i use begining with said letter appear has adrop down list(dont know what to call it)i am running windows 7 and ie 9,the thing is it used to work ps i am useing google .[email protected]=0 to get me away from the the google suggestions cockup.many thanks for looking.

A:ie autocomplete i think??????

Open IE and go to Tools >> Internet Options
Click the tab labelled Content.
In the Autocomplete section, click Settings.
Under Use Autocomplete for ....., tick Address Bar.
Under that, also tick Browsing history.
Click 'OK'.

Read other 1 answers

I know this is going to sound stupid, but could someone please help me remember where to find how to turn on/off autocomplete?


In IE, Tools> Internet Options> Content tab> AutoComplete button, uncheck all you don't want under
Use AutoComplete for
then OK, Apply and OK.

Read other 1 answers

just a quick question but i cannot get IE9 to Autocomplete
It doesn't even ask even though all the boxes are ticked in the content settings?
Any ideas please,thanks

A:IE9 Won't Autocomplete??

I notice that .
Maybe wil work with RTM .... "Fingers Crossed" ...
Hang tight .

Read other 1 answers

well i tryed everything .. everytiem i search something it ups it i read on a different form go to tools,internet option,content,click on autocomplete,uncheck web addresses , form , user naem and password on form .. tehhen i clear password and form the ok ok it wont work please help here pichttp://i4.photobucket.com/albums/y113/viet...etridofthis.jpg


sorry if the pic is crappy heres 1 http://www.andyrathbone.com/tips/images/autocomplete.gif

Read other 2 answers

Ever since I went from IE6 to IE7, I haven't been given the opportunity to turn on Autocomplete.

I'm just wondering if I still can and how?

A:Autocomplete In Ie7?

Tools > Options > click on the Content tab. Click on Settings next to Auto Complete & put a check mark next to whichever you want.Edited to correct the wording.

Read other 3 answers

Is there a file for IE5 that has all the web addresses that come up when you start to type an address in the address bar?
Where is this file?


A:IE5 autocomplete

I think what you're talking about is AutoComplete, correct? This pulls URLs from your C:\Windows\History folder. If you want it on, go to Tools, Internet Options, click the Advanced tab and check "Use inline AutoComplete" or uncheck if you think it's annoying like I do. Hope that helps.

Read other 1 answers

I posted this thread on the Web & Email forum. No solution from there, but it was suggested that I post this with Windows XP: My new computer using Windows XP Home Edition and IE 6.0 with SP1, does not autocomplete addresses I type into forms such as email addresses and others, e.g., when forwarding a webpage to an email address. My older computer has Windows 98 and IE 6.0, and includes this feature. I have checked all of the settings in IE and even in OE to be sure that they are proper. I have run scannow successfully. Any suggestions will be appreciated.


Read other 12 answers

I have been using MS Office Word 2007 for several years, but recently upgraded from Vista Ultimate-32 bit to Vista Ultimate-64 bit. Before this upgrade (and through no effort on my part), when I would begin to type either the name of a day or a month, I would get an automatic "tip" that would finish the word by pressing "Enter". This autocomplete function, which was very useful, no longer seems to be working since the upgrade. I checked Word Help, and it claims that "AutoComplete is still available for the current system date, months, and days of the week." Is there something I can do to reactivate it? Any help with this issue would really be appreciated. Thank you.


I have had a look and tried to reactivate it on my system.
It is in the word options, proofing, autocorrect, smart tags.
You an insert the date by clicking on the insert tab then date and time.
I have not been able to get the smart tags to work either.

Read other 3 answers

I'm running IE 5.5. I've started having this problem where all of a sudden I lose all of my Autocomplete info. These are mostly my usernames and passwords for sites. Any idea on why this might keep happening (it's not a virus), and better yet, is there a way I can restore all of them (a folder where they are kept).

PS-I had the same problem with IE 5.0 so I don't think it's a bug with 5.5

A:AutoComplete ???

Read other 7 answers

I use Yahoo! mail on the internet. Until they revamped their page ( around 7-1 ) I or my Dad could compose an e-mail, double click the "to" box, and a drop box would appear to show us the 25 or so e-mail addresses we regularly use. We would click one to put it in the box. Now the addresses have disappeared and the only way we were getting them back was by system restore until I ended up having to refresh the windows program. I still have the info for the "subject" box and for any of the other boxes EXCEPT the e-mail addresses for the "to" box in Yahoo!. Are these addresses stored somewhere on my PC or are they gone for good?

A:IE6 and AutoComplete

Welcome to the forums ladymantis62

I do believe that Yahoo stores the addresses on there server.

I have formatted and reloaded my os numerous times and as far as I can remember the address book has always been there on Yahoo's site.

Read other 2 answers

Is there any way that I can wipe out the Autocomplete history and start all over. I am getting tired of a lot of the old things that I never use always popping up, everytime I type something.


IE open it. got to Tools ---> Internet Options ---> Delete Cookies, History etc.. Click on content Tab the Autocomplete u can remove evrything from there

Read other 2 answers

This is a repost of thread that unfortunately was not solved: Refer to #524518-autocomplete-not-working

Not sure if this belongs here or in the Web Browser forum. Recently upgraded to IE7 (7.0.5730.11) and EVERYTHING went well. The only function that appears to not work is the AutoComplete funtion. I've tried all of the suggested fixes and it is still not working.

The function that I miss the most is the AutoComplete for filling in my "User Name" on the different forms I use. Any suggestions?? Thanks again...

Using XP SP2

A:Help with AutoComplete and IE7

Read other 16 answers

How we doing,
MY autocomplete is working,and can remove the entries through internet options.The only place that I can't remove autocomplete entries is in the search>files and folders section.OS 2K.
Much appreciated,

Read other answers

I have this really strange issue which i would love some help with
Basically when i type certain words correctly, they change to words which are spelt incorrectly for example swimming automatically changes to swimmign
This issue happens in outlook, word, and gmail
I have turned off autocomplete in office to no avail
I have now moved to completly new laptop running windows 7, all i moved across is my outlook.pst file and my keyboard yet the problem still exists
Thanks in advance for you time

A:Autocomplete Issue

I would suspect your keyboard.

Read other 2 answers

I have lost the autocomplete feature in forms and user names (not in web addresses
it seems) in IE7

A:IE7 Autocomplete not working

I assume you've confirmed that the boxes are checked in Autocomplete Settings (sorry, but even the obvious needs to be verified - we want to cover all the bases). Can you tell from addresses if somehow all autocomplete entries got deleted (and those in addresses are only recent since that might have happened)? I also assume you know it's not working because it isn't completing forms where it should be at placed you've visited before - I would like to know if it is currently working on new entries. Can you find some site where you can visit and verify that after completing the form and exiting the site and then re-entering the site that the new forms are not being completed either? Is that all that isn't working in IE? History being saved? Cookies being saved and working? Able to access sites without problems and open links or embedded files without problems?

First, we're going to check out IE to see if we can find the trouble there.

Try reviewing the following article:

Tips for solving problems with Internet Explorer

If that doesn't resolve the problem, then try the following two procedures in the order presented:

Troubleshooting and Internet Explorer’s (No Add-ons) Mode [Applies to IE7 & IE8 in all OSS]

Does the behavior persist if you Reset IE Advanced settings (RIES)?
http://support.microsoft.com/... Read more

Read other 1 answers

Alright, im sure you are all familiar withoutlooks ability to do autocomplete on email addresses that you type up and send an email for.
My question is as follows:
Say you were to type an email address out, fill in the subject and the body of the email and send it.
The email address is wrong, but from that point on when you go to type in the proper email address it populates with both the right and the wrong email address in the TO: feild.
Any idea's on how to delete these names from outlook?

A:Autocomplete woes!

I use OE rather than Outlook, but can't you just pull up your Addressbook and delete the bad entry? That's what I do with changes, corrections, etc.

Read other 2 answers

I have never had any problem with this before, and have actually never even heard of anybody having this problem. AutoComplete has given up the ghost on me. I have tried turning it off, and then back on but to no avail. It just refuses to work.

I mean it really isn't that big of a deal but it is a minor annoyance. Does anybody have any ideas how I can get this thing working?

A:AutoComplete isn't working.

See if this Microsoft Support fix will help.

Read other 2 answers

I have Win XP Home Edition. Autocomplete is not working
although all the boxes are checked. I understand that I need
to setup a user account that does not have administrative rights.
Security will not permit autocomplete to work if I am the only
administrator. I am a novice and I don't want to start changing
anything on my own for fear of creating problems with my ignorance. Any help will be appreciated.

Read other answers

In Outlook 2003 (and XP too if I remember right), Outlook will try to autocomplete an email address when you try typing one in the address field of a new email message. However, if I have 5 people in my address book who's display names start with "sm", I can type sm and Outlook gives me 2 addresses to choose from to autocomplete, sometimes 4, sometimes 5...I don't understand why Outlook doesn't always autocomplete my addresses. This is an awkward question so I hope it is clear enough.

A:Outlook Autocomplete

My guess is that there is too many to choose from so it requires more letters to *autocomplete*. I never have seen it NOT do it. Don't forget it will autocomplete on both display names AND addresses.

Read other 3 answers

Is there a way to autocomplete typing in Access?
We have designed a Table and a Form. We are continuely typing names into the form. It would be much easier and quicker if there was an autocomplete feature, like in Excel.

A:Autocomplete and Access

Read other 16 answers

Is there an option to have email addresses automatically fill themselves in the Outlook 97 on Windows 98 like in outlook express? I've looked but couldn't find it. Thanks.


It's under Tools>Options>Preferences Tab>Email Options button>Advanced Email Options button at the bottom, check "Automatic Name Checking."

Unlike Outlook Express, which completes the To line as soon as it has enough information, Outlook won't complete it until you've tabbed to another field.

Read other 1 answers