Over 1 million tech questions and answers.

Lenovo Y520 Wifi Problem

Q: Lenovo Y520 Wifi Problem

Read other answers
RELEVANCY SCORE 200
Preferred Solution: Lenovo Y520 Wifi Problem

I recommend downloading and running Reimage. It's a computer repair tool that has been proven to identify and fix many Windows problems with a high level of success.

I've used it in the past to identify and fix everything from blue screens (BSOD's), ActiveX errors, corrupt files and processes, dll/exe/sys errors, recover lost memory, Windows update problems, defragging, malware removal etc.

You can download it direct from this link http://downloadreimage.com/download.php. (This link will automatically start a download of Reimage that you can save to your computer.)

RELEVANCY SCORE 85.2

Hey all,  Just recently bought a Lenovo Y520 gaming laptop. Overall very satisified with it! Last week I added an SSD drive to it and decided to do a fresh reformat from the BIOS so the laptop would run at full power without any bloatware holding it back.  Did the reformat sucessfully, installed all drivers, and now the laptop is running perfectly, except for one thing.  Since the reformat, Wifi has been giving me constant problems. I've tried just about every solution available on the net but so far have had no luck. It's main issue is: when I go to power on the laptop after being turned off for an extended period of time (at least 8-10 hours), there's no wifi at all whatsoever. Windows doesn't detect my wifi at all, even under network adapters! I've downloaded the latest drivers directly from Lenovo and even took it one step further by getting direct drivers from intel themselves. In this condition, it only detects my ethernet port, so when I go to diagnose it, it doesn't consider Wifi an issue because it doesn't think it exists.  The ONLY solution to get Wifi to work for me is to restart the computer at least once, load up the BIOS, go to the Configurations tab and disable/re-enable Wireless Lan. After that, I boot it with the saved changes and boom, Wifi suddenly works again. Thing is, I shouldn't have to do this every time to get Wifi to work. Before the reformat, the Wifi was working absolutely fine with no issues whatso... Read more

Read other answers
RELEVANCY SCORE 72.4

My Lenovo Y520 is facing this very weird issue, I am sitting nearly 6 feets from my Wifi router to which network both my phone and my Lenovo machine are connected to. But Internet speed test (tested on fast.com  on phone gives me a 40Mbps speed while on my Legion Y520 gives a measly 1 Mbps at a stretch. What could be going on?

Read other answers
RELEVANCY SCORE 64.8

Hello everyone! I've got a problem with my Lenovo y520, bought about 3-4 months ago, I noticed that sometimes one white line at the bottom of the screen may appear out of nowhere (see screenshots), though it usually appears when I'm playing games. The line stands just at the bottom part of the screen, more exactly at the bottom part of the task bar. I must say that this problem didn't start to occur when I bought it, but after a while. Also, I noticed that while I'm playing video games, the screen would flicker (like a very short shut down) for 0.1 seconds, if you blink you'll literally miss it, and then the line appears. Sometimes, the screen flickers again and the white line would disappear. This problem doesn't occur everytime I play, but sometimes. The white line remains still, unless I restart the laptop. Now, I'm asking you for help, what is the cause of this problem and how can I solve it resulting in no appearances of such weird lines on my laptop's screen?Thanks.

Read other answers
RELEVANCY SCORE 64.8

My legion y520 will run a game for a little bit then crash then all my games will stop working and give me various errors such as unable to start 3d acceleration and other directx related errors. Also geforce experience keeps telling me something went wrong try restarting geforce experience over and over

Read other answers
RELEVANCY SCORE 63.2

Hi all,I have one dell S2340L which is tested and working complete fine on another lenovo laptop, but when connected to my new Y520-15IKBN, it is not working at all. the Y520-15IKBN is windows 10, and it detected this LCD in OS, i can duplicate and extend it, but nothing shown on this dell lcd. things i have tried, -reinstall all latest intel and nvidia driver-change all possible resolutions and refresh rate.  i cannot reset this OS because i have a lot of important working documents in it, please guide what else i can try. 

Read other answers
RELEVANCY SCORE 63.2

Since i formated my pc ... the system Win 10 can't recognize  the video card 1050TI .looks like my system does not display the dedicated graphic card? My laptop would disable all external video cards leaving the one othe chipset working.?? please i need help

Read other answers
RELEVANCY SCORE 63.2

Hello i have a Lenovo Y520 80WK014PTX;Processor: 1x Intel Core i5-7300HQ Processor(i5-7300HQ)Memory: 1x 16GBDDR42400Operating System: Windows 10 Home 64(TR:Turkish,EN:English)Hard Drive: 1x 128GB PCIe Graphics: 1x NVIDIA GTX1050Monitor: 15.6 1920x1080Bios: LENOVO 4KCN40WW 17.10.2017 First of all i have to say it is a great laptop and i am glad i chose Lenovo, it has one of the best cooling expect only one thing that i have a turbo boost problem. It looks like there is a thermal lock for I5 7300HQ which doesn't let Turbo boost after 80 degree celsius! When i use both Lenovo's strong cooling and my personal laptop cooler 7300HQ manages to keep turbo boost at 3095 mhz for hours in games such as BF1 and i can play them without facing any serious bottleneck nor stuttering while CPU tempetures are average 75 degree (78 maximum) and 1050 works at average 60 but there is too much noise ofc!! When i try to close Lenovo's strong cooling or my laptop cooler then bios locks 7300HQ at 2400 mhz and doesn't let it to use turbo boost no matter what and because of that im experiencing very bad bottleneck and stuttering in some games such as BF1 while CPU tempetures drops to average 68 degree! Im 100% sure this laptop can handle 7300HQ under 90 degree without strong cooling nor a laptop cooler so i wonder why there is such a harsh thermal lock? Perhaps the problem is my bios version?? I also believe bios shouldn't be locked, i know it is for protecting c... Read more

Read other answers
RELEVANCY SCORE 63.2

Hello,I purchased my laptop on 12th July 2018 and after 3 weeks I noticed this white light on the top right corner of my laptop in addition to white bands over the screen depending on the tilt position. What should I do? I purchased this laptop from UAE and now I am in India. It has 1 year international warranty and I was told that I can avail the warranty here in India but I am being denied the IWS in India. The customer service center is telling me that my laptop is not supported in India.    

Read other answers
RELEVANCY SCORE 63.2

Hi! My name is Greg and i have a huge problem with my freshly bought SSD. Its a WD Blue M2 Sata, i did research before i bought it so that its truly compatible with my lenovo y520. After i removed the back cover, i put it in place in correct way. I started the laptop, but the SSD cannot be recognized nor in BIOS nor in Disk Manager. I did so many forum research, i also reinstalled my windows 10 in AHCI mode. Nothing helped. Please if someone have a solution i would be so thankful.Yours SincerelyGreg

Read other answers
RELEVANCY SCORE 57.6

i need help my laptop dont show wifi connection i tried to reset many times still got the same problem please help me advance thank for everyone

A:LENOVO 3000 G400 WIFI PROBLEM NO WIFI CONNECTION

This is the Datacenter Systems Group forum as such we do not cover the Lenovo G400. I have requested that this be moved to the appropriate forum.
 
Admin note: post moved accordingly

Read other 1 answers
RELEVANCY SCORE 55.6
RELEVANCY SCORE 54

Hey everybody, I am trying to install Windows 10 x64 over USB (Created with Microsoft tool).BIOS version: 4KCN43WWWhat I want is to install Windows in UEFI Mode (Not legacy), but when I set everything in BIOS I can?t see USB on boot menu.I can use it and install it when I set: Boot Mode: Legacy SupportBoot Priority: UEFI First But that is not an option, I don?t want my Windows to be on Legacy mode.I am not able to install it like that and switch to UEFI after, keep getting error that HardDrive cannot be found.SATA Controller Mode is on ACHI.OS Optimized Defaults is on ENABLED.Secure Boot is DISABLED.Fast Boot is DISABLED. If anyone has any solution that I didn?t try it would be great.

Read other answers
RELEVANCY SCORE 54
RELEVANCY SCORE 54

Hello people, i have a big problem,bought a brand new laptop few days ago its Lenovo y520 i7-7700hq/16gb rams and gtx 1050ti 4gb, and i cant play games at all,tried tom clancys the division i have 15-10 fps there and the rust on medium settings have big laggs i dont know what to do,tried to set my battery settings to high performance still the same thing...Please help.

Read other answers
RELEVANCY SCORE 54

Hello, I own a Lenovo Legion Y520 (the one with 2tb HDD) and I would like to add an SSD to it as well. From what I've read, if I want to keep my HDD and add an SSD, I will need an M.2 type SSD. Also, I have found an SSD that I think would be compatible with my Y520, but I wanted to ask here before buying it. The SSD I'm talking about it the SSD WD Black 256GB PCI Express 3.0 x4 M.2 2280. I will also attach a picture of it, so if anyone could tell me if it's compatible, I'll be very thankful.This is the one 

Read other answers
RELEVANCY SCORE 54
RELEVANCY SCORE 54
RELEVANCY SCORE 54

For example this:http://eu.crucial.com/eur/en/bls8g4s26bfsdk I want to use in dual channel so i want to buy two.

A:Lenovo Y520 Can i use 2666mhz ram?

yes but it will run on your mother board maximum allowes 2400mhz

Read other 2 answers
RELEVANCY SCORE 54

Hi.My Lenovo have a 1tb hdd.I want to know if I can buy a ssd and the both disks.And if so what sdd can I buy MTM:80wk00mmpg

Read other answers
RELEVANCY SCORE 54

Hi there, I need to upgrade my ram, Currently housing 1 x 8gb module stock. Would someone kindly be able to offer me a list of compatible 8gb modules that I can purchase and install. Further to this due to my current location in Thailand I have the following more readily available. Crucial - CR239ELAB8TNTXANTH-99364522 Kingston HyperX - HX424S14IB2/8 Both clock in at 2400 Thanks in advance.

Read other answers
RELEVANCY SCORE 53.2

Hi, I've recently bought this laptop and I'm already getting an error message upon booting up.This one: I have ran sfc /scannow in cmd: However, the error upon booting up still persists. What should I do next?  

Read other answers
RELEVANCY SCORE 53.2

Hey guys, I just bought this computer today and I have encountered this problem. When I go to control panel -> display / dxdiag / AIDA64, I can only see Intel HD 630, but not my GTX 1050. I have tried reinstalling latest drivers and I changed the settings in NVIDIA control panel. I am using Windows 10 Pro. Thank you  

A:Lenovo Y520 dedicated GPU not showing

Hi Adomce123, 
 
Welcome to the Community Forums. 
 
Have you tried running dx diag with a high graphic application software running alongside?
 
The automatic switch from Intel to NVIDIA would happen when there is demand for it thus you were allowed to re install NVIDIA drivers and use the NVIDIA control setting since it was available in your system. This can also be checked in your device manager as well as lenovo diagnostics to confirm if the NVIDIA device if available.
 
Try going in the BIOS and verify options under Configuration Menu for graphic device to run on Discrete or UMA only as option. F10 to save setting before exit.
 
Update us how it goes.
 
Regards
 

Read other 1 answers
RELEVANCY SCORE 53.2

Everytime i charge my device to 100%The battery FULL CHARGE capacity seems to degrade a littleBtw, my laptop is only couple months oldThe battery report : https://drive.google.com/open?id=1XB2Xoj88xx1fXaV_vKE4J45g3Q0YUz8_

Read other answers
RELEVANCY SCORE 53.2

I purchased a Lenovo Y520 last year and I had to send it in once already due to the dedicated GPU dissappearing. When I got it back it lost a couple of screws and wouldn't connect wirelessly without a hard restart every time. This is not only annoying but bad for my laptop. I'd like to know how to fix this without sending it in.SPECS: RX 560 4GB GPU 500gb HDD 1 TB SSD 32GB RAM i5-7300HQ 

Read other answers