Over 1 million tech questions and answers.

USB 3.0 Ports Not Working - Y580

Q: USB 3.0 Ports Not Working - Y580

Y580, Win10 I just purchased a used Y580 cheap because it has non-functional USB 3.0 ports. The USB 2.0 port works fine.When I plug in a USB cable, it doesn't register anything, as if there's no power to the ports. Which leads me to believe it's not a driver issue...but I could be wrong about that. My thought was that the controller on the motherboard might be bad, but I don't know much about laptops, honestly. I'm more of a desktop guy when it comes to hardware. I'm not even sure if the USB controller is onboard or a separate board in the laptop. Any ideas on how to fix this, or am I just out of luck? Thanks. - Brian

Read other answers
RELEVANCY SCORE 200
Preferred Solution: USB 3.0 Ports Not Working - Y580

I recommend downloading and running DAP. It can help sort out any driver and firmware related issues on your system

It's worked out well for many of us in the past.

You can download it direct from this link http://downloaddap.org. (This link will open the download page of DAP so you can save a copy to your computer.)

RELEVANCY SCORE 79.2

My front left USB 3.0 ports stopped working a few days ago.  They can still provide power via a USB to Micro USB adapter cable, but will not recognise or power my mouse or headset. My device manager indicates that my Intel(r) USB 3.0 Extensible host controller cannot start (code 10).  I've tried reinstalling this driver, but that didn't sovle the problem. My rear right USB 2.0 port functions regularly.  My front right USB 3.0 port does not work because it has been physically damaged. I'd really like to have at least 2 functional USB ports to work with.  Can anyone help me figure out what's wrong with my left ports, or how I could replace the right front port?  Thanks.

Read other answers
RELEVANCY SCORE 56

Vista Ultimate 64-bit, ASUS Rampage Formula motherboard, USB mouse and keyboard connected in back ports.

Two things happened: Avira antivirus warned me of some threats which I either ignored or deleted. Windows Update had some updates ready (although I'm not sure if it updated).

I turned off my PC for a couple of hours, turned it back on and realized that my USB keyboard was not working on the password screen.

I eventually unplugged it from the back and plugged it into the front, where it worked. However, my USB mouse did not work when plugged into the second front port, nor did it work when plugged into the front port in which the keyboard worked.

I accessed System Restore using my keyboard and restored to one day previously. When it finished, both keyboard and mouse worked, although I got a pop-up message alerting me that the "drivers for your device could not be installed." When I clicked "OK," the mouse stopped working again.

I have checked BIOS and both mouse and keyboard are recognized, so it does not appear to be a hardware issue.
 

Read other answers
RELEVANCY SCORE 53.2

I've checked bios settings, turned on. I've installed and reinstalled the driver from 2 sources. I've enabled and disabled the adapter. I've restarted my laptop. This happened after I tried installing Windows 8.1 pro 64 bit. All other drivers are installed (Intel,Nvidia etc.)Ethernet works, but the WIfI button is greyed out.

Read other answers
RELEVANCY SCORE 53.2

I've checked bios settings, turned on. I've installed and reinstalled the driver from 2 sources. I've enabled and disabled the adapter. I've restarted my laptop. This happened after I tried installing Windows 8.1 pro 64 bit. All other drivers are installed (Intel,Nvidia etc.)Ethernet works, but the WIfI button is greyed out.

Read other answers
RELEVANCY SCORE 53.2

8GB, Hynix HMT41GS6BFR8A is not working on Lenovo y580, BIOS: 5DCN40WW (V2.07)HEX data of RAM SPD from anather computer with RWeverything: 000 92 13 0B 03 04 21 02 09 03 52 01 08 0A 00 FE 00
010 69 78 69 30 69 11 18 81 20 08 3C 3C 00 F0 83 01
020 00 00 00 00 00 00 00 00 00 88 00 00 00 00 00 00
030 00 00 00 00 00 00 00 00 00 00 00 00 0F 11 65 00
040 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
050 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
060 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
070 00 00 00 00 00 80 AD 01 14 30 1E 41 71 08 77 80
080 48 4D 54 34 31 47 53 36 42 46 52 38 41 2D 50 42
090 20 20 4E 30 80 AD 00 54 44 34 37 4E 36 31 33 34
0A0 4E 30 33 00 01 11 11 00 00 00 00 22 00 00 43 C0
0B0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0C0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0D0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0E0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0F0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00   This RAM works on another computer (asus) and does not work on Lenovo, why? BIOS problem or what?Examples:(Old memory, any slot)  - works normally.(Hynix only) - dont work, black screen.(Hynix slot0) and (Old memory slot1)  - dont work, black screen.(Hynix slot1) and (Old memory slot0)  - dont work, black screen.But Lenovo react for 5sec hold on power button, wich means system works.Is there any solution or BIOS update to fix this problem?Y580 is not too old to unsupport ... Read more

Read other answers
RELEVANCY SCORE 52.8

Laptop updated to Windows 10 then my friend downgraded back to Windows 7 and now the keyboard, mouse, and USB drives don't work and there's no backup image. HELP!!!

A:Lenovo y580 keyboard and track pad not working

Model # of laptop? Did you use the revert back to Windows 7 feature or clean install over Windows 10?
 
*edit* Sorry, saw you put the model # in the title.

Read other 2 answers
RELEVANCY SCORE 52.8

Hi,I upgraded my Ideapad Y580 to windows 8 and now I can't get the function key combination to turn on my wireless hardware.



Yash Manivannan








Solved!
Go to Solution.

A:Function Keys not working on Ideapad Y580 after up...

Please install lenovo energy management of windows 7 and then press fn+f5. The one of windows 8 does not work properly.http://download.lenovo.com/consumer/mobiles/cagt24ww.exe



Ishaan Ideapad Y560(i3 330m), Hp Elitebook 8460p!(i5-2520M) Hp Pavilion n208tx(i5-4200u)If you think a post helped you, then you can give Kudos to the post by pressing the Star on the left of the post. If you think a post solved your problem, then mark it as a solution so that others having the same problem can refer to it.

Read other 2 answers
RELEVANCY SCORE 52.8

Hi Everyone! My display backlights stopped working. I'm still able to see what is on the screen when i put my cellphone flashlight on the screen but it's really hard to see anything. From what I read online it might be just a fuse or the display itself. I was not able to locate the fuse on the motherboard, if someone can help me find the fuse would be great. At first I was thinking of ordering the display but some people changed the display and the problem was still there. Any advise would be appresiated.P.S. The laptop is already completly dissasembled  Thanks.

Read other answers
RELEVANCY SCORE 51.2

Greetings! I'm currently working on reinstalling win on my cousin's y580 with following specs:Intel(R) Core(TM) i3-3110M CPU @ 2.40GHz8GB RAMGEFORCE GTX 660M Everything went smoothly until the part where I want to install USB 3.0 drivers (responsible for 2x3.0 USB and 2.0 USB port). I tried everything from installing win7 drivers, uninstalling and reinstalling them with Windows Update to forcing INTEL drivers intalation. So far no luck. Browsing the forum I happened to find the topic: https://forums.lenovo.com/t5/Lenovo-P-Y-and-Z-series/USB-3-0-Ports-Not-Working-Y580/m-p/3457050#M149... , where the guy assumes that motherboard is broken cause he bought it with "broken USB ports". That is not the case, ports were working just fine on win8 until the moment win10 was introduced. In the device manager the driver shows the error 10. I also came for advice to my friend using the same notebook with better specs(i7) and they are working fine for him. So my question finally is: have anyone solved this problem for the given spec already and/or is it the case of the 64bit system(not fully supported with those specs)? I am frankly out of ideas rn. Cheers, Hubert  

Read other answers
RELEVANCY SCORE 50.4

This is a brand new custom built PC for web browsing for a motel lobby.

Win7 Home Premium
AMD A4-3300 Llano
MSI A55M-P33 FM1
Rosewill FBM-02 MicroATX Mini Tower

Running latest BIOS and latest drivers downloaded directly from manufacturer's website.

I tried switching between all 3 internal headers and none of them would detect the flash drive.

If I plug the drive in the rear ports it detects right away leading me to suspect the case's ports might be defective but I don't have another USB 2.0 card lying around to confirm.

Based on this info does it seem likely that the front ports themselves are faulty?

A:Front USB ports not working, but rear USB ports work…

You might check to see if the case end of the USB cables are properly plugged into the front panel holding the headers. Some board need more than one brand of USB drivers, Renesas, NEC, etc.

Read other 9 answers
RELEVANCY SCORE 49.6

So I'm sure this isnt' where this goes honestly but putting it out there just to try to help anybody else who struggled with this as long as I did... I ended up getting my two USB ports on the left side (turned out to be my 3.0 ports) to work again when they wouldn't recognize anything. I could use the 2 USB on the right 2.0 ports, but the transfer rate was terrible.  My response on another question where someone had a similar issue... good luck!  "Hi  Not sure if this will help you but I had the same problem, the two left ports were not working on my Dv7. This whole time I thought the right USB were my 3.0 ports so I figured it'd be okay but it's been over a year since I originally had this issue and was doing a bunch of system maintenance so figured I'd look through it again. Anyway, I went to Device Manager through the Computer Management tool. I know you can go straight to device manager, but just giving it to you exactly how I did it. You can just search computer management from Start.  So I selected Device Manager from the menu on the left side and it looked like regular device manager. Went down to Universal Serial bus Controllers... at this point I looked at the action menu on the right and selected more actions, view, and clicked Show Hidden Devices. After that i went through my USB Controllers one by one as I had done many times before and checked them out, tried updating drivers, etc... I noticed underneath the USB Controller... Read more

A:How I fixed my USB ports not working issue. Two ports on lef...

Hi @klark1kent , Thank you for visiting the HP Support Forums and Welcome and thanks for the important information. Have a good week. Thanks.

Read other 3 answers
RELEVANCY SCORE 47.6

Hey guys, brand new kid here. Fairly computer literate but not a whiz by any means. I had to do a Windows XP System Recovery on my HP desktop PC a few weeks ago and since then my USB 2.0 ports haven't been themselves.

Before when I used my Kingston 4gb SDHC card in my front USB 2.0 ports (as they're labeled) it worked at full speed with no problems. After the System Recovery, when I plug in the card it gives me a message saying "This device could perform faster if it were plugged into a High Speed USB 2.0 Port." The problem is, my Device Manager lists a high speed port and hub on my computer, but I get the same message on all the ports on my computer. I tried updating the drivers and uninstalling and reinstalling them but to no avail.

Is there any way to fix this?
 

A:USB 2.0 Ports working as regular USB ports

Read other 10 answers
RELEVANCY SCORE 44

All USB ports on my Dell Inspiron 530 stopped working and therefore no keyboard or mouse control available to work on recovery.  Is there any way to work around this problem? Although the computer was updated to Windows 7 Pro some time ago, I do still have both the Win 7 discs and the OEM discs that came with the computer. Any suggestions?  

A:USB Ports not working and no PS2 ports available

Get a live linux boot CD or DVD and see if the ports work outside the os.
Or Disconnect the hard drive and see if you can F2 into bios.

Read other 2 answers
RELEVANCY SCORE 44

Hey
Today i just bought some ear phones, with a connected mouth piece. Problem is that my two front ports are dodgy for the microphone and headphones. So if i put the jacks from my headset into the back, i have to take out my speaker input.. Is there any way i can have the speakers in, and the headset and revert back to each without going at the back and changing them? Any help appreciated
Thanks
 

A:Headset not working, front ports not working

First, its possible inside your computer case, there is just a loose cable that is causing the problem with the front jacks on your computer. Check inside, right behind where the earphone jack is for a cord running to somewhere on your motherboard or Sound card.

If that dosn't work,
Do you have a CD/DVD player with a earphone jack and have you tried that?
Assuming its the port that is bad itself and not just loose, you could check in at radio shack, bestbuy, or newegg.com for a cord that splits the output. If you get lucky you might find one with a chanel select that will allow you to swap which recieves the output.
The other option, from radio shack I got a Bluetooth USB adapter for $20 and a good pair of BT earphones, again purchased online for cheap (I recommend samsung BT500 earphones).

Another alternative, my speakers have a earphone jack in them as well (the computer speakers, as well as the reciever I currently have my sound card plugged into).

If you have a quality home theater set up, for $80 on new egg you can pick up a good soundcard with optical, Coax, and AV out which you plug into your home entertainment center that again will allow you to use headphones.
Good Luck
 

Read other 2 answers
RELEVANCY SCORE 41.6

Well, not that they aren't working, they just aren't installed/functioning.

In my new computer is a Gigabyte mobo GA-MA790XT-UD4P.

I updated the bios, and just about everything including the chipset.

Yet when i plug in USBs to the usb ports on either the front of back of my case, OR the media reader I have, it says

This USB Device can perform faster if you connect it to a Hi-Speed USB 2.0 port.
For a list of available ports, click here.

When i click on it, none of them are high speed ports, yet this motherboard is good quality from what i see.

Anyway to fix this?

Thanks

Also, XP Professional SP3 doesnt recognize that i have 4GB of ram, it says I only have 3.25, is this some kind of Cap?
 

A:USB 2.0 Ports Not Working?

First are you sure the devices are usb 2.0
Second check the bios for the following
USB EHCI Controller
Enables or disables the integrated USB 2.0 controller. (Default: Enabled)
 

Read other 2 answers
RELEVANCY SCORE 41.6

I logged onto dell.com today around 4:30 pm est, to try to fix an issue with my desk top which is only a couple of months old. I started a chat with Mohammed and he said that there would be no problem he would fix my issue which was my USB ports are not recognizing anything that is plugged into them. He ask for my phone number just in case we get disconnected he will call me. He remotes into my system and starts downloading Dell click to fix during the reboot we get disconnected, so I wait for him to contact me since I don’t have his contact info he has mine. Checking my phone and email nothing, this guy just downloaded something on my computer then disappears. So I get back on dell.com chat and get Venkata which it like we are starting over again I told her to look at my account gave her my service code and then here we go she give me a link to reconnect with her in case we get disconnected. 2hrs later she is searching for drivers I asked why it takes 2hrs for drivers, she then down loads chip set again updates bio’s nothing works so she deletes all of my drivers including access to internet which that is how we are communicating. Then the system restarts it a good hour on the restart to try to configure, so I click on the link that she told me to use to reconnect to her. I click on it and I get a message wrong access code. I am thinking she has my phone number she will call. Nothing. So I go back on line and try again to chat and I get a message chat not availab... Read more

Read other answers
RELEVANCY SCORE 41.6

my usb ports are not working in windows 10

Read other answers
RELEVANCY SCORE 41.6

Greetings all,

I am not going to tell my problem or trouble but rather to tell what I had done based on what I found out from other responses to "related issues" subjected above. I just thought that I must do this for the sake of others, brothers and sisters in Jesus Christ.

I wanted to go back to the threads that I have found helpful to post this but I am not that fond of using the search fields and somehow my google search results on this lappy is quite differ from the one i got on the usb-troubled lappy that i used to log into sevenforums. i have read through just about 10 of the related result on sevenforums but not one of them is the one i found out earlier.

anyways, what i did was: uninstalled all usb listings in device manager and then just shut down the lappy, unplug all cables including power cable and went out for a smoke. a few minutes later, came back and plugged the power cord and turned on the lappy. and somehow, windows auto-install everything and since the lappy is wirelessly connected to the internet like always, it also download and install everything. then i plug the main cause of the problem (microsoft 5-button intelligent mouse) and wait for the driver update wizard to complete; and now everything not only seems working fine, BUT actually working fine now.

thank you so much whoever you are.

regards and God Bless,

A:USB ports not working at all

Thanks for your solution zeamann!

May it help others with similar issues in the future.

Read other 1 answers
RELEVANCY SCORE 41.6

Please get me my 3.0 drivers....PCI Id's arePCI/VEN 1022&DEV_7814&SUBSYS_2B05103C&REV_01PCI/VEN 1022&DEV_7814&SUBSYS_2B05103CPCI/VEN 1022&DEV_7814&CC_0C0330PCI/VEN 1022&DEV_7814&CC_0C03There are yellow exclamation in device manager.

A:3.0 ports not working...

Shery. Try this one. https://downloadcenter.intel.com/download/22824/USB-3-0-Driver-Intel-USB-3-0-eXtensible-Host-Control... REO

Read other 2 answers
RELEVANCY SCORE 41.6

hi,
i have recently installed windows 7, previously it was vista, after 2 days both of the usb ports have stopped working,properties showing base system drive not installed.
how can i get both the usb ports working again.
laptop- hp pavilion dv4-1145go

A:usb ports not working

it seems a virus problem.. start in safe mode and run Malwarebytes. If you can not do this also try to "restore your computer" in previous setting.... hopefully the problem will be fixed.

Click Here to know how to restore your computer

Read other 1 answers
RELEVANCY SCORE 41.6

Hello,I have recently pulled out an old HP Compaq, stuck in a random hard drive, and tried to install Ubuntu through the disc drive. I couldn't, because the monitor wasn't showing anything. It's a sturdy cable, and a working monitor. I have a USB mouse and keyboard, and I plugged those in to the front and back, but they didn't work- my mouse and keyboard both use USB power. The SATA ports work, the power button works, and the disc drive works- just a reader.Oh- Before this, this computer wouldn't start due to the CMOS battery.Anyways, it starts up fine and posts, and I really don't want to replace the system board.My computer has Intel vPro, designed for Win XP, 2gb DDR3 memory on one chip, dvd reader that came with the thing. Thanks!

Read other answers
RELEVANCY SCORE 41.6

I moved my computer and none of my USB ports are working now. I have one in the front and four in the back.

I checked device manager and they show up. I did an uninstall, unhooked everything from them, rebooted, they show, but they don't work.

I have tried plugging my camera in and my memory stick and neither work in any port.

Help!

Nancy
 

A:USB ports not working

Read other 7 answers
RELEVANCY SCORE 41.6

Someone PLEASE help.  My USB ports have stopped working randomly.  Not too long ago i factory reset my computer and maybe this has triggered it?  IM not sure but i need my usb ports working asap.

A:USB PORTS NOT WORKING?

You might try reinstalling the Intel chipset drivers from the hp.com site.

Read other 1 answers
RELEVANCY SCORE 41.6

:BOW:
Greeetings my fellow students and sensais.i have a problem and i know this is the best place to get new moves{not that i have any}.great teachers and students i just got another machine.it is an IBM moterboard ??? i'll get the number later processor pentium 4,hard disk 80 gig,.so the machine came with Windows XP installed but no sound and the USB ports 4 the flash stik not working.gav it to a it guy who got the sound drives installed after reinstalling windows xp.but the usb ports are not functioning .have reinstalled window xp but no luck.under device manager the usb ports r showing functional and wen i stik in my flash the flash light goes on but nothing appear on the desktop.will some boby pliz provide some steps to activate the drives.show me some new styles to use on this problem & i'll b greatfull.:BOW:
 

A:USB PORTS are not working

This may be a faulty motherboard. Best and cheapest solution is to fit a card with USB ports on it.
 

Read other 8 answers
RELEVANCY SCORE 41.6

I hope this is the right place to post.

So I upgraded this morning from windows 7 to 8 and it all seemed to be working alright. Then my usb ports stopped working. Can't use mouse, doesn't recognize external hard drive or anything else.

For the first few minutes it was all working ok and I could use my wireless mouse etc. I'm usually on a wired internet connection but switched on the wireless to check that it all worked, right away I noticed 3 items pop up in the task bar which had the word "device" but they disappeared fairly quickly so I couldn't see what it was all about. After that, everything stopped working.

When I go to Device Manager, I see a list of "USB Hub Root" with yellow exclamations next to them.

Any ideas how to go about fixing the problem?

EDIT: When I right click on "USB Hub Root" it gives me this: Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

A:None of my USB ports are working.

Figured it out. After a bit of searching on google, found someone else had a similar problem. Turns out the driver for my ps3 controller was clashing with the usb root hub ports. Just uninstalled libusb-win32 and everything is working again.

Read other 1 answers
RELEVANCY SCORE 41.6

Sheesh, since I put together this new PC, I sure have been to this site a lot.
Anyways, I put my jumpdrive into my PC, but it wouldn't pick it up. I tried both ports, but nothing. I checked the mobo disk, and one of the options is for USB, but when I clicked on it, it said I need the SP1 because the drivers are included. I checked the disk in Explorer and clicked the USB icon and it said I already had the USB drivers from SP1.
 

A:My USB ports don't seem to be working

You mentioned SP1 but not which OS. I assume XP. Get SP2 and try again. If running 2000, get SP4.

Also, be sure all USB is turned on in the BIOS.
 

Read other 1 answers
RELEVANCY SCORE 41.6

Hey guys,

For the last couple of days I started getting a message whenever I plugged in my phone saying there is a USB power surge. After that happens all of my USB ports stop working. I have to reboot my computer.

Using windows 7 up to date.
I've deleted and reinstalled usb's
Turned off let computer put usbs to sleep
My computer is plugged into a surge protector

Any ideas?

Thanks in advance.
 

Read other answers
RELEVANCY SCORE 41.6

Ok so I have a windows 8 64 bit machine. I have a xerox personal scanner as well as a dell 2330d printer. My issue is that the scanner only works if i have it plugged into one of my usb ports on the front of my machine and will not work on any that are on the back of the machine. As for my printer it works on either one the front or the back. I have plugged the scanner into everyone on the back and still doesn't work but as soon as I plug it in on the front USB it works! I would like to be able to plug both plugs into the open available USB ports on the back of the machine but only the ports on the front work for my scanner! How can I fix the back ones to work with my scanner and why is it that only the front ones work with it and the back ones do not?

A:USB Ports not working

Hi there
Could be that your device is USB 1.1 and one set of USB ports are 2.0 only and the device is not compatible with USB 2.0.

(Or the other way around).

Cheers
jimbo

Read other 1 answers
RELEVANCY SCORE 41.6

Hi... for some reason the 2 USB hubs in the front of my computer
suddenly stopped working for the second time. Last time I remember I deleted the USBs in my device manager, but I don't remember which ones I deleted. I have USB hubs connected and my wireless mouse and keyboard usb bluetooths. How do I know which ones belong to the computer itself? If I delete all, will they get installed again when I reboot? Please help me...
 

A:USB ports are not working

Read other 6 answers
RELEVANCY SCORE 41.6

I have a IBM thinkpad t41 series with Windows XP. It also has an detachable docking station. There are two USB ports on the laptop and one USB port on the docking station. One day they were working and now all three are not being recognized. When something such as a plug and play is attached the device states that it is working correctly, but the laptop does not show that the device is connected. I have tried deleting and reinstalling service pack 1 & 2, reinstalling windows xp, going to Lennox and making sure all drivers were updated as well as double check the BIOS. I do notice when clicking the ADD HARDWARE under CONTROL PANEL I do get a message stating that my computer is already installing another hardware and is unable to add another until the present download is complete. However, I have no clue what other hardware is installing and have gone under CONTROL ALT DELETE to see if there is anything running that I am not aware of. What am I missing?
 

A:USB ports not working

Read other 7 answers
RELEVANCY SCORE 41.6

I have 4 USB ports on the back of my PC and 2 on the top. They have all stopped working.

I noticed this when my USB mouse stopped working. I tried the mouse in all of the ports and it didn't work in any. I then noticed that the external hard drives that I had plugged in did also not work - they do seem to power on but the PC does not recognize them.

I have been able to get the PC working by plugging in the (non USB) type of mouse but can't seem to get the USB ports working.

I am running Windows XP Pro.

Any ideas?
 

A:USB Ports Not Working

Read other 16 answers
RELEVANCY SCORE 41.6

Hello
i have an dell inspiron e1505
my usb ports are not working
i have tried deleting them and reinstalling. everything that the message boards suggest to do
in my windows/int file i have all the required files and extensions previously mentioned on a message board

when i go to my device manager the 4 usb ports are listed as well as a 5the enhanced port and then 4 generic usb port drivers that are always re-added when i attempt to reinstall the drivers.

does the motherboard need to be replaced? is there a way i can check? im currently living in russia and the language barrier makes going to a computer store difficult.

if the motherboard does need to be replaced can you please suggest where i can purchase one online and what i should look for. dell does not offer part replacements on their site

thank you
sara
 

A:USB ports not working

I don't know if this will help; but, I saved it in my notes:

From JohnWill at TechGuy.org, Dec 5, 2006 in reply to user whose USB ports seem to have quit working.

Click Start> Programs> Accessories> System Tools> System Restore. Create a restore point and name it something like "Before USB Fix". This is to bail you out if something goes wrong during the following process and makes things worse.

Create a file with NOTEPAD containing the following lines and save it as FIX.REG
-------------------------- Use text after this line --------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINEYSTEMurrentControlSetontrolession Managernvironment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
-------------------------- Use text before this line --------------------------------

Double click on FIX.REG and say yes to the Merge Into Registry question.

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives that you know are not present.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.
 

Read other 1 answers
RELEVANCY SCORE 41.6

i found some time ago that two of three usb ports of my laptop are not working. i have done the pc hardware diagnostics test and i result in a fail. now i don't know what to do. please help me.

Read other answers
RELEVANCY SCORE 41.6

my desktop PC is having some issues not sure how it happened but my display stopped working . My USB ports have stopped working as well.I opened up my pc the motherboard appears to have power..

any ideas?

thanks in advace
 

A:all usb ports and gpu not working

Read other 6 answers
RELEVANCY SCORE 41.6

I recently installed Windows 7 64 Bit on my HP 240 G4 Notebook. However, the USB 2.0 ports on my laptop seem to be not functioning. I have installed all the controller drivers listed on the HP Support page. It contains only USB 3.0 eXtensible Host Controller driver. What is the problem and how do i resolve it?

A:USB 2.0 Ports Not Working

Update chipset driver from HP website and check the occurance of the issue.  Have a great day !  I work on behalf of HPPlease click ?Accept as Solution ? on the post that solves your issue to help others find the solution.Click the Thumbs Up to say ?Thanks? for helping!

Read other 1 answers
RELEVANCY SCORE 41.6

none of my USB ports are working, can some one please help me????????????

A:none of my USB ports are working

Has this just occurred out of the blue? Would a system restore help?

Read other 1 answers
RELEVANCY SCORE 41.6

After a system crash, a re-install of Windows XP Home, and an online upgrade of all patches and SP2, everything seems fine exceppt that none of the devices using usb ports (printer, scanner, battery backup) works. What do I do to turn on the USB ports? Thanks for your help.
 

A:no USB ports working

Read other 7 answers
RELEVANCY SCORE 41.6

i have had this problem before, and i ended up doing a full format to fix it along with a few other problems at the time, but now its doing it again!

when i try my usb stick in any of the usb ports, it just wont recognise it. it doesnt even pop up with a message or anything, nothing happens at all. when i turn my printer on it wont recognise that either, and the cable for that has never been taken out.

i have a wireless keyboard and mouse which use a single usb reciever, which still works fine. my usb wireless networking adaptor still works ok, and i also have a 3d mouse which i use for CAD which also still work ok. (non of these cables are ever removed from there ports)

i have tried a system restore back to when it was working fine, but it hasnt fixed it.
no drivers appear to be out of date.

i also run ubuntu as a dual boot, and the usb's work fine in that. so its definately just a windows problem.

i am running windows 7 64bit.

thanks

A:usb ports not working again

Try uninstalling all the "USB Root Hubs" in Device Manager (right-click >> Uninstall), then restart Windows to re-install them automatically.

Note: Do not uninstall any of the Host Controllers, just the root hubs.

Read other 6 answers
RELEVANCY SCORE 41.6

I have searched for this problem and have found some information and have taken some recommended steps to fix the problem with no success.

I fried my CPU and after installing a new one none of the ports on the back of my box work. The USB ports do not work nor do the PS2 ports and it also appears that none of the expansion slots on the mobo work either. Fortunately the USB ports on the front of the box still function.

I tried deleting the USB drivers and reloading them. I tried reloading the motherboard drivers.

My board is a Biostar TA790GX XE.

I also have a couple of further questions.

1) I know that you usually cannot switch out a motherboard and use the same hard drive unless you through a process to make it all work. Is this still necessary if you install an identical motherboard? Can you put everything back on an identical motherboard and fire it right up?

2) Can somebody direct me to a good guide to doing back ups?

Thanks!!!
 

A:ports not working after new CPU

1) If you use an identical motherboard and nothing else was damaged then yes it will work.

2) I would make an Image rather than a backup, this is a very good free Imaging program :- http://www.macrium.com/reflectfree.aspx
 

Read other 2 answers
RELEVANCY SCORE 41.6

Hi there...

So, my USB 3.0 ports are not working with my USB 3.0 ext-HDD. It's an ADATA Nobility NH13
I don't have any other USB 3.0 equipment to test, but the ext-HDD works perfectly on my laptop and on my TV as well, so it's definitely not the HDDs fault.

When I plug in USB 2 devices, they work perfectly and at maximum speeds. Even the HDD does work when connected with a USB 2.0 cable instead of it's own 3.0 cable.

This behaviour is present on front as well as the rear ports.

In the Device Manager there IS a USB3.0 driver:

Intel(r) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)
Universal Serial Bus controllers
Generic USB xHCI Host Controller
PCI but 0, device 20, function 0
This device is working properly

Hardware IDs:
PCI\VEN_8086&DEV_8C31&SUBSYS_50071458&REV_04
PCI\VEN_8086&DEV_8C31&SUBSYS_50071458
PCI\VEN_8086&DEV_8C31&CC_0C0330
PCI\VEN_8086&DEV_8C31&CC_0C03

P.S. The specs are all up to date, so feel free to check them out.
P.P.S. In case you are that lazy, I am running Windows 8 Enterprise x64, and Gigabyte GA-Z87-HD3 motherboard

I am grateful for every answer
Thank you.

A:USB 3.0 ports not working

Can you try another cable? That may be all it is.

Read other 10 answers
RELEVANCY SCORE 41.6

Hi Guys...

USB Ports of my Computer r not working.....Where as drivers 4 USB Ports r inst. & also USB functions ENABLED in BIOS...
 

A:USB Ports not working...

Read other 11 answers
RELEVANCY SCORE 41.6

(using wireless and now cable)
So I have this problem where my internet isnt working even though I'm fully connected.

It started this morning and when I ran the diagnostic (from the "IE cannot open page" page) it said that

windows can't connect... using HTTp HTTPS or FTP... probably caused by firewall settings... check setting for port (80) port (443) and port (21)...

Via google I found a similar problem (http://forums.techguy.org/web-email/...s-443-ftp.html -if it helps) where the advice given was to reboot in Safe mode with networking.

I found an ethernet cable and plugged it in but when I tried starting up my computer in safe mode (all 3) it said that it couldn't due to power failure/power-reset button was pressed (neither of which happened I'm pretty sure)

It seems that the advice for this would be to get a diagnostic off of *wherever* but as the internet isn't working I can't.

Any advice?
Oh, and my dad was using it when it started and just said some pop-ups came up and he clicked something.

Thanks for reading and/or helping but could any advice be in laymans terms. thanks again.

A:Ports 21, 80 and 443 not working (or something)

Open a command prompt and see if you can ping yahoo (ping www.yahoo.com) see if you get any replies. I would run a virus scan and make sure the popup did not give you malware. If so, follow the 5 steps in my sig.

Read other 3 answers
RELEVANCY SCORE 41.6

Yesterday I plugged my cell phone into the computer and enabled it to use as usb. Immediately after that I noticed my usb mouse wasn't working and then realized the usb keyboard wasn't working. I tried a different mouse.....and still none of the ports on the computer would work. (They do however work on my laptop) Then I took the following steps. 

1. unplugged my usb mouse (and everything else) and tried all the different ports.
2. tried both a different usb mouse as well as wireless mouse (which needed a usb to connect. Nothing was recognized
3. unplugged everything, shut the computer down. Unplugged the computer. Left it like that overnight.
4. When got up turned on the computer then tried to plug in....nothing recognized

Read other answers
RELEVANCY SCORE 41.6

Hi, I have a Dell with Windows XP. I just restarted my computer and my mouse and keyboard were not working. I realized after restarting a few more times & nothing fixed this that nothing connected to my USB ports were working - my connection card, mouse, keyboard, etc... Of course, I can't access my compter at all since they don't work. The USB ports in the front and in the back do not work. I unplugged everything in a USB and restarted but it did not work. I do know that one of the ports in the front has some damage to it but I'm not sure if that would cause them all to suddenly not work? Any help is appreciated. Thank you!

Tammy

A:USP Ports are NOT working

Hi Tammy and welcome to TSF

When you boot, does the lights on the keyboard blink? Wondering if it is a problem all the time or just after Windows boots.

You need to try a PS/2 mouse and keyboard. See if you can borrow them if you don't have them. There is an adapter to interface USB to PS/2 that will work on a mouse, but I'm not sure if it would work on the keyboard. If you at least had a mouse, you could use the On-Screen Keyboard to check out the USB drivers, etc.

It might be the damaged USB port on the front of your computer. The USB connectors at the front are plugged onto the mother board. If you are confortable about going into your computer, you could unplug the front ports from the motherboard. If the problem is a damaged front port, that might clear it. If you decide to go inside your computer, be sure to unplug the computer before you start and touch the bare metal of the case before touching anything inside the computer. Discharge any static electricity from yourself.

Let us know how it goes.

Best regards,
Mack1

Read other 1 answers